1 |
%define major 20 |
2 |
%define libname %mklibname %{name} %{major} |
3 |
%define develname %mklibname %{name} -d |
4 |
|
5 |
Summary: GNU Pth - GNU Portable Threads |
6 |
Name: pth |
7 |
Version: 2.0.7 |
8 |
Release: %mkrel 8 |
9 |
License: LGPLv2+ |
10 |
Group: System/Libraries |
11 |
URL: http://www.gnu.org/software/pth/ |
12 |
Source0: ftp://ftp.gnu.org/pub/gnu/pth/%{name}-%{version}.tar.gz |
13 |
Source1: ftp://ftp.gnu.org/pub/gnu/pth/%{name}-%{version}.tar.gz.sig |
14 |
Patch1: %{name}-2.0.0-pth-config.in.patch |
15 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
16 |
|
17 |
%description |
18 |
Pth is a very portable POSIX/ANSI-C based library for Unix platforms |
19 |
which provides non-preemptive priority-based scheduling for multiple |
20 |
threads of execution ("multithreading") inside server applications. |
21 |
All threads run in the same address space of the server application, |
22 |
but each thread has it's own individual program-counter, run-time |
23 |
stack, signal mask and errno variable. |
24 |
|
25 |
%package -n %{libname} |
26 |
Summary: GNU Pth - GNU Portable Threads |
27 |
Group: System/Libraries |
28 |
|
29 |
%description -n %{libname} |
30 |
Pth is a very portable POSIX/ANSI-C based library for Unix platforms |
31 |
which provides non-preemptive priority-based scheduling for multiple |
32 |
threads of execution ("multithreading") inside server applications. |
33 |
All threads run in the same address space of the server application, |
34 |
but each thread has it's own individual program-counter, run-time |
35 |
stack, signal mask and errno variable. |
36 |
|
37 |
This package provides the main %{name} library. |
38 |
|
39 |
%package -n %{develname} |
40 |
Summary: GNU Pth - GNU Portable Threads (Headers and Static Libs) |
41 |
Group: Development/C |
42 |
Requires: %{libname} = %{version} |
43 |
Provides: %{name}-devel = %{version}-%{release} |
44 |
Provides: lib%{name}-devel = %{version}-%{release} |
45 |
Obsoletes: %mklibname %{name} 20 -d |
46 |
Provides: %mklibname %{name} 20 -d |
47 |
|
48 |
%description -n %{develname} |
49 |
Pth is a very portable POSIX/ANSI-C based library for Unix platforms. |
50 |
|
51 |
This package provides all necessary files to develop or compile any |
52 |
applications or libraries that use %{name} library. |
53 |
|
54 |
%prep |
55 |
%setup -q |
56 |
%patch1 -p1 -b .cflags-ldflags |
57 |
|
58 |
%build |
59 |
|
60 |
%configure2_5x \ |
61 |
--enable-optimize=yes \ |
62 |
--enable-pthread=no |
63 |
|
64 |
# (tpg) without this parallel make fails |
65 |
%make pth_p.h |
66 |
|
67 |
%make |
68 |
|
69 |
%check |
70 |
make test |
71 |
|
72 |
%install |
73 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
74 |
|
75 |
%makeinstall_std |
76 |
|
77 |
%multiarch_binaries %{buildroot}%{_bindir}/pth-config |
78 |
|
79 |
%clean |
80 |
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
81 |
|
82 |
%files -n %{libname} |
83 |
%defattr(-,root,root) |
84 |
%{_libdir}/lib*.so.%{major}* |
85 |
|
86 |
%files -n %{develname} |
87 |
%defattr(-,root,root) |
88 |
%doc AUTHORS ChangeLog NEWS PORTING README THANKS |
89 |
%{_bindir}/pth-config |
90 |
%multiarch %{multiarch_bindir}/pth-config |
91 |
%{_datadir}/aclocal/*.m4 |
92 |
%{_includedir}/* |
93 |
%{_libdir}/lib*.a |
94 |
%{_libdir}/lib*.la |
95 |
%{_libdir}/lib*.so |
96 |
%{_mandir}/man?/* |
97 |
|
98 |
|