/[packages]/cauldron/python-argcomplete/current/SPECS/python-argcomplete.spec
ViewVC logotype

Annotation of /cauldron/python-argcomplete/current/SPECS/python-argcomplete.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1437545 - (hide annotations) (download)
Thu Sep 5 13:28:16 2019 UTC (4 years, 7 months ago) by wally
File size: 2416 byte(s)
- new version 1.10.0
- drop python2 support
- rebuild for python3.8
1 wally 1355928 %global srcname argcomplete
2 mitya 1124416
3     # Currently it's broken: https://github.com/kislyuk/argcomplete/issues/174
4 mitya 1124464 %bcond_with check
5 mitya 1124416
6 wally 1355928 Name: python-%{srcname}
7 mitya 1124416 Summary: Bash tab completion for argparse
8 wally 1437545 Version: 1.10.0
9 wally 1355928 Release: %mkrel 1
10 mitya 1124465 Group: Development/Python
11 mitya 1124416 License: ASL 2.0
12     URL: https://github.com/kislyuk/argcomplete
13 wally 1355928 Source0: https://files.pythonhosted.org/packages/source/a/argcomplete/argcomplete-%{version}.tar.gz
14 mitya 1124416 BuildArch: noarch
15    
16     %global _description \
17     Argcomplete provides easy, extensible command line tab completion of\
18     arguments for your Python script.\
19     \
20     It makes two assumptions:\
21     \
22     * You are using bash as your shell\
23     * You are using argparse to manage your command line arguments/options\
24     \
25     Argcomplete is particularly useful if your program has lots of\
26     options or subparsers, and if your program can dynamically suggest\
27     completions for your argument/option values (for example, if the user\
28     is browsing resources over the network).
29    
30     %description %{_description}
31    
32 wally 1355928 %package -n python3-%{srcname}
33 mitya 1124416 Summary: %{summary}
34 mitya 1124465 Group: Development/Python
35 mitya 1124464 BuildRequires: pkgconfig(python3)
36 wally 1355928 BuildRequires: python3dist(setuptools)
37 mitya 1124416 %if %{with check}
38 wally 1355928 BuildRequires: python3dist(pexpect)
39 mitya 1124464 BuildRequires: tcsh
40 mitya 1124416 %endif
41 wally 1355928 %{?python_provide:%python_provide python3-%{srcname}}
42 mitya 1124464
43 mitya 1124416 # pkg_resources module is used from python-argcomplete-check-easy-install-script
44 wally 1355928 Requires: python3dist(setuptools)
45 mitya 1124416
46 wally 1355928 %description -n python3-%{srcname} %{_description}
47 mitya 1124416
48 wally 1355928 %prep
49     %autosetup -n %{srcname}-%{version}
50 mitya 1124416
51 wally 1355928 # Drop bundled egg-info
52     rm -rf %{srcname}.egg-info
53    
54 mitya 1124416 # Remove useless BRs
55     sed -i -r -e '/tests_require = /s/"(coverage|flake8|wheel)"[, ]*//g' setup.py
56    
57     %build
58     %py3_build
59    
60     %install
61     %py3_install
62 wally 1355928
63 mitya 1124416 mkdir -p %{buildroot}%{_sysconfdir}/bash_completion.d/
64 wally 1355928 install -p -m0644 %{buildroot}%{python3_sitelib}/%{srcname}/bash_completion.d/python-argcomplete.sh %{buildroot}%{_sysconfdir}/bash_completion.d/
65 mitya 1124416
66     %if %{with check}
67     %check
68     export LC_ALL=C.UTF-8
69     %{__python3} setup.py test
70     %endif
71    
72 wally 1355928 %files -n python3-%{srcname}
73 mitya 1124416 %license LICENSE.rst
74     %doc README.rst
75 wally 1355928 %{python3_sitelib}/%{srcname}-*.egg-info/
76     %{python3_sitelib}/%{srcname}/
77 mitya 1124416 %{_bindir}/activate-global-python-argcomplete
78     %{_bindir}/python-argcomplete-check-easy-install-script
79     %{_bindir}/python-argcomplete-tcsh
80     %{_bindir}/register-python-argcomplete
81     %{_sysconfdir}/bash_completion.d/python-argcomplete.sh

  ViewVC Help
Powered by ViewVC 1.1.30