/[packages]/cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec
ViewVC logotype

Annotation of /cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1224532 - (hide annotations) (download)
Wed May 2 09:33:26 2018 UTC (5 years, 11 months ago) by kekepower
File size: 3117 byte(s)
imported package python-argon2_cffi
1 kekepower 1224532 # Created by pyp2rpm-3.3.1
2     %global pypi_name argon2_cffi
3    
4     Name: python-%{pypi_name}
5     Version: 18.1.0
6     Release: %mkrel 1
7     Summary: The secure Argon2 password hashing algorithm
8     Group: Development/Python
9     License: MIT
10     URL: https://argon2-cffi.readthedocs.io/
11     Source0: %{pypi_name}-%{version}.tar.gz
12    
13     BuildRequires: pkgconfig(python2)
14     BuildRequires: python2dist(cffi) >= 1.0.0
15     BuildRequires: python2dist(coverage)
16     BuildRequires: python2dist(hypothesis)
17     BuildRequires: python2dist(pytest)
18     BuildRequires: python2dist(setuptools)
19     BuildRequires: python2dist(six)
20     BuildRequires: python2dist(wheel)
21    
22     BuildRequires: pkgconfig(python3)
23     BuildRequires: python3dist(cffi) >= 1.0.0
24     BuildRequires: python3dist(coverage)
25     BuildRequires: python3dist(hypothesis)
26     BuildRequires: python3dist(pytest)
27     BuildRequires: python3dist(setuptools)
28     BuildRequires: python3dist(six)
29     BuildRequires: python3dist(wheel)
30     BuildRequires: python3dist(sphinx)
31    
32     %description
33     CFFI-based Argon2 Bindings for Python .. image::
34    
35     %package -n python2-%{pypi_name}
36     Summary: %{summary}
37     %{?python_provide:%python_provide python2-%{pypi_name}}
38    
39     Requires: python2dist(cffi) >= 1.0.0
40     Requires: python2dist(coverage)
41     Requires: python2dist(hypothesis)
42     Requires: python2dist(pytest)
43     Requires: python2dist(six)
44     Requires: python2dist(sphinx)
45    
46     %description -n python2-%{pypi_name}
47     CFFI-based Argon2 Bindings for Python .. image::
48    
49     %package -n python3-%{pypi_name}
50     Summary: %{summary}
51     %{?python_provide:%python_provide python3-%{pypi_name}}
52    
53     Requires: python3dist(cffi) >= 1.0.0
54     Requires: python3dist(coverage)
55     Requires: python3dist(hypothesis)
56     Requires: python3dist(pytest)
57     Requires: python3dist(six)
58     Requires: python3dist(sphinx)
59    
60     %description -n python3-%{pypi_name}
61     CFFI-based Argon2 Bindings for Python .. image::
62    
63     %package -n python-%{pypi_name}-doc
64     Summary: argon2_cffi documentation
65     %description -n python-%{pypi_name}-doc
66     Documentation for argon2_cffi
67    
68     %prep
69     %autosetup -n %{pypi_name}-%{version}
70     # Remove bundled egg-info
71     rm -rf %{pypi_name}.egg-info
72    
73     %build
74     %py2_build
75     %py3_build
76     # generate html docs
77     PYTHONPATH=${PWD} sphinx-build-3 docs html
78     # remove the sphinx-build leftovers
79     rm -rf html/.{doctrees,buildinfo}
80    
81     %install
82     # Must do the default python version install last because
83     # the scripts in /usr/bin are overwritten with every setup.py install.
84     %py2_install
85     %py3_install
86    
87     %check
88     %{__python2} setup.py test
89     %{__python3} setup.py test
90    
91     %files -n python2-%{pypi_name}
92     %license LICENSE docs/license.rst extras/libargon2/LICENSE
93     %doc README.rst extras/libargon2/README.md
94     %{python2_sitearch}/argon2
95     %{python2_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info
96    
97     %files -n python3-%{pypi_name}
98     %license LICENSE docs/license.rst extras/libargon2/LICENSE
99     %doc README.rst extras/libargon2/README.md
100     %{python3_sitearch}/argon2
101     %{python3_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info
102    
103     %files -n python-%{pypi_name}-doc
104     %doc html
105     %license LICENSE docs/license.rst extras/libargon2/LICENSE
106    

  ViewVC Help
Powered by ViewVC 1.1.30