/[packages]/cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec
ViewVC logotype

Annotation of /cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1224534 - (hide annotations) (download)
Wed May 2 09:37:06 2018 UTC (5 years, 11 months ago) by kekepower
File size: 3153 byte(s)
- BR python2-enum34

1 kekepower 1224532 # Created by pyp2rpm-3.3.1
2     %global pypi_name argon2_cffi
3    
4     Name: python-%{pypi_name}
5     Version: 18.1.0
6     Release: %mkrel 1
7     Summary: The secure Argon2 password hashing algorithm
8     Group: Development/Python
9     License: MIT
10     URL: https://argon2-cffi.readthedocs.io/
11     Source0: %{pypi_name}-%{version}.tar.gz
12    
13     BuildRequires: pkgconfig(python2)
14     BuildRequires: python2dist(cffi) >= 1.0.0
15     BuildRequires: python2dist(coverage)
16     BuildRequires: python2dist(hypothesis)
17     BuildRequires: python2dist(pytest)
18     BuildRequires: python2dist(setuptools)
19     BuildRequires: python2dist(six)
20     BuildRequires: python2dist(wheel)
21 kekepower 1224534 BuildRequires: python2dist(enum34)
22 kekepower 1224532
23     BuildRequires: pkgconfig(python3)
24     BuildRequires: python3dist(cffi) >= 1.0.0
25     BuildRequires: python3dist(coverage)
26     BuildRequires: python3dist(hypothesis)
27     BuildRequires: python3dist(pytest)
28     BuildRequires: python3dist(setuptools)
29     BuildRequires: python3dist(six)
30     BuildRequires: python3dist(wheel)
31     BuildRequires: python3dist(sphinx)
32    
33     %description
34     CFFI-based Argon2 Bindings for Python .. image::
35    
36     %package -n python2-%{pypi_name}
37     Summary: %{summary}
38     %{?python_provide:%python_provide python2-%{pypi_name}}
39    
40     Requires: python2dist(cffi) >= 1.0.0
41     Requires: python2dist(coverage)
42     Requires: python2dist(hypothesis)
43     Requires: python2dist(pytest)
44     Requires: python2dist(six)
45     Requires: python2dist(sphinx)
46    
47     %description -n python2-%{pypi_name}
48     CFFI-based Argon2 Bindings for Python .. image::
49    
50     %package -n python3-%{pypi_name}
51     Summary: %{summary}
52     %{?python_provide:%python_provide python3-%{pypi_name}}
53    
54     Requires: python3dist(cffi) >= 1.0.0
55     Requires: python3dist(coverage)
56     Requires: python3dist(hypothesis)
57     Requires: python3dist(pytest)
58     Requires: python3dist(six)
59     Requires: python3dist(sphinx)
60    
61     %description -n python3-%{pypi_name}
62     CFFI-based Argon2 Bindings for Python .. image::
63    
64     %package -n python-%{pypi_name}-doc
65     Summary: argon2_cffi documentation
66     %description -n python-%{pypi_name}-doc
67     Documentation for argon2_cffi
68    
69     %prep
70     %autosetup -n %{pypi_name}-%{version}
71     # Remove bundled egg-info
72     rm -rf %{pypi_name}.egg-info
73    
74     %build
75     %py2_build
76     %py3_build
77     # generate html docs
78     PYTHONPATH=${PWD} sphinx-build-3 docs html
79     # remove the sphinx-build leftovers
80     rm -rf html/.{doctrees,buildinfo}
81    
82     %install
83     # Must do the default python version install last because
84     # the scripts in /usr/bin are overwritten with every setup.py install.
85     %py2_install
86     %py3_install
87    
88     %check
89     %{__python2} setup.py test
90     %{__python3} setup.py test
91    
92     %files -n python2-%{pypi_name}
93     %license LICENSE docs/license.rst extras/libargon2/LICENSE
94     %doc README.rst extras/libargon2/README.md
95     %{python2_sitearch}/argon2
96     %{python2_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info
97    
98     %files -n python3-%{pypi_name}
99     %license LICENSE docs/license.rst extras/libargon2/LICENSE
100     %doc README.rst extras/libargon2/README.md
101     %{python3_sitearch}/argon2
102     %{python3_sitearch}/%{pypi_name}-%{version}-py?.?.egg-info
103    
104     %files -n python-%{pypi_name}-doc
105     %doc html
106     %license LICENSE docs/license.rst extras/libargon2/LICENSE
107    

  ViewVC Help
Powered by ViewVC 1.1.30