/[packages]/cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec
ViewVC logotype

Contents of /cauldron/python-argon2_cffi/current/SPECS/python-argon2_cffi.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1565782 - (show annotations) (download)
Thu Apr 9 10:40:18 2020 UTC (4 years ago) by kekepower
File size: 1944 byte(s)
SILENT: Fix file list

1 # Created by pyp2rpm-3.3.1
2 %global pypi_name argon2-cffi
3 %global egg_name argon2_cffi
4
5 Name: python-%{pypi_name}
6 Version: 19.2.0
7 Release: %mkrel 1
8 Summary: The secure Argon2 password hashing algorithm
9 Group: Development/Python
10 License: MIT
11 URL: https://argon2-cffi.readthedocs.io/
12 Source0: https://pypi.io/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
13
14 BuildRequires: pkgconfig(python3)
15 BuildRequires: python3dist(cffi) >= 1.0.0
16 BuildRequires: python3dist(setuptools)
17 BuildRequires: python3dist(six)
18 BuildRequires: python3dist(wheel)
19 BuildRequires: python3dist(funcsigs)
20 # for docs
21 BuildRequires: python3dist(sphinx)
22 # for tests
23 BuildRequires: python3dist(coverage)
24 BuildRequires: python3dist(hypothesis)
25 BuildRequires: python3dist(pytest)
26
27 %description
28 CFFI-based Argon2 Bindings for Python.
29
30 %package -n python3-%{pypi_name}
31 Summary: %{summary}
32 %{?python_provide:%python_provide python3-%{pypi_name}}
33
34 Requires: python3dist(cffi) >= 1.0.0
35 Requires: python3dist(six)
36
37 %description -n python3-%{pypi_name}
38 CFFI-based Argon2 Bindings for Python.
39
40 %package -n python-%{pypi_name}-doc
41 Summary: argon2_cffi documentation
42
43 %description -n python-%{pypi_name}-doc
44 Documentation for argon2_cffi
45
46 %prep
47 %autosetup -n %{pypi_name}-%{version}
48
49 # Remove bundled egg-info
50 rm -rf %{pypi_name}.egg-info
51
52 %build
53 %py3_build
54
55 # generate html docs
56 PYTHONPATH=${PWD} sphinx-build docs html
57 # remove the sphinx-build leftovers
58 rm -rf html/.{doctrees,buildinfo}
59
60 %install
61 %py3_install
62
63 %check
64 %{__python3} setup.py test
65
66 %files -n python3-%{pypi_name}
67 %license LICENSE docs/license.rst extras/libargon2/LICENSE
68 %doc README.rst extras/libargon2/README.md
69 %{python3_sitearch}/argon2
70 %{python3_sitearch}/%{egg_name}-%{version}-py?.?.egg-info
71
72 %files -n python-%{pypi_name}-doc
73 %doc html
74 %license LICENSE docs/license.rst extras/libargon2/LICENSE
75

  ViewVC Help
Powered by ViewVC 1.1.30