/[packages]/cauldron/python-codepy/current/SPECS/python-codepy.spec
ViewVC logotype

Contents of /cauldron/python-codepy/current/SPECS/python-codepy.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 687940 - (show annotations) (download)
Tue Sep 16 20:07:20 2014 UTC (9 years, 7 months ago) by umeabot
File size: 1389 byte(s)
Mageia 5 Mass Rebuild
1 # Created by pyp2rpm-1.0.0
2 %global pypi_name codepy
3 %define version 2013.1
4
5 Name: python-codepy
6 Version: 2013.1
7 Release: %mkrel 6
8 Group: Development/Python
9 Summary: Generate and execute native code at run time
10
11 License: MIT
12 URL: http://mathema.tician.de/software/codepy
13 Source0: http://pypi.python.org/packages/source/c/codepy/codepy-%{version}.tar.gz
14 BuildArch: noarch
15
16 BuildRequires: python-devel
17 BuildRequires: python-sphinx
18 BuildRequires: python-setuptools
19
20 Requires: pythonegg(2)(pytools) >= 8
21 Requires: pythonegg(2)(cgen)
22
23 %description
24 CodePy is a C/C++ metaprogramming toolkit for Python. It handles two aspects of
25 native-code metaprogramming:
26
27 * Generating C/C++ source code.
28 * Compiling this source code and dynamically loading it into the
29 Python interpreter.
30
31 Both capabilities are meant to be used together, but also work on
32 their own.
33
34 %prep
35 %setup -q -n %{pypi_name}-%{version}
36 # Remove bundled egg-info
37 rm -rf %{pypi_name}.egg-info
38
39 # generate html docs
40 sphinx-build doc/source html
41 # remove the sphinx-build leftovers
42 rm -rf html/.{doctrees,buildinfo}
43
44 %build
45 %{__python} setup.py build
46
47 %install
48 %{__python} setup.py install --skip-build --root %{buildroot}
49
50 %files
51 %doc html
52 %{python_sitelib}/%{pypi_name}
53 %{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30