/[packages]/cauldron/python-gobject3/current/SPECS/python-gobject3.spec
ViewVC logotype

Contents of /cauldron/python-gobject3/current/SPECS/python-gobject3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 221179 - (show annotations) (download)
Wed Mar 7 15:42:18 2012 UTC (12 years ago) by anssi
File size: 3586 byte(s)
- adapt for an API change made in gnome bug #657385 (this change might
  get reverted later, though; adapt-for-gnome657385.patch)

1 %define oname pygobject
2
3 %define api 2.0
4 %define major 0
5 %define libname %mklibname pyglib-gi %api %major
6
7 %define _exclude_files_from_autoreq ^%{py_platsitedir}/gi/_gobject/__init__.py
8
9 %define url_ver %(echo %{version} | cut -d "." -f -2)
10
11 Summary: Python bindings for GObject Introspection
12 Name: python-gobject3
13 Version: 3.1.1
14 Release: %mkrel 2
15 Source0: http://download.gnome.org/sources/%{oname}/%{url_ver}/%{oname}-%{version}.tar.xz
16 Patch0: pygobject-2.90.2-link.patch
17 # Adapt for an API change - the API change might be reverted soon, in which
18 # case this patch should be removed. -Anssi 03/2012
19 # https://bugzilla.gnome.org/show_bug.cgi?id=657385
20 # https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/923171
21 Patch1: pygobject-adapt-for-gnome657385.patch
22 License: LGPLv2+ and MIT
23 Group: Development/Python
24 Url: http://www.gnome.org
25 BuildRequires: python-devel >= 2.5.2
26 BuildRequires: pkgconfig(glib-2.0) >= 2.24.0
27 BuildRequires: pkgconfig(gobject-introspection-1.0) >= 0.10.2
28 BuildRequires: pkgconfig(libffi) >= 3.0
29 BuildRequires: pkgconfig(pycairo) >= 1.2.0
30 BuildRequires: gtk-doc
31 BuildRequires: automake
32
33 %description
34 The %{name} package provides a convenient wrapper for the GObject library
35 for use in Python programs.
36
37 %package -n python-gi
38 Summary: Python bindings for GObject Introspection
39 Group: Development/Python
40 Provides: python-gobject-introspection = %{version}-%{release}
41 Provides: %{name} = %{version}-%{release}
42 Conflicts: python-gobject < 2.28.6-4
43
44 %description -n python-gi
45 The %{name} package provides a convenient wrapper for the GObject library
46 for use in Python programs.
47
48 This package contains the Python GObject Introspection bindings.
49
50 %package -n python-gi-cairo
51 Summary: Python-gi bindings for Cairo
52 Group: Development/Python
53 Requires: python-gi = %{version}-%{release}
54 Requires: python-cairo >= 1.2.0
55 Obsoletes: python-gobject-cairo < 2.28.6-4
56 Provides: python-gobject-cairo = %{version}-%{release}
57
58 %description -n python-gi-cairo
59 The %{name} package provides a convenient wrapper for the GObject library
60 for use in Python programs.
61
62 This package contains the Python-gi Cairo bindings.
63
64 %package -n %{libname}
65 Group: System/Libraries
66 Summary: Python GObject Introspection bindings shared library
67
68 %description -n %{libname}
69 This archive contains bindings for the GObject, to be used in Python
70 It is a fairly complete set of bindings, it's already rather useful,
71 and is usable to write moderately complex programs.
72
73 %package devel
74 Group: Development/C
75 Summary: Python-gobject development files
76 Requires: %{libname} = %{version}-%{release}
77
78 %description devel
79 This contains the python-gobject development files, including C
80 header, pkg-config file.
81
82 %prep
83 %setup -q -n %{oname}-%{version}
84 #patch0 -p0
85 %patch1 -p1
86
87 %build
88 %configure2_5x
89 %make LIBS="-lpython%{py_ver}"
90
91 %install
92 rm -rf %{buildroot}
93 %makeinstall_std
94
95 find %buildroot -name *.la | xargs rm
96
97 # dsextra stuff is for windows installs so remove it
98 rm -fr %{buildroot}%{python_sitearch}/gtk-2.0
99
100 # docs are out of date and are being reworked upstream
101 # so remove them
102 rm -rf %{buildroot}%{_datadir}/gtk-doc
103 rm -rf %{buildroot}%{_datadir}/pygobject
104
105 %files -n python-gi
106 %defattr(-,root,root)
107 %doc README NEWS AUTHORS ChangeLog
108 %py_platsitedir/gi
109 # Live in cairo subpackage
110 %exclude %py_platsitedir/gi/_gi_cairo.so
111
112 %files -n python-gi-cairo
113 %defattr(-,root,root)
114 %py_platsitedir/gi/_gi_cairo.so
115
116 %files -n %libname
117 %defattr(-,root,root)
118 %{_libdir}/libpyglib-gi-%{api}-python.so.%{major}*
119
120 %files devel
121 %defattr(-,root,root)
122 %{_includedir}/*
123 %{_libdir}/*.so
124 %{_libdir}/pkgconfig/*.pc

  ViewVC Help
Powered by ViewVC 1.1.30