1 |
%define module livestreamer |
2 |
|
3 |
Name: python-%{module} |
4 |
Version: 1.10.2 |
5 |
Release: %mkrel 4 |
6 |
Summary: CLI for piping video streams to video players |
7 |
License: BSD |
8 |
Group: Development/Python |
9 |
URL: http://livestreamer.tanuki.se/ |
10 |
Source0: https://github.com/chrippa/%{module}/archive/v%{version}.tar.gz |
11 |
BuildArch: noarch |
12 |
BuildRequires: python-setuptools |
13 |
|
14 |
Requires: python-requests |
15 |
Recommends: python-pycrypto |
16 |
Requires: python-pkg-resources |
17 |
Recommends: rtmpdump |
18 |
|
19 |
%description |
20 |
Livestreamer is CLI program that extracts streams from various services and |
21 |
pipes them into a video player of choice. |
22 |
|
23 |
#--------------------------------------------------------------------------- |
24 |
|
25 |
%package -n python3-%{module} |
26 |
Summary: CLI for piping video streams to video players |
27 |
Group: Development/Python |
28 |
BuildArch: noarch |
29 |
BuildRequires: python3-setuptools |
30 |
|
31 |
Requires: python3-requests |
32 |
Recommends: python3-pycrypto |
33 |
Requires: python3-pkg-resources |
34 |
Recommends: rtmpdump |
35 |
|
36 |
%description -n python3-%{module} |
37 |
Livestreamer is CLI program that extracts streams from various services and |
38 |
pipes them into a video player of choice. |
39 |
This is the Python 3 build of %{module}. |
40 |
|
41 |
#--------------------------------------------------------------------------- |
42 |
|
43 |
%prep |
44 |
%setup -q -n %{module}-%{version} |
45 |
cp -a . %{py3dir} |
46 |
|
47 |
%build |
48 |
pushd %{py3dir} |
49 |
%{__python3} setup.py build |
50 |
popd |
51 |
|
52 |
%{__python} setup.py build |
53 |
|
54 |
%install |
55 |
pushd %{py3dir} |
56 |
%{__python3} setup.py install --root=%{buildroot} --skip-build |
57 |
mv %{buildroot}%{_bindir}/livestreamer %{buildroot}%{_bindir}/python3-livestreamer |
58 |
popd |
59 |
|
60 |
%{__python} setup.py install --root=%{buildroot} --skip-build |
61 |
|
62 |
%files |
63 |
%doc AUTHORS *.rst LICENSE* |
64 |
%doc docs |
65 |
%{_bindir}/%{module} |
66 |
%{python_sitelib}/%{module} |
67 |
%{python_sitelib}/%{module}_cli |
68 |
%{python_sitelib}/%{module}-%{version}-py%{pyver}.egg-info |
69 |
|
70 |
%files -n python3-%{module} |
71 |
%doc AUTHORS *.rst LICENSE* |
72 |
%doc docs |
73 |
%{_bindir}/python3-%{module} |
74 |
%{python3_sitelib}/%{module} |
75 |
%{python3_sitelib}/%{module}_cli |
76 |
%{python3_sitelib}/%{module}-%{version}-py%{py3ver}.egg-info |