/[packages]/cauldron/python-matplotlib/current/SPECS/python-matplotlib.spec
ViewVC logotype

Contents of /cauldron/python-matplotlib/current/SPECS/python-matplotlib.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 90208 - (show annotations) (download)
Mon Apr 25 08:49:01 2011 UTC (12 years, 11 months ago) by grenoya
File size: 6501 byte(s)
- remove python-matplotlib-qt subpackage
1 %define module matplotlib
2 %define name python-%{module}
3 %define version 1.0.1
4 %define release %mkrel 1
5
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Summary: Matlab-style 2D plotting package for Python
10 Group: Development/Python
11 License: Python license
12 URL: http://matplotlib.sourceforge.net/
13 Source0: http://downloads.sourceforge.net/project/%{module}/%{module}/%{module}-%{version}/%{module}-%{version}.tar.gz
14 %{py_requires -d}
15 Patch0: setupext-tk-include-0.99.1.2.patch
16 Requires: python-numpy >= 1.1.0
17 Requires: python-configobj, python-dateutil, python-pytz
18 Requires: python-matplotlib-gtk = %{version}-%{release}
19 BuildRequires: python-setuptools
20 BuildRequires: python-numpy-devel >= 1.1.0
21 BuildRequires: libwxPythonGTK-devel, pygtk2.0-devel, cairo-devel
22 BuildRequires: tkinter, tcl-devel, tk-devel, freetype2-devel >= 2.1.7
23 BuildRequires: python-qt4
24 BuildRequires: libpng-devel, zlib-devel
25 BuildRequires: python-configobj, python-dateutil, python-pytz
26 BuildRequires: python-docutils, python-sphinx
27 BuildRequires: ipython
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29
30 %description
31 matplotlib is a Python 2D plotting library which produces publication
32 quality figures in a variety of hardcopy formats and interactive
33 environments across platforms. matplotlib can be used in Python
34 scripts, the python and ipython shell (a la Matlab or Mathematica), web
35 application servers, and various graphical user interface toolkits.
36
37 %package cairo
38 Summary: Cairo backend for matplotlib
39 Group: Development/Python
40 Requires: %{name} = %{version}-%{release}
41 Requires: python-cairo >= 1.2.0
42
43 %description cairo
44 This package contains the Cairo backend for matplotlib.
45
46 %package emf
47 Summary: EMF backend for matplotlib
48 Group: Development/Python
49 Requires: %{name} = %{version}-%{release}
50 Requires: python-pyemf
51
52 %description emf
53 This package contains the EMF backend for matplotlib.
54
55 %package fltk
56 Summary: FLTK backend for matplotlib
57 Group: Development/Python
58 Requires: %{name} = %{version}-%{release}
59 Requires: python-pyfltk
60
61 %description fltk
62 This package contains the FLTK backend for matplotlib.
63
64 %package gtk
65 Summary: GDK and GTK backends for matplotlib
66 Group: Development/Python
67 Requires: %{name} = %{version}-%{release}
68 Requires: pygtk2.0 >= 2.4.0
69 Requires: %{name}-cairo = %{version}-%{release}
70
71 %description gtk
72 This package contains the GDK and GTK backends for matplotlib.
73
74 %package qt4
75 Summary: Qt backend for matplotlib
76 Group: Development/Python
77 Requires: %{name} = %{version}-%{release}
78 Requires: python-qt4
79
80 %description qt4
81 This package contains the Qt4 backend for matplotlib.
82
83 %package svg
84 Summary: SVG backend for matplotlib
85 Group: Development/Python
86 Requires: %{name} = %{version}-%{release}
87 Requires: python-pyxml
88
89 %description svg
90 This package contains the SVG backend for matplotlib.
91
92 %package tk
93 Summary: Tk backend for matplotlib
94 Group: Development/Python
95 Requires: %{name} = %{version}-%{release}
96 Requires: tkinter
97
98 %description tk
99 This package contains the Tk backend for matplotlib.
100
101 %package wx
102 Summary: wxPython backend for matplotlib
103 Group: Development/Python
104 Requires: %{name} = %{version}-%{release}
105 Requires: wxPython
106
107 %description wx
108 This package contains the wxPython backend for matplotlib.
109
110 %package doc
111 Summary: Documentation for matplotlib
112 Group: Development/Python
113 BuildArch: noarch
114
115 %description doc
116 This package contains documentation and sample code for matplotlib.
117
118 %prep
119 %setup -q -n %{module}-%{version}
120 %patch0 -p0 -b .setupext
121
122 %build
123 find -name .svn | xargs rm -rf
124
125 # Remove duplicate test data file:
126 %__rm -f lib/matplotlib/tests/baseline_images/test_axes/shaped\ data.svg
127
128 PYTHONDONTWRITEBYTECODE= %__python setup.py build
129
130 # Need to make built matplotlib libs available for the sphinx extensions:
131 pushd doc
132 export PYTHONPATH=`dir -d ../build/lib.linux*`
133 ./make.py html
134 popd
135
136 %install
137 %__rm -rf %{buildroot}
138 PYTHONDONTWRITEBYTECODE= %__python setup.py install --root=%{buildroot} --record=FILELIST
139
140 %clean
141 %__rm -rf %{buildroot}
142
143 %files -f FILELIST
144 %defattr(-,root,root)
145 %exclude %{py_platsitedir}/%{module}/backends/backend_cairo.py*
146 %exclude %{py_platsitedir}/%{module}/backends/backend_emf.py*
147 %exclude %{py_platsitedir}/%{module}/backends/backend_fltkagg.py*
148 %exclude %{py_platsitedir}/%{module}/backends/backend_gdk.py*
149 %exclude %{py_platsitedir}/%{module}/backends/backend_gtk.py*
150 %exclude %{py_platsitedir}/%{module}/backends/backend_gtkagg.py*
151 %exclude %{py_platsitedir}/%{module}/backends/backend_gtkcairo.py*
152 %exclude %{py_platsitedir}/%{module}/backends/_backend_gdk.so
153 %exclude %{py_platsitedir}/%{module}/backends/_gtkagg.so
154 %exclude %{py_platsitedir}/%{module}/backends/backend_qt.py*
155 %exclude %{py_platsitedir}/%{module}/backends/backend_qtagg.py*
156 %exclude %{py_platsitedir}/%{module}/backends/backend_qt4.py*
157 %exclude %{py_platsitedir}/%{module}/backends/backend_qt4agg.py*
158 %exclude %{py_platsitedir}/%{module}/backends/backend_svg.py*
159 %exclude %{py_platsitedir}/%{module}/backends/backend_tkagg.py*
160 %exclude %{py_platsitedir}/%{module}/backends/tkagg.py*
161 %exclude %{py_platsitedir}/%{module}/backends/_tkagg.so
162 %exclude %{py_platsitedir}/%{module}/backends/backend_wx.py*
163 %exclude %{py_platsitedir}/%{module}/backends/backend_wxagg.py*
164
165 %files cairo
166 %defattr(-,root,root)
167 %{py_platsitedir}/%{module}/backends/backend_cairo.py*
168
169 %files emf
170 %defattr(-,root,root)
171 %{py_platsitedir}/%{module}/backends/backend_emf.py*
172
173 %files fltk
174 %defattr(-,root,root)
175 %{py_platsitedir}/%{module}/backends/backend_fltkagg.py*
176
177 %files gtk
178 %defattr(-,root,root)
179 %{py_platsitedir}/%{module}/backends/backend_gdk.py*
180 %{py_platsitedir}/%{module}/backends/backend_gtk.py*
181 %{py_platsitedir}/%{module}/backends/backend_gtkagg.py*
182 %{py_platsitedir}/%{module}/backends/backend_gtkcairo.py*
183 %{py_platsitedir}/%{module}/backends/_backend_gdk.so
184 %{py_platsitedir}/%{module}/backends/_gtkagg.so
185
186 %files qt4
187 %defattr(-,root,root)
188 %{py_platsitedir}/%{module}/backends/backend_qt4.py*
189 %{py_platsitedir}/%{module}/backends/backend_qt4agg.py*
190
191 %files svg
192 %defattr(-,root,root)
193 %{py_platsitedir}/%{module}/backends/backend_svg.py*
194
195 %files tk
196 %defattr(-,root,root)
197 %{py_platsitedir}/%{module}/backends/backend_tkagg.py*
198 %{py_platsitedir}/%{module}/backends/tkagg.py*
199 %{py_platsitedir}/%{module}/backends/_tkagg.so
200
201 %files wx
202 %defattr(-,root,root)
203 %{py_platsitedir}/%{module}/backends/backend_wx.py*
204 %{py_platsitedir}/%{module}/backends/backend_wxagg.py*
205
206 %files doc
207 %doc license/ examples/ CHANGELOG INTERACTIVE KNOWN_BUGS TODO doc/build/html/*
208
209

  ViewVC Help
Powered by ViewVC 1.1.30