1 |
|
2 |
Name: python-mglob |
3 |
Version: 0.4 |
4 |
Release: %mkrel 2 |
5 |
Summary: Enhanced file name globbing module |
6 |
|
7 |
Group: Development/Python |
8 |
License: MIT |
9 |
URL: http://pypi.python.org/pypi/mglob |
10 |
Source0: http://pypi.python.org/packages/source/m/mglob/mglob-%{version}.zip |
11 |
# sent upstream via mail |
12 |
Patch0: mglob-0.4-built-in-set.patch |
13 |
|
14 |
BuildArch: noarch |
15 |
BuildRequires: python-devel |
16 |
BuildRequires: python-setuptools |
17 |
|
18 |
BuildRequires: python3-devel |
19 |
BuildRequires: python3-setuptools |
20 |
|
21 |
%description |
22 |
Usable as stand-alone utility (for xargs, backticks etc.), or as a globbing |
23 |
library for own python programs. |
24 |
Some enhanced features are recursion, exclusion, and directory omission. |
25 |
|
26 |
%package -n python3-mglob |
27 |
Group: Development/Python |
28 |
Summary: Enhanced file name globbing module |
29 |
%description -n python3-mglob |
30 |
Usable as stand-alone utility (for xargs, backticks etc.), or as a globbing |
31 |
library for own python programs. |
32 |
Some enhanced features are recursion, exclusion, and directory omission. |
33 |
|
34 |
%prep |
35 |
%setup -q -n mglob-%{version} |
36 |
%patch0 |
37 |
sed -i -e '/^#!\//, 1d' mglob.py |
38 |
|
39 |
cp -a . %{py3dir} |
40 |
find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|' |
41 |
|
42 |
%{_bindir}/2to3 --write --nobackups %{py3dir} |
43 |
|
44 |
find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|' |
45 |
|
46 |
|
47 |
%build |
48 |
pushd %{py3dir} |
49 |
%{__python3} setup.py build |
50 |
popd |
51 |
|
52 |
%{__python} setup.py build |
53 |
|
54 |
|
55 |
%install |
56 |
pushd %{py3dir} |
57 |
%{__python3} setup.py install -O1 --skip-build --root %{buildroot} |
58 |
mv %{buildroot}%{_bindir}/mglob %{buildroot}%{_bindir}/python3-mglob |
59 |
popd |
60 |
|
61 |
%{__python} setup.py install -O1 --skip-build --root %{buildroot} |
62 |
|
63 |
|
64 |
%files |
65 |
%{_bindir}/mglob |
66 |
%{python_sitelib}/mglob.py* |
67 |
%{python_sitelib}/mglob-%{version}-py?.?.egg-info |
68 |
|
69 |
%files -n python3-mglob |
70 |
%{_bindir}/python3-mglob |
71 |
%{python3_sitelib}/__pycache__/mglob.cpython* |
72 |
%{python3_sitelib}/mglob.py* |
73 |
%{python3_sitelib}/mglob-%{version}-py?.?.egg-info |
74 |
|