/[packages]/cauldron/python-pip/current/SPECS/python-pip.spec
ViewVC logotype

Annotation of /cauldron/python-pip/current/SPECS/python-pip.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 412711 - (hide annotations) (download)
Wed May 8 21:20:53 2013 UTC (10 years, 11 months ago) by neoclust
File size: 1170 byte(s)
fix proxy support
1 joequant 329022 # Created by pyp2rpm-1.0.0
2     %global pypi_name pip
3 neoclust 412591 %define version 1.3.1
4 joequant 329022
5     Name: python-pip
6     Version: %{version}
7 neoclust 412711 Release: %mkrel 2
8 joequant 329022 Group: Development/Python
9     Summary: pip installs packages. Python packages. An easy_install replacement
10    
11     License: MIT
12 neoclust 392884 URL: http://pypi.python.org/pypi/pip
13 joequant 329022 Source0: http://pypi.python.org/packages/source/p/pip/pip-%{version}.tar.gz
14 neoclust 412711
15     Patch0: pip-1.3.1-fix-proxy-support.patch
16    
17 joequant 329022 BuildArch: noarch
18    
19     BuildRequires: python-devel
20 neoclust 392901 BuildRequires: python-setuptools
21 joequant 329022
22 neoclust 401418 Requires: python-setuptools
23     Requires: python-pkg-resources
24    
25 joequant 329022 %description
26     `pip` is a tool for installing and managing Python packages, such as
27     those found in the `Python Package Index`_. It's a replacement for
28     easy_install_.
29    
30     %prep
31     %setup -q -n %{pypi_name}-%{version}
32     # Remove bundled egg-info
33     rm -rf %{pypi_name}.egg-info
34    
35 neoclust 412711 %apply_patches
36 joequant 329022
37     %build
38     %{__python} setup.py build
39    
40    
41     %install
42     %{__python} setup.py install --skip-build --root %{buildroot}
43    
44    
45     %files
46     %doc LICENSE.txt
47     %{_bindir}/pip
48     %{_bindir}/pip-2.7
49     %{python_sitelib}/%{pypi_name}
50     %{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30