/[packages]/cauldron/python-pip/current/SPECS/python-pip.spec
ViewVC logotype

Annotation of /cauldron/python-pip/current/SPECS/python-pip.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 739105 - (hide annotations) (download)
Tue Oct 14 22:14:55 2014 UTC (9 years, 5 months ago) by umeabot
File size: 2900 byte(s)
Second Mageia 5 Mass Rebuild
1 philippem 617149 %define pypi_name pip
2 philippem 625292 %define build_wheel 1
3 joequant 329022
4 philippem 625238 %if 0%{?build_wheel}
5     %define python2_wheelname %{pypi_name}-%{version}-py2.py3-none-any.whl
6     %define python3_wheelname %python2_wheelname
7     %endif
8    
9 joequant 329022 Name: python-pip
10 philippem 625238 Version: 1.5.6
11 umeabot 739105 Release: %mkrel 7
12 joequant 329022 Group: Development/Python
13     Summary: pip installs packages. Python packages. An easy_install replacement
14     License: MIT
15 neoclust 392884 URL: http://pypi.python.org/pypi/pip
16 philippem 617149 Source0: http://pypi.python.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
17 philippem 625238 Patch0: pip-1.5.6-allow-stripping-prefix-from-wheel-RECORD-files.patch
18 joequant 329022 BuildArch: noarch
19 philippem 458721 BuildRequires: pkgconfig(python)
20 neoclust 392901 BuildRequires: python-setuptools
21 philippem 625238 %if 0%{?build_wheel}
22     BuildRequires: python-pip
23     BuildRequires: python-wheel
24 philippem 632194 Provides: pythonegg(2)(pip)
25 philippem 625238 %endif
26 neoclust 401418 Requires: python-setuptools
27     Requires: python-pkg-resources
28    
29 joequant 329022 %description
30     `pip` is a tool for installing and managing Python packages, such as
31     those found in the `Python Package Index`_. It's a replacement for
32     easy_install_.
33    
34 philippem 458721 %package -n python3-pip
35     Summary: A tool for installing and managing Python3 packages
36     Group: Development/Python
37     BuildRequires: pkgconfig(python3)
38     BuildRequires: python3-setuptools
39 philippem 625238 %if 0%{?build_wheel}
40     BuildRequires: python3-pip
41     BuildRequires: python3-wheel
42 philippem 632194 Provides: pythonegg(3)(pip)
43 philippem 625238 %endif
44 philippem 458721 Requires: python3-setuptools
45    
46     %description -n python3-pip
47     Pip is a replacement for `easy_install
48     <http://peak.telecommunity.com/DevCenter/EasyInstall>`_. It uses mostly the
49     same techniques for finding packages, so packages that were made
50     easy_installable should be pip-installable as well.
51    
52 joequant 329022 %prep
53     %setup -q -n %{pypi_name}-%{version}
54     # Remove bundled egg-info
55     rm -rf %{pypi_name}.egg-info
56    
57 neoclust 412711 %apply_patches
58 philippem 458721 %{__sed} -i '1d' pip/__init__.py
59 joequant 329022
60 philippem 458721 cp -a . %{py3dir}
61    
62 joequant 329022 %build
63 philippem 625238 %if 0%{?build_wheel}
64     %{__python} setup.py bdist_wheel
65     %else
66 joequant 329022 %{__python} setup.py build
67 philippem 625238 %endif
68    
69 philippem 458721 pushd %{py3dir}
70 philippem 625238 %if 0%{?build_wheel}
71     %{__python3} setup.py bdist_wheel
72     %else
73 philippem 458721 %{__python3} setup.py build
74 philippem 625238 %endif
75 philippem 458721 popd
76 joequant 329022
77     %install
78 philippem 458721 pushd %{py3dir}
79 philippem 625238 %if 0%{?build_wheel}
80     pip3 install -I dist/%{python3_wheelname} --root %{buildroot} --strip-file-prefix %{buildroot}
81     # TODO: we have to remove this by hand now, but it'd be nice if we wouldn't have to
82     # (pip install wheel doesn't overwrite)
83     rm %{buildroot}%{_bindir}/pip
84     %else
85 philippem 458721 %{__python3} setup.py install --skip-build --root %{buildroot}
86 philippem 625238 %endif
87 philippem 458721 popd
88 philippem 625238
89     %if 0%{?build_wheel}
90     pip2 install -I dist/%{python2_wheelname} --root %{buildroot} --strip-file-prefix %{buildroot}
91     %else
92 philippem 458721 %{__python} setup.py install -O1 --skip-build --root %{buildroot}
93 philippem 625238 %endif
94 philippem 458721
95    
96 joequant 329022 %files
97 philippem 458721 %doc LICENSE.txt PKG-INFO docs
98     %attr(755,root,root) %{_bindir}/pip
99 philippem 617149 %attr(755,root,root) %{_bindir}/pip2*
100 philippem 458721 %{python_sitelib}/pip*
101    
102     %files -n python3-pip
103     %doc LICENSE.txt PKG-INFO docs
104 philippem 617149 %attr(755,root,root) %{_bindir}/pip3*
105 philippem 458721 %{python3_sitelib}/pip*
106    

  ViewVC Help
Powered by ViewVC 1.1.30