1 |
%define module pyzolib |
2 |
|
3 |
Name: python-%{module} |
4 |
Version: 0.3.3 |
5 |
Release: %mkrel 4 |
6 |
Summary: Provides basic functionality for the Pyzo environment |
7 |
License: BSD |
8 |
Group: Development/Python |
9 |
URL: http://bitbucket.org/pyzo/pyzolib |
10 |
Source0: https://pypi.python.org/packages/source/p/%{module}/%{module}-%{version}.tar.gz |
11 |
BuildArch: noarch |
12 |
BuildRequires: python-setuptools |
13 |
Requires: pyside |
14 |
|
15 |
%description |
16 |
The pyzolib package provides basic functionality for the Pyzo environment. |
17 |
It contains a collection of modules and small packages that should be |
18 |
imported as "from pyzolib import xxx" |
19 |
|
20 |
The packages currently are: |
21 |
* path - object oriented path processing (no more os.path.x) |
22 |
* paths - Get paths to useful directories in a cross platform manner. |
23 |
* qt - Proxy for importing QtCore et al. from PySide or PyQt4 |
24 |
* ssdf - the Simple Structured Data Format (for config files and scientific |
25 |
databases) |
26 |
* insertdocs - a sphynx pre-processor to include docstrings in the text, |
27 |
allowing readthedocs.org to host the docs without requiring importing code. |
28 |
* pyximport - for easy on the fly compilation of Cython, using the Pyzo |
29 |
environment to establish the location of a gcc compiler. |
30 |
* gccutils - used by the above to manage the gcc compiler. |
31 |
* interprerers - list the Python interpreters available on this system. |
32 |
* dllutils - utilities to set the RPATH in dynamic libararies and remove |
33 |
dependencies on the MSVCR from the embedded manifest. |
34 |
* shebang - for making shebangs in pyzo distro absolute. |
35 |
|
36 |
This is the Python 2 version of %{module}. |
37 |
|
38 |
#--------------------------------------------------------------------------- |
39 |
|
40 |
%package -n python3-%{module} |
41 |
Summary: Provides basic functionality for the Pyzo environment |
42 |
Group: Development/Python |
43 |
BuildArch: noarch |
44 |
BuildRequires: python3-setuptools |
45 |
Requires: python3-pyside |
46 |
|
47 |
%description -n python3-%{module} |
48 |
The pyzolib package provides basic functionality for the Pyzo environment. |
49 |
It contains a collection of modules and small packages that should be |
50 |
imported as "from pyzolib import xxx" |
51 |
|
52 |
The packages currently are: |
53 |
* path - object oriented path processing (no more os.path.x) |
54 |
* paths - Get paths to useful directories in a cross platform manner. |
55 |
* qt - Proxy for importing QtCore et al. from PySide or PyQt4 |
56 |
* ssdf - the Simple Structured Data Format (for config files and scientific |
57 |
databases) |
58 |
* insertdocs - a sphynx pre-processor to include docstrings in the text, |
59 |
allowing readthedocs.org to host the docs without requiring importing code. |
60 |
* pyximport - for easy on the fly compilation of Cython, using the Pyzo |
61 |
environment to establish the location of a gcc compiler. |
62 |
* gccutils - used by the above to manage the gcc compiler. |
63 |
* interprerers - list the Python interpreters available on this system. |
64 |
* dllutils - utilities to set the RPATH in dynamic libararies and remove |
65 |
dependencies on the MSVCR from the embedded manifest. |
66 |
* shebang - for making shebangs in pyzo distro absolute. |
67 |
|
68 |
This is the Python 3 version of %{module}. |
69 |
|
70 |
#--------------------------------------------------------------------------- |
71 |
|
72 |
%prep |
73 |
%setup -q -n %{module}-%{version} |
74 |
%apply_patches |
75 |
cp -a . %{py3dir} |
76 |
|
77 |
%build |
78 |
pushd %{py3dir} |
79 |
%{__python3} setup.py build |
80 |
popd |
81 |
|
82 |
%{__python} setup.py build |
83 |
|
84 |
%install |
85 |
pushd %{py3dir} |
86 |
%{__python3} setup.py install --root=%{buildroot} --skip-build |
87 |
popd |
88 |
|
89 |
%{__python} setup.py install --root=%{buildroot} --skip-build |
90 |
|
91 |
%files |
92 |
%{python_sitelib}/* |
93 |
|
94 |
%files -n python3-%{module} |
95 |
%{python3_sitelib}/* |