/[packages]/cauldron/python-repoze-sphinx-autointerface/current/SPECS/python-repoze-sphinx-autointerface.spec
ViewVC logotype

Contents of /cauldron/python-repoze-sphinx-autointerface/current/SPECS/python-repoze-sphinx-autointerface.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1289996 - (show annotations) (download)
Thu Sep 20 21:26:28 2018 UTC (5 years, 6 months ago) by umeabot
File size: 2439 byte(s)
Mageia 7 Mass Rebuild
1 %global pkgname repoze.sphinx.autointerface
2 %global srcname %(tr . - <<< %{pkgname})
3
4 Name: python-%{srcname}
5 Version: 0.8
6 Release: %mkrel 3
7 Group: Development/Python
8 Summary: Auto-generate Sphinx API docs from Zope interfaces
9
10 License: BSD
11 URL: https://github.com/repoze/%{pkgname}
12 Source0: https://github.com/repoze/%{pkgname}/archive/%{version}/%{pkgname}-%{version}.tar.gz
13 BuildArch: noarch
14
15 BuildRequires: pkgconfig(python2)
16 BuildRequires: python-setuptools
17 BuildRequires: python-sphinx
18 BuildRequires: python-zope-interface
19
20 BuildRequires: python3-devel
21 BuildRequires: python3-setuptools
22 BuildRequires: python3-sphinx
23 BuildRequires: python3-zope-interface
24
25 Requires: python-sphinx
26 Requires: python-zope-interface
27
28 %{?python_provide:%python_provide python-%{srcname}}
29
30 %global common_desc \
31 This package defines an extension for the Sphinx documentation system. \
32 The extension allows generation of API documentation by introspection of \
33 zope.interface instances in code.
34
35 %description
36 %{common_desc}
37
38 %package -n python3-%{srcname}
39 Group: Development/Python
40 Summary: Auto-generate Sphinx API docs from Zope interfaces
41 Requires: python3-sphinx
42 Requires: python3-zope-interface
43
44 %{?python_provide:%python_provide python3-%{srcname}}
45
46 %description -n python3-%{srcname}
47 %{common_desc}
48
49 %prep
50 %setup -q -c
51
52 cp -a %{pkgname}-%{version} python3-%{pkgname}-%{version}
53
54 %build
55
56 # Python 2 build
57 pushd %{pkgname}-%{version}
58 %py2_build
59 python2 %{_bindir}/rst2html --no-datestamp CHANGES.rst CHANGES.html
60 python2 %{_bindir}/rst2html --no-datestamp README.rst README.html
61 popd
62
63 # Python 3 build
64 pushd python3-%{pkgname}-%{version}
65 %py3_build
66 popd
67
68 %install
69
70 # Python 2 install
71 pushd %{pkgname}-%{version}
72 %py2_install
73 popd
74
75 # Python 3 install
76 pushd python3-%{pkgname}-%{version}
77 %py3_install
78 popd
79
80 %files
81 %doc %{pkgname}-%{version}/CHANGES.html %{pkgname}-%{version}/CONTRIBUTORS.txt
82 %doc %{pkgname}-%{version}/README.html
83 %license %{pkgname}-%{version}/COPYRIGHT.txt %{pkgname}-%{version}/LICENSE.txt
84 %{python2_sitelib}/*
85
86 %files -n python3-%{srcname}
87 %doc %{pkgname}-%{version}/CHANGES.html %{pkgname}-%{version}/CONTRIBUTORS.txt
88 %doc %{pkgname}-%{version}/README.html
89 %license %{pkgname}-%{version}/COPYRIGHT.txt %{pkgname}-%{version}/LICENSE.txt
90 %{python3_sitelib}/*
91

  ViewVC Help
Powered by ViewVC 1.1.30