/[packages]/cauldron/python-repoze-sphinx-autointerface/current/SPECS/python-repoze-sphinx-autointerface.spec
ViewVC logotype

Contents of /cauldron/python-repoze-sphinx-autointerface/current/SPECS/python-repoze-sphinx-autointerface.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1104367 - (show annotations) (download)
Wed May 24 10:48:43 2017 UTC (6 years, 10 months ago) by mitya
File size: 2749 byte(s)
imported package python-repoze-sphinx-autointerface
1 %if 0%{?fedora} || 0%{?rhel} >= 8
2 %global with_py3 1
3 %endif
4
5 %global pkgname repoze.sphinx.autointerface
6 %global srcname %(tr . - <<< %{pkgname})
7
8 Name: python-%{srcname}
9 Version: 0.8
10 Release: 4%{?dist}
11 Summary: Auto-generate Sphinx API docs from Zope interfaces
12
13 License: BSD
14 URL: https://github.com/repoze/%{pkgname}
15 Source0: https://github.com/repoze/%{pkgname}/archive/%{version}/%{pkgname}-%{version}.tar.gz
16 BuildArch: noarch
17
18 BuildRequires: python2-devel
19 BuildRequires: python2-setuptools
20 BuildRequires: python2-sphinx
21 BuildRequires: python-zope-interface
22
23 %if 0%{?with_py3}
24 BuildRequires: python3-devel
25 BuildRequires: python3-setuptools
26 BuildRequires: python3-sphinx
27 BuildRequires: python3-zope-interface
28 %endif
29
30 %global common_desc \
31 This package defines an extension for the Sphinx documentation system. \
32 The extension allows generation of API documentation by introspection of \
33 zope.interface instances in code.
34
35 %description
36 %{common_desc}
37
38 %package -n python2-%{srcname}
39 Summary: Auto-generate Sphinx API docs from Zope interfaces
40 Requires: python2-sphinx
41 Requires: python-zope-interface
42
43 %{?python_provide:%python_provide python2-%{srcname}}
44
45 %description -n python2-%{srcname}
46 %{common_desc}
47
48 %if 0%{?with_py3}
49 %package -n python3-%{srcname}
50 Summary: Auto-generate Sphinx API docs from Zope interfaces
51 Requires: python3-sphinx
52 Requires: python3-zope-interface
53
54 %{?python_provide:%python_provide python3-%{srcname}}
55
56 %description -n python3-%{srcname}
57 %{common_desc}
58 %endif
59
60 %prep
61 %setup -q -c
62
63 %if 0%{?with_py3}
64 cp -a %{pkgname}-%{version} python3-%{pkgname}-%{version}
65 %endif
66
67 %build
68 # Python 2 build
69 pushd %{pkgname}-%{version}
70 %py2_build
71 python2 %{_bindir}/rst2html --no-datestamp CHANGES.rst CHANGES.html
72 python2 %{_bindir}/rst2html --no-datestamp README.rst README.html
73 popd
74
75 %if 0%{?with_py3}
76 # Python 3 build
77 pushd python3-%{pkgname}-%{version}
78 %py3_build
79 popd
80 %endif
81
82 %install
83 # Python 2 install
84 pushd %{pkgname}-%{version}
85 %py2_install
86 popd
87
88 %if 0%{?with_py3}
89 # Python 3 install
90 pushd python3-%{pkgname}-%{version}
91 %py3_install
92 popd
93 %endif
94
95 %files -n python2-%{srcname}
96 %doc %{pkgname}-%{version}/CHANGES.html %{pkgname}-%{version}/CONTRIBUTORS.txt
97 %doc %{pkgname}-%{version}/README.html
98 %license %{pkgname}-%{version}/COPYRIGHT.txt %{pkgname}-%{version}/LICENSE.txt
99 %{python2_sitelib}/*
100
101 %if 0%{?with_py3}
102 %files -n python3-%{srcname}
103 %doc %{pkgname}-%{version}/CHANGES.html %{pkgname}-%{version}/CONTRIBUTORS.txt
104 %doc %{pkgname}-%{version}/README.html
105 %license %{pkgname}-%{version}/COPYRIGHT.txt %{pkgname}-%{version}/LICENSE.txt
106 %{python3_sitelib}/*
107 %endif
108

  ViewVC Help
Powered by ViewVC 1.1.30