/[packages]/cauldron/python-sympy/current/SPECS/python-sympy.spec
ViewVC logotype

Contents of /cauldron/python-sympy/current/SPECS/python-sympy.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 688373 - (show annotations) (download)
Tue Sep 16 20:19:28 2014 UTC (9 years, 7 months ago) by umeabot
File size: 3965 byte(s)
Mageia 5 Mass Rebuild
1 %define module sympy
2
3 Summary: Python library for symbolic mathematics
4 Name: python-%{module}
5 Version: 0.7.3
6 Release: %mkrel 6
7 Source0: https://github.com/%{module}/%{module}/releases/download/%{module}-%{version}/%{module}-%{version}.tar.gz
8 Source1: https://github.com/%{module}/%{module}/releases/download/%{module}-%{version}/%{module}-%{version}-py3.3.tar.gz
9 Patch0: sympy-0.7.3-strip-internal-mpmath.patch
10 License: BSD
11 Group: Development/Python
12 Url: http://sympy.googlecode.com/
13 Requires: python-numpy
14 Requires: python-mpmath
15 Requires: python-matplotlib
16 Recommends: python-gmpy >= 1.03, python-pyglet
17 BuildRequires: python-devel
18 BuildRequires: python-sphinx
19 BuildRequires: python-mpmath
20 BuildArch: noarch
21
22 %description
23 SymPy is a Python library for symbolic mathematics. It aims to become
24 a full-featured computer algebra system (CAS) while keeping the code
25 as simple as possible in order to be comprehensible and easily
26 extensible. SymPy is written entirely in Python and does not require
27 any external libraries, except optionally for plotting support.
28
29 %package texmacs
30 Summary: TeXmacs integration for sympy
31 Group: Development/Python
32 Requires: %{name} = %{version}-%{release}, TeXmacs
33
34 %description texmacs
35 This package contains a TeXmacs plugin for sympy.
36
37 %package examples
38 Summary: Sympy examples
39 Group: Development/Python
40 Requires: %{name} = %{version}-%{release}
41
42 %description examples
43 This package contains example input for sympy.
44
45 %package doc
46 Summary: Documentation for sympy
47 Group: Development/Python
48
49 %description doc
50 man and HTML documentation for sympy.
51
52 %package -n python3-%{module}
53 Summary: Python 3 library for symbolic mathematics
54 Group: Development/Python
55 BuildRequires: python3-devel
56 BuildRequires: python3-mpmath
57 Requires: python3-numpy
58 Requires: python3-mpmath
59 Requires: python3-matplotlib
60
61 %description -n python3-%{module}
62 SymPy is a Python 3 library for symbolic mathematics. It aims to become
63 a full-featured computer algebra system (CAS) while keeping the code
64 as simple as possible in order to be comprehensible and easily
65 extensible. SymPy is written entirely in Python 3 and does not require
66 any external libraries, except optionally for plotting support.
67
68 %prep
69 %setup -q -n %{module}-%{version}
70 %patch0 -b .mpmath
71 rm -rf sympy/mpmath doc/src/modules/mpmath
72 mkdir %{py3dir}
73 pushd %{py3dir}
74 gzip -dc %{SOURCE1} | tar -xvvf -
75 popd
76
77 %build
78 %{__python} setup.py build
79
80 pushd doc
81 make html
82 popd
83
84 pushd %{py3dir}/%{module}-%{version}
85 rm sympy/mpmath/libmp/exec_py2.py
86 %{__python3} setup.py build
87 popd
88
89 %install
90 pushd %{py3dir}/%{module}-%{version}
91 %{__python3} setup.py install -O1 --skip-build --root %{buildroot}
92 mv %{buildroot}%{_bindir}/isympy %{buildroot}%{_bindir}/python3-isympy
93 popd
94
95 %{__python} setup.py install -O1 --skip-build --root %{buildroot}
96 # Remove extra files
97 rm -f %{buildroot}%{_bindir}/{,doc}test
98
99 # Install the TeXmacs integration
100 cp -p data/TeXmacs/bin/tm_sympy %{buildroot}%{_bindir}
101 mkdir -p %{buildroot}%{_datadir}/TeXmacs/plugins/sympy
102 cp -a data/TeXmacs/progs %{buildroot}%{_datadir}/TeXmacs/plugins/sympy
103
104 # Don't let an executable script go into the documentation
105 chmod a-x examples/all.py
106
107 # Install the HTML documentation
108 mkdir -p %{buildroot}%{_docdir}/%{name}-doc
109 cp -a doc/_build/html %{buildroot}%{_docdir}/%{name}-doc
110 rm -f %{buildroot}%{_docdir}/%{name}-doc/html/.buildinfo
111 rm -fr %{buildroot}%{_docdir}/%{name}-doc/i18n
112
113 %files
114 %doc AUTHORS LICENSE PKG-INFO
115 %{python_sitelib}/sympy/
116 %{python_sitelib}/sympy-%{version}-*.egg-info
117 %{_bindir}/isympy
118
119 %files texmacs
120 %doc data/TeXmacs/LICENSE
121 %{_bindir}/tm_sympy
122 %{_datadir}/TeXmacs/plugins/sympy/
123
124 %files examples
125 %doc examples
126
127 %files doc
128 %docdir %{_docdir}/%{name}-doc/html
129 %{_docdir}/%{name}-doc/html
130 %{_mandir}/man1/isympy.1*
131
132 %files -n python3-%{module}
133 %doc AUTHORS LICENSE PKG-INFO
134 %{python3_sitelib}/sympy/
135 %{python3_sitelib}/sympy-%{version}-*.egg-info
136 %{_bindir}/python3-isympy
137

  ViewVC Help
Powered by ViewVC 1.1.30