/[packages]/cauldron/python-tempita/current/SPECS/python-tempita.spec
ViewVC logotype

Contents of /cauldron/python-tempita/current/SPECS/python-tempita.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 688378 - (show annotations) (download)
Tue Sep 16 20:19:37 2014 UTC (9 years, 7 months ago) by umeabot
File size: 1767 byte(s)
Mageia 5 Mass Rebuild
1 %define tarname Tempita
2
3 Summary: A very small text templating language
4 Name: python-tempita
5 Version: 0.5.2
6 Release: %mkrel 3
7 Source0: https://pypi.python.org/packages/source/T/%{tarname}/%{tarname}-%{version}.tar.gz
8 License: MIT
9 Group: Development/Python
10 URL: http://pythonpaste.org/tempita/
11 BuildArch: noarch
12 BuildRequires: python-setuptools
13
14 %description
15 Tempita is a small templating language for text substitution.
16
17 This isn't meant to be the Next Big Thing in templating; it's just a
18 handy little templating language for when your project outgrows
19 string.Template or % substitution. It's small, it embeds Python in
20 strings, and it doesn't do much else.
21
22 %package -n python3-tempita
23 Summary: A very small text templating language
24 Group: Development/Python
25 BuildRequires: python3-setuptools
26
27 %description -n python3-tempita
28 Tempita is a small templating language for text substitution.
29
30 This isn't meant to be the Next Big Thing in templating; it's just a
31 handy little templating language for when your project outgrows
32 string.Template or % substitution. It's small, it embeds Python in
33 strings, and it doesn't do much else.
34 This package contains the Tempita module built for use with python3.
35
36 %prep
37 %setup -q -n %{tarname}-%{version}
38 rm -rf *.egg-info
39 rm -rf %{py3dir}
40 cp -a . %{py3dir}
41
42 %build
43 CFLAGS="%{optflags}" %{__python} setup.py build
44
45 pushd %{py3dir}
46 CFLAGS="%{optflags}" %{__python3} setup.py build
47 popd
48
49 %install
50 pushd %{py3dir}
51 %{__python3} setup.py install --skip-build --root %{buildroot}
52 popd
53
54 %{__python} setup.py install --skip-build --root %{buildroot}
55
56 %files
57 %{python_sitelib}/tempita
58 %{python_sitelib}/Tempita-%{version}*.egg-info
59
60 %files -n python3-tempita
61 %{python3_sitelib}/tempita
62 %{python3_sitelib}/Tempita-%{version}*.egg-info
63
64

  ViewVC Help
Powered by ViewVC 1.1.30