/[packages]/cauldron/python-test/current/SPECS/python-test.spec
ViewVC logotype

Annotation of /cauldron/python-test/current/SPECS/python-test.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 329025 - (hide annotations) (download)
Sun Dec 9 07:00:00 2012 UTC (11 years, 4 months ago) by joequant
File size: 1247 byte(s)
imported package python-test
1 joequant 329025 # Created by pyp2rpm-1.0.0
2     %global pypi_name pytest
3     %define version 2.3.4
4    
5     Name: python-test
6     Version: %{version}
7     Release: %mkrel 1
8     Group: Development/Python
9     Summary: py.test: simple powerful testing with Python
10    
11     License: MIT
12     URL: TODO:
13     Source0: http://pypi.python.org/packages/source/p/pytest/pytest-%{version}.zip
14     BuildArch: noarch
15    
16     BuildRequires: python-devel
17     BuildRequires: python-sphinx
18    
19     Requires: python-py >= 1.4.12
20    
21     %description
22     The `py.test`` testing tool makes it easy to write small tests, yet
23     scales to support complex functional testing. It provides
24    
25     - auto-discovery of test modules and functions,
26     - detailed info on failing `assert statements
27    
28     %prep
29     %setup -q -n %{pypi_name}-%{version}
30     # Remove bundled egg-info
31     rm -rf %{pypi_name}.egg-info
32    
33     # generate html docs
34     sphinx-build doc/en html
35     # remove the sphinx-build leftovers
36     rm -rf html/.{doctrees,buildinfo}
37    
38    
39     %build
40     %{__python} setup.py build
41    
42    
43     %install
44     %{__python} setup.py install --skip-build --root %{buildroot}
45    
46    
47     %files
48     %doc html README.txt LICENSE
49     %{_bindir}/py.test*
50     %{python_sitelib}/_%{pypi_name}
51     %{python_sitelib}/%{pypi_name}.py*
52     %{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30