/[packages]/cauldron/python-tinycss/current/SPECS/python-tinycss.spec
ViewVC logotype

Annotation of /cauldron/python-tinycss/current/SPECS/python-tinycss.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 548067 - (hide annotations) (download)
Wed Oct 30 20:31:19 2013 UTC (10 years, 5 months ago) by neoclust
File size: 1437 byte(s)
imported package python-tinycss
1 neoclust 548067 %global pypi_name tinycss
2     %global pypi_oname tinycss
3    
4     %define version 0.3
5     %define python3 1
6    
7     Name: python-%{pypi_name}
8     Version: %{version}
9     Release: %mkrel 1
10     Group: Development/Python
11     Summary: tinycss is a complete yet simple CSS parser for Python
12    
13     License: MIT
14     URL: http://pypi.python.org/pypi/%{pypi_name}
15     Source0: http://pypi.python.org/packages/source/c/%{pypi_oname}/%{pypi_oname}-%{version}.tar.gz
16    
17     BuildRequires: pkgconfig(python)
18     BuildRequires: python-setuptools
19    
20     %description
21     tinycss is a complete yet simple CSS parser for Python
22    
23     %if %python3
24     %package -n python3-%{pypi_name}
25     Summary: tinycss is a complete yet simple CSS parser for Python
26     Group: Development/Python
27    
28     BuildRequires: pkgconfig(python3)
29     BuildRequires: python3-setuptools
30    
31     %description -n python3-%{pypi_name}
32     tinycss is a complete yet simple CSS parser for Python
33     %endif
34    
35     %prep
36     %setup -q -n %{pypi_oname}-%{version}
37    
38     %apply_patches
39    
40     %if %python3
41     cp -a . %{py3dir}
42     %endif
43    
44     %build
45     %{__python} setup.py build
46    
47     %if %python3
48     pushd %{py3dir}
49     %{__python3} setup.py build
50     popd
51     %endif
52    
53     %install
54     %if %python3
55     pushd %{py3dir}
56     %{__python3} setup.py install --skip-build --root %{buildroot}
57     popd
58     %endif
59    
60     %{__python} setup.py install -O1 --skip-build --root %{buildroot}
61    
62     %files
63     %py_platsitedir/%{pypi_name}*
64    
65     %if %python3
66     %files -n python3-%{pypi_name}
67     %py3_platsitedir/%{pypi_name}*
68     %endif

  ViewVC Help
Powered by ViewVC 1.1.30