/[packages]/cauldron/python-twisted-core/current/SPECS/python-twisted-core.spec
ViewVC logotype

Contents of /cauldron/python-twisted-core/current/SPECS/python-twisted-core.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 688389 - (show annotations) (download)
Tue Sep 16 20:19:55 2014 UTC (9 years, 6 months ago) by umeabot
File size: 2076 byte(s)
Mageia 5 Mass Rebuild
1 %define mainver %(echo %{version} | sed -e 's/\\([0-9]*\\.[0-9]*\\)\\.[0-9]*/\\1/')
2 # we don't want to provide private python extension libs
3 %define _exclude_files_from_autoprov %{python_sitearch}/.*\\.so\\|%{python3_sitearch}/.*\\.so
4
5 %define module TwistedCore
6
7 Name: python-twisted-core
8 Version: 14.0.0
9 Release: %mkrel 2
10 Summary: Event-based framework for internet applications
11 License: MIT
12 Group: Development/Python
13 URL: http://twistedmatrix.com/projects/core/
14 Source0: http://twistedmatrix.com/Releases/Core/%{mainver}/%{module}-%{version}.tar.bz2
15 BuildRequires: python-devel
16 BuildRequires: python-zope-interface
17 # ovitters: pkgconfig(gobject-introspection-1.0) includes script to determine typelib() auto buildrequires
18 BuildRequires: pkgconfig(gobject-introspection-1.0)
19
20 Requires: pycrypto
21 Requires: python-OpenSSL
22 Requires: python-zope-interface
23 Requires: python-gi
24
25 Conflicts: python-twisted < 2.0.0
26 Obsoletes: python-twisted-core-doc < 13.1.0-6
27
28 %description
29 Twisted is a framework, written in Python, for writing networked
30 applications. It includes implementations of a number of commonly used
31 network services such as a web server, an IRC chat server, a mail
32 server, a relational database interface and an object broker. Developers
33 can build applications using all of these services as well as custom
34 services that they write themselves. Twisted also includes a user
35 authentication system that controls access to services and provides
36 services with user context information to implement their own security
37 models.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %{__python} setup.py build
44
45 %install
46 %{__python} setup.py install --root=%{buildroot} --skip-build
47
48 # no need for c source code
49 find %{buildroot}%{python_sitearch}/twisted -type f -name '*.c' | xargs rm -f
50
51
52 %files
53 %doc CREDITS LICENSE NEWS README ChangeLog.Old
54 %{_bindir}/*
55 %dir %{python_sitearch}/twisted
56 %{python_sitearch}/twisted/*
57 %{python_sitearch}/Twisted_Core-%{version}-py%{pyver}.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30