/[packages]/cauldron/python-urlgrabber/current/SPECS/python-urlgrabber.spec
ViewVC logotype

Contents of /cauldron/python-urlgrabber/current/SPECS/python-urlgrabber.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 688403 - (show annotations) (download)
Tue Sep 16 20:20:19 2014 UTC (9 years, 7 months ago) by umeabot
File size: 1907 byte(s)
Mageia 5 Mass Rebuild
1 %define oname urlgrabber
2
3 Summary: A high-level cross-protocol url-grabber
4 Name: python-%oname
5 Version: 3.10.1
6 Release: %mkrel 3
7 Source0: http://urlgrabber.baseurl.org/download/%{oname}-%{version}.tar.gz
8 License: LGPLv2+
9 Group: Development/Python
10 Url: http://urlgrabber.baseurl.org/
11 BuildRequires: python-devel
12 BuildRequires: python-curl
13 BuildArch: noarch
14 Requires: python-curl
15
16 %description
17 A high-level cross-protocol url-grabber.
18
19 Using urlgrabber, data can be fetched in three basic ways:
20
21 urlgrab(url) copy the file to the local filesystem
22 urlopen(url) open the remote file and return a file object (like
23 urllib2.urlopen)
24 urlread(url) return the contents of the file as a string
25
26 When using these functions (or methods), urlgrabber supports the following
27 features:
28
29 * identical behavior for http://, ftp://, and file:// urls
30 * http keepalive - faster downloads of many files by using only a single
31 connection
32 * byte ranges - fetch only a portion of the file
33 * reget - for a urlgrab, resume a partial download
34 * progress meters - the ability to report download progress automatically,
35 even when using urlopen!
36 * throttling - restrict bandwidth usage
37 * retries - automatically retry a download if it fails. The number of retries
38 and failure types are configurable.
39 * authenticated server access for http and ftp
40 * proxy support - support for authenticated http and ftp proxies
41 * mirror groups - treat a list of mirrors as a single source, automatically
42 switching mirrors if there is a failure.
43
44
45 %prep
46 %setup -q -n %oname-%version
47
48 %build
49 %{__python} setup.py build
50
51 %install
52 rm -rf %buildroot installed-docs
53 %{__python} setup.py install --root=%{buildroot}
54 mv %buildroot%_datadir/doc/%oname-%version/ installed-docs
55
56
57 %files
58 %doc installed-docs/*
59 %{_bindir}/%oname
60 %{_libexecdir}/urlgrabber-ext-down
61 %{python_sitelib}/%oname/
62 %{python_sitelib}/*.egg-info

  ViewVC Help
Powered by ViewVC 1.1.30