/[packages]/cauldron/python-which/current/SPECS/python-which.spec
ViewVC logotype

Contents of /cauldron/python-which/current/SPECS/python-which.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 688423 - (show annotations) (download)
Tue Sep 16 20:20:53 2014 UTC (9 years, 7 months ago) by umeabot
File size: 1184 byte(s)
Mageia 5 Mass Rebuild
1 Name: python-which
2 Version: 1.1.0
3 Release: %mkrel 12
4 Summary: Small which replacement that can be used as a Python module
5
6 Group: Development/Python
7 License: MIT
8 URL: http://trentm.com/projects/which/
9 Source0: http://trentm.com/downloads/which/%{version}/which-%{version}.zip
10
11 BuildArch: noarch
12 BuildRequires: python
13 BuildRequires: python-devel
14
15 %description
16 which.py is a small which replacement. It has the following features:
17
18 * it can print all matches on the PATH;
19 * it can note "near misses" on the PATH (e.g. files that match but
20 may not, say, have execute permissions); and
21 * it can be used as a Python module.
22
23
24 %prep
25 %setup -q -n which-%{version}
26
27
28 %build
29 %{__python} setup.py build
30
31
32 %install
33 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
34 # add a script that calls the python module
35 cat << \EOF > which-python
36 #!/bin/sh
37 python -m which $@
38 EOF
39 mkdir -p $RPM_BUILD_ROOT%{_bindir}
40 install -m0755 -p which-python $RPM_BUILD_ROOT%{_bindir}
41
42
43 %files
44 %doc LICENSE.txt README.txt TODO.txt
45 %{_bindir}/which-python
46 %{python_sitelib}/which.py*
47 %{python_sitelib}/which-*.egg-info
48
49
50
51

  ViewVC Help
Powered by ViewVC 1.1.30