/[packages]/cauldron/python-whoosh/current/SPECS/python-whoosh.spec
ViewVC logotype

Contents of /cauldron/python-whoosh/current/SPECS/python-whoosh.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 730936 - (show annotations) (download)
Sun Sep 28 08:30:06 2014 UTC (9 years, 6 months ago) by dglent
File size: 2089 byte(s)
imported package python-whoosh
1 %global mod_name Whoosh
2
3 Name: python-whoosh
4 Version: 2.5.7
5 Release: %mkrel 1
6 Summary: Fast, pure-Python full text indexing, search, and spell checking library
7 License: BSD
8 URL: http://pythonhosted.org/Whoosh/
9 Source0: https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
10 BuildArch: noarch
11 BuildRequires: python-devel
12 BuildRequires: python-setuptools
13 BuildRequires: python-nose
14 BuildRequires: python-sphinx
15
16 %description
17 Whoosh is a fast, featureful full-text indexing and searching library
18 implemented in pure Python. Programmers can use it to easily add search
19 functionality to their applications and websites. Every part of how Whoosh
20 works can be extended or replaced to meet your needs exactly.
21
22 %package -n python3-whoosh
23 Summary: Fast, pure-Python full text indexing, search, and spell checking library
24 BuildArch: noarch
25 BuildRequires: python3-devel
26 BuildRequires: python3-setuptools
27 BuildRequires: python3-nose
28 BuildRequires: python3-sphinx
29
30 %description -n python3-whoosh
31 Whoosh is a fast, featureful full-text indexing and searching library
32 implemented in pure Python. Programmers can use it to easily add search
33 functionality to their applications and websites. Every part of how Whoosh
34 works can be extended or replaced to meet your needs exactly.
35
36 %prep
37 %setup -q -n %{mod_name}-%{version}
38 cp -a . %{py3dir}
39
40 %build
41 %{__python} setup.py build
42 sphinx-build docs/source docs/html
43 rm -f docs/html/.buildinfo
44 rm -rf docs/html/.doctrees
45
46 pushd %{py3dir}
47 %{__python3} setup.py build
48 sphinx-build docs/source docs/html
49 rm -f docs/html/.buildinfo
50 rm -rf docs/html/.doctrees
51 popd
52
53 %install
54 %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
55
56 pushd %{py3dir}
57 %{__python3} setup.py install --skip-build --root %{buildroot}
58 popd
59
60 %files
61 %doc docs/html/ README.txt LICENSE.txt
62 %{python_sitelib}/*.egg-info/
63 %{python_sitelib}/whoosh
64
65 %files -n python3-whoosh
66 %doc docs/html/ README.txt LICENSE.txt
67 %{python3_sitelib}/*.egg-info/
68 %{python3_sitelib}/whoosh
69
70

Properties

Name Value
svn:executable *

  ViewVC Help
Powered by ViewVC 1.1.30