1 |
%define version 2.7.0 |
2 |
%define prerel beta2 |
3 |
%define rel 1 |
4 |
|
5 |
%if %prerel |
6 |
%define srcname %{name}-%{version}%prerel |
7 |
%define release %mkrel 0.%prerel.%rel |
8 |
%else |
9 |
%define srcname %{name}-%{version} |
10 |
%define release %mkrel %rel |
11 |
%endif |
12 |
|
13 |
%define build_nox 1 |
14 |
|
15 |
Name: qbittorrent |
16 |
Version: %{version} |
17 |
Release: %{release} |
18 |
Summary: A lightweight but featureful BitTorrent client |
19 |
Group: Networking/File transfer |
20 |
License: GPLv2+ |
21 |
Url: http://qbittorrent.sourceforge.net/ |
22 |
%if %prerel |
23 |
Source0: http://downloads.sourceforge.net/project/qbittorrent/qbittorrent-unstable/%{name}-%{version}%{prerel}.tar.gz |
24 |
%else |
25 |
Source0: http://downloads.sourceforge.net/project/qbittorrent/qbittorrent/qbittorrent-%{version}/qbittorrent-%{version}.tar.gz |
26 |
%endif |
27 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot |
28 |
BuildRequires: qt4-devel >= 4:4.6 |
29 |
BuildRequires: boost-devel |
30 |
BuildRequires: libtorrent-rasterbar-devel >= 0.14.4 |
31 |
BuildRequires: libnotify-devel >= 0.4.2 |
32 |
Requires: python |
33 |
Requires: geoip |
34 |
|
35 |
%description |
36 |
A lightweight but feature-full BitTorrent client that aims to be very easy |
37 |
to use. It is multi-platform and provides a Qt4 graphical interface. |
38 |
|
39 |
%package -n %{name}-nox |
40 |
Summary: A Headless Bittorrent Client |
41 |
Group: Networking/File transfer |
42 |
|
43 |
%description -n %{name}-nox |
44 |
A Headless Bittorrent Client with a feature rich Web UI allowing users to |
45 |
control the clinet remotely. |
46 |
|
47 |
%prep |
48 |
%setup -q -n %{srcname} -a 0 |
49 |
|
50 |
%build |
51 |
%setup_compile_flags |
52 |
|
53 |
# build the headless part aka nox |
54 |
%if %build_nox |
55 |
pushd %{srcname} |
56 |
./configure \ |
57 |
--prefix=%{_prefix} \ |
58 |
--qtdir=%{qt4dir} \ |
59 |
--disable-gui \ |
60 |
--disable-libnotify \ |
61 |
--disable-geoip-database |
62 |
%make |
63 |
popd |
64 |
%endif |
65 |
|
66 |
# build the GUI |
67 |
./configure \ |
68 |
--prefix=%{_prefix} \ |
69 |
--qtdir=%{qt4dir} |
70 |
%make |
71 |
|
72 |
%install |
73 |
rm -rf %{buildroot} |
74 |
|
75 |
# install headless part |
76 |
%if %build_nox |
77 |
pushd %{srcname} |
78 |
make INSTALL_ROOT=%{buildroot} install |
79 |
popd |
80 |
%endif |
81 |
|
82 |
# install gui |
83 |
make INSTALL_ROOT=%{buildroot} install |
84 |
|
85 |
%clean |
86 |
rm -rf %{buildroot} |
87 |
|
88 |
%files |
89 |
%defattr(-,root,root,-) |
90 |
%doc AUTHORS Changelog COPYING NEWS README TODO |
91 |
%{_bindir}/%{name} |
92 |
%{_datadir}/applications/qBittorrent.desktop |
93 |
%{_iconsdir}/hicolor/*/apps/%{name}.png |
94 |
%{_mandir}/man1/%{name}.1* |
95 |
|
96 |
%if %build_nox |
97 |
%files -n %{name}-nox |
98 |
%defattr(-,root,root,-) |
99 |
%{_bindir}/%{name}-nox |
100 |
%{_mandir}/man1/%{name}-nox.1* |
101 |
%endif |