/[packages]/cauldron/qt4/current/SPECS/qt4.spec
ViewVC logotype

Contents of /cauldron/qt4/current/SPECS/qt4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 16736 - (show annotations) (download)
Thu Jan 13 23:46:57 2011 UTC (13 years, 3 months ago) by blino
File size: 32488 byte(s)
remove unneeded distro name in comment

1 %define _default_patch_fuzz 1
2 %define _disable_exceptions 1
3
4 %bcond_without postgres
5 %bcond_without mysql
6 %bcond_without sqlite
7 %bcond_without tds
8 %bcond_without cups
9 %bcond_without qvfb
10 %bcond_without docs
11
12 %bcond_with odbc
13 %bcond_with debug
14 %bcond_with ibase
15 %bcond_with local_phonon_package
16
17 #git clone git://gitorious.org/+kde-developers/qt/kde-qt.git
18 #cd kde-qt
19 #git archive --format=tar --prefix=kde-qt-everywhere-opensource-src-4.6.2/ master | bzip2 >/tmp/kde-qt-everywhere-opensource-src-4.6.2.tar.bz2
20 %define with_kde_qt 0
21 %define kdeqttarballdir kde-qt-everywhere-opensource-src-%{qtversion}
22 %define with_qt_snapshot 0
23
24 %define qtmajor 4
25 %define qtminor 7
26 %define qtsubminor 1
27
28 %define qtversion %{qtmajor}.%{qtminor}.%{qtsubminor}
29
30 %define libqt %mklibname qt %qtmajor
31 %define libqtdevel %mklibname qt %qtmajor -d
32 %define libqt3support %mklibname qt3support %qtmajor
33 %define libqtcore %mklibname qtcore %qtmajor
34 %define libqtdesigner %mklibname qtdesigner %qtmajor
35 %define libqtgui %mklibname qtgui %qtmajor
36 %define libqtnetwork %mklibname qtnetwork %qtmajor
37 %define libqtopengl %mklibname qtopengl %qtmajor
38 %define libqtsql %mklibname qtsql %qtmajor
39 %define libqtxml %mklibname qtxml %qtmajor
40 %define libqtscripttools %mklibname qtscripttools %qtmajor
41 %define libqtxmlpatterns %mklibname qtxmlpatterns %qtmajor
42 %define libqtsvg %mklibname qtsvg %qtmajor
43 %define libqttest %mklibname qttest %qtmajor
44 %define libqdbus %mklibname qtdbus %qtmajor
45 %define libqtscript %mklibname qtscript %qtmajor
46 %define libqtclucene %mklibname qtclucene %qtmajor
47 %define libqthelp %mklibname qthelp %qtmajor
48 %define libqtwebkit %mklibname qtwebkit %qtmajor
49 %define libqtmultimedia %mklibname qtmultimedia %qtmajor
50 %define libphonon %mklibname phonon %qtmajor
51 %define libqtdeclarative %mklibname qtdeclarative %qtmajor
52 %define qtlib qt4
53 %define qtdir %_prefix/lib/qt4
54 %define pluginsdir %_libdir/qt4/plugins
55 %define translationdir %qtdir/translations
56
57 %if %with_kde_qt
58 %define qttarballdir kde-qt-everywhere-opensource-src-%{qtversion}
59 %else
60 %define qttarballdir qt-everywhere-opensource-src-%{qtversion}
61 %endif
62 Name: %{qtlib}
63 Version: %{qtversion}
64 Release: %mkrel 5
65 Epoch: 4
66 Summary: Qt GUI toolkit
67 Group: Development/KDE and Qt
68 License: LGPLv2 with exceptions or GPLv3 with exceptions
69 URL: http://qt.nokia.com/
70 %if %with_kde_qt
71 Source0: http://get.qt.nokia.com/qt/source/%{kdeqttarballdir}.tar.bz2
72 Source6: qt-everywhere-opensource-src-doc-4.6.2.tar.bz2
73 %else
74 Source0: http://get.qt.nokia.com/qt/source/%{qttarballdir}.tar.gz
75 %endif
76 Source2: qt4.macros
77 Source3: mageia-designer-qt4.desktop
78 Source4: mageia-assistant-qt4.desktop
79 Source5: mageia-linguist-qt4.desktop
80 Patch0: qt-x11-opensource-src-4.6.0-qvfb.patch
81 Patch1: qt-everywhere-opensource-src-4.7.0-force-gb18030-for-gb2312.patch
82 Patch2: qt-everywhere-opensource-src-4.7.1-fix-str-fmt.patch
83 Patch4: qt-everywhere-opensource-src-4.6.1-add_missing_bold_style.diff
84 Patch5: qt-everywhere-opensource-src-4.6.1-use_ft_glyph_embolden_to_fake_bold.diff
85 #(nl): https://bugs.kde.org/180051
86 Patch6: qt-everywhere-opensource-src-4.6.1-improve-cups-support.patch
87 Patch7: qt-everywhere-opensource-src-gitc0887695-fix-QGraphicsView-crash.patch
88 Patch8: qt-everywhere-opensource-src-4.6.2-cups-QTBUG-6471.patch
89 Patch9: qt-everywhere-opensource-src-4.7.1-fix-crash-filtering-columns.patch
90 Patch10: qt-everywhere-opensource-src-4.7.1-fix-text-qtextcursor-crash-qt-bug-15857.patch
91
92 BuildRequires: libxtst-devel
93 BuildRequires: libxslt-devel
94 BuildRequires: libalsa-devel
95 BuildRequires: pulseaudio-devel
96 BuildRequires: GL-devel
97 BuildRequires: Mesa-common-devel
98 BuildRequires: zlib-devel
99 BuildRequires: openssl-devel
100 BuildRequires: libpng-devel
101 BuildRequires: libjpeg-devel
102 BuildRequires: libmng-devel
103 BuildRequires: lcms-devel
104 BuildRequires: cups-devel
105 BuildRequires: freetype2-devel
106 BuildRequires: libfontconfig-devel
107 BuildRequires: expat-devel
108 BuildRequires: libdbus-devel >= 0.92
109 BuildRequires: termcap-devel
110 BuildRequires: libpam-devel
111 BuildRequires: readline-devel
112 BuildRequires: perl
113 BuildRequires: glib2-devel
114 BuildRequires: libxml2-devel
115 BuildRequires: binutils >= 2.18
116 # For qtgtk style
117 BuildRequires: gtk+2-devel
118
119 Provides: %{qtlib}
120 BuildRoot: %{_tmppath}/%{name}-%{version}-root
121
122 %description
123 Qt is a GUI software toolkit which simplifies the task of writing and
124 maintaining GUI (Graphical User Interface) applications for the X
125 Window System. Qt is written in C++ and is fully object-oriented.
126
127 This package contains the shared library needed to run Qt
128 applications, as well as the README files for Qt.
129
130 #------------------------------------------------------------------------
131
132 %package common
133 Group: Development/KDE and Qt
134 Summary: config, language file for Qt
135
136 %description common
137 This package contains all config file and language file.
138
139 %files common
140 %defattr(-,root,root,-)
141 %attr(0755,root,root) %_sysconfdir/profile.d/*
142 %dir %{qtdir}
143 %dir %{qtdir}/bin
144 %dir %pluginsdir
145 %{qtdir}/phrasebooks
146 %if %with docs
147 %dir %{qtdir}/translations
148 %{qtdir}/translations/qt_*
149 %endif
150 %if %{with_kde_qt}
151 #%_docdir/%name/README.kde-qt
152 %endif
153
154 #------------------------------------------------------------------------
155 # CORE QT LIBRARIES
156 #-------------------------------------------------------------------------
157
158 %package -n %{libqtxml}
159 Summary: QT%{qtmajor} component library
160 Group: System/Libraries
161 Requires(pre): %{name}-common = %epoch:%version
162 Provides: qtxmllib = %epoch:%version
163
164 %description -n %{libqtxml}
165 QT%{qtmajor} component library.
166
167 %files -n %{libqtxml}
168 %defattr(-,root,root,-)
169 %_libdir/libQtXml.so.%{qtmajor}*
170
171 #-------------------------------------------------------------------------
172
173 %package -n %{libqtscripttools}
174 Summary: QT%{qtmajor} component library
175 Group: System/Libraries
176 Requires(pre): %{name}-common = %epoch:%version
177 Provides: qtscripttoolslib = %epoch:%version
178
179 %description -n %{libqtscripttools}
180 QT%{qtmajor} component library.
181
182 %files -n %{libqtscripttools}
183 %defattr(-,root,root,-)
184 %_libdir/libQtScriptTools.so.%{qtmajor}*
185
186 #-------------------------------------------------------------------------
187
188 %package -n %{libqtxmlpatterns}
189 Summary: QT%{qtmajor} component library
190 Group: System/Libraries
191 Requires(pre): %{name}-common = %epoch:%version
192 Requires: %{name}-xmlpatterns = %epoch:%version
193
194 %description -n %{libqtxmlpatterns}
195 QT%{qtmajor} component library.
196
197 %files -n %{libqtxmlpatterns}
198 %defattr(-,root,root,-)
199 %_libdir/libQtXmlPatterns.so.%{qtmajor}*
200
201 #-------------------------------------------------------------------------
202
203 %package -n %{libqtsql}
204 Summary: QT%{qtmajor} component library
205 Group: System/Libraries
206 Requires(pre): %{name}-common = %epoch:%version
207 Provides: qtsqllib = %epoch:%version
208
209 %description -n %{libqtsql}
210 QT%{qtmajor} component library.
211
212 %files -n %{libqtsql}
213 %defattr(-,root,root,-)
214 %_libdir/libQtSql.so.%{qtmajor}*
215
216 #-------------------------------------------------------------------------
217
218 %package -n %{libqtnetwork}
219 Summary: QT%{qtmajor} component library
220 Group: System/Libraries
221 Requires(pre): %{name}-common = %epoch:%version
222 Provides: qtnetworklib = %epoch:%version
223
224 %description -n %{libqtnetwork}
225 QT%{qtmajor} component library.
226
227 %files -n %{libqtnetwork}
228 %defattr(-,root,root,-)
229 %_libdir/libQtNetwork.so.%{qtmajor}*
230
231 #-------------------------------------------------------------------------
232
233 %package -n %{libqtscript}
234 Summary: QT%{qtmajor} component library
235 Group: System/Libraries
236 Requires(pre): %{name}-common = %epoch:%version
237 Provides: libqtscript = %epoch:%version
238
239 %description -n %{libqtscript}
240 QT%{qtmajor} component library.
241
242 %files -n %{libqtscript}
243 %defattr(-,root,root,-)
244 %_libdir/libQtScript.so.%{qtmajor}*
245 %pluginsdir/script
246
247 #-------------------------------------------------------------------------
248
249 %package -n %{libqtgui}
250 Summary: QT%{qtmajor} component library
251 Group: System/Libraries
252 Requires(pre): %{name}-common = %epoch:%version
253 Conflicts: %{libqtcore} <= 2:4.2.2-%mkrel 2
254 Provides: qtguilib = %epoch:%version
255
256 %description -n %{libqtgui}
257 QT%{qtmajor} component library.
258
259 %files -n %{libqtgui}
260 %defattr(-,root,root,-)
261 %_libdir/libQtGui.so.%{qtmajor}*
262 %pluginsdir/imageformats
263 %pluginsdir/inputmethods/libqimsw-multi.so*
264
265 #-------------------------------------------------------------------------
266
267 %package -n %{libqtsvg}
268 Summary: QT%{qtmajor} component library
269 Group: System/Libraries
270 Requires(pre): %{name}-common = %epoch:%version
271 Provides: qtsvglib = %epoch:%version
272
273 %description -n %{libqtsvg}
274 QT%{qtmajor} component library.
275
276 %files -n %{libqtsvg}
277 %defattr(-,root,root,-)
278 %_libdir/libQtSvg.so.%{qtmajor}*
279 %pluginsdir/iconengines/libqsvgicon.*
280
281 #-------------------------------------------------------------------------
282
283 %package -n %{libqttest}
284 Summary: QT%{qtmajor} component library
285 Group: System/Libraries
286 Requires(pre): %{name}-common = %epoch:%version
287 Provides: qttestlib = %epoch:%version
288
289 %description -n %{libqttest}
290 QT%{qtmajor} component library.
291
292 %files -n %{libqttest}
293 %defattr(-,root,root,-)
294 %_libdir/libQtTest.so.%{qtmajor}*
295
296 #-------------------------------------------------------------------------
297
298 %package -n %{libqtwebkit}
299 Summary: QT%{qtmajor} component library
300 Group: System/Libraries
301 Requires(pre): %{name}-common = %epoch:%version
302 Provides: qtwebkitlib = %epoch:%version
303
304 %description -n %{libqtwebkit}
305 QT%{qtmajor} component library.
306
307 %files -n %{libqtwebkit}
308 %defattr(-,root,root,-)
309 %_libdir/libQtWebKit.so.%{qtmajor}*
310
311 #-------------------------------------------------------------------------
312
313 %package -n %{libqthelp}
314 Summary: QT%{qtmajor} component library
315 Group: System/Libraries
316 Requires(pre): %{name}-common = %epoch:%version
317 Provides: qthelplib = %epoch:%version
318
319 %description -n %{libqthelp}
320 QT%{qtmajor} component library.
321
322 %files -n %{libqthelp}
323 %defattr(-,root,root,-)
324 %_libdir/libQtHelp.so.%{qtmajor}*
325
326 #-------------------------------------------------------------------------
327
328 %package -n %{libqtclucene}
329 Summary: QT%{qtmajor} component library
330 Group: System/Libraries
331 Requires(pre): %{name}-common = %epoch:%version
332 Provides: qtclucenelib = %epoch:%version
333
334 %description -n %{libqtclucene}
335 QT%{qtmajor} component library.
336
337 %files -n %{libqtclucene}
338 %defattr(-,root,root,-)
339 %_libdir/libQtCLucene.so.%{qtmajor}*
340
341 #-------------------------------------------------------------------------
342
343 %package -n %{libqtcore}
344 Summary: QT%{qtmajor} component library
345 Group: System/Libraries
346 Requires(pre): %{name}-common = %epoch:%version
347 Conflicts: %{libqtgui} <= 2:4.2.2-%mkrel 2
348 Provides: qtcorelib = %epoch:%version
349 Obsoletes: %{_lib}qtuitools4
350 Obsoletes: qt4-codecs-plugin-%_lib
351
352 %description -n %{libqtcore}
353 QT%{qtmajor} component library.
354
355 %files -n %{libqtcore}
356 %defattr(-,root,root,-)
357 %_libdir/libQtCore.so.%{qtmajor}*
358 %dir %pluginsdir/codecs
359 %pluginsdir/codecs/*.so*
360
361 #-------------------------------------------------------------------------
362
363 %package -n %{libqt3support}
364 Summary: QT%{qtmajor} component library
365 Group: System/Libraries
366 Requires(pre): %{name}-common = %epoch:%version
367 Provides: qt3supportlib = %epoch:%version
368
369 %description -n %{libqt3support}
370 QT%{qtmajor} component library.
371
372 %files -n %{libqt3support}
373 %defattr(-,root,root,-)
374 %_libdir/libQt3Support.so.%{qtmajor}*
375
376 #-------------------------------------------------------------------------
377
378 %package -n %{libqtopengl}
379 Summary: QT%{qtmajor} component library
380 Group: System/Libraries
381 Requires(pre): %{name}-common = %epoch:%version
382 Provides: qtopengllib = %epoch:%version
383
384 %description -n %{libqtopengl}
385 QT%{qtmajor} component library.
386
387 %files -n %{libqtopengl}
388 %defattr(-,root,root,-)
389 %_libdir/libQtOpenGL.so.%{qtmajor}*
390
391 #-------------------------------------------------------------------------
392
393 %package -n %{libqtdesigner}
394 Summary: QT%{qtmajor} component library
395 Group: System/Libraries
396 Requires(pre): %{name}-common = %epoch:%version
397 Provides: qtdesignerlib = %epoch:%version
398 # Had wrong major:
399 Obsoletes: %{_lib}qtdesigner1 < 2:4.3.4-4
400
401 %description -n %{libqtdesigner}
402 QT%{qtmajor} component library.
403
404 %files -n %{libqtdesigner}
405 %defattr(-,root,root,-)
406 %_libdir/libQtDesigner.so.%{qtmajor}*
407 %_libdir/libQtDesignerComponents.so.%{qtmajor}*
408
409 #-------------------------------------------------------------------------
410
411 %package -n %{libqdbus}
412 Summary: QT dbus lib
413 Group: System/Libraries
414 Requires(pre): %{name}-common = %epoch:%version
415 Provides: qdbuslib = %epoch:%version
416
417 %description -n %{libqdbus}
418 QT dbus lib.
419
420 %files -n %{libqdbus}
421 %defattr(-,root,root,-)
422 %_libdir/libQtDBus.so.%{qtmajor}*
423
424 #-------------------------------------------------------------------------
425
426 %package -n %{libqtmultimedia}
427 Summary: QT multimedia lib
428 Group: System/Libraries
429 Requires(pre): %{name}-common = %epoch:%version
430
431 %description -n %{libqtmultimedia}
432 QT multimedia lib.
433
434 %files -n %{libqtmultimedia}
435 %defattr(-,root,root,-)
436 %_libdir/libQtMultimedia.so.%{qtmajor}*
437
438 #-------------------------------------------------------------------------
439
440 %if %with local_phonon_package
441
442 %package -n %{libphonon}
443 Summary: QT phonon library
444 Group: System/Libraries
445 Requires(pre): %{name}-common = %epoch:%version
446
447 %description -n %{libphonon}
448 Qt phonon library.
449
450 %files -n %{libphonon}
451 %defattr(-,root,root,-)
452 %_libdir/libphonon.so.%{qtmajor}*
453
454 #-------------------------------------------------------------------------
455
456 %package -n phonon-gstreamer
457 Summary: QT phonon gstreamer backend
458 Group: System/Libraries
459 Provides: phonon-backend = %{epoch}:%{version}
460 BuildRequires: libgstreamer-devel
461 BuildRequires: libgstreamer-plugins-base-devel
462 Requires: gstreamer0.10-plugins-good
463 Requires: gstreamer0.10-pulse
464 Suggests: gstreamer0.10-ffmpeg
465 Suggests: gstreamer0.10-soup
466 %if %mdkversion >= 201000
467 Obsoletes: arts
468 Obsoletes: arts3
469 %endif
470
471 %description -n phonon-gstreamer
472 Qt phonon library.
473
474 %files -n phonon-gstreamer
475 %defattr(-,root,root,-)
476 %pluginsdir/phonon_backend/libphonon_gstreamer.so
477
478 %endif
479
480 #-------------------------------------------------------------------------
481
482 %package qtdbus
483 Summary: QT dbus binary
484 Group: Development/KDE and Qt
485 Requires(pre): %{libqdbus} >= 4:4.5.2
486
487 %description qtdbus
488 QT dbus binary.
489
490 %files qtdbus
491 %defattr(-,root,root,-)
492 %{qtdir}/bin/qdbus
493 %{qtdir}/bin/qdbusviewer
494
495 #-------------------------------------------------------------------------
496
497 %package -n %{libqtdeclarative}
498 Summary: QT phonon library
499 Group: System/Libraries
500 Requires(pre): %{name}-common = %epoch:%version
501
502 %description -n %{libqtdeclarative}
503 Qt phonon library.
504
505 %files -n %{libqtdeclarative}
506 %defattr(-,root,root,-)
507 %_libdir/libQtDeclarative.so.%{qtmajor}*
508
509 #-------------------------------------------------------------------------
510
511 %package qmlviewer
512 Summary: Qt4 qmlviewer utility
513 Group: Development/KDE and Qt
514
515 %description qmlviewer
516 Qt4 qmlviewer utility.
517
518 %files qmlviewer
519 %defattr(-,root,root,-)
520 %{qtdir}/bin/qmlviewer
521 %qtdir/imports/Qt
522 %qtdir/imports/QtWebKit/libqmlwebkitplugin.so
523 %qtdir/imports/QtWebKit/qmldir
524 %pluginsdir/bearer/libqgenericbearer.so
525 %pluginsdir/bearer/libqnmbearer.so
526 %pluginsdir/bearer/libqconnmanbearer.so
527 %pluginsdir/designer/libqdeclarativeview.so
528
529 #-------------------------------------------------------------------------
530
531 %package -n %{libqtdevel}
532 Summary: Development files for the Qt GUI toolkit
533 Group: Development/KDE and Qt
534 Requires: %{name}-common = %epoch:%version
535 Requires: qt4-qtconfig
536 Provides: qt4-devel = %epoch:%version-%release
537 Provides: libqt4-devel = %epoch:%version-%release
538 Obsoletes: %{mklibname -d QtWebKit} < %version
539 Conflicts: %{_lib}qtxml4 < 2:4.3.4-3
540 Conflicts: %{_lib}qtsql4 < 2:4.3.4-3
541 Conflicts: %{_lib}qtnetwork4 < 2:4.3.4-3
542 Conflicts: %{_lib}qtscript4 < 2:4.3.4-3
543 Conflicts: %{_lib}qtgui4 < 2:4.3.4-3
544 Conflicts: %{_lib}qtsvg4 < 2:4.3.4-3
545 Conflicts: %{_lib}qttest4 < 2:4.3.4-3
546 Conflicts: %{_lib}qtcore4 < 2:4.3.4-3
547 Conflicts: %{_lib}qt3support4 < 2:4.3.4-3
548 Conflicts: %{_lib}qtopengl4 < 2:4.3.4-3
549 Conflicts: %{_lib}qtdesigner1 < 2:4.3.4-3
550 Conflicts: %{_lib}qtdbus4 < 2:4.3.4-3
551 Conflicts: %{_lib}qassistant1 < 2:4.3.4-3
552 Conflicts: %{_lib}qttest4 < 2:4.3.4-3
553 Conflicts: %{_lib}qtcore4 < 2:4.3.4-3
554 Conflicts: qt4-linguist < 2:4.4.3-3
555 Requires: %{libqtdeclarative} = %epoch:%version
556 Requires: %{libqt3support} = %epoch:%version
557 Requires: %{libqt3support} = %epoch:%version
558 Requires: %{libqtcore} = %epoch:%version
559 Requires: %{libqtdesigner} = %epoch:%version
560 Requires: %{libqtgui} = %epoch:%version
561 Requires: %{libqtnetwork} = %epoch:%version
562 Requires: %{libqtopengl} = %epoch:%version
563 Requires: %{libqtsql} = %epoch:%version
564 Requires: %{libqtxml} = %epoch:%version
565 Requires: %{libqtscripttools} = %epoch:%version
566 Requires: %{libqtxmlpatterns} = %epoch:%version
567 Requires: %{libqtsvg} = %epoch:%version
568 Requires: %{libqtclucene} = %epoch:%version
569 Requires: %{libqttest} = %epoch:%version
570 Requires: %{libqdbus} = %epoch:%version
571 Requires: %{libqtwebkit} = %epoch:%version
572 Requires: %{libqtscript} = %epoch:%version
573 Requires: %{libqthelp} = %epoch:%version
574 Requires: %{libqtmultimedia} = %epoch:%version
575 %if %with local_phonon_package
576 Requires: %{libphonon} = %epoch:%version
577 %else
578 Requires: phonon-devel
579 %endif
580 Requires: qt4-qtdbus = %epoch:%version
581 Requires: qt4-designer-plugin-phonon = %epoch:%version
582 Requires: qt4-designer-plugin-webkit = %epoch:%version
583 Requires: qt4-designer-plugin-qt3support = %epoch:%version
584 Requires: mesaglu-devel
585 Requires: png-devel
586 Requires: jpeg-devel
587 Requires: make
588
589 %description -n %{libqtdevel}
590 The %{qtlib}-devel package contains the files necessary to develop
591 applications using the Qt GUI toolkit: the header files, the Qt
592 meta object compiler, and the static libraries. See the address
593 http://qt.nokia.com/ for more information about Qt.
594
595 Install %{qtlib}-devel if you want to develop GUI applications using the Qt
596 toolkit.
597
598 %post -n %{libqtdevel}
599 update-alternatives --install %_bindir/qmake qmake %qtdir/bin/qmake 20
600
601 %postun -n %{libqtdevel}
602 if ! [ -e %qtdir/bin/qmake ]; then
603 update-alternatives --remove qmake %qtdir/bin/qmake
604 fi
605
606 %files -n %{libqtdevel}
607 %defattr(-,root,root,-)
608 %{qtdir}/bin/moc*
609 %{qtdir}/bin/qmake*
610 %{qtdir}/bin/uic*
611 %{qtdir}/bin/rcc*
612 %{qtdir}/bin/qt3to4*
613 %{qtdir}/bin/pixeltool*
614 %{qtdir}/bin/lreleas*
615 %{qtdir}/bin/lupdat*
616 %{qtdir}/bin/qdbusxml2cpp
617 %{qtdir}/bin/qdbuscpp2xml
618 %{qtdir}/bin/xmlpatternsvalidator
619 %{qtdir}/bin/qttracereplay
620 %_sysconfdir/rpm/macros.d/*
621 %{qtdir}/include
622 %{qtdir}/mkspecs
623 %_libdir/*.so
624 %_libdir/*.la
625 %_libdir/*.a
626 %_libdir/*.prl
627 %_libdir/pkgconfig/*
628 %{qtdir}/q3porting.xml
629
630 #-------------------------------------------------------------------------
631
632 %package xmlpatterns
633 Summary: Qt4 xmlpatterns utility
634 Group: Development/KDE and Qt
635
636 %description xmlpatterns
637 Qt4 xmlpatterns utility.
638
639 %files xmlpatterns
640 %defattr(-,root,root,-)
641 %{qtdir}/bin/xmlpatterns
642
643 #-------------------------------------------------------------------------
644
645 %package qtconfig
646 Summary: Main Qt4 configuration utility
647 Group: Development/KDE and Qt
648 Conflicts: qt4-common <= 2:4.3.3
649
650 %description qtconfig
651 Main Qt 4.3 configuration utility.
652
653 %post qtconfig
654 update-alternatives --install %_bindir/qtconfig qtconfig %qtdir/bin/qtconfig 20
655
656 %postun qtconfig
657 if ! [ -e %qtdir/bin/qtconfig ]; then
658 update-alternatives --remove qtconfig %qtdir/bin/qtconfig
659 fi
660
661 %files qtconfig
662 %defattr(-,root,root,-)
663 %{qtdir}/bin/qtconf*
664 %if %with docs
665 %{qtdir}/translations/qtconfig*
666 %endif
667
668 #-------------------------------------------------------------------------
669
670 %if %with docs
671
672 %package doc
673 Summary: HTML Documentation for Qt version %{version}
674 Group: Books/Computer books
675 BuildArch: noarch
676
677 %description doc
678 HTML documentation for the Qt toolkit. To view the documentation,
679 please load up the file /usr/lib/%{qtlib}/doc/html/index.html in your
680 favourite browser.
681
682 %post doc
683 # Remove old qt4 doc directories
684 find %_docdir -maxdepth 1 -type d -name qt-4.\* -exec rm -rf {} \;
685
686 %files doc
687 %defattr(-,root,root,-)
688 %_docdir/%name/doc/html
689 %_docdir/%name/doc/qch
690
691 %endif
692
693 #-------------------------------------------------------------------------
694
695 %package examples
696 Summary: Example programs made with Qt version %{version}
697 Group: Books/Computer books
698 Obsoletes: qt4-tutorial
699 Obsoletes: %{name}-examples < 4:4.7.0-3
700
701 %description examples
702 Example programs made with Qt version %{version}.
703
704 %files examples
705 %defattr(-,root,root,-)
706 %{qtdir}/examples
707 %{qtdir}/demos
708
709 #-------------------------------------------------------------------------
710
711 %package linguist
712 Summary: QT linguist translation utility
713 Group: Books/Computer books
714 Requires(post): desktop-file-utils
715 Requires(postun): desktop-file-utils
716 Conflicts: %name-common <= 4.3.3-4
717
718 %description linguist
719 Qt Linguist provides easy translation of Qt GUIs to different.
720 languages
721
722 %files linguist
723 %defattr(-,root,root,-)
724 %{qtdir}/bin/lingu*
725 %{qtdir}/bin/lconvert*
726 %{_datadir}/applications/*linguist*.desktop
727 %if %with docs
728 %{qtdir}/translations/linguist*
729 %endif
730
731 #-------------------------------------------------------------------------
732
733 %package assistant
734 Summary: QT assistantion doc utility
735 Group: Books/Computer books
736 Requires: qt4-database-plugin-sqlite
737 Suggests: qt4-doc
738 Requires(post): desktop-file-utils
739 Requires(postun): desktop-file-utils
740 Conflicts: %name-common <= 4.3.3-4
741
742 %description assistant
743 Qt Assistant provides a documentation Browser.
744
745 %files assistant
746 %defattr(-,root,root,-)
747 %{qtdir}/bin/assistant*
748 %{qtdir}/bin/qcollectiongen*
749 %{qtdir}/bin/qhelpconv*
750 %{qtdir}/bin/qhelpgen*
751 %{_datadir}/applications/*assistant*.desktop
752 %if %with docs
753 %{qtdir}/translations/assistant*
754 %endif
755
756 #-------------------------------------------------------------------------
757
758 %if ! %without odbc
759
760 %package database-plugin-odbc
761 Summary: Database plugin for ODBC Qt support
762 Group: Development/KDE and Qt
763 Obsoletes: qt4-database-plugin-odbc-%_lib
764 BuildRequires: unixODBC-devel
765
766 %description database-plugin-odbc
767 Database plugin for ODBC Qt support.
768
769 %files database-plugin-odbc
770 %defattr(-,root,root,-)
771 %pluginsdir/sqldrivers/libqsqlodbc*
772
773 %endif
774
775 #-------------------------------------------------------------------------
776
777 %if ! %without mysql
778
779 %package database-plugin-mysql
780 Summary: Database plugin for mysql Qt support
781 Group: Development/KDE and Qt
782 Obsoletes: qt4-database-plugin-mysql-%_lib
783 BuildRequires: mysql-devel
784
785 %description database-plugin-mysql
786 Database plugin for mysql Qt support.
787
788 %files database-plugin-mysql
789 %defattr(-,root,root,-)
790 %pluginsdir/sqldrivers/libqsqlmysql*
791
792 %endif
793
794 #-------------------------------------------------------------------------
795
796 %if ! %without sqlite
797
798 %package database-plugin-sqlite
799 Summary: Database plugin for sqlite Qt support
800 Group: Databases
801 Obsoletes: qt4-database-plugin-sqlite-%_lib
802 BuildRequires: sqlite3-devel
803
804 %description database-plugin-sqlite
805 Database plugin for sqlite Qt support.
806
807 %files database-plugin-sqlite
808 %defattr(-,root,root,-)
809 %pluginsdir/sqldrivers/libqsqlite*
810 %endif
811
812 #-------------------------------------------------------------------------
813
814 %if ! %without tds
815
816 %package database-plugin-tds
817 Summary: Database plugin for freetds Qt support
818 Group: Databases
819 Obsoletes: qt4-database-plugin-tds-%_lib
820 BuildRequires: freetds-devel
821
822 %description database-plugin-tds
823 Database plugin for freetds Qt support.
824
825 %files database-plugin-tds
826 %defattr(-,root,root,-)
827 %pluginsdir/sqldrivers/libqsqltds*
828
829 %endif
830
831 #-------------------------------------------------------------------------
832
833 %if %with ibase
834
835 %package database-plugin-ibase
836 Summary: Database plugin for interbase Qt support
837 Group: Development/KDE and Qt
838 Obsoletes: qt4-database-plugin-ibase-%_lib
839 BuildRequires: firebird-devel
840
841 %description database-plugin-ibase
842 Database plugin for interbase Qt support.
843
844 %files database-plugin-ibase
845 %defattr(-,root,root,-)
846 %pluginsdir/sqldrivers/libqsqlibase*
847 %endif
848
849 #-------------------------------------------------------------------------
850
851 %if ! %without postgres
852
853 %package database-plugin-pgsql
854 Summary: Database plugin for pgsql Qt support
855 Group: Development/KDE and Qt
856 Obsoletes: qt4-database-plugin-pgsql-%_lib
857 BuildRequires: postgresql-devel
858 BuildRequires: libpq-devel
859
860 %description database-plugin-pgsql
861 Database plugin for pgsql Qt support.
862
863 %files database-plugin-pgsql
864 %defattr(-,root,root,-)
865 %pluginsdir/sqldrivers/libqsqlpsql*
866
867 %endif
868
869 #-------------------------------------------------------------------------
870
871 %package graphicssystems-plugin
872 Summary: Graphicssystems plugins for Qt4
873 Group: Development/KDE and Qt
874 Obsoletes: qt4-graphicssystems-plugin-%_lib
875
876 %description graphicssystems-plugin
877 Graphicssystems plugins for Qt4.
878
879 %files graphicssystems-plugin
880 %defattr(-,root,root,-)
881 %dir %pluginsdir/graphicssystems
882 %pluginsdir/graphicssystems/*
883
884 #-------------------------------------------------------------------------
885
886 %package accessibility-plugin
887 Summary: Accessibility plugins for Qt4
888 Group: Development/KDE and Qt
889 Obsoletes: qt4-accessibility-plugin-%_lib
890
891 %description accessibility-plugin
892 Acessibility plugins for Qt4.
893
894 %files accessibility-plugin
895 %defattr(-,root,root,-)
896 %dir %pluginsdir/accessible
897 %pluginsdir/accessible/*
898
899 #-------------------------------------------------------------------------
900
901 %package designer
902 Summary: %{qtlib} visual design tool
903 Group: Development/KDE and Qt
904 Requires: %{libqtdevel} = %epoch:%version
905 Conflicts: %name-common <= 4.3.3-4
906
907 %description designer
908 The Qt Designer is a visual design tool that makes designing and
909 implementing user interfaces a lot easier.
910
911 %files designer
912 %defattr(-,root,root,-)
913 %{qtdir}/bin/design*
914 %{_datadir}/applications/*designer*.desktop
915 %if %with docs
916 %{qtdir}/translations/designer_*
917 %endif
918
919 #-------------------------------------------------------------------------
920
921 %package designer-plugin-phonon
922 Summary: designer plugin for phonon Qt support
923 Group: Development/KDE and Qt
924
925 %description designer-plugin-phonon
926 designer plugin for phonon Qt support.
927
928 %files designer-plugin-phonon
929 %defattr(-,root,root,-)
930 %pluginsdir/designer/libphonon*
931
932 #-------------------------------------------------------------------------
933
934 %package designer-plugin-webkit
935 Summary: designer plugin for webkit Qt support
936 Group: Development/KDE and Qt
937
938 %description designer-plugin-webkit
939 designer plugin for webkit Qt support.
940
941 %files designer-plugin-webkit
942 %defattr(-,root,root,-)
943 %pluginsdir/designer/libqwebview*
944
945 #-------------------------------------------------------------------------
946
947 %package designer-plugin-qt3support
948 Summary: designer plugin for qt3support Qt support
949 Group: Development/KDE and Qt
950
951 %description designer-plugin-qt3support
952 designer plugin for qt3support Qt support.
953
954 %files designer-plugin-qt3support
955 %defattr(-,root,root,-)
956 %pluginsdir/designer/libqt3supportwidget*
957
958 #-------------------------------------------------------------------------
959
960 %if ! %without qvfb
961
962 %package qvfb
963 Summary: %{qtlib} embedded virtual terminal
964 Group: Development/KDE and Qt
965 Conflicts: %name-common <= 4.3.3-4
966
967 %description qvfb
968 Qt 4 Embedded Virtual Terminal.
969
970 %files qvfb
971 %defattr(-,root,root,-)
972 %{qtdir}/bin/qvf*
973 %if %with docs
974 %{qtdir}/translations/qvfb*
975 %endif
976
977 %endif
978
979 #-------------------------------------------------------------------------
980 #%if %with docs
981
982 %package qdoc3
983 Summary: %{qtlib} documentation generator
984 Group: Development/KDE and Qt
985 Conflicts: %name-common <= 4.3.3-4
986
987 %description qdoc3
988 Qt 4 documentation generator.
989
990 %files qdoc3
991 %defattr(-,root,root,-)
992 %{qtdir}/bin/qdoc3
993
994 #%endif
995
996 #-------------------------------------------------------------------------
997
998 %prep
999 %if %with_kde_qt
1000 %setup -q -n qt
1001 #-a6
1002 %else
1003 %setup -q -n %{qttarballdir}
1004 %endif
1005
1006 %patch1 -p0
1007 %patch2 -p1
1008 %patch4 -p0
1009 #%patch6 -p0
1010 # REAPPLY ?
1011 ##%patch8 -p1
1012 %patch9 -p0
1013 %patch10 -p0
1014
1015 # QMAKE_STRIP need to be clear to allow -debug package
1016 sed -e "s|^QMAKE_STRIP.*=.*|QMAKE_STRIP =|" -i mkspecs/common/linux.conf
1017 sed -e "s|^QMAKE_CFLAGS_RELEASE.*$|QMAKE_CFLAGS_RELEASE += %{optflags} -DPIC -fPIC|" \
1018 -e "s|^QMAKE_LFLAGS .*$|QMAKE_LFLAGS += %{ldflags}|" \
1019 -e "s|^QMAKE_LFLAGS_PLUGIN.*\+= |QMAKE_LFLAGS_PLUGIN += %(echo %ldflags|sed -e 's#-Wl,--no-undefined##') |" \
1020 -i mkspecs/common/g++.conf
1021
1022 # let makefile create missing .qm files, the .qm files should be included in qt upstream
1023 for f in translations/*.ts ; do
1024 touch ${f%.ts}.qm
1025 done
1026
1027 %build
1028 export QTDIR=`/bin/pwd`
1029 export PATH=$QTDIR/bin:$PATH
1030
1031 # Don't include headers or link with /usr/X11R6/{include,lib}
1032 perl -pi -e 's@/X11R6/@/@' mkspecs/linux-*/qmake.conf mkspecs/common/linux.conf
1033
1034 #--------------------------------------------------------
1035
1036 # Removed options from configure
1037 # lets check if it is still necessary
1038 # -L%_prefix/%_lib crashs current build
1039 #
1040 #-L%_prefix/%_lib \
1041 #
1042 #%if ! %without postgres
1043 #-I%{_includedir}/pgsql \
1044 #-I%{_includedir}/pgsql/server \
1045 #
1046 #%if ! %without mysql
1047 #-I%{_includedir}/mysql \
1048
1049 ./configure \
1050 -prefix %{qtdir} \
1051 -sysconfdir %_sysconfdir \
1052 -libdir %_libdir \
1053 -docdir %_docdir/%name/doc \
1054 -plugindir %pluginsdir \
1055 -translationdir %translationdir \
1056 %if %with debug
1057 -debug \
1058 -verbose \
1059 %else
1060 -release \
1061 -silent \
1062 %endif
1063 -opensource \
1064 -confirm-license \
1065 -shared \
1066 -no-separate-debug-info \
1067 -no-rpath \
1068 -no-pch \
1069 -optimized-qmake \
1070 -reduce-relocations \
1071 -openssl-linked \
1072 -dbus-linked \
1073 -qvfb \
1074 -qt-gif \
1075 -gtkstyle \
1076 -xmlpatterns \
1077 -opengl desktop \
1078 -platform linux-g++ \
1079 %if ! %{with_cups}
1080 -no-cups \
1081 %endif
1082 %if ! %with local_phonon_package
1083 -no-phonon-backend \
1084 %endif
1085 %if ! %without postgres
1086 -plugin-sql-psql \
1087 %endif
1088 %if ! %without mysql
1089 -plugin-sql-mysql \
1090 %else
1091 -no-sql-mysql \
1092 %endif
1093 %if %with ibase
1094 -plugin-sql-ibase \
1095 %else
1096 -no-sql-ibase \
1097 %endif
1098 %if ! %without sqlite
1099 -plugin-sql-sqlite \
1100 -system-sqlite \
1101 -no-sql-sqlite2 \
1102 %else
1103 -no-sql-sqlite \
1104 -no-sql-sqlite2 \
1105 %endif
1106 %if ! %without odbc
1107 -plugin-sql-odbc \
1108 %else
1109 -no-sql-odbc \
1110 %endif
1111 %if %without docs
1112 -nomake demos \
1113 -nomake examples
1114 %endif
1115
1116 %make
1117
1118 %if ! %without qvfb
1119 make -C tools/qvfb
1120 %endif
1121
1122 %install
1123 rm -rf %buildroot
1124 install -d %buildroot%_bindir
1125 install -d %buildroot%_docdir/%name
1126 install -d %buildroot%_sysconfdir
1127 install -d %buildroot%_sysconfdir/profile.d
1128
1129 make INSTALL_ROOT=%buildroot \
1130 sub-tools-install_subtargets-ordered \
1131 %if %with docs
1132 install_htmldocs \
1133 install_qchdocs \
1134 install_translations \
1135 %endif
1136 install_qmake \
1137 install_mkspecs
1138
1139 %if %{with_kde_qt}
1140 #install -m 0644 README.kde-qt %buildroot%_docdir/%name
1141 %endif
1142
1143 # recreate .qm files
1144 LD_LIBRARY_PATH=`pwd`/lib bin/lrelease translations/*.ts
1145
1146 %if ! %without qvfb
1147 # Install qvfb
1148 %make -C tools/qvfb INSTALL_ROOT=%buildroot install
1149 %endif
1150
1151 mkdir -p %buildroot%_datadir/applications
1152 install -m 644 %SOURCE3 %buildroot%_datadir/applications
1153 install -m 644 %SOURCE4 %buildroot%_datadir/applications
1154 install -m 644 %SOURCE5 %buildroot%_datadir/applications
1155
1156 # Fix mkspec link
1157 pushd %buildroot%{qtdir}/mkspecs
1158 rm -f default
1159 ln -sf %{qtdir}/mkspecs/linux-g++ default
1160 popd
1161
1162 # Copy examples/tutorial and demos
1163 for subdir in examples demos; do
1164 for dir in `find $subdir -type d -name .obj`; do rm -rf $dir; done
1165 for dir in `find $subdir -type d -name .moc`; do rm -rf $dir; done
1166 cp -a $subdir %buildroot/%{qtdir}
1167 done
1168
1169 # Fix all buildroot paths
1170 find %buildroot/%_libdir -type f -name '*prl' -exec perl -pi -e "s, -L%_builddir/\S+,,g" {} \;
1171 find %buildroot/%_libdir -type f -name '*prl' -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" {} \;
1172 find %buildroot/%_libdir -type f -name '*la' -print -exec perl -pi -e "s, -L%_builddir/?\S+,,g" {} \;
1173 find %buildroot/%qtdir/mkspecs -name 'qmake.conf' -exec chmod -x -- {} \;
1174 find %buildroot/%qtdir/mkspecs -name Info.plist.app -exec chmod -x -- {} \;
1175
1176 # Don't reference %{builddir} neither /usr(/X11R6)?/ in .pc files.
1177 perl -pi -e '\
1178 s@-L/usr/X11R6/%{_lib} @@g;\
1179 s@-I/usr/X11R6/include @@g;\
1180 s@-L/%{_builddir}\S+@@g'\
1181 `find . -name \*.pc`
1182
1183 # Install rpm macros
1184 mkdir -p %buildroot/%_sysconfdir/rpm/macros.d
1185 install -m 0644 %SOURCE2 %buildroot/%_sysconfdir/rpm/macros.d
1186
1187 # Profiles
1188 cat > %buildroot%_sysconfdir/profile.d/60qt4.sh << EOF
1189 #!/bin/bash
1190
1191 # Qt4 is the main Qt on system
1192 export QTDIR=%qtdir
1193
1194 [ -z \$QT4DOCDIR ] && export QT4DOCDIR=%_docdir/qt4/doc
1195
1196 if [ -z \$(echo \$PATH | grep "%{qtdir}/bin") ]; then
1197 PATH=\${PATH}:%{qtdir}/bin
1198 export PATH
1199 fi
1200
1201 EOF
1202
1203 # We need a proper removal
1204 %if ! %with local_phonon_package
1205 rm -rf %{buildroot}/%_libdir/libphonon.*
1206 rm -rf %{buildroot}/%{qtdir}/include/phonon
1207 rm -rf %{buildroot}/%{_libdir}/pkgconfig/phonon.pc
1208 rm -rf %{buildroot}/%{_libdir}/qt4/plugins/phonon_backend/libphonon_gstreamer.so
1209 %endif
1210
1211 %clean
1212 rm -rf %buildroot
1213
1214

  ViewVC Help
Powered by ViewVC 1.1.30