1 |
%define pkgconfigdir %_datadir/pkgconfig |
2 |
|
3 |
%define qtxdglibdevel %mklibname qtxdg -d |
4 |
%define libnamedevel %mklibname %name -d |
5 |
|
6 |
%define git e777e8c |
7 |
%define gitdate 20121022 |
8 |
%define minor 42 |
9 |
%define oversion 0.5.0 |
10 |
%define oname razor |
11 |
|
12 |
Name: %{oname}qt |
13 |
Version: 0.5.1 |
14 |
#Release: %mkrel -c git%{gitdate} 8 |
15 |
Release: %mkrel 2 |
16 |
License: LGPLv2+ |
17 |
#Source0: https://github.com/downloads/Razor-qt/razor-qt/%{name}-%{version}.tar.bz2 |
18 |
# git -- https://github.com/Razor-qt/razor-qt/tarball/master |
19 |
#Source0: Razor-qt-razor-qt-%{oversion}-%{minor}-g%{git}.tar.gz |
20 |
# stable release |
21 |
Source0: https://github.com/downloads/Razor-qt/razor-qt/%{name}-%{version}.tar.bz2 |
22 |
|
23 |
# mageia light theme |
24 |
# https://bitbucket.org/_pmat_/razorqt-mga-themes/ |
25 |
Source1: mga-light-theme.tar.bz2 |
26 |
|
27 |
Patch0: %{name}-config-mouse-desktop.patch |
28 |
Patch1: %{name}-autosuspend-desktop.patch |
29 |
Patch2: %{name}-mga-theme.patch |
30 |
Patch3: %{name}-autostart.patch |
31 |
Patch4: %{oname}-panel-quicklaunch.patch |
32 |
Patch5: %{name}-0.5.0-systemd.patch |
33 |
Group: Graphical desktop/Other |
34 |
Summary: Razor is a lightweight desktop toolbox |
35 |
Url: http://%{oname}-qt.org |
36 |
BuildRequires: cmake |
37 |
BuildRequires: file-devel |
38 |
BuildRequires: qt4-devel >= 4.6.0 |
39 |
BuildRequires: qt4-linguist |
40 |
BuildRequires: libxcomposite-devel |
41 |
BuildRequires: udev-devel >= 128 |
42 |
BuildRequires: doxygen |
43 |
BuildRequires: libxcursor-devel |
44 |
BuildRequires: desktop-file-utils |
45 |
BuildRequires: pkgconfig(liblightdm-qt-2) |
46 |
BuildRequires: pkgconfig(polkit-qt-agent-1) |
47 |
BuildRequires: pkgconfig(polkit-agent-1) |
48 |
|
49 |
%description |
50 |
Razor-qt is an advanced, easy-to-use, and fast desktop environment based on |
51 |
Qt technologies. It has been tailored for users who value simplicity, speed, |
52 |
and an intuitive interface. |
53 |
|
54 |
#------------------------------------------------------------------------------ |
55 |
|
56 |
%define librazormount_major 0 |
57 |
%define librazormount %mklibname razormount %{librazormount_major} |
58 |
|
59 |
%package -n %librazormount |
60 |
Summary: RazorQt shared library |
61 |
Group: System/Libraries |
62 |
License: LGPLv2+ |
63 |
|
64 |
%description -n %librazormount |
65 |
%{summary} |
66 |
|
67 |
%files -n %librazormount |
68 |
%_libdir/lib%{oname}mount.so.%{librazormount_major}* |
69 |
%pkgconfigdir/%{oname}mount.pc |
70 |
|
71 |
#------------------------------------------------------------------------------ |
72 |
|
73 |
%define librazorqt_major 0 |
74 |
%define librazorqt %mklibname razorqt %{librazorqt_major} |
75 |
|
76 |
%package -n %librazorqt |
77 |
Summary: RazorQt shared library |
78 |
Group: System/Libraries |
79 |
License: LGPLv2+ |
80 |
|
81 |
%description -n %librazorqt |
82 |
%{summary} |
83 |
|
84 |
%files -n %librazorqt |
85 |
%_libdir/lib%{oname}qt.so.%{librazorqt_major}* |
86 |
%pkgconfigdir/%{name}.pc |
87 |
|
88 |
#------------------------------------------------------------------------------ |
89 |
|
90 |
%define librazorqxt_major 0 |
91 |
%define librazorqxt %mklibname razorqxt %{librazorqxt_major} |
92 |
|
93 |
%package -n %librazorqxt |
94 |
Summary: Customized part of the libqxt library |
95 |
Group: System/Libraries |
96 |
# BSD3 (gpl2 and gpl3 compatible, as from http://fedoraproject.org/wiki/Licensing#SoftwareLicenses) |
97 |
License: BSD |
98 |
|
99 |
%description -n %librazorqxt |
100 |
%{summary} |
101 |
|
102 |
%files -n %librazorqxt |
103 |
%doc libraries/%{oname}qxt/LICENSE |
104 |
%_libdir/lib%{oname}qxt.so.%{librazorqxt_major}* |
105 |
%pkgconfigdir/%{oname}qxt.pc |
106 |
|
107 |
#------------------------------------------------------------------------------ |
108 |
|
109 |
%define libqtxdg_major 0 |
110 |
%define libqtxdg %mklibname qtxdg %{libqtxdg_major} |
111 |
|
112 |
%package -n %libqtxdg |
113 |
Summary: Xdg manipulation library using Qt4 |
114 |
Group: System/Libraries |
115 |
# qiconloader.cpp and qiconloader_p.h -> lgplv2 |
116 |
# xdg* files -> lgplv2+ |
117 |
License: LGPLv2+ |
118 |
|
119 |
%description -n %libqtxdg |
120 |
%{summary} |
121 |
|
122 |
%files -n %libqtxdg |
123 |
%_libdir/libqtxdg.so.%{libqtxdg_major}* |
124 |
|
125 |
#-------------------------------------------------------------------- |
126 |
|
127 |
%package -n %libnamedevel |
128 |
Summary: RazorQt development package |
129 |
Group: Development/Other |
130 |
Requires: %librazormount = %{version}-%{release} |
131 |
Requires: %librazorqt = %{version}-%{release} |
132 |
Requires: %librazorqxt = %{version}-%{release} |
133 |
License: GPLv2 and LGPLv2+ |
134 |
|
135 |
%description -n %libnamedevel |
136 |
%{summary} |
137 |
|
138 |
%files -n %libnamedevel |
139 |
%{_libdir}/lib%{oname}*.so |
140 |
%{_includedir}/%{oname}*/ |
141 |
%{_bindir}/%{oname}-x11info |
142 |
|
143 |
#------------------------------------------------------------------------------ |
144 |
|
145 |
%package -n %{qtxdglibdevel} |
146 |
Summary: Development files for QtXdg library |
147 |
Group: Development/Other |
148 |
Requires: %{libqtxdg} = %{version}-%{release} |
149 |
License: LGPLv2+ |
150 |
|
151 |
%description -n %{qtxdglibdevel} |
152 |
%{summary} |
153 |
|
154 |
%files -n %{qtxdglibdevel} |
155 |
%{_libdir}/libqtxdg.so |
156 |
%{_includedir}/qtxdg/ |
157 |
%pkgconfigdir/qtxdg.pc |
158 |
|
159 |
#-------------------------------------------------------------------- |
160 |
|
161 |
%package appswitcher |
162 |
Summary: RazorQt application switcher |
163 |
Group: System/X11 |
164 |
Requires: %{name}-data = %{version}-%{release} |
165 |
License: LGPLv2+ |
166 |
|
167 |
Conflicts: %{name}-appswitcher <= 0.4.99-0.git20120914.4.mga3 |
168 |
Obsoletes: %{name}-appswitcher <= 0.4.99-0.git20120914.4.mga3 |
169 |
|
170 |
%description appswitcher |
171 |
%{summary} |
172 |
|
173 |
%files appswitcher |
174 |
%{_bindir}/%{oname}-appswitcher |
175 |
|
176 |
#-------------------------------------------------------------------- |
177 |
|
178 |
%package desktop |
179 |
Summary: RazorQt desktop |
180 |
Group: Graphical desktop/Other |
181 |
Requires: %{name}-data = %{version}-%{release} |
182 |
Requires: %{name}-config-desktop = %{version}-%{release} |
183 |
License: LGPLv2+ |
184 |
|
185 |
Conflicts: %{name}-desktop <= 0.4.99-0.git20120914.4.mga3 |
186 |
Obsoletes: %{name}-desktop <= 0.4.99-0.git20120914.4.mga3 |
187 |
|
188 |
%description desktop |
189 |
%{summary} |
190 |
|
191 |
%files desktop |
192 |
%{_bindir}/%{oname}-desktop |
193 |
%{_libdir}/%{oname}-desktop |
194 |
%dir %{_datadir}/%{oname} |
195 |
%{_sysconfdir}/%{oname}/desktop.conf |
196 |
%{_datadir}/%{oname}/%{oname}-desktop/ |
197 |
|
198 |
#-------------------------------------------------------------------- |
199 |
|
200 |
%package panel |
201 |
Summary: RazorQt panel |
202 |
Group: Graphical desktop/Other |
203 |
License: LGPLv2+ |
204 |
Requires: %{name}-data = %{version}-%{release} |
205 |
Requires: %{name}-config-appearance = %{version}-%{release} |
206 |
Requires: %{name}-config-mouse = %{version}-%{release} |
207 |
|
208 |
Conflicts: %{name}-panel <= 0.4.99-0.git20120914.4.mga3 |
209 |
Obsoletes: %{name}-panel <= 0.4.99-0.git20120914.4.mga3 |
210 |
|
211 |
%description panel |
212 |
%{summary} |
213 |
|
214 |
%files panel |
215 |
%{_bindir}/%{oname}-panel |
216 |
%{_libdir}/%{oname}-panel/ |
217 |
%{_datadir}/%{oname}/%{oname}-panel/ |
218 |
%{_sysconfdir}/%{oname}/%{oname}-panel/panel.conf |
219 |
|
220 |
#-------------------------------------------------------------------- |
221 |
|
222 |
%package data |
223 |
Summary: RazorQt resources and shared data |
224 |
Group: Graphical desktop/Other |
225 |
BuildArch: noarch |
226 |
|
227 |
Conflicts: %{name}-data <= 0.4.99-0.git20120914.4.mga3 |
228 |
Obsoletes: %{name}-data <= 0.4.99-0.git20120914.4.mga3 |
229 |
|
230 |
%description data |
231 |
%{summary} |
232 |
|
233 |
%files data |
234 |
%dir %{_datadir}/%{oname} |
235 |
%dir %{_datadir}/%{oname}/themes |
236 |
%dir %{_datadir}/%{oname}/graphics |
237 |
%{_sysconfdir}/%{oname}/%{oname}.conf |
238 |
%{_datadir}/%{oname}/graphics/* |
239 |
%{_datadir}/%{oname}/themes/* |
240 |
%config %_sysconfdir/xdg/menus/%{oname}-applications.menu |
241 |
%config %_sysconfdir/xdg/autostart/*.desktop |
242 |
%config %_sysconfdir/%{oname}/windowmanagers.conf |
243 |
%{_datadir}/desktop-directories/%{oname}* |
244 |
%{_datadir}/lib%{name} |
245 |
%{_datadir}/libqtxdg/ |
246 |
# temp files - it will be removed when it becomes part of upstream |
247 |
%{_datadir}/icons/hicolor/scalable/apps/laptop-lid* |
248 |
|
249 |
#-------------------------------------------------------------------- |
250 |
|
251 |
%package autosuspend |
252 |
Summary: RazorQt autosuspend application |
253 |
Group: Graphical desktop/Other |
254 |
Requires: %{name}-data = %{version}-%{release} |
255 |
Requires: %{name}-config-autosuspend = %{version}-%{release} |
256 |
Requires: %{name}-power = %{version}-%{release} |
257 |
License: LGPLv2+ |
258 |
|
259 |
%description autosuspend |
260 |
%{summary} |
261 |
|
262 |
%files autosuspend |
263 |
%{_bindir}/%{oname}-autosuspend |
264 |
#%{_datadir}/applications/%{oname}-autosuspend.desktop |
265 |
%dir %{_datadir}/%{oname}/%{oname}-autosuspend |
266 |
%{_datadir}/%{oname}/%{oname}-autosuspend/* |
267 |
%{_iconsdir}/hicolor/scalable/apps/%{oname}-autosuspend.svg |
268 |
|
269 |
#-------------------------------------------------------------------- |
270 |
|
271 |
%package power |
272 |
Summary: RazorQt power application |
273 |
Group: Graphical desktop/Other |
274 |
Requires: %{name}-data = %{version}-%{release} |
275 |
License: LGPLv2+ |
276 |
|
277 |
Conflicts: %{name}-power <= 0.4.99-0.git20120914.4.mga3 |
278 |
Obsoletes: %{name}-power <= 0.4.99-0.git20120914.4.mga3 |
279 |
|
280 |
%description power |
281 |
%{summary} |
282 |
|
283 |
%files power |
284 |
%{_bindir}/%{oname}-power |
285 |
%dir %{_datadir}/%{oname}/%{oname}-power |
286 |
%{_datadir}/%{oname}/%{oname}-power/*.qm |
287 |
%{_datadir}/applications/%{oname}-power.desktop |
288 |
|
289 |
#-------------------------------------------------------------------- |
290 |
|
291 |
%package runner |
292 |
Summary: RazorQt runner application |
293 |
Group: Graphical desktop/Other |
294 |
Requires: %{name}-data = %{version}-%{release} |
295 |
License: LGPLv2+ |
296 |
|
297 |
Conflicts: %{name}-runner <= 0.4.99-0.git20120914.4.mga3 |
298 |
Obsoletes: %{name}-runner <= 0.4.99-0.git20120914.4.mga3 |
299 |
|
300 |
%description runner |
301 |
%{summary} |
302 |
|
303 |
%files runner |
304 |
%{_bindir}/%{oname}-runner |
305 |
%dir %{_datadir}/%{oname}/%{oname}-runner |
306 |
%{_datadir}/%{oname}/%{oname}-runner/* |
307 |
|
308 |
#-------------------------------------------------------------------- |
309 |
|
310 |
%package notificationd |
311 |
Summary: RazorQt notification system |
312 |
Group: Graphical desktop/Other |
313 |
Requires: %{name}-config-notificationd |
314 |
|
315 |
%description notificationd |
316 |
%{summary} |
317 |
|
318 |
%files notificationd |
319 |
%{_bindir}/%{oname}-notificationd |
320 |
|
321 |
#-------------------------------------------------------------------- |
322 |
|
323 |
%package globalkeyshortcuts |
324 |
Summary: RazorQt global key shortcuts system |
325 |
Group: Graphical desktop/Other |
326 |
Requires: %{name}-config-globalkeyshortcuts |
327 |
|
328 |
%description globalkeyshortcuts |
329 |
%{summary} |
330 |
|
331 |
%files globalkeyshortcuts |
332 |
%{_bindir}/%{oname}-globalkeyshortcuts |
333 |
|
334 |
#-------------------------------------------------------------------- |
335 |
|
336 |
%package session |
337 |
Summary: RazorQt session |
338 |
Group: Graphical desktop/Other |
339 |
Requires: %{name}-data = %{version}-%{release} |
340 |
Requires: %{name}-config-session = %{version}-%{release} |
341 |
Requires: %{name}-notificationd = %{version}-%{release} |
342 |
Requires: %{name}-globalkeyshortcuts = %{version}-%{release} |
343 |
Requires: openbox |
344 |
License: LGPLv2+ |
345 |
|
346 |
Conflicts: %{name}-session <= 0.4.99-0.git20120914.4.mga3 |
347 |
Obsoletes: %{name}-session <= 0.4.99-0.git20120914.4.mga3 |
348 |
|
349 |
%description session |
350 |
%{summary} |
351 |
|
352 |
%files session |
353 |
%{_bindir}/%{oname}-session |
354 |
%{_bindir}/%{oname}-about |
355 |
%{_bindir}/%{oname}-openssh-askpass |
356 |
%{_bindir}/start%{oname} |
357 |
%{_datadir}/applications/%{oname}-about.desktop |
358 |
%{_sysconfdir}/%{oname}/session.conf |
359 |
%dir %{_datadir}/%{oname}/%{oname}-session |
360 |
%{_datadir}/%{oname}/%{oname}-session/* |
361 |
%{_sysconfdir}/X11/wmsession.d/* |
362 |
|
363 |
#-------------------------------------------------------------------- |
364 |
|
365 |
%package config |
366 |
Summary: RazorQt config tools |
367 |
Group: Graphical desktop/Other |
368 |
License: LGPLv2+ |
369 |
Requires: %{name}-data = %{version}-%{release} |
370 |
|
371 |
Conflicts: %{name}-config <= 0.4.99-0.git20120914.4.mga3 |
372 |
Obsoletes: %{name}-config <= 0.4.99-0.git20120914.4.mga3 |
373 |
|
374 |
%description config |
375 |
%{summary} |
376 |
|
377 |
%files config |
378 |
%{_bindir}/%{oname}-config |
379 |
%{_datadir}/applications/%{oname}-config.desktop |
380 |
%{_datadir}/applications/%{oname}-config-qtconfig.desktop |
381 |
%config %_sysconfdir/xdg/menus/%{oname}-config.menu |
382 |
%dir %{_datadir}/%{oname}/%{oname}-config |
383 |
%{_datadir}/%{oname}/%{oname}-config/razor-config-appearance*.qm |
384 |
%{_datadir}/%{oname}/%{oname}-config/%{oname}-config_*.qm |
385 |
|
386 |
#-------------------------------------------------------------------- |
387 |
|
388 |
%package config-globalkeyshortcuts |
389 |
Summary: RazorQt globalkeyshortcuts configuration tool |
390 |
Group: Graphical desktop/Other |
391 |
Requires: %{name}-config = %{version}-%{release} |
392 |
|
393 |
%description config-globalkeyshortcuts |
394 |
%{summary} |
395 |
|
396 |
%files config-globalkeyshortcuts |
397 |
%{_bindir}/%{oname}-config-globalkeyshortcuts |
398 |
%{_datadir}/applications/%{oname}-config-globalkeyshortcuts.desktop |
399 |
%{_datadir}/%{oname}/%{oname}-config-globalkeyshortcuts/%{oname}-config-globalkeyshortcuts*.qm |
400 |
|
401 |
#-------------------------------------------------------------------- |
402 |
|
403 |
%package config-notificationd |
404 |
Summary: RazorQt notificationd configuration tool |
405 |
Group: Graphical desktop/Other |
406 |
Requires: %{name}-config = %{version}-%{release} |
407 |
|
408 |
%description config-notificationd |
409 |
%{summary} |
410 |
|
411 |
%files config-notificationd |
412 |
%{_bindir}/%{oname}-config-notificationd |
413 |
%{_datadir}/applications/%{oname}-config-notificationd.desktop |
414 |
|
415 |
#-------------------------------------------------------------------- |
416 |
|
417 |
%package config-desktop |
418 |
Summary: RazorQt desktop configuration tool |
419 |
Group: Graphical desktop/Other |
420 |
Requires: %{name}-config = %{version}-%{release} |
421 |
|
422 |
%description config-desktop |
423 |
%{summary} |
424 |
|
425 |
%files config-desktop |
426 |
%{_bindir}/%{oname}-config-desktop |
427 |
%{_datadir}/applications/%{oname}-config-desktop.desktop |
428 |
|
429 |
|
430 |
#-------------------------------------------------------------------- |
431 |
|
432 |
%package config-autosuspend |
433 |
Summary: RazorQt autosuspend configuration tool |
434 |
Group: Graphical desktop/Other |
435 |
Requires: %{name}-config = %{version}-%{release} |
436 |
|
437 |
%description config-autosuspend |
438 |
%{summary} |
439 |
|
440 |
%files config-autosuspend |
441 |
%{_bindir}/%{oname}-config-autosuspend |
442 |
%{_datadir}/applications/%{oname}-config-autosuspend.desktop |
443 |
%{_datadir}/%{oname}/%{oname}-config-autosuspend/%{oname}-config-autosuspend*.qm |
444 |
|
445 |
#-------------------------------------------------------------------- |
446 |
|
447 |
%package config-session |
448 |
Summary: RazorQt session configuration tool |
449 |
Group: Graphical desktop/Other |
450 |
Requires: %{name}-config = %{version}-%{release} |
451 |
|
452 |
%description config-session |
453 |
%{summary} |
454 |
|
455 |
%files config-session |
456 |
%{_bindir}/%{oname}-config-session |
457 |
%{_datadir}/applications/%{oname}-config-session.desktop |
458 |
%dir %{_datadir}/%{oname}/%{oname}-config-session |
459 |
%{_datadir}/%{oname}/%{oname}-config-session/* |
460 |
|
461 |
#-------------------------------------------------------------------- |
462 |
|
463 |
%package config-mouse |
464 |
Summary: RazorQt mouse configuration tool |
465 |
Group: Graphical desktop/Other |
466 |
Requires: %{name}-config = %{version}-%{release} |
467 |
License: GPLv2 or GPLv3 |
468 |
|
469 |
%description config-mouse |
470 |
%{summary} |
471 |
|
472 |
%files config-mouse |
473 |
%{_bindir}/%{oname}-config-mouse |
474 |
%{_datadir}/applications/%{oname}-config-mouse.desktop |
475 |
%{_datadir}/%{oname}/%{oname}-config/%{oname}-config-mouse*.qm |
476 |
|
477 |
#-------------------------------------------------------------------- |
478 |
|
479 |
%package config-appearance |
480 |
Summary: RazorQt appearance configuration tool |
481 |
Group: Graphical desktop/Other |
482 |
Requires: %{name}-config = %{version}-%{release} |
483 |
License: LGPLv2+ |
484 |
|
485 |
%description config-appearance |
486 |
%{summary} |
487 |
|
488 |
%files config-appearance |
489 |
%{_bindir}/%{oname}-config-appearance |
490 |
%{_datadir}/applications/%{oname}-config-appearance.desktop |
491 |
|
492 |
|
493 |
#-------------------------------------------------------------------- |
494 |
|
495 |
%package confupdate |
496 |
Summary: RazorQt configuration update tool |
497 |
Requires: %{name}-data = %{version}-%{release} |
498 |
|
499 |
Conflicts: %{name}-confupdate <= 0.4.99-0.git20120914.4.mga3 |
500 |
Obsoletes: %{name}-confupdate <= 0.4.99-0.git20120914.4.mga3 |
501 |
|
502 |
%description confupdate |
503 |
Tool to update configuration from razorqt version 0.4.1 to 0.5.0 |
504 |
|
505 |
%files confupdate |
506 |
%{_bindir}/%{oname}-confupdate |
507 |
%dir %{_datadir}/%{oname}/%{oname}-confupdate |
508 |
%{_datadir}/%{oname}/%{oname}-confupdate/desktop-041-050.py |
509 |
%{_datadir}/%{oname}/%{oname}-confupdate/%{oname}-0.5.upd |
510 |
%{_libdir}/%{oname}-confupdate_bin/sesion_modules |
511 |
|
512 |
#-------------------------------------------------------------------- |
513 |
|
514 |
%package policykit-agent |
515 |
Summary: A Qt based PolicyKit agent |
516 |
Group: Graphical desktop/Other |
517 |
|
518 |
%description policykit-agent |
519 |
%{summary} |
520 |
|
521 |
It provides a simple agent for the usage of RazorQt desktop or |
522 |
any other desktop. |
523 |
|
524 |
%files policykit-agent |
525 |
%{_bindir}/%{oname}-policykit-agent |
526 |
|
527 |
#-------------------------------------------------------------------- |
528 |
|
529 |
%package -n lightdm-%{name}-greeter |
530 |
Summary: LightDM greeter that uses the Razor-qt (Qt based) lib kit |
531 |
Group: Graphical desktop/Other |
532 |
Provides: lightdm-greeter |
533 |
Requires: %{name}-data = %{version}-%{release} |
534 |
Requires: %{name}-power = %{version}-%{release} |
535 |
Requires: lightdm |
536 |
|
537 |
%description -n lightdm-%{name}-greeter |
538 |
A LightDM greeter that uses the Razor-qt and Qt libraries, it was written |
539 |
for Razor-qt but it can be used standalone as well. |
540 |
|
541 |
This package is part of the Razor-qt. |
542 |
|
543 |
%files -n lightdm-%{name}-greeter |
544 |
%{_bindir}/razor-lightdm-greeter |
545 |
%{_datadir}/xgreeters/lightdm-razor-greeter.desktop |
546 |
|
547 |
%post -n lightdm-%{name}-greeter |
548 |
%{_sbindir}/update-alternatives \ |
549 |
--install %{_datadir}/xgreeters/lightdm-greeter.desktop \ |
550 |
lightdm-greeter \ |
551 |
%{_datadir}/xgreeters/lightdm-razor-greeter.desktop \ |
552 |
10 |
553 |
|
554 |
%postun -n lightdm-%{name}-greeter |
555 |
if [ $1 -eq 0 ]; then |
556 |
%{_sbindir}/update-alternatives \ |
557 |
--remove lightdm-greeter \ |
558 |
%{_datadir}/xgreeters/lightdm-razor-greeter.desktop |
559 |
fi |
560 |
|
561 |
#-------------------------------------------------------------------- |
562 |
|
563 |
%prep |
564 |
# git |
565 |
#%setup -q -n Razor-qt-razor-qt-%{git} |
566 |
# stable release |
567 |
%setup -q |
568 |
%patch2 -p1 -b .mgatheme |
569 |
%patch4 -p1 -b .razorpanelquicklaunch |
570 |
%patch5 -p1 -b .rzrsystemd |
571 |
|
572 |
%build |
573 |
%cmake_qt4 \ |
574 |
-DENABLE_POLICYKIT=ON \ |
575 |
-DBUNDLE_XDG_UTILS=NO |
576 |
%make |
577 |
|
578 |
%install |
579 |
%makeinstall_std -C build |
580 |
|
581 |
pushd %{buildroot}%{_datadir}/%{oname}/themes/ |
582 |
tar -xjf %{SOURCE1} |
583 |
popd |
584 |
|
585 |
install -D -d -m 755 %{buildroot}%{_datadir}/pkgconfig |
586 |
mv %{buildroot}%{_libdir}/pkgconfig/*.pc %{buildroot}%{_datadir}/pkgconfig |
587 |
rm -fr %{buildroot}%{_libdir}/pkgconfig |
588 |
|
589 |
for i in `find %{buildroot}%{_datadir}/applications/ -type f -name "*.desktop"`; |
590 |
do |
591 |
desktop-file-validate $i |
592 |
done |
593 |
|
594 |
#======================================== |
595 |
# the session file |
596 |
|
597 |
mkdir -p %{buildroot}%{_sysconfdir}/X11/wmsession.d |
598 |
outfile=%{buildroot}%{_sysconfdir}/X11/wmsession.d/05%{oname} |
599 |
|
600 |
cat > $outfile << EOF |
601 |
NAME=RazorDesktop |
602 |
DESC=The RazorQt Desktop Environment |
603 |
EXEC=/usr/bin/start%{oname} |
604 |
SCRIPT: |
605 |
exec /usr/bin/start%{oname} |
606 |
|
607 |
EOF |
608 |
|
609 |
rm -f %{buildroot}%{_datadir}/apps/kdm/sessions/*.desktop |
610 |
rm -f %{buildroot}%{_datadir}/xsessions/*.desktop |