/[packages]/cauldron/readline/current/SPECS/readline.spec
ViewVC logotype

Contents of /cauldron/readline/current/SPECS/readline.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 273158 - (show annotations) (download)
Sat Jul 21 17:42:31 2012 UTC (11 years, 9 months ago) by colin
File size: 3332 byte(s)
Update for usrmove
1 %define major 6
2 %define lib_name_orig lib%{name}
3 %define libname %mklibname %{name} %{major}
4 %define develname %mklibname %{name} -d
5
6 Summary: Library for reading lines from a terminal
7 Name: readline
8 Version: 6.2
9 Release: %mkrel 5
10 License: GPLv3
11 Group: System/Libraries
12 Url: http://tiswww.case.edu/php/chet/readline/rltop.html
13 Source0: ftp://ftp.gnu.org/gnu/readline/%{name}-%{version}.tar.gz
14 Source1: ftp://ftp.gnu.org/gnu/readline/%{name}-%{version}.tar.gz.sig
15 Patch0: readline-4.3-no_rpath.patch
16 Patch1: readline-4.1-outdated.patch
17 Patch2: rl-header.patch
18 Patch3: rl-attribute.patch
19 Patch4: readline-6.0-fix-shared-libs-perms.patch
20 # upstream patches:
21 Patch101: ftp://ftp.gnu.org/gnu/readline/readline-6.2-patches/readline62-001
22 BuildRequires: ncursesw-devel
23
24 %description
25 The "readline" library will read a line from the terminal and return it,
26 allowing the user to edit the line with the standard emacs editing keys.
27 It allows the programmer to give the user an easier-to-use and more
28 intuitive interface.
29
30 %package -n %{libname}
31 Summary: Shared libraries for readline
32 Group: System/Libraries
33 Requires(pre): filesystem >= 2.1.9-18
34 Provides: %{name} = %{version}-%{release}
35 Obsoletes: %{name}
36
37 %description -n %{libname}
38 This package contains the library needed to run programs dynamically
39 linked to readline.
40
41 %package doc
42 Summary: Readline documentation in GNU info format
43 Group: Books/Computer books
44 Requires: %{libname} = %{version}-%{release}
45 Provides: %{name}-doc = %{version}-%{release}
46 Obsoletes: %{libname}-doc
47
48 %description doc
49 This package contains readline documentation in the GNU info format.
50
51 %package -n %{develname}
52 Summary: Files for developing programs that use the readline library
53 Group: Development/C
54 Requires(pre): filesystem >= 2.1.9-18
55 Requires: ncursesw-devel
56 Requires: %{libname} = %{version}-%{release}
57 Provides: %{lib_name_orig}-devel = %{version}-%{release}
58 Provides: %{name}-devel = %{version}-%{release}
59 Obsoletes: %{mklibname readline 5 -d}
60 Obsoletes: %{name}-devel < 6.0-2
61
62 %description -n %{develname}
63 The "readline" library will read a line from the terminal and return it,
64 using prompt as a prompt. If prompt is null, no prompt is issued. The
65 line returned is allocated with malloc(3), so the caller must free it when
66 finished. The line returned has the final newline removed, so only the
67 text of the line remains.
68
69 %prep
70 %setup -q
71 %patch0 -p1 -b .no_rpath
72 %patch1 -p1 -b .outdated
73 %patch2 -p1 -b .header
74 %patch3 -p1 -b .attribute
75 %patch4 -p1 -b .fix-perms
76 %patch101 -p0 -b .001
77 # Fix upstream perm Bug #3053
78 chmod 644 examples/rlfe/ChangeLog
79
80 libtoolize --copy --force
81
82 %build
83
84 export LDFLAGS="-I%{_includedir}/ncursesw -lncursesw"
85
86 %configure2_5x \
87 --with-curses \
88 --enable-multibyte
89
90 perl -p -i -e 's|-Wl,-rpath.*||' shlib/Makefile
91
92 %make
93
94 %install
95 %makeinstall_std
96
97 perl -p -i -e 's|/usr/local/bin/perl|/usr/bin/perl|' doc/texi2html
98
99 %post doc
100 %{_install_info history.info}
101 %{_install_info readline.info}
102
103 %preun doc
104 %{_remove_install_info history.info}
105 %{_remove_install_info readline.info}
106
107 %files -n %{libname}
108 %{_libdir}/lib*.so.%{major}*
109
110 %files doc
111 %{_infodir}/*info*
112
113 %files -n %{develname}
114 %doc CHANGELOG CHANGES MANIFEST README USAGE
115 %doc doc examples support
116 %{_mandir}/man3/*
117 %{_datadir}/readline
118 %{_includedir}/readline
119 %{_libdir}/lib*.a
120 %{_libdir}/lib*.so

  ViewVC Help
Powered by ViewVC 1.1.30