/[packages]/cauldron/refind/current/SPECS/refind.spec
ViewVC logotype

Annotation of /cauldron/refind/current/SPECS/refind.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1258338 - (hide annotations) (download)
Tue Sep 11 11:10:21 2018 UTC (5 years, 7 months ago) by martinw
File size: 4326 byte(s)
SILENT fix i586 build, exclude arm

1 martinw 1258338 %ifarch %{ix86}
2 martinw 1258332 %define efiarch ia32
3     %endif
4     %ifarch x86_64
5     %define efiarch x64
6     %endif
7    
8     %define debug_package %{nil}
9    
10     Name: refind
11     Version: 0.11.2
12     Release: %mkrel 1
13     Summary: EFI boot manager
14     License: GPLv3
15     Group: System/Boot and Init
16     URL: http://www.rodsbooks.com/refind/
17     Source0: https://sourceforge.net/projects/refind/files/%version/refind-src-%version.tar.gz
18     # Replace old Mageia icon with current version
19     Source1: os_mageia.png
20     # Fix ESP mount point and GNU EFI library paths
21     Patch0: mga-system-path-fixes.patch
22     # Add --nvramonly option to refind-install
23     Patch1: install-nvram-only.patch
24 martinw 1258338 ExclusiveArch: %{ix86} x86_64
25 martinw 1258332 BuildRequires: gnu-efi-devel
26     Requires: efibootmgr
27    
28     %description
29    
30     A graphical boot manager for EFI- and UEFI-based computers, such as all
31     Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
32     boot menu showing all the EFI boot loaders on the EFI-accessible
33     partitions, and optionally BIOS-bootable partitions on Macs and BIOS boot
34     entries on UEFI PCs with CSMs. EFI-compatible OSes, including Linux,
35     provide boot loaders that rEFInd can detect and launch. rEFInd can launch
36     Linux EFI boot loaders such as ELILO, GRUB Legacy, GRUB 2, and 3.3.0 and
37     later kernels with EFI stub support. EFI file system drivers for ext2/3/4fs,
38     ReiserFS, Btrfs, NTFS, HFS+, and ISO-9660 enable rEFInd to read boot
39     loaders from these file systems, too. rEFInd's ability to detect boot
40     loaders at run time makes it very easy to use, particularly when paired with
41     Linux kernels that provide EFI stub support.
42    
43     %prep
44     %autosetup -p1
45     cp %{SOURCE1} icons/
46    
47     %build
48     make LIBDIR=%{_libdir} gnuefi
49     make LIBDIR=%{_libdir} fs_gnuefi
50    
51     %install
52     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/
53    
54     # Copy the rEFInd binaries (rEFInd proper and drivers)
55     install -Dp -m0644 refind/refind*.efi %{buildroot}%{_datadir}/%{name}/refind/
56     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}
57     cp -a drivers_%{efiarch}/* %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}/
58     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}
59     install -Dp -m0644 gptsync/gptsync_%{efiarch}.efi %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}/gptsync_%{efiarch}.efi
60    
61     # Copy configuration and support files
62     install -Dp -m0644 refind.conf-sample %{buildroot}%{_datadir}/%{name}/refind/
63     cp -a icons %{buildroot}%{_datadir}/%{name}/refind/
64     rm -rf %{buildroot}%{_datadir}/%{name}/refind/icons/svg
65     install -Dp -m0755 refind-install %{buildroot}%{_datadir}/%{name}/
66    
67     # Copy man pages
68     mkdir -p %{buildroot}%{_mandir}/man8
69     install -Dp -m0644 docs/man/mvrefind.8 %{buildroot}%{_mandir}/man8
70     install -Dp -m0644 docs/man/mkrlconf.8 %{buildroot}%{_mandir}/man8
71     install -Dp -m0644 docs/man/refind-install.8 %{buildroot}%{_mandir}/man8
72     install -Dp -m0644 docs/man/refind-mkdefault.8 %{buildroot}%{_mandir}/man8
73    
74     # Copy scripts
75     mkdir -p %{buildroot}%{_sbindir}
76     install -Dp -m0755 mkrlconf %{buildroot}%{_sbindir}/
77     install -Dp -m0755 mvrefind %{buildroot}%{_sbindir}/
78     install -Dp -m0755 refind-mkdefault %{buildroot}%{_sbindir}/
79     ln -sr %{buildroot}%{_datadir}/%{name}/refind-install %{buildroot}%{_sbindir}
80    
81     # Copy banners and fonts
82     cp -a banners %{buildroot}%{_datadir}/%{name}/
83     cp -a fonts %{buildroot}%{_datadir}/%{name}/
84    
85     # Create version file and urpmi README files
86     echo %{version} > VERSION
87    
88     echo "Version %{version} of the rEFInd boot manager has been installed in the ESP." > .README.installed
89    
90     echo "Version %{version} of the rEFInd boot manager is now available." > README.urpmi
91     echo "To install it in the ESP, either use drakboot or, as root user," >> README.urpmi
92     echo "execute the command '/sbin/refind-install'." >> README.urpmi
93     echo "If you are having no problems with booting your system, there is" >> README.urpmi
94     echo "no need to install this update in the ESP." >> README.urpmi
95    
96     %post
97     if [ -d /boot/EFI/EFI ] ; then
98     if [ ! -e /boot/EFI/EFI/refind ] ; then
99     %{_sbindir}/refind-install --yes && cp %{_docdir}/%{name}/.README.installed %{_docdir}/%{name}/README.urpmi
100     fi
101     fi
102    
103     %files
104     %doc NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt docs/Styles docs/refind
105     %doc VERSION README.urpmi .README.installed
106     %{_sbindir}/mkrlconf
107     %{_sbindir}/mvrefind
108     %{_sbindir}/refind-install
109     %{_sbindir}/refind-mkdefault
110     %{_datadir}/%{name}
111     %{_mandir}/man8/*

  ViewVC Help
Powered by ViewVC 1.1.30