/[packages]/cauldron/refind/current/SPECS/refind.spec
ViewVC logotype

Annotation of /cauldron/refind/current/SPECS/refind.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1342446 - (hide annotations) (download)
Mon Dec 17 18:52:52 2018 UTC (5 years, 8 months ago) by martinw
File size: 4097 byte(s)
- new version 0.11.4
- support 32-bit UEFI on 64-bit O/S

1 martinw 1258338 %ifarch %{ix86}
2 martinw 1258332 %define efiarch ia32
3     %endif
4     %ifarch x86_64
5     %define efiarch x64
6     %endif
7    
8     %define debug_package %{nil}
9    
10     Name: refind
11 martinw 1342446 Version: 0.11.4
12     Release: %mkrel 1
13 martinw 1258332 Summary: EFI boot manager
14     License: GPLv3
15     Group: System/Boot and Init
16     URL: http://www.rodsbooks.com/refind/
17     Source0: https://sourceforge.net/projects/refind/files/%version/refind-src-%version.tar.gz
18     # Replace old Mageia icon with current version
19     Source1: os_mageia.png
20     # Fix ESP mount point and GNU EFI library paths
21     Patch0: mga-system-path-fixes.patch
22     # Add --nvramonly option to refind-install
23     Patch1: install-nvram-only.patch
24 martinw 1342446 # Support 32-bit EFI on 64-bit O/S (and vice versa)
25     Patch2: detect-efi-size.patch
26 martinw 1258338 ExclusiveArch: %{ix86} x86_64
27 martinw 1258332 BuildRequires: gnu-efi-devel
28 martinw 1342446 Provides: bootloader
29 martinw 1258332 Requires: efibootmgr
30    
31     %description
32    
33     A graphical boot manager for EFI- and UEFI-based computers, such as all
34     Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
35     boot menu showing all the EFI boot loaders on the EFI-accessible
36     partitions, and optionally BIOS-bootable partitions on Macs and BIOS boot
37     entries on UEFI PCs with CSMs. EFI-compatible OSes, including Linux,
38     provide boot loaders that rEFInd can detect and launch. rEFInd can launch
39     Linux EFI boot loaders such as ELILO, GRUB Legacy, GRUB 2, and 3.3.0 and
40     later kernels with EFI stub support. EFI file system drivers for ext2/3/4fs,
41     ReiserFS, Btrfs, NTFS, HFS+, and ISO-9660 enable rEFInd to read boot
42     loaders from these file systems, too. rEFInd's ability to detect boot
43     loaders at run time makes it very easy to use, particularly when paired with
44     Linux kernels that provide EFI stub support.
45    
46     %prep
47     %autosetup -p1
48     cp %{SOURCE1} icons/
49    
50     %build
51     make LIBDIR=%{_libdir} gnuefi
52     make LIBDIR=%{_libdir} fs_gnuefi
53    
54     %install
55     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/
56    
57     # Copy the rEFInd binaries (rEFInd proper and drivers)
58     install -Dp -m0644 refind/refind*.efi %{buildroot}%{_datadir}/%{name}/refind/
59     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}
60     cp -a drivers_%{efiarch}/* %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}/
61     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}
62     install -Dp -m0644 gptsync/gptsync_%{efiarch}.efi %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}/gptsync_%{efiarch}.efi
63    
64     # Copy configuration and support files
65     install -Dp -m0644 refind.conf-sample %{buildroot}%{_datadir}/%{name}/refind/
66     cp -a icons %{buildroot}%{_datadir}/%{name}/refind/
67     rm -rf %{buildroot}%{_datadir}/%{name}/refind/icons/svg
68     install -Dp -m0755 refind-install %{buildroot}%{_datadir}/%{name}/
69    
70     # Copy man pages
71     mkdir -p %{buildroot}%{_mandir}/man8
72     install -Dp -m0644 docs/man/mvrefind.8 %{buildroot}%{_mandir}/man8
73     install -Dp -m0644 docs/man/mkrlconf.8 %{buildroot}%{_mandir}/man8
74     install -Dp -m0644 docs/man/refind-install.8 %{buildroot}%{_mandir}/man8
75     install -Dp -m0644 docs/man/refind-mkdefault.8 %{buildroot}%{_mandir}/man8
76    
77     # Copy scripts
78     mkdir -p %{buildroot}%{_sbindir}
79     install -Dp -m0755 mkrlconf %{buildroot}%{_sbindir}/
80     install -Dp -m0755 mvrefind %{buildroot}%{_sbindir}/
81     install -Dp -m0755 refind-mkdefault %{buildroot}%{_sbindir}/
82     ln -sr %{buildroot}%{_datadir}/%{name}/refind-install %{buildroot}%{_sbindir}
83    
84     # Copy banners and fonts
85     cp -a banners %{buildroot}%{_datadir}/%{name}/
86     cp -a fonts %{buildroot}%{_datadir}/%{name}/
87    
88 martinw 1258909 # Create version file and urpmi README file
89 martinw 1258332 echo %{version} > VERSION
90     echo "Version %{version} of the rEFInd boot manager is now available." > README.urpmi
91     echo "To install it in the ESP, either use drakboot or, as root user," >> README.urpmi
92     echo "execute the command '/sbin/refind-install'." >> README.urpmi
93     echo "If you are having no problems with booting your system, there is" >> README.urpmi
94     echo "no need to install this update in the ESP." >> README.urpmi
95    
96     %files
97     %doc NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt docs/Styles docs/refind
98 martinw 1258909 %doc VERSION README.urpmi
99 martinw 1258332 %{_sbindir}/mkrlconf
100     %{_sbindir}/mvrefind
101     %{_sbindir}/refind-install
102     %{_sbindir}/refind-mkdefault
103     %{_datadir}/%{name}
104     %{_mandir}/man8/*

  ViewVC Help
Powered by ViewVC 1.1.30