/[packages]/cauldron/refind/current/SPECS/refind.spec
ViewVC logotype

Annotation of /cauldron/refind/current/SPECS/refind.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 2044221 - (hide annotations) (download)
Sun Feb 25 14:30:59 2024 UTC (6 months, 2 weeks ago) by martinw
File size: 4593 byte(s)
- new version 0.14.0
  o drop upstreamed patch

1 martinw 1258338 %ifarch %{ix86}
2 martinw 1258332 %define efiarch ia32
3     %endif
4     %ifarch x86_64
5     %define efiarch x64
6     %endif
7    
8     %define debug_package %{nil}
9    
10     Name: refind
11 martinw 2044221 Version: 0.14.0
12     Release: %mkrel 1
13 martinw 1258332 Summary: EFI boot manager
14     License: GPLv3
15     Group: System/Boot and Init
16 danf 1916906 URL: https://www.rodsbooks.com/refind/
17 martinw 1258332 Source0: https://sourceforge.net/projects/refind/files/%version/refind-src-%version.tar.gz
18     # Replace old Mageia icon with current version
19     Source1: os_mageia.png
20 martinw 1671569 # Use Mageia dark blue background
21     Source2: dark-blue-banner.png
22 martinw 1258332 # Fix ESP mount point and GNU EFI library paths
23     Patch0: mga-system-path-fixes.patch
24     # Add --nvramonly option to refind-install
25     Patch1: install-nvram-only.patch
26 martinw 1342446 # Support 32-bit EFI on 64-bit O/S (and vice versa)
27     Patch2: detect-efi-size.patch
28 martinw 1671569 # Change default banner
29 martinw 1876339 Patch3: use-dark-blue-banner.patch
30 martinw 1671569
31 martinw 1258338 ExclusiveArch: %{ix86} x86_64
32 martinw 1258332 BuildRequires: gnu-efi-devel
33 martinw 1342446 Provides: bootloader
34 martinw 1258332 Requires: efibootmgr
35    
36     %description
37    
38     A graphical boot manager for EFI- and UEFI-based computers, such as all
39     Intel-based Macs and recent (most 2011 and later) PCs. rEFInd presents a
40     boot menu showing all the EFI boot loaders on the EFI-accessible
41     partitions, and optionally BIOS-bootable partitions on Macs and BIOS boot
42     entries on UEFI PCs with CSMs. EFI-compatible OSes, including Linux,
43     provide boot loaders that rEFInd can detect and launch. rEFInd can launch
44     Linux EFI boot loaders such as ELILO, GRUB Legacy, GRUB 2, and 3.3.0 and
45     later kernels with EFI stub support. EFI file system drivers for ext2/3/4fs,
46     ReiserFS, Btrfs, NTFS, HFS+, and ISO-9660 enable rEFInd to read boot
47     loaders from these file systems, too. rEFInd's ability to detect boot
48     loaders at run time makes it very easy to use, particularly when paired with
49     Linux kernels that provide EFI stub support.
50    
51     %prep
52     %autosetup -p1
53 martinw 1671569 cp %{SOURCE1} %{SOURCE2} icons/
54 martinw 1258332
55     %build
56     make LIBDIR=%{_libdir} gnuefi
57     make LIBDIR=%{_libdir} fs_gnuefi
58    
59     %install
60     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/
61    
62     # Copy the rEFInd binaries (rEFInd proper and drivers)
63     install -Dp -m0644 refind/refind*.efi %{buildroot}%{_datadir}/%{name}/refind/
64     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}
65     cp -a drivers_%{efiarch}/* %{buildroot}%{_datadir}/%{name}/refind/drivers_%{efiarch}/
66     mkdir -p %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}
67     install -Dp -m0644 gptsync/gptsync_%{efiarch}.efi %{buildroot}%{_datadir}/%{name}/refind/tools_%{efiarch}/gptsync_%{efiarch}.efi
68    
69     # Copy configuration and support files
70     install -Dp -m0644 refind.conf-sample %{buildroot}%{_datadir}/%{name}/refind/
71     cp -a icons %{buildroot}%{_datadir}/%{name}/refind/
72     rm -rf %{buildroot}%{_datadir}/%{name}/refind/icons/svg
73     install -Dp -m0755 refind-install %{buildroot}%{_datadir}/%{name}/
74    
75     # Copy man pages
76     mkdir -p %{buildroot}%{_mandir}/man8
77     install -Dp -m0644 docs/man/mvrefind.8 %{buildroot}%{_mandir}/man8
78     install -Dp -m0644 docs/man/mkrlconf.8 %{buildroot}%{_mandir}/man8
79     install -Dp -m0644 docs/man/refind-install.8 %{buildroot}%{_mandir}/man8
80     install -Dp -m0644 docs/man/refind-mkdefault.8 %{buildroot}%{_mandir}/man8
81    
82     # Copy scripts
83     mkdir -p %{buildroot}%{_sbindir}
84     install -Dp -m0755 mkrlconf %{buildroot}%{_sbindir}/
85     install -Dp -m0755 mvrefind %{buildroot}%{_sbindir}/
86     install -Dp -m0755 refind-mkdefault %{buildroot}%{_sbindir}/
87     ln -sr %{buildroot}%{_datadir}/%{name}/refind-install %{buildroot}%{_sbindir}
88    
89     # Copy banners and fonts
90     cp -a banners %{buildroot}%{_datadir}/%{name}/
91     cp -a fonts %{buildroot}%{_datadir}/%{name}/
92    
93 martinw 1876381 # Create sysconfig file
94     mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
95     echo "REFIND_BANNER=%{_datadir}/%{name}/refind/icons/dark-blue-banner.png" > %{buildroot}%{_sysconfdir}/sysconfig/refind
96     echo "MAGEIA_THEME=%{_datadir}/mga/backgrounds/Mageia-Default-3840x2160.png" >> %{buildroot}%{_sysconfdir}/sysconfig/refind
97    
98 martinw 1258909 # Create version file and urpmi README file
99 martinw 1258332 echo %{version} > VERSION
100     echo "Version %{version} of the rEFInd boot manager is now available." > README.urpmi
101     echo "To install it in the ESP, either use drakboot or, as root user," >> README.urpmi
102     echo "execute the command '/sbin/refind-install'." >> README.urpmi
103     echo "If you are having no problems with booting your system, there is" >> README.urpmi
104     echo "no need to install this update in the ESP." >> README.urpmi
105    
106     %files
107     %doc NEWS.txt COPYING.txt LICENSE.txt README.txt CREDITS.txt docs/Styles docs/refind
108 martinw 1258909 %doc VERSION README.urpmi
109 martinw 1258332 %{_sbindir}/mkrlconf
110     %{_sbindir}/mvrefind
111     %{_sbindir}/refind-install
112     %{_sbindir}/refind-mkdefault
113     %{_datadir}/%{name}
114     %{_mandir}/man8/*
115 martinw 1876381 %config %{_sysconfdir}/sysconfig/refind

  ViewVC Help
Powered by ViewVC 1.1.30