/[packages]/cauldron/roundcubemail/current/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/current/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 129152 - (hide annotations) (download)
Mon Jul 25 14:06:51 2011 UTC (12 years, 8 months ago) by dams
File size: 4882 byte(s)
Remove link to Mandriva Wiki
1 dams 129152 %define rel 2
2 dams 129149 %define beta 0
3     %if %beta
4     %define release %mkrel 0.%beta.%rel
5     %define distname %name-%version-%beta-dep.tar.gz
6     %define dirname %name-%version-%beta-dep
7     %else
8     %define release %mkrel %rel
9     %define distname %name-%version-dep.tar.gz
10     %define dirname %name-%version-dep
11     %endif
12    
13     Name: roundcubemail
14     Version: 0.5.3
15     Release: %{release}
16     Summary: A PHP-based webmail server
17     Group: System/Servers
18 dams 129151 License: GPLv3
19 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
20     # rather than including them, which is better for our purposes.
21     # - AdamW 2007/07
22     URL: http://www.roundcube.net/
23     Source0: http://downloads.sourceforge.net/roundcubemail/%{distname}
24     Epoch: 1
25     #BuildRequires: apache-devel pcre-devel rpm-helper
26     Requires: apache-mod_php
27     Requires: php-gd
28     Requires: php-gettext
29     Requires: php-iconv
30     Requires: php-mbstring
31     Requires: php-mcrypt
32     Requires: php-openssl
33     Requires: php-pspell
34     Requires: php-session
35     Requires: php-pear-Auth_SASL
36     Requires: php-pear-Mail_Mime
37     Requires: php-pear-Net_SMTP
38     Requires: php-pear-Net_LDAP2
39     Requires: php-pear-MDB2
40     Requires: php-pear-Net_IDNA2
41     # The installer suggests the use of these, but they're not
42     # required - AdamW 2011/01
43     Suggests: php-fileinfo
44     Suggests: php-intl
45     # Most people will probably use mysql, but you can use sqlite or
46     # pgsql, so not a hard require - AdamW 2008/10
47     Suggests: php-pear-MDB2_Driver_mysql
48    
49     BuildArch: noarch
50    
51     %description
52     RoundCube Webmail is a browser-based multilingual IMAP client with an
53     application-like user interface. It provides full functionality you
54     expect from an e-mail client, including MIME support, address book,
55     folder manipulation, message searching and spell checking. RoundCube
56     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
57     The user interface is fully skinnable using XHTML and CSS 2.
58    
59     %prep
60     %setup -q -n %{dirname}
61    
62     %build
63    
64     %install
65     rm -rf %{buildroot}
66     # tell it that we're moving the configuration files
67     for i in installer/index.php program/include/iniset.php; do \
68     sed -i \
69     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
70     $i; \
71     done
72     # use systemwide log dir and temp dir
73     sed -i \
74     -e 's,logs/,%{_logdir}/%{name}/,g' \
75     -e 's,temp/,/tmp/,g' \
76     config/main.inc.php.dist
77     mkdir -p %{buildroot}%{_datadir}/%{name}
78     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
79     mkdir -p %{buildroot}%{_logdir}/%{name}
80     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
81     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php.dist
82     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
83     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php.dist
84     rm -rf config
85     rm -rf temp
86     rm -rf logs
87     cp -a * %{buildroot}%{_datadir}/%{name}
88    
89     pushd %{buildroot}%{_datadir}/%{name}
90     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
91     popd
92    
93    
94     cat <<EOF > README.urpmi
95    
96     It therefore differs from a standard installation in the following
97     ways:
98    
99     * Logs are stored to /var/log/roundcubemail
100     * Temporary files are placed in /tmp
101     * Configuration files (main.inc.php and db.inc.php) are placed in
102     /etc/roundcubemail
103    
104     You will need to edit /etc/roundcubemail/main.inc.php and
105     /etc/roundcubemail/db.inc.php appropriately for your site before you
106     can use Roundcube. You must at least configure an appropriate mail
107     server and port in main.inc.php, and change the
108     $rcmail_config['des_key'] setting. In db.inc.php you must configure
109     an appropriate database location and user; in the most simple
110     configuration, you would create a new user and database both named
111     'roundcubemail' on a MySQL server running on the same machine, give
112     the roundcubemail user full read/write access to the roundcubemail
113     database, and set db.inc.php appropriately. Roundcubemail ships with
114     an installer which can help you do all this, but it is disabled by
115     default for security reasons. You can enable it in main.inc.php by
116     setting the 'enable_installer' variable to 'true'. Then browse to
117     http://server/roundcubemail/installer to use the installer.
118     EOF
119    
120     mkdir -p %{buildroot}%{_webappconfdir}
121     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
122     Alias /%{name} %{_datadir}/%{name}
123    
124     <Directory %{_datadir}/%{name}>
125     Order allow,deny
126     Allow from all
127     </Directory>
128    
129     <Directory %{_datadir}/%{name}/SQL>
130     Order deny,allow
131     Deny from all
132     </Directory>
133    
134     php_value suhosin.session.encrypt Off
135     EOF
136    
137     %clean
138     rm -rf %{buildroot}
139    
140     %files
141     %doc CHANGELOG README README.urpmi UPGRADING
142     %{_datadir}/%{name}
143     %dir %{_sysconfdir}/%{name}
144     %{_logdir}/%{name}
145     # these store the default values, the installer refers to them
146     # no need to edit them so they're not tagged config - AdamW 2011/01
147     %{_sysconfdir}/%{name}/db.inc.php.dist
148     %{_sysconfdir}/%{name}/main.inc.php.dist
149     %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
150     %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
151     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30