/[packages]/cauldron/roundcubemail/current/SPECS/roundcubemail.spec
ViewVC logotype

Annotation of /cauldron/roundcubemail/current/SPECS/roundcubemail.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 188741 - (hide annotations) (download)
Thu Dec 29 18:26:38 2011 UTC (12 years, 3 months ago) by guillomovitch
File size: 5068 byte(s)
- ensure db configuration file is not world-readable
- don't ship useless file under configuration directory
- use herein document for README.urpmi
- fix some typos in README.urpmi

1 dams 188735 %define rel 2
2 dams 129149 %define beta 0
3     %if %beta
4     %define release %mkrel 0.%beta.%rel
5     %define distname %name-%version-%beta-dep.tar.gz
6     %define dirname %name-%version-%beta-dep
7     %else
8     %define release %mkrel %rel
9     %define distname %name-%version-dep.tar.gz
10     %define dirname %name-%version-dep
11     %endif
12    
13     Name: roundcubemail
14 dams 184800 Version: 0.7
15 dams 129149 Release: %{release}
16     Summary: A PHP-based webmail server
17     Group: System/Servers
18 dams 129151 License: GPLv3
19 dams 129149 # Use the -dep tarballs. These use system copies of the PHP stuff
20     # rather than including them, which is better for our purposes.
21     # - AdamW 2007/07
22     URL: http://www.roundcube.net/
23     Source0: http://downloads.sourceforge.net/roundcubemail/%{distname}
24     Epoch: 1
25     #BuildRequires: apache-devel pcre-devel rpm-helper
26     Requires: apache-mod_php
27     Requires: php-gd
28     Requires: php-gettext
29     Requires: php-iconv
30     Requires: php-mbstring
31     Requires: php-mcrypt
32     Requires: php-openssl
33     Requires: php-pspell
34     Requires: php-session
35     Requires: php-pear-Auth_SASL
36     Requires: php-pear-Mail_Mime
37     Requires: php-pear-Net_SMTP
38     Requires: php-pear-Net_LDAP2
39     Requires: php-pear-MDB2
40     Requires: php-pear-Net_IDNA2
41     # The installer suggests the use of these, but they're not
42     # required - AdamW 2011/01
43     Suggests: php-fileinfo
44     Suggests: php-intl
45     # Most people will probably use mysql, but you can use sqlite or
46     # pgsql, so not a hard require - AdamW 2008/10
47     Suggests: php-pear-MDB2_Driver_mysql
48    
49     BuildArch: noarch
50    
51     %description
52     RoundCube Webmail is a browser-based multilingual IMAP client with an
53     application-like user interface. It provides full functionality you
54     expect from an e-mail client, including MIME support, address book,
55     folder manipulation, message searching and spell checking. RoundCube
56     Webmail is written in PHP and requires a MySQL or PostgreSQL database.
57     The user interface is fully skinnable using XHTML and CSS 2.
58    
59 dams 188735 If upgading an existing installation, please read instructions under
60     %{docdir}/README.urpmi for upgrading your MySQL/PostgreSQL/SQLite
61     database.
62    
63 dams 129149 %prep
64     %setup -q -n %{dirname}
65    
66     %build
67    
68     %install
69     rm -rf %{buildroot}
70     # tell it that we're moving the configuration files
71     for i in installer/index.php program/include/iniset.php; do \
72     sed -i \
73     -e "s,INSTALL_PATH . 'config','%{_sysconfdir}/%{name}',g" \
74     $i; \
75     done
76     # use systemwide log dir and temp dir
77     sed -i \
78     -e 's,logs/,%{_logdir}/%{name}/,g' \
79     -e 's,temp/,/tmp/,g' \
80     config/main.inc.php.dist
81     mkdir -p %{buildroot}%{_datadir}/%{name}
82     mkdir -p %{buildroot}%{_sysconfdir}/%{name}
83     mkdir -p %{buildroot}%{_logdir}/%{name}
84     cp -a config/db.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/db.inc.php
85     cp -a config/main.inc.php.dist %{buildroot}%{_sysconfdir}/%{name}/main.inc.php
86     rm -rf config
87     rm -rf temp
88     rm -rf logs
89     cp -a * %{buildroot}%{_datadir}/%{name}
90    
91     pushd %{buildroot}%{_datadir}/%{name}
92     rm -f CHANGELOG INSTALL UPGRADING LICENSE README
93     popd
94    
95     mkdir -p %{buildroot}%{_webappconfdir}
96     cat > %{buildroot}%{_webappconfdir}/%{name}.conf <<EOF
97     Alias /%{name} %{_datadir}/%{name}
98    
99     <Directory %{_datadir}/%{name}>
100     Order allow,deny
101     Allow from all
102     </Directory>
103    
104     <Directory %{_datadir}/%{name}/SQL>
105     Order deny,allow
106     Deny from all
107     </Directory>
108    
109     php_value suhosin.session.encrypt Off
110     EOF
111    
112 guillomovitch 188741 cat > README.urpmi <<EOF
113     Mageia RPM specific notes
114    
115     setup
116     -----
117     The setup used here differs from a standard installation in the following
118     ways:
119     * Logs are stored to /var/log/roundcubemail
120     * Temporary files are placed in /tmp
121     * Configuration files (main.inc.php and db.inc.php) are placed in
122     %{_sysconfdir}/roundcubemail
123    
124     upgrade
125     -------
126     Use the GUI to do the configuration/upgrade:
127     RoundCube provides an installer which can help you to do all
128     the installation/upgrade. The feature is disabled by default for
129     security reasons but you can enable it in 'main.inc.php' by
130     setting the 'enable_installer' variable to 'true'.
131     Once done, browse http://server/roundcubemail/installer
132    
133     Use the CLI to do the configuration/upgrade:
134     You will need to edit %{_sysconfdir}/roundcubemail/main.inc.php and
135     %{_sysconfdir}/roundcubemail/db.inc.php appropriately for your site before you
136     can use Roundcube. You must at least configure an appropriate mail
137     server and port in main.inc.php, and change the
138     $rcmail_config['des_key'] setting. In db.inc.php you must configure
139     an appropriate database location and user; in the most simple
140     configuration, you would create a new user and database both named
141     'roundcubemail' on a MySQL server running on the same machine, give
142     the roundcubemail user full read/write access to the roundcubemail
143     database, and set db.inc.php appropriately.
144    
145     Information:
146     - you can drop all of the tables and use the '*.initial.sql' file
147     to fully recreate the database.
148     - If any database change is needed, go to %{_datadir}/roundcubemail/SQL
149     and use '*.update.sql' where '*' is your database backend type.
150     EOF
151    
152 dams 129149 %files
153 dams 188735 %doc CHANGELOG README UPGRADING
154 dams 129149 %{_datadir}/%{name}
155     %dir %{_sysconfdir}/%{name}
156     %{_logdir}/%{name}
157 guillomovitch 188741 %attr(640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php
158 dams 129149 %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php
159     %config(noreplace) %{_webappconfdir}/%{name}.conf

  ViewVC Help
Powered by ViewVC 1.1.30