/[packages]/cauldron/rpm-mageia-setup/current/SPECS/rpm-mageia-setup.spec
ViewVC logotype

Annotation of /cauldron/rpm-mageia-setup/current/SPECS/rpm-mageia-setup.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 560992 - (hide annotations) (download)
Fri Dec 27 21:46:59 2013 UTC (10 years, 3 months ago) by pterjan
File size: 2992 byte(s)
Use correct macro for gems dir now that rubygems moved
1 blino 25078 # hardcoded so that build from another distro keeps this name
2     # (mandatory to have correct package name and source name)
3 blino 25060 %define _real_vendor mageia
4 blino 3459
5 blino 3384 %if %{?distsuffix:0}%{?!distsuffix:1}
6 blino 3486 %define distsuffix .mga
7 blino 3384 %endif
8    
9     %if %{?mkrel:0}%{?!mkrel:1}
10 blino 3487 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?distro_release:%distro_release}%{?subrel:.%subrel}
11 blino 3384 %endif
12    
13     # This can be useful for backport, as rpm-4.2
14     # provides the emacs-spec mode
15     %define have_emacsmodespec 1
16    
17     %{?_with_emacsspecmode: %define have_emacsmodespec 1}
18     %{?_without_emacsspecmode: %define have_emacsmodespec 0}
19    
20 blino 3406 Summary: The %{distribution} rpm configuration and scripts
21 blino 25060 Name: rpm-%{_real_vendor}-setup
22 pterjan 560992 Version: 1.196
23 pterjan 558577 Release: %mkrel 1
24 tmb 47647 Source0: %{name}-%{version}.tar.xz
25 fwang 390061 Source1: gettarball.sh
26 dmorgan 489553 # NO PATCH ACCEPTED: WORK in GIT!!!!
27     Patch0: rpm-mageia-setup-1.190-fix-osgi.patch
28 blino 3384 License: GPLv2+
29 fwang 390718 Group: System/Packaging
30 tmb 24937 Url: http://www.mageia.org/
31 blino 3384 BuildRequires: rpm-devel
32 tv 264691 %rename rpm-mandriva-setup
33 blino 3384
34     %description
35 blino 3406 The %{distribution} rpm configuration and scripts.
36 blino 3384
37     %package build
38 fwang 390718 Group: System/Packaging
39 blino 3406 Summary: The %{distribution} rpm configuration and scripts to build rpms
40 blino 3404 Requires: spec-helper
41 misc 142547 Requires: multiarch-utils
42     # needed for script to extract pkgconfig info
43 blino 3384 Requires: pkgconfig
44     Requires: python-pkg-resources
45 blino 201807 Requires: rpmlint-mageia-policy
46 blino 3384 Requires: %name = %version-%release
47 blino 3404 # for product version macros
48 misc 142548 Requires: %{_real_vendor}-release
49 tv 264691 %rename rpm-mandriva-setup-build
50 tv 278305 Requires: dwz
51 blino 3384
52     %description build
53 blino 3406 The %{distribution} rpm configuration and scripts dedicated to build rpms.
54 blino 3384
55     %prep
56     %setup -q
57 dmorgan 489553 %apply_patches
58 blino 3384
59     %build
60 misc 142547 %configure2_5x
61 blino 3384
62     %make
63    
64     %install
65     %makeinstall_std
66    
67 cjw 119922 mkdir -p %{buildroot}%{_sysconfdir}/rpm/macros.d
68 blino 3384
69 misc 142547 # FIXME better fix the Makefile directly in the source code
70 cjw 119922 mv %{buildroot}%{_prefix}/lib/rpm/%{_real_vendor}/macros %{buildroot}%{_sysconfdir}/rpm/macros.d/20common.macros
71     mv %{buildroot}%{_sysconfdir}/rpm/macros.d/{build.macros,20build.macros}
72 blino 3384
73     %if %have_emacsmodespec
74     # spec mode for emacs
75     install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
76     install -m644 rpm-spec-mode.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/
77    
78     install -d $RPM_BUILD_ROOT%{_sysconfdir}/emacs/site-start.d
79     cat <<EOF >$RPM_BUILD_ROOT%{_sysconfdir}/emacs/site-start.d/%{name}.el
80     (setq auto-mode-alist (cons '("\\\\.spec$" . rpm-spec-mode) auto-mode-alist))
81 blino 3488 (autoload 'rpm-spec-mode "rpm-spec-mode" "RPM spec mode (for %{distribution})." t)
82 blino 3384 EOF
83     %endif
84    
85     %check
86     make test
87    
88     %files
89 blino 25060 %dir %{_prefix}/lib/rpm/%{_real_vendor}
90 tmb 47647 %{_prefix}/lib/rpm/%{_real_vendor}/rpmrc
91 blino 3384 %dir %{_sysconfdir}/rpm/macros.d
92     %{_sysconfdir}/rpm/macros.d/20common.macros
93    
94     %files build
95 dmorgan 450289 %doc NEWS
96 blino 3384 %{_sysconfdir}/rpm/macros.d/20build.macros
97 tv 275050 %{_sysconfdir}/rpm/macros.d/dwz.macros
98 blino 25060 %{_prefix}/lib/rpm/%{_real_vendor}/*
99 tmb 47647 %exclude %{_prefix}/lib/rpm/%{_real_vendor}/rpmrc
100 blino 3384 %if %have_emacsmodespec
101     %{_datadir}/emacs/site-lisp/rpm-spec-mode.el
102     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/%{name}.el
103     %endif

  ViewVC Help
Powered by ViewVC 1.1.30