/[packages]/cauldron/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /cauldron/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 276213 - (hide annotations) (download)
Mon Jul 30 17:59:52 2012 UTC (11 years, 8 months ago) by tv
File size: 19983 byte(s)
- add minidebug support
- build with db-5.3
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 255921 %define rpmversion 4.10.0
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 276213 %define release %mkrel %{?snapver:0.%{snapver}.}6
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97     # (fredl) add loging facilities through syslog
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
123 tmb 343
124     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
125     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
126     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
127     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
128     # but this is bad design anyway
129 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
130 tmb 343
131     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
132 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
133 tv 215854 Patch134: extcond.diff
134 tmb 343
135 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
136 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
137     # implementation: as long as debugedit can just overwrite data in the elf
138     # sections things keep relatively easy, but if dest_dir is longer than the
139     # original directory, debugedit would have to expand the whole elf file. Which
140     # might be technically possible but debugedit currently does not even try to."
141 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
142 dmorgan 49378
143 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
144     # with this patch, "#%define foo bar" is a fatal error
145 dmorgan 185007 # Bug still valid => Send upstream for review.
146 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
147 tmb 343
148     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
149 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
150     Patch146: rpm-4.9.1.1-filetriggers.patch
151 tmb 343
152     # add two fatal errors (during package build)
153 dmorgan 185007 # Useful ? to drop ?
154     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
155 tmb 343
156     # (nb: see the patch for more info about this issue)
157 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
158 tmb 343
159 dmorgan 185007 #Patch157: introduce-_after_setup-which-is-called-after-setup.patch
160     #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
161 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
162 tmb 343
163     Patch1007: rpm-4.6.0-rc3-xz-support.patch
164    
165     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
166     # as this breaks stuff that installs files to $DOCDIR during %%install
167 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
168 tmb 343
169     # Turbolinux patches
170     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
171     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
172    
173 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
174 dmorgan 49378
175 tv 262316 # (tv) fix tests:
176     Patch2100: rpm-4.10.0-fix-testsuite.diff
177 tv 255921
178 tmb 343 Patch3000: mips_macros.patch
179     Patch3001: fix_stack_protector_check.patch
180 tv 256616 Patch3002: mips_define_isa_macros.patch
181     Patch3003: rpm_arm_mips_isa_macros.patch
182     Patch3004: rpm_add_armv5tl.patch
183 tmb 343
184 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
185     # and not full path
186     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
187 tv 223198 #
188 dmorgan 185007 # Fedora patches
189 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
190     #
191 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
192     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
193 tv 276213 Patch3501: rpm-minidebuginfo.patch
194 dmorgan 185007
195     License: GPLv2+
196     BuildRequires: autoconf
197 tmb 343 BuildRequires: zlib-devel
198     BuildRequires: bzip2-devel
199 tv 276213 BuildRequires: liblzma-devel >= 5
200 dmorgan 185007 BuildRequires: automake
201 tmb 343 BuildRequires: elfutils-devel
202     BuildRequires: libbeecrypt-devel
203 dmorgan 185007 BuildRequires: ed
204     BuildRequires: gettext-devel
205 tmb 343 BuildRequires: libsqlite3-devel
206 tv 276213 BuildRequires: db5.3-devel
207 tmb 343 BuildRequires: neon-devel
208     BuildRequires: popt-devel
209     BuildRequires: nss-devel
210     BuildRequires: magic-devel
211 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
212 tmb 343 BuildRequires: readline-devel
213     BuildRequires: ncurses-devel
214 dmorgan 185007 BuildRequires: openssl-devel
215 tv 256683 BuildRequires: lua5.1-devel
216 dmorgan 185007 BuildRequires: libcap-devel
217     # Needed for doc
218 tmb 343 #BuildRequires: graphviz
219 dmorgan 185007 BuildRequires: tetex
220 tmb 343 %if %buildpython
221     BuildRequires: python-devel
222     %endif
223 tv 223263 # for testsuite:
224     BuildRequires: fakechroot
225 tmb 343
226     Requires: bzip2 >= 0.9.0c-2
227     Requires: lzma
228     Requires: cpio
229     Requires: gawk
230     Requires: glibc >= 2.1.92
231     Requires: mktemp
232 tmb 345 Requires: setup >= 2.2.0-8
233 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
234 tmb 343 Requires: update-alternatives
235     Requires: %librpmname = %epoch:%version-%release
236     URL: http://rpm.org/
237     %define git_url http://rpm.org/git/rpm.git
238 dmorgan 185007 Requires(pre): rpm-helper
239 tmb 343 Requires(pre): coreutils
240 dmorgan 185007 Requires(postun): rpm-helper
241 tmb 343
242 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
243 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
244 dmorgan 185007
245 tmb 343 %description
246     RPM is a powerful command line driven package management system capable of
247     installing, uninstalling, verifying, querying, and updating software packages.
248     Each software package consists of an archive of files along with information
249     about the package like its version, a description, etc.
250    
251 dmorgan 185191 %package -n %librpmbuild
252     Summary: Libraries for building and signing RPM packages
253     Group: System/Libraries
254     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
255     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
256    
257     %description -n %librpmbuild
258     This package contains the RPM shared libraries for building and signing
259     packages.
260    
261     %package -n %librpmsign
262     Summary: Libraries for building and signing RPM packages
263     Group: System/Libraries
264    
265     %description -n %librpmsign
266     This package contains the RPM shared libraries for building and signing
267     packages.
268    
269 tmb 343 %package -n %librpmname
270 tmb 345 Summary: Library used by rpm
271     Group: System/Libraries
272     Provides: librpm = %version-%release
273 tmb 343
274     %description -n %librpmname
275     RPM is a powerful command line driven package management system capable of
276     installing, uninstalling, verifying, querying, and updating software packages.
277     This package contains common files to all applications based on rpm.
278    
279     %package -n %librpmnamedevel
280     Summary: Development files for applications which will manipulate RPM packages
281     Group: Development/C
282     Requires: rpm = %epoch:%{version}-%{release}
283     Provides: librpm-devel = %version-%release
284     Provides: rpm-devel = %version-%release
285 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
286     Requires: %librpmbuild = %epoch:%version-%release
287     Requires: %librpmsign = %epoch:%version-%release
288 tmb 343
289     %description -n %librpmnamedevel
290     This package contains the RPM C library and header files. These
291     development files will simplify the process of writing programs
292     which manipulate RPM packages and databases and are intended to make
293     it easier to create graphical package managers or any other tools
294     that need an intimate knowledge of RPM packages in order to function.
295    
296     This package should be installed if you want to develop programs that
297     will manipulate RPM packages and databases.
298    
299     %package build
300     Summary: Scripts and executable programs used to build packages
301     Group: System/Configuration/Packaging
302     Requires: autoconf
303     Requires: automake
304     Requires: file
305     Requires: gcc-c++
306     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
307 dmorgan 185007 Requires: libtool-base
308     Requires: patch
309 tmb 343 Requires: make
310     Requires: tar
311     Requires: unzip
312     Requires: elfutils
313 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
314 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
315 dmorgan 185007 Requires: perl(YAML::Tiny)
316 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
317 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
318 tmb 343
319     %description build
320     This package contains scripts and executable programs that are used to
321     build packages using RPM.
322    
323 dmorgan 185007 %package sign
324     Summary: Package signing support
325     Group: System/Base
326    
327     %description sign
328     This package contains support for digitally signing RPM packages.
329    
330 tmb 343 %if %buildpython
331     %package -n python-rpm
332     Summary: Python bindings for apps which will manipulate RPM packages
333     Group: Development/Python
334     Requires: rpm = %epoch:%{version}-%{release}
335    
336     %description -n python-rpm
337     The rpm-python package contains a module which permits applications
338     written in the Python programming language to use the interface
339     supplied by RPM (RPM Package Manager) libraries.
340    
341     This package should be installed if you want to develop Python
342     programs that will manipulate RPM packages and databases.
343     %endif
344    
345     %prep
346     %setup -q -n %name-%srcver
347 dmorgan 186388 %apply_patches
348 tmb 343
349     %build
350     autoreconf
351    
352     %if %builddebug
353     RPM_OPT_FLAGS=-g
354     %endif
355 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
356 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
357 fwang 215771 %configure2_5x \
358 tmb 343 --enable-nls \
359     --enable-python \
360     --enable-sqlite3 \
361     --without-javaglue \
362     %if %builddebug
363     --enable-debug \
364     %endif
365 dmorgan 185007 --with-external-db \
366 tmb 343 %if %buildpython
367     --with-python=%{pyver} \
368     %else
369     --without-python \
370     %endif
371 dmorgan 185007 %if ! %buildplugins
372     --disable-plugins \
373     %endif
374 tmb 343 --with-glob \
375     --without-selinux \
376 dmorgan 185007 --without-apidocs \
377     --with-cap
378 tmb 343
379     %make
380    
381     %install
382 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
383 tmb 343
384     make DESTDIR=%buildroot install
385    
386 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
387    
388 tmb 343 # Save list of packages through cron
389     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
390     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
391    
392     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
393     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
394    
395     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
396     for dbi in \
397     Basenames Conflictname Dirnames Group Installtid Name Providename \
398     Provideversion Removetid Requirename Requireversion Triggername \
399 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
400     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
401 tmb 343 do
402     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
403     done
404    
405     test -d doc-copy || mkdir doc-copy
406     rm -rf doc-copy/*
407     ln -f doc/manual/* doc-copy/
408     rm -f doc-copy/Makefile*
409    
410     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
411    
412     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
413     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
414     # Put your own system macros here
415     # usually contains
416    
417     # Set this one according your locales
418     # %%_install_langs
419    
420     EOF
421    
422     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
423    
424 tv 206214 %check
425     make check
426    
427 tmb 343 %pre
428     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
429    
430     rm -rf /usr/lib/rpm/*-mandrake-*
431 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
432 tmb 343
433 tmb 345
434 tmb 343 %post
435     # nuke __db.00? when updating to this rpm
436     rm -f /var/lib/rpm/__db.00?
437    
438 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
439 tmb 343 /bin/rpm --initdb
440     fi
441    
442     %postun
443     /usr/share/rpm-helper/del-user rpm $1 rpm
444    
445     %define rpmattr %attr(0755, rpm, rpm)
446    
447     %files -f %{name}.lang
448     %defattr(-,root,root)
449     %doc GROUPS CHANGES doc/manual/[a-z]*
450     %attr(0755,rpm,rpm) /bin/rpm
451     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
452     %attr(0755, rpm, rpm) %{_bindir}/gendiff
453     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
454 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
455 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
456     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
457     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
458    
459     %dir %{_localstatedir}/spool/repackage
460     %dir %{rpmdir}
461     %dir /etc/rpm
462     %config(noreplace) /etc/rpm/macros
463     %dir /etc/rpm/macros.d
464     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
465     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
466     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
467     %attr(0644, rpm, rpm) %{rpmdir}/macros
468     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
469     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
470     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
471     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
472 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
473     %attr(0755, rpm, rpm) %{rpmdir}/script.req
474 tv 256610 %exclude %{rpmdir}/tcl.req
475 tmb 343
476     %rpmattr %{rpmdir}/rpm2cpio.sh
477     %rpmattr %{rpmdir}/tgpg
478    
479 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
480     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
481    
482 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
483     %ifarch %{ix86} x86_64
484     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
485     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
486     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
487     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
488 rtp 267694 %else
489     %exclude %{rpmdir}/platform/i*86-linux/macros
490     %exclude %{rpmdir}/platform/athlon-linux/macros
491     %exclude %{rpmdir}/platform/pentium*-linux/macros
492     %exclude %{rpmdir}/platform/geode-linux/macros
493 tmb 343 %endif
494     %ifarch x86_64
495     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
496     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
497     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
498 rtp 267694 %else
499     %exclude %{rpmdir}/platform/amd64-linux/macros
500     %exclude %{rpmdir}/platform/ia32e-linux/macros
501     %exclude %{rpmdir}/platform/x86_64-linux/macros
502 tmb 343 %endif
503     %ifarch %arm
504 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
505 tv 256613 %else
506     %exclude %{rpmdir}/platform/arm*/macros
507 tmb 343 %endif
508     %ifarch %mips
509     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
510     %endif
511     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
512 tv 256613 # new in 4.10.0:
513     %exclude %{rpmdir}/platform/alpha*-linux/macros
514     %exclude %{rpmdir}/platform/sparc*-linux/macros
515     %exclude %{rpmdir}/platform/ia64*-linux/macros
516     %exclude %{rpmdir}/platform/ppc*-linux/macros
517     %exclude %{rpmdir}/platform/s390*-linux/macros
518     %exclude %{rpmdir}/platform/sh*-linux/macros
519 tmb 343
520 tv 256613
521    
522 tmb 343 %{_mandir}/man[18]/*.[18]*
523     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
524     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
525     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
526     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
527     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
528     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
529    
530     %config(noreplace,missingok) /etc/cron.daily/rpm
531     %config(noreplace,missingok) /etc/logrotate.d/rpm
532    
533     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
534    
535     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
536    
537     %rpmdbattr /var/lib/rpm/Basenames
538     %rpmdbattr /var/lib/rpm/Conflictname
539     %rpmdbattr /var/lib/rpm/__db.0*
540     %rpmdbattr /var/lib/rpm/Dirnames
541     %rpmdbattr /var/lib/rpm/Group
542     %rpmdbattr /var/lib/rpm/Installtid
543     %rpmdbattr /var/lib/rpm/Name
544 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
545 tmb 343 %rpmdbattr /var/lib/rpm/Packages
546     %rpmdbattr /var/lib/rpm/Providename
547     %rpmdbattr /var/lib/rpm/Provideversion
548     %rpmdbattr /var/lib/rpm/Removetid
549     %rpmdbattr /var/lib/rpm/Requirename
550     %rpmdbattr /var/lib/rpm/Requireversion
551 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
552     %rpmdbattr /var/lib/rpm/Sigmd5
553 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
554    
555     %files build
556     %defattr(-,root,root)
557     %doc CHANGES
558     %doc doc-copy/*
559     %rpmattr %{_bindir}/rpmbuild
560 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
561 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
562     %rpmattr %{_prefix}/lib/rpm/check-files
563     %rpmattr %{_prefix}/lib/rpm/debugedit
564 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
565 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
566     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
567     %rpmattr %{_prefix}/lib/rpm/find-provides
568     %rpmattr %{_prefix}/lib/rpm/find-requires
569 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
570 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
571     %rpmattr %{_prefix}/lib/rpm/perl.prov
572     %rpmattr %{_prefix}/lib/rpm/perl.req
573    
574     %rpmattr %{_prefix}/lib/rpm/check-buildroot
575     %rpmattr %{_prefix}/lib/rpm/check-prereqs
576     %rpmattr %{_prefix}/lib/rpm/check-rpaths
577     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
578     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
579     %rpmattr %{_prefix}/lib/rpm/macros.perl
580     %rpmattr %{_prefix}/lib/rpm/macros.php
581     %rpmattr %{_prefix}/lib/rpm/macros.python
582     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
583     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
584 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
585     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
586 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
587     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
588    
589     %rpmattr %{_prefix}/lib/rpm/rpmdeps
590 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
591 tmb 343
592 tv 255921
593 tmb 343 %{_mandir}/man8/rpmbuild.8*
594     %{_mandir}/man8/rpmdeps.8*
595    
596     %if %buildpython
597     %files -n python-rpm
598     %defattr(-,root,root)
599     %{_libdir}/python*/site-packages/rpm
600     %endif
601    
602     %files -n %librpmname
603     %defattr(-,root,root)
604 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
605     %{_libdir}/librpmio.so.%{libmajor}*
606 dmorgan 185007 %if %{with plugins}
607     %{_libdir}/rpm-plugins
608     %endif
609    
610     %files -n %librpmbuild
611 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
612 tmb 343
613 dmorgan 185007 %files -n %librpmsign
614     %{_libdir}/librpmsign.so.%{libmajorsign}*
615    
616     %files sign
617     %defattr(-,root,root)
618     %{_bindir}/rpmsign
619     %{_mandir}/man8/rpmsign.8*
620    
621 tmb 343 %files -n %librpmnamedevel
622     %defattr(-,root,root)
623     %{_includedir}/rpm
624     %{_libdir}/librpm.so
625     %{_libdir}/librpmio.so
626     %{_libdir}/librpmbuild.so
627 dmorgan 185007 %{_libdir}/librpmsign.so
628 tmb 343 %{_libdir}/pkgconfig/rpm.pc
629 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30