/[packages]/cauldron/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /cauldron/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 327228 - (hide annotations) (download)
Thu Dec 6 10:24:50 2012 UTC (11 years, 4 months ago) by tv
File size: 20584 byte(s)
drop patch not intended for 4.10 (SILENT)
1 dmorgan 185007 %define lib64arches x86_64
2 tmb 343
3     %ifarch %lib64arches
4     %define _lib lib64
5     %else
6     %define _lib lib
7     %endif
8    
9     %define _prefix /usr
10     %define _libdir %_prefix/%_lib
11     %define _bindir %_prefix/bin
12     %define _sysconfdir /etc
13     %define _datadir /usr/share
14     %define _defaultdocdir %_datadir/doc
15     %define _localstatedir /var
16     %define _infodir %_datadir/info
17    
18     %if %{?apply_patches:0}%{?!apply_patches:1}
19     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
20     %endif
21    
22     # Define directory which holds rpm config files, and some binaries actually
23     # NOTE: it remains */lib even on lib64 platforms as only one version
24     # of rpm is supported anyway, per architecture
25     %define rpmdir %{_prefix}/lib/rpm
26    
27     %if %{?mklibname:0}%{?!mklibname:1}
28     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
29     %endif
30    
31     %if %{?distsuffix:0}%{?!distsuffix:1}
32 tmb 345 %define distsuffix .mga
33 tmb 343 %endif
34    
35     %if %{?mkrel:0}%{?!mkrel:1}
36 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
37 tmb 343 %endif
38    
39     %if %{?mips:0}%{?!mips:1}
40     %define mips mips mipsel mips32 mips32el mips64 mips64el
41     %endif
42    
43     %if %{?pyver:0}%{?!pyver:1}
44     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
45     %endif
46    
47 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
48     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
49 tmb 343
50 tv 302329 %define rpmversion 4.10.1
51 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
52 tv 264614 %define libver 4.10
53 tv 255921 %define libmajor 3
54     %define libmajorsign 1
55 tv 327195 %define release %mkrel %{?snapver:0.%{snapver}.}6
56 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
57 tmb 345 %define librpmnamedevel %mklibname -d rpm
58 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
59     %define librpmbuild %mklibname rpmbuild %{libmajor}
60 tmb 343
61     %define buildpython 1
62     %define rpmsetup_version 1.34
63    
64     %define builddebug 0
65     %{?_with_debug:%define builddebug 1}
66    
67     %{?_with_python:%define buildpython 1}
68     %{?_without_python:%define buildpython 0}
69    
70 dmorgan 186381 # disable plugins initially
71 dmorgan 185007 %define buildplugins 0
72     %{?_with_plugins:%define buildplugins 1}
73    
74 tmb 343 Summary: The RPM package management system
75     Name: rpm
76     Epoch: 1
77 dmorgan 185007 Version: %{rpmversion}
78 dmorgan 49378 Release: %{release}
79 tmb 343 Group: System/Configuration/Packaging
80     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
81 dmorgan 185007 # Add some undocumented feature to gendiff
82     # Send upstream ? drop ?
83     Patch17: rpm-4.4.2.2-gendiff-improved.patch
84 tmb 343
85     # if %post of foo-2 fails,
86     # or if %preun of foo-1 fails,
87     # or if %postun of foo-1 fails,
88     # => foo-1 is not removed, so we end up with both packages in rpmdb
89     # this patch makes rpm ignore the error in those cases
90 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
91 tmb 343 #
92     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
93     # scripts is ignored with or without this patch)
94 tv 262316 # Needed for urpmi testsuite:
95 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
96 tmb 343
97 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
98 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
99 tmb 343
100 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
101     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
102 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
103     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
104 blino 25212
105 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
106     # From popular request, we allow to do this
107 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
108     Patch70: rpm-4.9.1-bb-shortcircuit.patch
109 tmb 343
110     # don't conflict for doc files
111     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
112 tv 256243 Patch83: rpm-4.10.0-no-doc-conflicts.patch
113 tmb 343
114     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
115     # (is this working??)
116     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
117    
118     # Fix diff issue when buildroot contains some "//"
119 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
120 tmb 343
121     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
122 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
123 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
124 tmb 343
125     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
126     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
127     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
128     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
129     # but this is bad design anyway
130 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
131 tmb 343
132     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
133 tv 255921 Patch133: rpm-4.10.0-weakdeps.patch
134 tv 215854 Patch134: extcond.diff
135 tmb 343
136 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
137 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
138     # implementation: as long as debugedit can just overwrite data in the elf
139     # sections things keep relatively easy, but if dest_dir is longer than the
140     # original directory, debugedit would have to expand the whole elf file. Which
141     # might be technically possible but debugedit currently does not even try to."
142 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
143 dmorgan 49378
144 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
145     # with this patch, "#%define foo bar" is a fatal error
146 dmorgan 185007 # Bug still valid => Send upstream for review.
147 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
148 tmb 343
149     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
150 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
151     Patch146: rpm-4.9.1.1-filetriggers.patch
152 tmb 343
153     # add two fatal errors (during package build)
154 dmorgan 185007 # Useful ? to drop ?
155     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
156 tmb 343
157     # (nb: see the patch for more info about this issue)
158 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
159 tmb 343
160 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
161 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
162 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
163 tmb 343
164     Patch1007: rpm-4.6.0-rc3-xz-support.patch
165    
166     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
167     # as this breaks stuff that installs files to $DOCDIR during %%install
168 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
169 tmb 343
170     # Turbolinux patches
171     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
172     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
173    
174 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
175 dmorgan 49378
176 tv 262316 # (tv) fix tests:
177     Patch2100: rpm-4.10.0-fix-testsuite.diff
178 tv 255921
179 tmb 343 Patch3000: mips_macros.patch
180     Patch3001: fix_stack_protector_check.patch
181 tv 256616 Patch3002: mips_define_isa_macros.patch
182     Patch3003: rpm_arm_mips_isa_macros.patch
183     Patch3004: rpm_add_armv5tl.patch
184 tmb 343
185 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
186     # and not full path
187     Patch3005: rpm-4.10-fix-testsuite-pathes.patch
188 tv 223198 #
189 dmorgan 185007 # Fedora patches
190 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
191     #
192 colin 272737 # (cg) Fedora patch to enable a new check used in the 'filesystem' package for usrmove
193     Patch3500: rpm-4.9.1.2-rpmlib-filesystem-check.patch
194 tv 327188 # (tv) Compressed debuginfo support (UPSTREAM)::
195 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
196 tv 327188 # (tv) Mini debuginfo support (UPSTREAM)::
197 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
198 tv 327188 # (tv) fix a rpm-4.10 regression (UPSTREAM)::
199 tv 325714 Patch3503: rpm-4.10.1-skipped-hardlinks.patch
200 dmorgan 185007
201 tv 276795 # (tv) merge mga stuff from rpm-setup:
202     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
203 tv 327188 # (tv) enhance debugedit message (UPSTREAM):
204 tv 308048 Patch4001: fix-debugedit-log.diff
205 tv 276795
206 tv 327195 # (tv) upstream fix for RPMDBI_LABEL (UPSTREAM)::
207     Patch4002: nvra-prep.diff
208    
209    
210 dmorgan 185007 License: GPLv2+
211     BuildRequires: autoconf
212 tmb 343 BuildRequires: zlib-devel
213     BuildRequires: bzip2-devel
214 tv 276213 BuildRequires: liblzma-devel >= 5
215 dmorgan 185007 BuildRequires: automake
216 tmb 343 BuildRequires: elfutils-devel
217     BuildRequires: libbeecrypt-devel
218 dmorgan 185007 BuildRequires: ed
219     BuildRequires: gettext-devel
220 tmb 343 BuildRequires: libsqlite3-devel
221 tv 276213 BuildRequires: db5.3-devel
222 tmb 343 BuildRequires: neon-devel
223     BuildRequires: popt-devel
224     BuildRequires: nss-devel
225     BuildRequires: magic-devel
226 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
227 tmb 343 BuildRequires: readline-devel
228     BuildRequires: ncurses-devel
229 dmorgan 185007 BuildRequires: openssl-devel
230 tv 256683 BuildRequires: lua5.1-devel
231 dmorgan 185007 BuildRequires: libcap-devel
232     # Needed for doc
233 tmb 343 #BuildRequires: graphviz
234 dmorgan 185007 BuildRequires: tetex
235 tmb 343 %if %buildpython
236     BuildRequires: python-devel
237     %endif
238 tv 223263 # for testsuite:
239     BuildRequires: fakechroot
240 tmb 343
241     Requires: bzip2 >= 0.9.0c-2
242 tv 302008 Requires: xz
243 tmb 343 Requires: cpio
244     Requires: gawk
245     Requires: glibc >= 2.1.92
246     Requires: mktemp
247 tmb 345 Requires: setup >= 2.2.0-8
248 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
249 tmb 343 Requires: update-alternatives
250     Requires: %librpmname = %epoch:%version-%release
251     URL: http://rpm.org/
252     %define git_url http://rpm.org/git/rpm.git
253 dmorgan 185007 Requires(pre): rpm-helper
254 tmb 343 Requires(pre): coreutils
255 dmorgan 185007 Requires(postun): rpm-helper
256 tmb 343
257 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
258 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
259 dmorgan 185007
260 tmb 343 %description
261     RPM is a powerful command line driven package management system capable of
262     installing, uninstalling, verifying, querying, and updating software packages.
263     Each software package consists of an archive of files along with information
264     about the package like its version, a description, etc.
265    
266 dmorgan 185191 %package -n %librpmbuild
267     Summary: Libraries for building and signing RPM packages
268     Group: System/Libraries
269     Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
270     Provides: rpm-build-libs%{_isa} = %{version}-%{release}
271    
272     %description -n %librpmbuild
273     This package contains the RPM shared libraries for building and signing
274     packages.
275    
276     %package -n %librpmsign
277     Summary: Libraries for building and signing RPM packages
278     Group: System/Libraries
279    
280     %description -n %librpmsign
281     This package contains the RPM shared libraries for building and signing
282     packages.
283    
284 tmb 343 %package -n %librpmname
285 tmb 345 Summary: Library used by rpm
286     Group: System/Libraries
287     Provides: librpm = %version-%release
288 tmb 343
289     %description -n %librpmname
290     RPM is a powerful command line driven package management system capable of
291     installing, uninstalling, verifying, querying, and updating software packages.
292     This package contains common files to all applications based on rpm.
293    
294     %package -n %librpmnamedevel
295     Summary: Development files for applications which will manipulate RPM packages
296     Group: Development/C
297     Requires: rpm = %epoch:%{version}-%{release}
298     Provides: librpm-devel = %version-%release
299     Provides: rpm-devel = %version-%release
300 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
301     Requires: %librpmbuild = %epoch:%version-%release
302     Requires: %librpmsign = %epoch:%version-%release
303 tmb 343
304     %description -n %librpmnamedevel
305     This package contains the RPM C library and header files. These
306     development files will simplify the process of writing programs
307     which manipulate RPM packages and databases and are intended to make
308     it easier to create graphical package managers or any other tools
309     that need an intimate knowledge of RPM packages in order to function.
310    
311     This package should be installed if you want to develop programs that
312     will manipulate RPM packages and databases.
313    
314     %package build
315     Summary: Scripts and executable programs used to build packages
316     Group: System/Configuration/Packaging
317     Requires: autoconf
318     Requires: automake
319     Requires: file
320     Requires: gcc-c++
321     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
322 dmorgan 185007 Requires: libtool-base
323     Requires: patch
324 tmb 343 Requires: make
325     Requires: tar
326     Requires: unzip
327     Requires: elfutils
328 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
329 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
330 dmorgan 185007 Requires: perl(YAML::Tiny)
331 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
332 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
333 tmb 343
334     %description build
335     This package contains scripts and executable programs that are used to
336     build packages using RPM.
337    
338 dmorgan 185007 %package sign
339     Summary: Package signing support
340     Group: System/Base
341    
342     %description sign
343     This package contains support for digitally signing RPM packages.
344    
345 tmb 343 %if %buildpython
346     %package -n python-rpm
347     Summary: Python bindings for apps which will manipulate RPM packages
348     Group: Development/Python
349     Requires: rpm = %epoch:%{version}-%{release}
350    
351     %description -n python-rpm
352     The rpm-python package contains a module which permits applications
353     written in the Python programming language to use the interface
354     supplied by RPM (RPM Package Manager) libraries.
355    
356     This package should be installed if you want to develop Python
357     programs that will manipulate RPM packages and databases.
358     %endif
359    
360     %prep
361     %setup -q -n %name-%srcver
362 dmorgan 186388 %apply_patches
363 tmb 343
364     %build
365     autoreconf
366    
367     %if %builddebug
368     RPM_OPT_FLAGS=-g
369     %endif
370 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
371 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
372 fwang 215771 %configure2_5x \
373 tmb 343 --enable-nls \
374     --enable-python \
375     --enable-sqlite3 \
376     --without-javaglue \
377     %if %builddebug
378     --enable-debug \
379     %endif
380 dmorgan 185007 --with-external-db \
381 tmb 343 %if %buildpython
382     --with-python=%{pyver} \
383     %else
384     --without-python \
385     %endif
386 dmorgan 185007 %if ! %buildplugins
387     --disable-plugins \
388     %endif
389 tmb 343 --with-glob \
390     --without-selinux \
391 dmorgan 185007 --without-apidocs \
392     --with-cap
393 tmb 343
394     %make
395    
396     %install
397 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
398 tmb 343
399     make DESTDIR=%buildroot install
400    
401 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
402    
403 tmb 343 # Save list of packages through cron
404     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
405     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
406    
407     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
408     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
409    
410     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
411     for dbi in \
412     Basenames Conflictname Dirnames Group Installtid Name Providename \
413     Provideversion Removetid Requirename Requireversion Triggername \
414 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
415     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
416 tmb 343 do
417     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
418     done
419    
420     test -d doc-copy || mkdir doc-copy
421     rm -rf doc-copy/*
422     ln -f doc/manual/* doc-copy/
423     rm -f doc-copy/Makefile*
424    
425     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
426    
427     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
428     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
429     # Put your own system macros here
430     # usually contains
431    
432     # Set this one according your locales
433     # %%_install_langs
434    
435     EOF
436    
437     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
438    
439 tv 206214 %check
440     make check
441    
442 tmb 343 %pre
443     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
444    
445     rm -rf /usr/lib/rpm/*-mandrake-*
446 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
447 tmb 343
448 tmb 345
449 tmb 343 %post
450     # nuke __db.00? when updating to this rpm
451     rm -f /var/lib/rpm/__db.00?
452    
453 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
454 tmb 343 /bin/rpm --initdb
455     fi
456    
457     %postun
458     /usr/share/rpm-helper/del-user rpm $1 rpm
459    
460     %define rpmattr %attr(0755, rpm, rpm)
461    
462     %files -f %{name}.lang
463     %defattr(-,root,root)
464     %doc GROUPS CHANGES doc/manual/[a-z]*
465     %attr(0755,rpm,rpm) /bin/rpm
466     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
467     %attr(0755, rpm, rpm) %{_bindir}/gendiff
468     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
469 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
470 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
471     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
472     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
473    
474     %dir %{_localstatedir}/spool/repackage
475     %dir %{rpmdir}
476     %dir /etc/rpm
477     %config(noreplace) /etc/rpm/macros
478     %dir /etc/rpm/macros.d
479     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
480     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
481     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
482     %attr(0644, rpm, rpm) %{rpmdir}/macros
483     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
484     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
485     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
486     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
487 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
488     %attr(0755, rpm, rpm) %{rpmdir}/script.req
489 tv 256610 %exclude %{rpmdir}/tcl.req
490 tmb 343
491     %rpmattr %{rpmdir}/rpm2cpio.sh
492     %rpmattr %{rpmdir}/tgpg
493    
494 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
495     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
496    
497 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
498     %ifarch %{ix86} x86_64
499     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
500     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
501     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
502     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
503 rtp 267694 %else
504     %exclude %{rpmdir}/platform/i*86-linux/macros
505     %exclude %{rpmdir}/platform/athlon-linux/macros
506     %exclude %{rpmdir}/platform/pentium*-linux/macros
507     %exclude %{rpmdir}/platform/geode-linux/macros
508 tmb 343 %endif
509     %ifarch x86_64
510     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
511     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
512     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
513 rtp 267694 %else
514     %exclude %{rpmdir}/platform/amd64-linux/macros
515     %exclude %{rpmdir}/platform/ia32e-linux/macros
516     %exclude %{rpmdir}/platform/x86_64-linux/macros
517 tmb 343 %endif
518     %ifarch %arm
519 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
520 tv 256613 %else
521     %exclude %{rpmdir}/platform/arm*/macros
522 tmb 343 %endif
523     %ifarch %mips
524     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
525     %endif
526     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
527 tv 256613 # new in 4.10.0:
528     %exclude %{rpmdir}/platform/alpha*-linux/macros
529     %exclude %{rpmdir}/platform/sparc*-linux/macros
530     %exclude %{rpmdir}/platform/ia64*-linux/macros
531     %exclude %{rpmdir}/platform/ppc*-linux/macros
532     %exclude %{rpmdir}/platform/s390*-linux/macros
533     %exclude %{rpmdir}/platform/sh*-linux/macros
534 tmb 343
535 tv 256613
536    
537 tmb 343 %{_mandir}/man[18]/*.[18]*
538     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
539     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
540     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
541     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
542     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
543     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
544    
545     %config(noreplace,missingok) /etc/cron.daily/rpm
546     %config(noreplace,missingok) /etc/logrotate.d/rpm
547    
548     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
549    
550     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
551    
552     %rpmdbattr /var/lib/rpm/Basenames
553     %rpmdbattr /var/lib/rpm/Conflictname
554     %rpmdbattr /var/lib/rpm/__db.0*
555     %rpmdbattr /var/lib/rpm/Dirnames
556     %rpmdbattr /var/lib/rpm/Group
557     %rpmdbattr /var/lib/rpm/Installtid
558     %rpmdbattr /var/lib/rpm/Name
559 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
560 tmb 343 %rpmdbattr /var/lib/rpm/Packages
561     %rpmdbattr /var/lib/rpm/Providename
562     %rpmdbattr /var/lib/rpm/Provideversion
563     %rpmdbattr /var/lib/rpm/Removetid
564     %rpmdbattr /var/lib/rpm/Requirename
565     %rpmdbattr /var/lib/rpm/Requireversion
566 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
567     %rpmdbattr /var/lib/rpm/Sigmd5
568 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
569    
570     %files build
571     %defattr(-,root,root)
572     %doc CHANGES
573     %doc doc-copy/*
574     %rpmattr %{_bindir}/rpmbuild
575 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
576 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
577     %rpmattr %{_prefix}/lib/rpm/check-files
578     %rpmattr %{_prefix}/lib/rpm/debugedit
579 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
580 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
581     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
582     %rpmattr %{_prefix}/lib/rpm/find-provides
583     %rpmattr %{_prefix}/lib/rpm/find-requires
584 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
585 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
586     %rpmattr %{_prefix}/lib/rpm/perl.prov
587     %rpmattr %{_prefix}/lib/rpm/perl.req
588    
589     %rpmattr %{_prefix}/lib/rpm/check-buildroot
590     %rpmattr %{_prefix}/lib/rpm/check-prereqs
591     %rpmattr %{_prefix}/lib/rpm/check-rpaths
592     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
593     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
594     %rpmattr %{_prefix}/lib/rpm/macros.perl
595     %rpmattr %{_prefix}/lib/rpm/macros.php
596     %rpmattr %{_prefix}/lib/rpm/macros.python
597     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
598     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
599 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
600     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
601 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
602     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
603    
604     %rpmattr %{_prefix}/lib/rpm/rpmdeps
605 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
606 tmb 343
607 tv 255921
608 tmb 343 %{_mandir}/man8/rpmbuild.8*
609     %{_mandir}/man8/rpmdeps.8*
610    
611     %if %buildpython
612     %files -n python-rpm
613     %defattr(-,root,root)
614     %{_libdir}/python*/site-packages/rpm
615     %endif
616    
617     %files -n %librpmname
618     %defattr(-,root,root)
619 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
620     %{_libdir}/librpmio.so.%{libmajor}*
621 dmorgan 185007 %if %{with plugins}
622     %{_libdir}/rpm-plugins
623     %endif
624    
625     %files -n %librpmbuild
626 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
627 tmb 343
628 dmorgan 185007 %files -n %librpmsign
629     %{_libdir}/librpmsign.so.%{libmajorsign}*
630    
631     %files sign
632     %defattr(-,root,root)
633     %{_bindir}/rpmsign
634     %{_mandir}/man8/rpmsign.8*
635    
636 tmb 343 %files -n %librpmnamedevel
637     %defattr(-,root,root)
638     %{_includedir}/rpm
639     %{_libdir}/librpm.so
640     %{_libdir}/librpmio.so
641     %{_libdir}/librpmbuild.so
642 dmorgan 185007 %{_libdir}/librpmsign.so
643 tmb 343 %{_libdir}/pkgconfig/rpm.pc
644 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30