/[packages]/cauldron/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /cauldron/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 469312 - (hide annotations) (download)
Thu Aug 22 02:41:57 2013 UTC (10 years, 8 months ago) by kamil
File size: 20673 byte(s)
- be more generic with hardcoding linux specific configuration in the .spec
1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 447559 #define snapver rc2
56 tv 441832 %define rpmversion 4.11.1
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 kamil 469312 %define release %mkrel %{?snapver:0.%{snapver}.}2
62 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
63 tmb 345 %define librpmnamedevel %mklibname -d rpm
64 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
65     %define librpmbuild %mklibname rpmbuild %{libmajor}
66 tmb 343
67     %define buildpython 1
68     %define rpmsetup_version 1.34
69    
70     %define builddebug 0
71     %{?_with_debug:%define builddebug 1}
72    
73     %{?_with_python:%define buildpython 1}
74     %{?_without_python:%define buildpython 0}
75    
76 dmorgan 186381 # disable plugins initially
77 dmorgan 185007 %define buildplugins 0
78     %{?_with_plugins:%define buildplugins 1}
79    
80 tmb 343 Summary: The RPM package management system
81     Name: rpm
82     Epoch: 1
83 dmorgan 185007 Version: %{rpmversion}
84 dmorgan 49378 Release: %{release}
85 fwang 390713 Group: System/Packaging
86 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
87 dmorgan 185007 # Add some undocumented feature to gendiff
88     # Send upstream ? drop ?
89     Patch17: rpm-4.4.2.2-gendiff-improved.patch
90 tmb 343
91     # if %post of foo-2 fails,
92     # or if %preun of foo-1 fails,
93     # or if %postun of foo-1 fails,
94     # => foo-1 is not removed, so we end up with both packages in rpmdb
95     # this patch makes rpm ignore the error in those cases
96 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
97 tmb 343 #
98     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
99     # scripts is ignored with or without this patch)
100 tv 262316 # Needed for urpmi testsuite:
101 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
102 tmb 343
103 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
104 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
105 tmb 343
106 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
107     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
108 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
109     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
110 blino 25212
111 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
112     # From popular request, we allow to do this
113 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
114     Patch70: rpm-4.9.1-bb-shortcircuit.patch
115 tmb 343
116     # don't conflict for doc files
117     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
118 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
119 tmb 343
120     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
121     # (is this working??)
122     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
123    
124     # Fix diff issue when buildroot contains some "//"
125 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
126 tmb 343
127     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
128 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
129 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
130 tmb 343
131     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
132     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
133     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
134     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
135     # but this is bad design anyway
136 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
137 tmb 343
138     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
139 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
140 tv 215854 Patch134: extcond.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
157     Patch146: rpm-4.9.1.1-filetriggers.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 tv 332323 # (tv) fix aborting when ordering empty transactions:
209     Patch4006: fix-order-on-empty-transactions.diff
210 tv 327195
211    
212 dmorgan 185007 License: GPLv2+
213     BuildRequires: autoconf
214 tmb 343 BuildRequires: zlib-devel
215     BuildRequires: bzip2-devel
216 tv 276213 BuildRequires: liblzma-devel >= 5
217 dmorgan 185007 BuildRequires: automake
218 tmb 343 BuildRequires: elfutils-devel
219     BuildRequires: libbeecrypt-devel
220 dmorgan 185007 BuildRequires: ed
221     BuildRequires: gettext-devel
222 tmb 343 BuildRequires: libsqlite3-devel
223 tv 276213 BuildRequires: db5.3-devel
224 tmb 343 BuildRequires: neon-devel
225     BuildRequires: popt-devel
226     BuildRequires: nss-devel
227     BuildRequires: magic-devel
228 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
229 tmb 343 BuildRequires: readline-devel
230     BuildRequires: ncurses-devel
231 dmorgan 185007 BuildRequires: openssl-devel
232 tv 256683 BuildRequires: lua5.1-devel
233 dmorgan 185007 BuildRequires: libcap-devel
234     # Needed for doc
235 tmb 343 #BuildRequires: graphviz
236 dmorgan 185007 BuildRequires: tetex
237 tmb 343 %if %buildpython
238     BuildRequires: python-devel
239     %endif
240 tv 223263 # for testsuite:
241     BuildRequires: fakechroot
242 tmb 343
243     Requires: bzip2 >= 0.9.0c-2
244 tv 302008 Requires: xz
245 tmb 343 Requires: cpio
246     Requires: gawk
247     Requires: glibc >= 2.1.92
248     Requires: mktemp
249 tmb 345 Requires: setup >= 2.2.0-8
250 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
251 tmb 343 Requires: update-alternatives
252     Requires: %librpmname = %epoch:%version-%release
253     URL: http://rpm.org/
254     %define git_url http://rpm.org/git/rpm.git
255 dmorgan 185007 Requires(pre): rpm-helper
256 tmb 343 Requires(pre): coreutils
257 dmorgan 185007 Requires(postun): rpm-helper
258 tmb 343
259 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
260 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
261 dmorgan 185007
262 tmb 343 %description
263     RPM is a powerful command line driven package management system capable of
264     installing, uninstalling, verifying, querying, and updating software packages.
265     Each software package consists of an archive of files along with information
266     about the package like its version, a description, etc.
267    
268 dmorgan 185191 %package -n %librpmbuild
269     Summary: Libraries for building and signing RPM packages
270     Group: System/Libraries
271 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
272 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
273    
274     %description -n %librpmbuild
275     This package contains the RPM shared libraries for building and signing
276     packages.
277    
278     %package -n %librpmsign
279     Summary: Libraries for building and signing RPM packages
280     Group: System/Libraries
281    
282     %description -n %librpmsign
283     This package contains the RPM shared libraries for building and signing
284     packages.
285    
286 tmb 343 %package -n %librpmname
287 tmb 345 Summary: Library used by rpm
288     Group: System/Libraries
289     Provides: librpm = %version-%release
290 tmb 343
291     %description -n %librpmname
292     RPM is a powerful command line driven package management system capable of
293     installing, uninstalling, verifying, querying, and updating software packages.
294     This package contains common files to all applications based on rpm.
295    
296     %package -n %librpmnamedevel
297     Summary: Development files for applications which will manipulate RPM packages
298     Group: Development/C
299     Requires: rpm = %epoch:%{version}-%{release}
300     Provides: librpm-devel = %version-%release
301     Provides: rpm-devel = %version-%release
302 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
303     Requires: %librpmbuild = %epoch:%version-%release
304     Requires: %librpmsign = %epoch:%version-%release
305 tmb 343
306     %description -n %librpmnamedevel
307     This package contains the RPM C library and header files. These
308     development files will simplify the process of writing programs
309     which manipulate RPM packages and databases and are intended to make
310     it easier to create graphical package managers or any other tools
311     that need an intimate knowledge of RPM packages in order to function.
312    
313     This package should be installed if you want to develop programs that
314     will manipulate RPM packages and databases.
315    
316     %package build
317     Summary: Scripts and executable programs used to build packages
318 fwang 390713 Group: System/Packaging
319 tmb 343 Requires: autoconf
320     Requires: automake
321     Requires: file
322     Requires: gcc-c++
323     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
324 dmorgan 185007 Requires: libtool-base
325     Requires: patch
326 tmb 343 Requires: make
327     Requires: tar
328     Requires: unzip
329     Requires: elfutils
330 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
331 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
332 dmorgan 185007 Requires: perl(YAML::Tiny)
333 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
334 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
335 tmb 343
336     %description build
337     This package contains scripts and executable programs that are used to
338     build packages using RPM.
339    
340 dmorgan 185007 %package sign
341     Summary: Package signing support
342     Group: System/Base
343    
344     %description sign
345     This package contains support for digitally signing RPM packages.
346    
347 tmb 343 %if %buildpython
348     %package -n python-rpm
349     Summary: Python bindings for apps which will manipulate RPM packages
350     Group: Development/Python
351     Requires: rpm = %epoch:%{version}-%{release}
352    
353     %description -n python-rpm
354     The rpm-python package contains a module which permits applications
355     written in the Python programming language to use the interface
356     supplied by RPM (RPM Package Manager) libraries.
357    
358     This package should be installed if you want to develop Python
359     programs that will manipulate RPM packages and databases.
360     %endif
361    
362     %prep
363     %setup -q -n %name-%srcver
364 dmorgan 186388 %apply_patches
365 tmb 343
366     %build
367 tv 447560 aclocal
368     automake-1.14 --add-missing
369     automake
370 tmb 343 autoreconf
371    
372     %if %builddebug
373     RPM_OPT_FLAGS=-g
374     %endif
375 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
376 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
377 fwang 215771 %configure2_5x \
378 tmb 343 --enable-nls \
379     --enable-python \
380     --enable-sqlite3 \
381     --without-javaglue \
382     %if %builddebug
383     --enable-debug \
384     %endif
385 dmorgan 185007 --with-external-db \
386 tmb 343 %if %buildpython
387     --with-python=%{pyver} \
388     %else
389     --without-python \
390     %endif
391 dmorgan 185007 %if ! %buildplugins
392     --disable-plugins \
393     %endif
394 tmb 343 --with-glob \
395     --without-selinux \
396 dmorgan 185007 --without-apidocs \
397     --with-cap
398 tmb 343
399     %make
400    
401     %install
402 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
403 tmb 343
404     make DESTDIR=%buildroot install
405    
406 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
407    
408 tmb 343 # Save list of packages through cron
409     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
410     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
411    
412     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
413     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
414    
415     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
416     for dbi in \
417     Basenames Conflictname Dirnames Group Installtid Name Providename \
418     Provideversion Removetid Requirename Requireversion Triggername \
419 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
420     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
421 tmb 343 do
422     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
423     done
424    
425     test -d doc-copy || mkdir doc-copy
426     rm -rf doc-copy/*
427     ln -f doc/manual/* doc-copy/
428     rm -f doc-copy/Makefile*
429    
430     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
431    
432     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
433     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
434     # Put your own system macros here
435     # usually contains
436    
437     # Set this one according your locales
438     # %%_install_langs
439    
440     EOF
441    
442     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
443    
444 tv 206214 %check
445     make check
446 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
447 tv 206214
448 tmb 343 %pre
449     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
450    
451     rm -rf /usr/lib/rpm/*-mandrake-*
452 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
453 tmb 343
454 tmb 345
455 tmb 343 %post
456     # nuke __db.00? when updating to this rpm
457     rm -f /var/lib/rpm/__db.00?
458    
459 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
460 tmb 343 /bin/rpm --initdb
461     fi
462    
463     %postun
464     /usr/share/rpm-helper/del-user rpm $1 rpm
465    
466     %define rpmattr %attr(0755, rpm, rpm)
467    
468     %files -f %{name}.lang
469     %defattr(-,root,root)
470     %doc GROUPS CHANGES doc/manual/[a-z]*
471     %attr(0755,rpm,rpm) /bin/rpm
472     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
473     %attr(0755, rpm, rpm) %{_bindir}/gendiff
474     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
475 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
476 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
477     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
478     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
479    
480     %dir %{_localstatedir}/spool/repackage
481     %dir %{rpmdir}
482     %dir /etc/rpm
483     %config(noreplace) /etc/rpm/macros
484     %dir /etc/rpm/macros.d
485     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
486     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
487     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
488     %attr(0644, rpm, rpm) %{rpmdir}/macros
489     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
490     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
491     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
492     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
493 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
494     %attr(0755, rpm, rpm) %{rpmdir}/script.req
495 tv 256610 %exclude %{rpmdir}/tcl.req
496 tmb 343
497     %rpmattr %{rpmdir}/rpm2cpio.sh
498     %rpmattr %{rpmdir}/tgpg
499    
500 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
501     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
502    
503 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
504     %ifarch %{ix86} x86_64
505     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
506     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
507     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
508     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
509 rtp 267694 %else
510 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
511     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
512     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
513     %exclude %{rpmdir}/platform/geode-%{_os}/macros
514 tmb 343 %endif
515     %ifarch x86_64
516     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
517     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
518     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
519 rtp 267694 %else
520 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
521     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
522     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
523 tmb 343 %endif
524     %ifarch %arm
525 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
526 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
527 tv 256613 %else
528     %exclude %{rpmdir}/platform/arm*/macros
529 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
530 tmb 343 %endif
531     %ifarch %mips
532     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
533     %endif
534     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
535 tv 256613 # new in 4.10.0:
536 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
537     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
538     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
539     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
540     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
541     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
542 tmb 343
543 tv 256613
544    
545 tmb 343 %{_mandir}/man[18]/*.[18]*
546     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
547     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
548     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
549     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
550     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
551     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
552    
553     %config(noreplace,missingok) /etc/cron.daily/rpm
554     %config(noreplace,missingok) /etc/logrotate.d/rpm
555    
556     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
557    
558     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
559    
560     %rpmdbattr /var/lib/rpm/Basenames
561     %rpmdbattr /var/lib/rpm/Conflictname
562     %rpmdbattr /var/lib/rpm/__db.0*
563     %rpmdbattr /var/lib/rpm/Dirnames
564     %rpmdbattr /var/lib/rpm/Group
565     %rpmdbattr /var/lib/rpm/Installtid
566     %rpmdbattr /var/lib/rpm/Name
567 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
568 tmb 343 %rpmdbattr /var/lib/rpm/Packages
569     %rpmdbattr /var/lib/rpm/Providename
570     %rpmdbattr /var/lib/rpm/Provideversion
571     %rpmdbattr /var/lib/rpm/Removetid
572     %rpmdbattr /var/lib/rpm/Requirename
573     %rpmdbattr /var/lib/rpm/Requireversion
574 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
575     %rpmdbattr /var/lib/rpm/Sigmd5
576 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
577    
578     %files build
579     %defattr(-,root,root)
580     %doc CHANGES
581     %doc doc-copy/*
582     %rpmattr %{_bindir}/rpmbuild
583 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
584 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
585     %rpmattr %{_prefix}/lib/rpm/check-files
586     %rpmattr %{_prefix}/lib/rpm/debugedit
587 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
588 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
589     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
590     %rpmattr %{_prefix}/lib/rpm/find-provides
591     %rpmattr %{_prefix}/lib/rpm/find-requires
592 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
593 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
594     %rpmattr %{_prefix}/lib/rpm/perl.prov
595     %rpmattr %{_prefix}/lib/rpm/perl.req
596    
597     %rpmattr %{_prefix}/lib/rpm/check-buildroot
598     %rpmattr %{_prefix}/lib/rpm/check-prereqs
599     %rpmattr %{_prefix}/lib/rpm/check-rpaths
600     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
601     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
602     %rpmattr %{_prefix}/lib/rpm/macros.perl
603     %rpmattr %{_prefix}/lib/rpm/macros.php
604     %rpmattr %{_prefix}/lib/rpm/macros.python
605     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
606     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
607 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
608     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
609 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
610     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
611    
612     %rpmattr %{_prefix}/lib/rpm/rpmdeps
613 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
614 tmb 343
615 tv 255921
616 tmb 343 %{_mandir}/man8/rpmbuild.8*
617     %{_mandir}/man8/rpmdeps.8*
618    
619     %if %buildpython
620     %files -n python-rpm
621     %defattr(-,root,root)
622     %{_libdir}/python*/site-packages/rpm
623     %endif
624    
625     %files -n %librpmname
626     %defattr(-,root,root)
627 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
628     %{_libdir}/librpmio.so.%{libmajor}*
629 dmorgan 185007 %if %{with plugins}
630     %{_libdir}/rpm-plugins
631     %endif
632    
633     %files -n %librpmbuild
634 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
635 tmb 343
636 dmorgan 185007 %files -n %librpmsign
637     %{_libdir}/librpmsign.so.%{libmajorsign}*
638    
639     %files sign
640     %defattr(-,root,root)
641     %{_bindir}/rpmsign
642     %{_mandir}/man8/rpmsign.8*
643    
644 tmb 343 %files -n %librpmnamedevel
645     %defattr(-,root,root)
646     %{_includedir}/rpm
647     %{_libdir}/librpm.so
648     %{_libdir}/librpmio.so
649     %{_libdir}/librpmbuild.so
650 dmorgan 185007 %{_libdir}/librpmsign.so
651 tmb 343 %{_libdir}/pkgconfig/rpm.pc
652 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30