/[packages]/cauldron/rpm/current/SPECS/rpm.spec
ViewVC logotype

Annotation of /cauldron/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 490444 - (hide annotations) (download)
Wed Oct 2 15:56:41 2013 UTC (10 years, 6 months ago) by colin
File size: 21435 byte(s)
Disable debuginfo extraction 'fix' as it breaks more than it fixes
1 dmorgan 185007 %define lib64arches x86_64
2 kamil 469312 %define lib64oses linux
3 tmb 343
4     %ifarch %lib64arches
5 kamil 469312 %ifos %lib64oses
6 tmb 343 %define _lib lib64
7     %else
8     %define _lib lib
9     %endif
10 kamil 469312 %else
11     %define _lib lib
12     %endif
13 tmb 343
14     %define _prefix /usr
15     %define _libdir %_prefix/%_lib
16     %define _bindir %_prefix/bin
17     %define _sysconfdir /etc
18     %define _datadir /usr/share
19     %define _defaultdocdir %_datadir/doc
20     %define _localstatedir /var
21     %define _infodir %_datadir/info
22    
23     %if %{?apply_patches:0}%{?!apply_patches:1}
24     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
25     %endif
26    
27     # Define directory which holds rpm config files, and some binaries actually
28     # NOTE: it remains */lib even on lib64 platforms as only one version
29     # of rpm is supported anyway, per architecture
30     %define rpmdir %{_prefix}/lib/rpm
31    
32     %if %{?mklibname:0}%{?!mklibname:1}
33     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
34     %endif
35    
36     %if %{?distsuffix:0}%{?!distsuffix:1}
37 tmb 345 %define distsuffix .mga
38 tmb 343 %endif
39    
40     %if %{?mkrel:0}%{?!mkrel:1}
41 tmb 345 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 tmb 343 %endif
43    
44     %if %{?mips:0}%{?!mips:1}
45     %define mips mips mipsel mips32 mips32el mips64 mips64el
46     %endif
47    
48     %if %{?pyver:0}%{?!pyver:1}
49     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50     %endif
51    
52 blino 25213 %define __find_requires %{rpmdir}/%{_real_vendor}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53     %define __find_provides %{rpmdir}/%{_real_vendor}/find-provides
54 tmb 343
55 tv 447559 #define snapver rc2
56 tv 441832 %define rpmversion 4.11.1
57 dmorgan 185007 %define srcver %{rpmversion}%{?snapver:-%{snapver}}
58 tv 264614 %define libver 4.10
59 tv 255921 %define libmajor 3
60     %define libmajorsign 1
61 colin 490444 %define release %mkrel %{?snapver:0.%{snapver}.}4
62 dmorgan 185007 %define librpmname %mklibname rpm %{libmajor}
63 tmb 345 %define librpmnamedevel %mklibname -d rpm
64 dmorgan 185007 %define librpmsign %mklibname rpmsign %{libmajor}
65     %define librpmbuild %mklibname rpmbuild %{libmajor}
66 tmb 343
67     %define buildpython 1
68     %define rpmsetup_version 1.34
69    
70     %define builddebug 0
71     %{?_with_debug:%define builddebug 1}
72    
73     %{?_with_python:%define buildpython 1}
74     %{?_without_python:%define buildpython 0}
75    
76 dmorgan 186381 # disable plugins initially
77 dmorgan 185007 %define buildplugins 0
78     %{?_with_plugins:%define buildplugins 1}
79    
80 tmb 343 Summary: The RPM package management system
81     Name: rpm
82     Epoch: 1
83 dmorgan 185007 Version: %{rpmversion}
84 dmorgan 49378 Release: %{release}
85 fwang 390713 Group: System/Packaging
86 tmb 343 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
87 dmorgan 185007 # Add some undocumented feature to gendiff
88     # Send upstream ? drop ?
89     Patch17: rpm-4.4.2.2-gendiff-improved.patch
90 tmb 343
91     # if %post of foo-2 fails,
92     # or if %preun of foo-1 fails,
93     # or if %postun of foo-1 fails,
94     # => foo-1 is not removed, so we end up with both packages in rpmdb
95     # this patch makes rpm ignore the error in those cases
96 dmorgan 185007 # failing %pre must still make the rpm install fail (mdv #23677)
97 tmb 343 #
98     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
99     # scripts is ignored with or without this patch)
100 tv 262316 # Needed for urpmi testsuite:
101 dmorgan 185007 Patch22: rpm-4.9.0-non-pre-scripts-dont-fail.patch
102 tmb 343
103 tv 327188 # (fredl) add loging facilities through syslog (pushed upstream, might be replaced by a rpm pluging in 4.11):
104 dmorgan 185007 Patch31: rpm-4.9.0-syslog.patch
105 tmb 343
106 tmb 47730 # - force /usr/lib/rpm/mageia/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
107     # - read /usr/lib/rpm/mageia/rpmpopt (not only /usr/lib/rpm/rpmpopt)
108 dmorgan 185007 # if we deprecated the use of rpm -ba , ..., we can get rid of this patch
109     Patch64: rpm-4.9.1.1-mageia-rpmrc-rpmpopt.patch
110 blino 25212
111 tmb 343 # In original rpm, -bb --short-circuit does not work and run all stage
112     # From popular request, we allow to do this
113 dmorgan 185007 # http://qa.mandriva.com/show_bug.cgi?id=15896
114     Patch70: rpm-4.9.1-bb-shortcircuit.patch
115 tmb 343
116     # don't conflict for doc files
117     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
118 tv 332065 Patch83: rpm-4.11.0-no-doc-conflicts.patch
119 tmb 343
120     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
121     # (is this working??)
122     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
123    
124     # Fix diff issue when buildroot contains some "//"
125 tv 256243 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
126 tmb 343
127     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
128 tv 327188 # Upstream 4.11 will have /usr/lib/rpm/macros.d:
129 dmorgan 185007 Patch114: rpm-4.9.0-read-macros_d-dot-macros.patch
130 tmb 343
131     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
132     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
133     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
134     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
135     # but this is bad design anyway
136 dmorgan 46862 #Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
137 tmb 343
138     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
139 tv 441832 Patch133: rpm-4.11.1-weakdeps.patch
140 tv 215854 Patch134: extcond.diff
141 tmb 343
142 dmorgan 49378 # (from Turbolinux) remove a wrong check in case %_topdir is /RPM (ie when it is short)
143 tv 256612 # Panu said: "To my knowledge this is a true technical limitation of the
144     # implementation: as long as debugedit can just overwrite data in the elf
145     # sections things keep relatively easy, but if dest_dir is longer than the
146     # original directory, debugedit would have to expand the whole elf file. Which
147     # might be technically possible but debugedit currently does not even try to."
148 dmorgan 185007 Patch135: rpm-4.9.0-fix-debugedit.patch
149 dmorgan 49378
150 tmb 343 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
151     # with this patch, "#%define foo bar" is a fatal error
152 dmorgan 185007 # Bug still valid => Send upstream for review.
153 tv 256243 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
154 tmb 343
155     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
156 dmorgan 185007 # Will be allowed to be dropped when "Collection" won't be experimental anymore.
157     Patch146: rpm-4.9.1.1-filetriggers.patch
158 tmb 343
159     # add two fatal errors (during package build)
160 dmorgan 185007 # Useful ? to drop ?
161     #Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
162 tmb 343
163     # (nb: see the patch for more info about this issue)
164 dmorgan 185007 #Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
165 tmb 343
166 wally 324218 Patch157: rpm-4.10.1-introduce-_after_setup-which-is-called-after-setup.patch
167 dmorgan 185007 #Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
168 tv 256243 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
169 tmb 343
170     Patch1007: rpm-4.6.0-rc3-xz-support.patch
171    
172     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
173     # as this breaks stuff that installs files to $DOCDIR during %%install
174 dmorgan 185007 #Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
175 tmb 343
176 tv 441933 # Fedora patches
177    
178 tmb 343 # Turbolinux patches
179     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
180     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
181    
182 tv 256243 Patch2006: rpm-4.10.0-setup-rubygems.patch
183 dmorgan 49378
184 tv 262316 # (tv) fix tests:
185 tv 441832 Patch2100: rpm-4.11.1-fix-testsuite.diff
186 tv 255921
187 tmb 343 Patch3000: mips_macros.patch
188 tv 256616 Patch3002: mips_define_isa_macros.patch
189     Patch3003: rpm_arm_mips_isa_macros.patch
190     Patch3004: rpm_add_armv5tl.patch
191 tmb 343
192 rtp 267694 # when using fakechroot, make sure that testsuite pathes are against /
193     # and not full path
194 tv 441832 Patch3005: rpm-4.11.1-fix-testsuite-pathes.patch
195 tv 223198 #
196 dmorgan 185007 # Fedora patches
197 tv 223198 # Patches 41xx are already in upstream and are 1xx in FC
198     #
199 tv 332643 # (tv) Temporary Patch to provide support for updates (FC):
200     Patch3500: rpm-4.10.90-rpmlib-filesystem-check.patch
201 tv 327924 # (tv) Compressed debuginfo support (UPSTREAM):
202 tv 276745 Patch3501: rpm-4.10.0-dwz-debuginfo.patch
203 tv 327924 # (tv) Mini debuginfo support (UPSTREAM):
204 tv 276745 Patch3502: rpm-4.10.0-minidebuginfo.patch
205 dmorgan 185007
206 tv 276795 # (tv) merge mga stuff from rpm-setup:
207     Patch4000: rpm-4.10.0-find-debuginfo__mga-cfg.diff
208 tv 332323 # (tv) fix aborting when ordering empty transactions:
209     Patch4006: fix-order-on-empty-transactions.diff
210 colin 487636 # (cg) fix debuginfo extraction. Sometimes, depending on local setup, the
211     # extraction of debuginfo can fail. This happens if you have a shared build dir
212     # which contains lots of subfolders for different packages (i.e. the default
213     # you would get if you rpm -i lots of srpms and build a whole bunch of them)
214     # This fix simply uses the real build dir passed in as an argument to the script
215     # rather than the top level %_builddir definition (aka $RPM_BUILD_DIR).
216 colin 490444 # (cg) This messes up the debuginfo packages themselves due to bad paths.
217     # I suspect the real problem lies in the debugedit binary which I will debug further.
218     # Leaving this here so I don't forget (aka it annoys tv enough to bug me if it's
219     # still here after any reasonable length of time!)
220     #Patch4007: rpm-4.11.1-fix-debuginfo-extraction.patch
221 tv 327195
222 dmorgan 185007 License: GPLv2+
223     BuildRequires: autoconf
224 tmb 343 BuildRequires: zlib-devel
225     BuildRequires: bzip2-devel
226 tv 276213 BuildRequires: liblzma-devel >= 5
227 dmorgan 185007 BuildRequires: automake
228 tmb 343 BuildRequires: elfutils-devel
229     BuildRequires: libbeecrypt-devel
230 dmorgan 185007 BuildRequires: ed
231     BuildRequires: gettext-devel
232 tmb 343 BuildRequires: libsqlite3-devel
233 tv 276213 BuildRequires: db5.3-devel
234 tmb 343 BuildRequires: neon-devel
235     BuildRequires: popt-devel
236     BuildRequires: nss-devel
237     BuildRequires: magic-devel
238 blino 25213 BuildRequires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
239 tmb 343 BuildRequires: readline-devel
240     BuildRequires: ncurses-devel
241 dmorgan 185007 BuildRequires: openssl-devel
242 tv 256683 BuildRequires: lua5.1-devel
243 dmorgan 185007 BuildRequires: libcap-devel
244     # Needed for doc
245 tmb 343 #BuildRequires: graphviz
246 dmorgan 185007 BuildRequires: tetex
247 tmb 343 %if %buildpython
248     BuildRequires: python-devel
249     %endif
250 tv 223263 # for testsuite:
251     BuildRequires: fakechroot
252 tmb 343
253     Requires: bzip2 >= 0.9.0c-2
254 tv 302008 Requires: xz
255 tmb 343 Requires: cpio
256     Requires: gawk
257     Requires: glibc >= 2.1.92
258     Requires: mktemp
259 tmb 345 Requires: setup >= 2.2.0-8
260 blino 25213 Requires: rpm-%{_real_vendor}-setup >= 1.85
261 tmb 343 Requires: update-alternatives
262     Requires: %librpmname = %epoch:%version-%release
263     URL: http://rpm.org/
264     %define git_url http://rpm.org/git/rpm.git
265 dmorgan 185007 Requires(pre): rpm-helper
266 tmb 343 Requires(pre): coreutils
267 dmorgan 185007 Requires(postun): rpm-helper
268 tmb 343
269 tv 257955 Conflicts: perl-URPM < 4.0-2.mga3
270 fwang 260027 Conflicts: jpackage-utils < 1:1.7.5-17
271 dmorgan 185007
272 tmb 343 %description
273     RPM is a powerful command line driven package management system capable of
274     installing, uninstalling, verifying, querying, and updating software packages.
275     Each software package consists of an archive of files along with information
276     about the package like its version, a description, etc.
277    
278 dmorgan 185191 %package -n %librpmbuild
279     Summary: Libraries for building and signing RPM packages
280     Group: System/Libraries
281 tv 332644 Obsoletes: rpm-build-libs%{_isa} < %{version}-%{release}
282 dmorgan 185191 Provides: rpm-build-libs%{_isa} = %{version}-%{release}
283    
284     %description -n %librpmbuild
285     This package contains the RPM shared libraries for building and signing
286     packages.
287    
288     %package -n %librpmsign
289     Summary: Libraries for building and signing RPM packages
290     Group: System/Libraries
291    
292     %description -n %librpmsign
293     This package contains the RPM shared libraries for building and signing
294     packages.
295    
296 tmb 343 %package -n %librpmname
297 tmb 345 Summary: Library used by rpm
298     Group: System/Libraries
299     Provides: librpm = %version-%release
300 tmb 343
301     %description -n %librpmname
302     RPM is a powerful command line driven package management system capable of
303     installing, uninstalling, verifying, querying, and updating software packages.
304     This package contains common files to all applications based on rpm.
305    
306     %package -n %librpmnamedevel
307     Summary: Development files for applications which will manipulate RPM packages
308     Group: Development/C
309     Requires: rpm = %epoch:%{version}-%{release}
310     Provides: librpm-devel = %version-%release
311     Provides: rpm-devel = %version-%release
312 dmorgan 185220 Requires: %librpmname = %epoch:%version-%release
313     Requires: %librpmbuild = %epoch:%version-%release
314     Requires: %librpmsign = %epoch:%version-%release
315 tmb 343
316     %description -n %librpmnamedevel
317     This package contains the RPM C library and header files. These
318     development files will simplify the process of writing programs
319     which manipulate RPM packages and databases and are intended to make
320     it easier to create graphical package managers or any other tools
321     that need an intimate knowledge of RPM packages in order to function.
322    
323     This package should be installed if you want to develop programs that
324     will manipulate RPM packages and databases.
325    
326     %package build
327     Summary: Scripts and executable programs used to build packages
328 fwang 390713 Group: System/Packaging
329 tmb 343 Requires: autoconf
330     Requires: automake
331     Requires: file
332     Requires: gcc-c++
333     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
334 dmorgan 185007 Requires: libtool-base
335     Requires: patch
336 tmb 343 Requires: make
337     Requires: tar
338     Requires: unzip
339     Requires: elfutils
340 jquelin 167931 Requires: perl(CPAN::Meta) >= 2.112.150
341 jquelin 167751 Requires: perl(ExtUtils::MakeMaker) >= 6.570_700
342 dmorgan 185007 Requires: perl(YAML::Tiny)
343 tmb 343 Requires: rpm = %epoch:%{version}-%{release}
344 blino 25213 Requires: rpm-%{_real_vendor}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
345 tmb 343
346     %description build
347     This package contains scripts and executable programs that are used to
348     build packages using RPM.
349    
350 dmorgan 185007 %package sign
351     Summary: Package signing support
352     Group: System/Base
353    
354     %description sign
355     This package contains support for digitally signing RPM packages.
356    
357 tmb 343 %if %buildpython
358     %package -n python-rpm
359     Summary: Python bindings for apps which will manipulate RPM packages
360     Group: Development/Python
361     Requires: rpm = %epoch:%{version}-%{release}
362    
363     %description -n python-rpm
364     The rpm-python package contains a module which permits applications
365     written in the Python programming language to use the interface
366     supplied by RPM (RPM Package Manager) libraries.
367    
368     This package should be installed if you want to develop Python
369     programs that will manipulate RPM packages and databases.
370     %endif
371    
372     %prep
373     %setup -q -n %name-%srcver
374 dmorgan 186388 %apply_patches
375 tmb 343
376     %build
377 tv 447560 aclocal
378     automake-1.14 --add-missing
379     automake
380 tmb 343 autoreconf
381    
382     %if %builddebug
383     RPM_OPT_FLAGS=-g
384     %endif
385 tv 262316 export CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
386 tmb 343 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
387 fwang 215771 %configure2_5x \
388 tmb 343 --enable-nls \
389     --enable-python \
390     --enable-sqlite3 \
391     --without-javaglue \
392     %if %builddebug
393     --enable-debug \
394     %endif
395 dmorgan 185007 --with-external-db \
396 tmb 343 %if %buildpython
397     --with-python=%{pyver} \
398     %else
399     --without-python \
400     %endif
401 dmorgan 185007 %if ! %buildplugins
402     --disable-plugins \
403     %endif
404 tmb 343 --with-glob \
405     --without-selinux \
406 dmorgan 185007 --without-apidocs \
407     --with-cap
408 tmb 343
409     %make
410    
411     %install
412 dmorgan 185007 rm -rf $RPM_BUILD_ROOT
413 tmb 343
414     make DESTDIR=%buildroot install
415    
416 dmorgan 170213 find $RPM_BUILD_ROOT -name "*.la"|xargs rm -f
417    
418 tmb 343 # Save list of packages through cron
419     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
420     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
421    
422     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
423     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
424    
425     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
426     for dbi in \
427     Basenames Conflictname Dirnames Group Installtid Name Providename \
428     Provideversion Removetid Requirename Requireversion Triggername \
429 dmorgan 185007 Obsoletename Packages Sha1header Sigmd5 __db.001 __db.002 \
430     __db.003 __db.004 __db.005 __db.006 __db.007 __db.008 __db.009
431 tmb 343 do
432     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
433     done
434    
435     test -d doc-copy || mkdir doc-copy
436     rm -rf doc-copy/*
437     ln -f doc/manual/* doc-copy/
438     rm -f doc-copy/Makefile*
439    
440     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
441    
442     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
443     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
444     # Put your own system macros here
445     # usually contains
446    
447     # Set this one according your locales
448     # %%_install_langs
449    
450     EOF
451    
452     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
453    
454 tv 206214 %check
455     make check
456 tv 441931 [ "$(ls -A tests/rpmtests.dir)" ] && cat tests/rpmtests.log
457 tv 206214
458 tmb 343 %pre
459     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
460    
461     rm -rf /usr/lib/rpm/*-mandrake-*
462 blino 25213 rm -rf /usr/lib/rpm/*-%{_real_vendor}-*
463 tmb 343
464 tmb 345
465 tmb 343 %post
466     # nuke __db.00? when updating to this rpm
467     rm -f /var/lib/rpm/__db.00?
468    
469 dmorgan 185007 if [ ! -f /var/lib/rpm/Packages ]; then
470 tmb 343 /bin/rpm --initdb
471     fi
472    
473     %postun
474     /usr/share/rpm-helper/del-user rpm $1 rpm
475    
476     %define rpmattr %attr(0755, rpm, rpm)
477    
478     %files -f %{name}.lang
479     %defattr(-,root,root)
480     %doc GROUPS CHANGES doc/manual/[a-z]*
481     %attr(0755,rpm,rpm) /bin/rpm
482     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
483     %attr(0755, rpm, rpm) %{_bindir}/gendiff
484     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
485 dmorgan 185007 %attr(0755, rpm, rpm) %{_bindir}/rpmkeys
486 tmb 343 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
487 colin 490405 %{_bindir}/rpmquery
488     %{_bindir}/rpmverify
489 tmb 343
490     %dir %{_localstatedir}/spool/repackage
491     %dir %{rpmdir}
492     %dir /etc/rpm
493     %config(noreplace) /etc/rpm/macros
494     %dir /etc/rpm/macros.d
495     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
496     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
497     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
498     %attr(0644, rpm, rpm) %{rpmdir}/macros
499     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
500     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
501     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
502     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
503 dmorgan 187127 %attr(0755, rpm, rpm) %{rpmdir}/elfdeps
504     %attr(0755, rpm, rpm) %{rpmdir}/script.req
505 tv 256610 %exclude %{rpmdir}/tcl.req
506 tmb 343
507     %rpmattr %{rpmdir}/rpm2cpio.sh
508     %rpmattr %{rpmdir}/tgpg
509    
510 blino 185127 %dir %attr( -, rpm, rpm) %{rpmdir}/fileattrs
511     %attr(0644, rpm, rpm) %{rpmdir}/fileattrs/*.attr
512    
513 tmb 343 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
514     %ifarch %{ix86} x86_64
515     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
516     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
517     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
518     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
519 rtp 267694 %else
520 kamil 469312 %exclude %{rpmdir}/platform/i*86-%{_os}/macros
521     %exclude %{rpmdir}/platform/athlon-%{_os}/macros
522     %exclude %{rpmdir}/platform/pentium*-%{_os}/macros
523     %exclude %{rpmdir}/platform/geode-%{_os}/macros
524 tmb 343 %endif
525     %ifarch x86_64
526     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
527     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
528     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
529 rtp 267694 %else
530 kamil 469312 %exclude %{rpmdir}/platform/amd64-%{_os}/macros
531     %exclude %{rpmdir}/platform/ia32e-%{_os}/macros
532     %exclude %{rpmdir}/platform/x86_64-%{_os}/macros
533 tmb 343 %endif
534     %ifarch %arm
535 dmorgan 195260 %attr( -, rpm, rpm) %{rpmdir}/platform/arm*
536 tv 441834 %attr( -, rpm, rpm) %{rpmdir}/platform/aarch64*/macros
537 tv 256613 %else
538     %exclude %{rpmdir}/platform/arm*/macros
539 tv 441834 %exclude %{rpmdir}/platform/aarch64*/macros
540 tmb 343 %endif
541     %ifarch %mips
542     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
543     %endif
544     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
545 tv 256613 # new in 4.10.0:
546 kamil 469312 %exclude %{rpmdir}/platform/alpha*-%{_os}/macros
547     %exclude %{rpmdir}/platform/sparc*-%{_os}/macros
548     %exclude %{rpmdir}/platform/ia64*-%{_os}/macros
549     %exclude %{rpmdir}/platform/ppc*-%{_os}/macros
550     %exclude %{rpmdir}/platform/s390*-%{_os}/macros
551     %exclude %{rpmdir}/platform/sh*-%{_os}/macros
552 tmb 343
553 tv 256613
554    
555 tmb 343 %{_mandir}/man[18]/*.[18]*
556     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
557     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
558     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
559     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
560     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
561     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
562    
563     %config(noreplace,missingok) /etc/cron.daily/rpm
564     %config(noreplace,missingok) /etc/logrotate.d/rpm
565    
566     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
567    
568     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
569    
570     %rpmdbattr /var/lib/rpm/Basenames
571     %rpmdbattr /var/lib/rpm/Conflictname
572     %rpmdbattr /var/lib/rpm/__db.0*
573     %rpmdbattr /var/lib/rpm/Dirnames
574     %rpmdbattr /var/lib/rpm/Group
575     %rpmdbattr /var/lib/rpm/Installtid
576     %rpmdbattr /var/lib/rpm/Name
577 dmorgan 185007 %rpmdbattr /var/lib/rpm/Obsoletename
578 tmb 343 %rpmdbattr /var/lib/rpm/Packages
579     %rpmdbattr /var/lib/rpm/Providename
580     %rpmdbattr /var/lib/rpm/Provideversion
581     %rpmdbattr /var/lib/rpm/Removetid
582     %rpmdbattr /var/lib/rpm/Requirename
583     %rpmdbattr /var/lib/rpm/Requireversion
584 dmorgan 185007 %rpmdbattr /var/lib/rpm/Sha1header
585     %rpmdbattr /var/lib/rpm/Sigmd5
586 tmb 343 %rpmdbattr /var/lib/rpm/Triggername
587    
588     %files build
589     %defattr(-,root,root)
590     %doc CHANGES
591     %doc doc-copy/*
592     %rpmattr %{_bindir}/rpmbuild
593 dmorgan 185007 %rpmattr %{_bindir}/rpmspec
594 tmb 343 %rpmattr %{_prefix}/lib/rpm/brp-*
595     %rpmattr %{_prefix}/lib/rpm/check-files
596     %rpmattr %{_prefix}/lib/rpm/debugedit
597 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/desktop-file.prov
598 tmb 343 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
599     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
600     %rpmattr %{_prefix}/lib/rpm/find-provides
601     %rpmattr %{_prefix}/lib/rpm/find-requires
602 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/fontconfig.prov
603 tmb 343 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
604     %rpmattr %{_prefix}/lib/rpm/perl.prov
605     %rpmattr %{_prefix}/lib/rpm/perl.req
606    
607     %rpmattr %{_prefix}/lib/rpm/check-buildroot
608     %rpmattr %{_prefix}/lib/rpm/check-prereqs
609     %rpmattr %{_prefix}/lib/rpm/check-rpaths
610     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
611     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
612     %rpmattr %{_prefix}/lib/rpm/macros.perl
613     %rpmattr %{_prefix}/lib/rpm/macros.php
614     %rpmattr %{_prefix}/lib/rpm/macros.python
615     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
616     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
617 dmorgan 46862 %rpmattr %{_prefix}/lib/rpm/ocaml-find-provides.sh
618     %rpmattr %{_prefix}/lib/rpm/ocaml-find-requires.sh
619 tmb 343 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
620     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
621    
622     %rpmattr %{_prefix}/lib/rpm/rpmdeps
623 dmorgan 185007 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
624 tmb 343
625 tv 255921
626 tmb 343 %{_mandir}/man8/rpmbuild.8*
627     %{_mandir}/man8/rpmdeps.8*
628    
629     %if %buildpython
630     %files -n python-rpm
631     %defattr(-,root,root)
632     %{_libdir}/python*/site-packages/rpm
633     %endif
634    
635     %files -n %librpmname
636     %defattr(-,root,root)
637 dmorgan 46862 %{_libdir}/librpm.so.%{libmajor}*
638     %{_libdir}/librpmio.so.%{libmajor}*
639 dmorgan 185007 %if %{with plugins}
640     %{_libdir}/rpm-plugins
641     %endif
642    
643     %files -n %librpmbuild
644 dmorgan 46862 %{_libdir}/librpmbuild.so.%{libmajor}*
645 tmb 343
646 dmorgan 185007 %files -n %librpmsign
647     %{_libdir}/librpmsign.so.%{libmajorsign}*
648    
649     %files sign
650     %defattr(-,root,root)
651     %{_bindir}/rpmsign
652     %{_mandir}/man8/rpmsign.8*
653    
654 tmb 343 %files -n %librpmnamedevel
655     %defattr(-,root,root)
656     %{_includedir}/rpm
657     %{_libdir}/librpm.so
658     %{_libdir}/librpmio.so
659     %{_libdir}/librpmbuild.so
660 dmorgan 185007 %{_libdir}/librpmsign.so
661 tmb 343 %{_libdir}/pkgconfig/rpm.pc
662 dmorgan 185007

  ViewVC Help
Powered by ViewVC 1.1.30