/[packages]/cauldron/rpm/current/SPECS/rpm.spec
ViewVC logotype

Contents of /cauldron/rpm/current/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 24754 - (show annotations) (download)
Wed Jan 19 21:32:25 2011 UTC (13 years, 3 months ago) by tmb
File size: 22425 byte(s)
drop P64, as it's manbo specific
1 # Do not change this spec directly but in the svn
2 # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3
4 %define lib64arches x86_64 ppc64 sparc64
5
6 %ifarch %lib64arches
7 %define _lib lib64
8 %else
9 %define _lib lib
10 %endif
11
12 %define _prefix /usr
13 %define _libdir %_prefix/%_lib
14 %define _bindir %_prefix/bin
15 %define _sysconfdir /etc
16 %define _datadir /usr/share
17 %define _defaultdocdir %_datadir/doc
18 %define _localstatedir /var
19 %define _infodir %_datadir/info
20
21 %if %{?apply_patches:0}%{?!apply_patches:1}
22 %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23 %endif
24
25 # Define directory which holds rpm config files, and some binaries actually
26 # NOTE: it remains */lib even on lib64 platforms as only one version
27 # of rpm is supported anyway, per architecture
28 %define rpmdir %{_prefix}/lib/rpm
29
30 %if %{?mklibname:0}%{?!mklibname:1}
31 %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32 %endif
33
34 %define lc_distro %(echo %{distribution} | tr "A-Z" "a-z")
35
36 %if %{?distsuffix:0}%{?!distsuffix:1}
37 %define distsuffix .mga
38 %endif
39
40 %if %{?mkrel:0}%{?!mkrel:1}
41 %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:.mga}%{?mageia_release:%mageia_release}%{?subrel:.%subrel}
42 %endif
43
44 %if %{?mips:0}%{?!mips:1}
45 %define mips mips mipsel mips32 mips32el mips64 mips64el
46 %endif
47
48 %if %{?pyver:0}%{?!pyver:1}
49 %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
50 %endif
51
52 %define __find_requires %{rpmdir}/%{lc_distro}/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
53 %define __find_provides %{rpmdir}/%{lc_distro}/find-provides
54
55 %define rpmversion 4.6.1
56 %define srcver %rpmversion
57 %define libver 4.6
58 %define release %mkrel 9
59 %define librpmname %mklibname rpm %{libver}
60 %define librpmnamedevel %mklibname -d rpm
61
62 %define buildpython 1
63
64 %define rpmsetup_version 1.34
65
66 %define builddebug 0
67 %{?_with_debug:%define builddebug 1}
68
69 %{?_with_python:%define buildpython 1}
70 %{?_without_python:%define buildpython 0}
71
72 Summary: The RPM package management system
73 Name: rpm
74 Epoch: 1
75 Version: %{rpmversion}
76 Release: %{release}
77 Group: System/Configuration/Packaging
78
79 Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
80
81 # Add some undocumented feature to gendiff
82 Patch17: rpm-4.4.2.2-gendiff-improved.patch
83
84 # if %post of foo-2 fails,
85 # or if %preun of foo-1 fails,
86 # or if %postun of foo-1 fails,
87 # => foo-1 is not removed, so we end up with both packages in rpmdb
88 # this patch makes rpm ignore the error in those cases
89 # failing %pre must still make the rpm install fail (#23677)
90 #
91 # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
92 # scripts is ignored with or without this patch)
93 Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
94
95 # (fredl) add loging facilities through syslog
96 Patch31: rpm-4.6.0-rc1-syslog.patch
97
98 # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
99 # (is it still needed?)
100 Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
101
102 # In original rpm, -bb --short-circuit does not work and run all stage
103 # From popular request, we allow to do this
104 # http://qa.mandriva.com/show_bug.cgi?id=15896
105 Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
106
107 # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
108 # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
109 # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
110 Patch71: rpm-4.6.0-ordererase.patch
111
112 # don't conflict for doc files
113 # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
114 Patch83: rpm-4.6.0-no-doc-conflicts.patch
115
116 # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
117 # (is this working??)
118 Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
119
120 # Fix diff issue when buildroot contains some "//"
121 Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
122
123 # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
124 Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
125
126 # remove unused skipDir functionality that conflicts with patch124 below
127 Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
128
129 # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
130 # files from the package (eg COPYING) in the db. This is quite costly when not in cache
131 # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
132 # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
133 # but this is bad design anyway
134 Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
135
136 # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
137 Patch133: rpm-4.6.0-rc1-weakdeps.patch
138
139 # convert data in the header to a specific encoding which used in the selected locale.
140 Patch137: rpm-4.6.0-rc1-headerIconv.patch
141
142 Patch140: rpm-russian-translation.patch
143
144 # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
145 Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
146
147 # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
148 # with this patch, "#%define foo bar" is a fatal error
149 Patch145: rpm-forbid-badly-commented-define-in-spec.patch
150
151 # cf http://wiki.mandriva.com/en/Rpm_filetriggers
152 Patch146: rpm-4.6.0-rc1-filetriggers.patch
153
154 # add two fatal errors (during package build)
155 Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
156
157 # (nb: see the patch for more info about this issue)
158 Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
159
160 Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
161
162 Patch157: introduce-_after_setup-which-is-called-after-setup.patch
163 Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
164 Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
165
166 # fixes backported from 4.7.1, see patch files for full changelog entries
167 # fixes ignored Requires(pre) and (post) when they have a plain Requires counterpart
168 Patch161: rpm-fix-corequisites.patch
169 Patch162: rpm-fix-islegacyprereq.patch
170 # map PreReq into Requires(pre,preun) at build
171 Patch163: rpm-map-prereq.patch
172
173 # avoid "canonicalization unexpectedly shrank by one character" error from
174 # debugedit by adding '/' to the end of the string when the error would be
175 # triggered
176 # see https://bugzilla.redhat.com/show_bug.cgi?id=304121 and
177 # https://bugzilla.redhat.com/show_bug.cgi?id=482903
178
179 Patch164: rpm-4.6.1-updated-debugedit-for-debug_pubtypes-section.patch
180 Patch165: rpm-4.6.0-fix-debugedit-canonicalization-error.patch
181
182 #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
183
184 # default behaviour in rpm-jbj >= 4.4.6
185 Patch1005: rpm-allow-conflicting-ghost-files.patch
186
187 # (nb: see the patch for more info about this issue)
188 Patch1006: rpm-4.6.0-rc1-compat-PayloadIsLzma.patch
189
190 Patch1007: rpm-4.6.0-rc3-xz-support.patch
191
192 # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
193 # as this breaks stuff that installs files to $DOCDIR during %%install
194 Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
195
196 # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
197 # break when these unknown tags might be found in the rpmdb. Notice that this
198 # will only make rpm recognize these, not implement actual support for them..
199 Patch1009: rpm-4.6.0-rpm5-tags.patch
200
201 # Avoid adding Lua sources/patches twice when recursing. (backport from upstream git)
202 Patch1010: rpm-4.6.0-lua-add-sources-and-patches-only-once.patch
203
204 # Check chroot return code before running lua script
205 Patch1011: rpm-4.6.0-do-not-run-lua-scripts-when-chroot-fails.patch
206
207 # Check chroot return code before running external script
208 Patch1012: rpm-4.6.0-do-not-run-scripts-when-chroot-fails.patch
209
210 # Make sure files in debug packages have good default perms, fixes bug #57758
211 Patch1013: rpm-4.6.0-fix-debug-info-default-permissions.patch
212
213 # Remove BDB XA support to fix compilation with db 4.8 (upstream)
214 Patch1014: rpm-4.6.0-bdb-xa-removal.patch
215
216 # Refuse to build a rpm with 2 identical triggers (#60699)
217 #Patch1015: rpm-4.6.0-duplicate-triggers.patch
218
219 # fix %exclude behaviour to only exclude files from a specific package, not
220 # from adding the files to list of files that's not unpackaged.
221 # Reintroduces past behaviour as with rpm 4.4.8 & enforces compatibility with
222 # rpm5.org
223 Patch1016: rpm-4.6.0-dont-add-excluded-files-to-check_fileList.patch
224
225 # make rpmvercmp handle missing values and make versioned conflicts behave
226 # consistently with requires. (#55810)
227 Patch1017: rpm-4.6.0-rpmvercmp-handle-missing-values.patch
228
229 # Automatically handle ruby gem extraction in %setup
230 PAtch1018: rpm-4.6.1-setup-rubygems.patch
231
232 # Turbolinux patches
233 # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
234 Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
235 # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
236 Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
237
238 # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
239 #
240 # This patch fixes the problem when the post-scripts launched by rpm-build.
241 # The post-scripts launched by rpm-build works in LANG environment. If LANG is
242 # other locale except C, then some commands launched by post-scripts will not
243 # display characters which you expected.
244 Patch2005: rpm-4.6.0-rc1-buildlang.patch
245
246 Patch3000: mips_macros.patch
247 Patch3001: fix_stack_protector_check.patch
248 Patch3002: rpm-4.6.1-mips_define_isa_macros.patch
249 Patch3003: rpm-4.6.1-arm_mips_isa_macros.patch
250 Patch3004: rpm_add_armv5tl.patch
251
252 License: GPL
253 BuildRequires: autoconf >= 2.57
254 BuildRequires: zlib-devel
255 BuildRequires: bzip2-devel
256 BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
257 BuildRequires: automake >= 1.8
258 BuildRequires: elfutils-devel
259 BuildRequires: sed >= 4.0.3
260 BuildRequires: libbeecrypt-devel
261 BuildRequires: ed, gettext-devel
262 BuildRequires: libsqlite3-devel
263 BuildRequires: db4.8-devel
264 BuildRequires: neon-devel
265 BuildRequires: popt-devel
266 BuildRequires: nss-devel
267 BuildRequires: magic-devel
268 BuildRequires: rpm-%{lc_distro}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
269 BuildRequires: readline-devel
270 BuildRequires: ncurses-devel
271 BuildRequires: openssl-devel >= 0.9.8
272 BuildRequires: lua-devel
273 # Need for doc
274 #BuildRequires: graphviz
275 BuildRequires: tetex
276 %if %buildpython
277 BuildRequires: python-devel
278 %endif
279
280 Requires: bzip2 >= 0.9.0c-2
281 Requires: lzma
282 Requires: cpio
283 Requires: gawk
284 Requires: glibc >= 2.1.92
285 Requires: mktemp
286 Requires: setup >= 2.2.0-8
287 Requires: rpm-%{lc_distro}-setup >= 1.85
288 Requires: update-alternatives
289 Requires: %librpmname = %epoch:%version-%release
290 Conflicts: patch < 2.5
291 Conflicts: menu < 2.1.5-29
292 Conflicts: locales < 2.3.1.1
293 Conflicts: man-pages-fr < 0.9.7-16
294 Conflicts: man-pages-pl < 0.4-9
295 Conflicts: perl-URPM < 1.63-3
296 # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
297 Conflicts: urpmi-recover
298 URL: http://rpm.org/
299 %define git_url http://rpm.org/git/rpm.git
300 Requires(pre): rpm-helper >= 0.8
301 Requires(pre): coreutils
302 Requires(postun): rpm-helper >= 0.8
303 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
304
305 %description
306 RPM is a powerful command line driven package management system capable of
307 installing, uninstalling, verifying, querying, and updating software packages.
308 Each software package consists of an archive of files along with information
309 about the package like its version, a description, etc.
310
311 %package -n %librpmname
312 Summary: Library used by rpm
313 Group: System/Libraries
314 Provides: librpm = %version-%release
315
316 %description -n %librpmname
317 RPM is a powerful command line driven package management system capable of
318 installing, uninstalling, verifying, querying, and updating software packages.
319 This package contains common files to all applications based on rpm.
320
321 %package -n %librpmnamedevel
322 Summary: Development files for applications which will manipulate RPM packages
323 Group: Development/C
324 Requires: rpm = %epoch:%{version}-%{release}
325 Provides: librpm-devel = %version-%release
326 Provides: rpm-devel = %version-%release
327 Obsoletes: rpm-devel < 4.4.1
328 Obsoletes: %{_lib}rpm4.4-devel
329 Obsoletes: %{_lib}rpm4.2-devel
330
331 %description -n %librpmnamedevel
332 This package contains the RPM C library and header files. These
333 development files will simplify the process of writing programs
334 which manipulate RPM packages and databases and are intended to make
335 it easier to create graphical package managers or any other tools
336 that need an intimate knowledge of RPM packages in order to function.
337
338 This package should be installed if you want to develop programs that
339 will manipulate RPM packages and databases.
340
341 %package build
342 Summary: Scripts and executable programs used to build packages
343 Group: System/Configuration/Packaging
344 Requires: autoconf
345 Requires: automake
346 Requires: file
347 Requires: gcc-c++
348 # We need cputoolize & amd64-* alias to x86_64-* in config.sub
349 Requires: libtool-base >= 1.4.3-5
350 Requires: patch >= 2.5.9-7
351 Requires: make
352 Requires: tar
353 Requires: unzip
354 Requires: elfutils
355 Requires: rpm = %epoch:%{version}-%{release}
356 Requires: rpm-%{lc_distro}-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
357
358 %description build
359 This package contains scripts and executable programs that are used to
360 build packages using RPM.
361
362 %if %buildpython
363 %package -n python-rpm
364 Summary: Python bindings for apps which will manipulate RPM packages
365 Group: Development/Python
366 Requires: python >= %{pyver}
367 Requires: rpm = %epoch:%{version}-%{release}
368 Obsoletes: rpm-python < %epoch:%version-%release
369 Provides: rpm-python = %version-%release
370
371 %description -n python-rpm
372 The rpm-python package contains a module which permits applications
373 written in the Python programming language to use the interface
374 supplied by RPM (RPM Package Manager) libraries.
375
376 This package should be installed if you want to develop Python
377 programs that will manipulate RPM packages and databases.
378 %endif
379
380 %prep
381 %setup -q -n %name-%srcver
382 %apply_patches
383
384 %build
385
386 autoreconf
387
388 %if %builddebug
389 RPM_OPT_FLAGS=-g
390 %endif
391 CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
392 %configure \
393 --enable-nls \
394 --enable-python \
395 --enable-sqlite3 \
396 --without-javaglue \
397 %if %builddebug
398 --enable-debug \
399 %endif
400 --with-external-db \
401 %if %buildpython
402 --with-python=%{pyver} \
403 %else
404 --without-python \
405 %endif
406 --with-glob \
407 --without-selinux \
408 --without-apidocs
409
410 %make
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414
415 make DESTDIR=%buildroot install
416
417 %ifarch ppc powerpc
418 ln -sf ppc-%{lc_distro}-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-%{lc_distro}-linux
419 %endif
420
421 #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
422
423 # Save list of packages through cron
424 mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
425 install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
426
427 mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
428 install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
429
430 mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
431 for dbi in \
432 Basenames Conflictname Dirnames Group Installtid Name Providename \
433 Provideversion Removetid Requirename Requireversion Triggername \
434 Packages __db.001 __db.002 __db.003 __db.004
435 do
436 touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
437 done
438
439 test -d doc-copy || mkdir doc-copy
440 rm -rf doc-copy/*
441 ln -f doc/manual/* doc-copy/
442 rm -f doc-copy/Makefile*
443
444 mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
445
446 mkdir -p %buildroot%_sysconfdir/rpm/macros.d
447 cat > %buildroot%_sysconfdir/rpm/macros <<EOF
448 # Put your own system macros here
449 # usually contains
450
451 # Set this one according your locales
452 # %%_install_langs
453
454 EOF
455
456 # Get rid of unpackaged files
457 (cd $RPM_BUILD_ROOT;
458 rm -rf .%{_includedir}/beecrypt/
459 rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
460 rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
461 rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
462 rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
463 rm -f .%{rpmdir}/trpm
464 rm -f .%{_bindir}/rpmdiff
465 )
466
467 %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %pre
473 if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
474 echo "
475 You have both
476 /var/lib/rpm/packages.rpm db1 format installed package headers
477 /var/lib/rpm/Packages db3 format installed package headers
478 Please remove (or at least rename) one of those files, and re-install.
479 "
480 exit 1
481 fi
482
483 /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
484
485 rm -rf /usr/lib/rpm/*-mandrake-*
486 rm -rf /usr/lib/rpm/*-%{lc_distro}-*
487
488
489 %post
490 # nuke __db.00? when updating to this rpm
491 rm -f /var/lib/rpm/__db.00?
492
493 if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
494 then
495 sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
496 fi
497
498 if [ -f /var/lib/rpm/packages.rpm ]; then
499 /bin/chown rpm.rpm /var/lib/rpm/*.rpm
500 elif [ ! -f /var/lib/rpm/Packages ]; then
501 /bin/rpm --initdb
502 fi
503
504 %postun
505 /usr/share/rpm-helper/del-user rpm $1 rpm
506
507 %triggerpostun -- rpm < 1:4.4.2.3-11
508 if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
509 echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
510 mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
511 fi
512
513 %define rpmattr %attr(0755, rpm, rpm)
514
515 %files -f %{name}.lang
516 %defattr(-,root,root)
517 %doc GROUPS CHANGES doc/manual/[a-z]*
518 %attr(0755,rpm,rpm) /bin/rpm
519 %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
520 %attr(0755, rpm, rpm) %{_bindir}/gendiff
521 %attr(0755, rpm, rpm) %{_bindir}/rpmdb
522 %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
523 %attr(0755, rpm, rpm) %{_bindir}/rpmsign
524 %attr(0755, rpm, rpm) %{_bindir}/rpmquery
525 %attr(0755, rpm, rpm) %{_bindir}/rpmverify
526
527 %dir %{_localstatedir}/spool/repackage
528 %dir %{rpmdir}
529 %dir /etc/rpm
530 %config(noreplace) /etc/rpm/macros
531 %dir /etc/rpm/macros.d
532 %attr(0755, rpm, rpm) %{rpmdir}/config.guess
533 %attr(0755, rpm, rpm) %{rpmdir}/config.sub
534 #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
535 %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
536 %attr(0644, rpm, rpm) %{rpmdir}/macros
537 %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
538 %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
539 %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
540 %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
541
542 %rpmattr %{rpmdir}/rpm2cpio.sh
543 %rpmattr %{rpmdir}/tgpg
544
545 %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
546 %ifarch %{ix86} x86_64
547 %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
548 %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
549 %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
550 %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
551 %endif
552 %ifarch alpha
553 %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
554 %endif
555 %ifarch %{sunsparc}
556 %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
557 %endif
558 %ifarch ppc powerpc
559 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
560 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
561 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
562 %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
563 %endif
564 %ifarch ppc powerpc ppc64
565 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
566 %endif
567 %ifarch ppc64
568 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
569 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
570 %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
571 %endif
572 %ifarch ia64
573 %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
574 %endif
575 %ifarch x86_64
576 %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
577 %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
578 %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
579 %endif
580 %ifarch %arm
581 %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
582 %endif
583 %ifarch %mips
584 %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
585 %endif
586 %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
587
588 %{_mandir}/man[18]/*.[18]*
589 %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
590 %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
591 %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
592 %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
593 %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
594 %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
595
596 %config(noreplace,missingok) /etc/cron.daily/rpm
597 %config(noreplace,missingok) /etc/logrotate.d/rpm
598
599 %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
600
601 %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
602
603 %rpmdbattr /var/lib/rpm/Basenames
604 %rpmdbattr /var/lib/rpm/Conflictname
605 %rpmdbattr /var/lib/rpm/__db.0*
606 %rpmdbattr /var/lib/rpm/Dirnames
607 %rpmdbattr /var/lib/rpm/Group
608 %rpmdbattr /var/lib/rpm/Installtid
609 %rpmdbattr /var/lib/rpm/Name
610 %rpmdbattr /var/lib/rpm/Packages
611 %rpmdbattr /var/lib/rpm/Providename
612 %rpmdbattr /var/lib/rpm/Provideversion
613 %rpmdbattr /var/lib/rpm/Removetid
614 %rpmdbattr /var/lib/rpm/Requirename
615 %rpmdbattr /var/lib/rpm/Requireversion
616 %rpmdbattr /var/lib/rpm/Triggername
617
618 %files build
619 %defattr(-,root,root)
620 %doc CHANGES
621 %doc doc-copy/*
622 %rpmattr %{_bindir}/rpmbuild
623 %rpmattr %{_prefix}/lib/rpm/brp-*
624 %rpmattr %{_prefix}/lib/rpm/check-files
625 %rpmattr %{_prefix}/lib/rpm/debugedit
626 %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
627 %rpmattr %{_prefix}/lib/rpm/find-lang.sh
628 %rpmattr %{_prefix}/lib/rpm/find-provides
629 %rpmattr %{_prefix}/lib/rpm/find-requires
630 %rpmattr %{_prefix}/lib/rpm/perldeps.pl
631 %rpmattr %{_prefix}/lib/rpm/perl.prov
632 %rpmattr %{_prefix}/lib/rpm/perl.req
633
634 %rpmattr %{_prefix}/lib/rpm/check-buildroot
635 %rpmattr %{_prefix}/lib/rpm/check-prereqs
636 %rpmattr %{_prefix}/lib/rpm/check-rpaths
637 %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
638 %rpmattr %{_prefix}/lib/rpm/javadeps
639 %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
640 %rpmattr %{_prefix}/lib/rpm/macros.perl
641 %rpmattr %{_prefix}/lib/rpm/macros.php
642 %rpmattr %{_prefix}/lib/rpm/macros.python
643 %rpmattr %{_prefix}/lib/rpm/mono-find-provides
644 %rpmattr %{_prefix}/lib/rpm/mono-find-requires
645 %rpmattr %{_prefix}/lib/rpm/osgideps.pl
646 %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
647 %rpmattr %{_prefix}/lib/rpm/rpmdiff
648
649 %rpmattr %{_prefix}/lib/rpm/rpmdeps
650 #%rpmattr %{_prefix}/lib/rpm/trpm
651 %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
652
653 %{_mandir}/man8/rpmbuild.8*
654 %{_mandir}/man8/rpmdeps.8*
655
656 %if %buildpython
657 %files -n python-rpm
658 %defattr(-,root,root)
659 %{_libdir}/python*/site-packages/rpm
660 %endif
661
662 %files -n %librpmname
663 %defattr(-,root,root)
664 %{_libdir}/librpm-%{libver}.so
665 %{_libdir}/librpmio-%{libver}.so
666 %{_libdir}/librpmbuild-%{libver}.so
667
668 %files -n %librpmnamedevel
669 %defattr(-,root,root)
670 %{_includedir}/rpm
671 %{_libdir}/librpm.la
672 %{_libdir}/librpm.so
673 %{_libdir}/librpmio.la
674 %{_libdir}/librpmio.so
675 %{_libdir}/librpmbuild.la
676 %{_libdir}/librpmbuild.so
677 %{_libdir}/pkgconfig/rpm.pc

  ViewVC Help
Powered by ViewVC 1.1.30