/[packages]/cauldron/rpm/pristine/SPECS/rpm.spec
ViewVC logotype

Annotation of /cauldron/rpm/pristine/SPECS/rpm.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 343 - (hide annotations) (download)
Sat Jan 8 00:05:19 2011 UTC (13 years, 3 months ago) by tmb
Original Path: cauldron/rpm/current/SPECS/rpm.spec
File size: 23011 byte(s)
imported package rpm
1 tmb 343 # Do not change this spec directly but in the svn
2     # $Id: rpm.spec 134789 2007-03-27 15:13:43Z nanardon $
3    
4     %define lib64arches x86_64 ppc64 sparc64
5    
6     %ifarch %lib64arches
7     %define _lib lib64
8     %else
9     %define _lib lib
10     %endif
11    
12     %define _prefix /usr
13     %define _libdir %_prefix/%_lib
14     %define _bindir %_prefix/bin
15     %define _sysconfdir /etc
16     %define _datadir /usr/share
17     %define _defaultdocdir %_datadir/doc
18     %define _localstatedir /var
19     %define _infodir %_datadir/info
20    
21     %if %{?apply_patches:0}%{?!apply_patches:1}
22     %define apply_patches %(for p in `grep '^Patch.*:' "%{_specdir}/rpm.spec" | cut -d':' -f2-`; do echo "patch -p1 -F0 -i %{_sourcedir}/$p"; done )
23     %endif
24    
25     # Define directory which holds rpm config files, and some binaries actually
26     # NOTE: it remains */lib even on lib64 platforms as only one version
27     # of rpm is supported anyway, per architecture
28     %define rpmdir %{_prefix}/lib/rpm
29    
30     %if %{?mklibname:0}%{?!mklibname:1}
31     %define mklibname(ds) %{_lib}%{1}%{?2:%{2}}%{?3:_%{3}}%{-s:-static}%{-d:-devel}
32     %endif
33    
34     %if %{?distsuffix:0}%{?!distsuffix:1}
35     %define distsuffix mdv
36     %endif
37    
38     %if %{?mkrel:0}%{?!mkrel:1}
39     %define mkrel(c:) %{-c: 0.%{-c*}.}%{1}%{?distsuffix:%distsuffix}%{?!distsuffix:mdv}%{?mandriva_release:%mandriva_release}%{?subrel:.%subrel}
40     %endif
41    
42     %if %{?mips:0}%{?!mips:1}
43     %define mips mips mipsel mips32 mips32el mips64 mips64el
44     %endif
45    
46     %if %{?pyver:0}%{?!pyver:1}
47     %define pyver %(python -V 2>&1 | cut -f2 -d" " | cut -f1,2 -d".")
48     %endif
49    
50     %if %_vendor == Mandriva
51     %define __find_requires %{rpmdir}/mandriva/find-requires %{?buildroot:%{buildroot}} %{?_target_cpu:%{_target_cpu}}
52     %define __find_provides %{rpmdir}/mandriva/find-provides
53     %endif
54    
55     %define rpmversion 4.6.1
56     %define srcver %rpmversion
57     %define libver 4.6
58     %define release %mkrel 6
59     %define librpmname %mklibname rpm %{libver}
60     %define librpmnamedevel %mklibname -d rpm
61    
62     %define buildpython 1
63    
64     %if %_vendor == Mandriva
65     %if %{mdkversion} >= 200710
66     # MDV 2007.1 builds with --hash-style=gnu by default
67     %define rpmsetup_version 1.34
68     %endif
69     %endif
70    
71     %define builddebug 0
72     %{?_with_debug:%define builddebug 1}
73    
74     %{?_with_python:%define buildpython 1}
75     %{?_without_python:%define buildpython 0}
76    
77     Summary: The RPM package management system
78     Name: rpm
79     Epoch: 1
80     Version: %{rpmversion}
81     Release: %{release}
82     Group: System/Configuration/Packaging
83    
84     Source: http://www.rpm.org/releases/rpm-%{libver}.x/rpm-%{srcver}.tar.bz2
85    
86     # Add some undocumented feature to gendiff
87     Patch17: rpm-4.4.2.2-gendiff-improved.patch
88    
89     # if %post of foo-2 fails,
90     # or if %preun of foo-1 fails,
91     # or if %postun of foo-1 fails,
92     # => foo-1 is not removed, so we end up with both packages in rpmdb
93     # this patch makes rpm ignore the error in those cases
94     # failing %pre must still make the rpm install fail (#23677)
95     #
96     # (nb: the exit code for pretrans/posttrans & trigger/triggerun/triggerpostun
97     # scripts is ignored with or without this patch)
98     Patch22: rpm-4.6.0-rc1-non-pre-scripts-dont-fail.patch
99    
100     # (fredl) add loging facilities through syslog
101     Patch31: rpm-4.6.0-rc1-syslog.patch
102    
103     # part of Backport from 4.2.1 provides becoming obsoletes bug (fpons)
104     # (is it still needed?)
105     Patch49: rpm-4.6.0-rc1-provides-obsoleted.patch
106    
107     # - force /usr/lib/rpm/manbo/rpmrc instead of /usr/lib/rpm/<vendor>/rpmrc
108     # - read /usr/lib/rpm/manbo/rpmpopt (not only /usr/lib/rpm/rpmpopt)
109     Patch64: rpm-4.6.0-rc2-manbo-rpmrc-rpmpopt.patch
110    
111     # In original rpm, -bb --short-circuit does not work and run all stage
112     # From popular request, we allow to do this
113     # http://qa.mandriva.com/show_bug.cgi?id=15896
114     Patch70: rpm-4.6.0-rc1-bb-shortcircuit.patch
115    
116     # http://www.redhat.com/archives/rpm-list/2005-April/msg00131.html
117     # http://www.redhat.com/archives/rpm-list/2005-April/msg00132.html
118     # is this useful? "at least erasure ordering is just as non-existent as it was in 4.4.x" says Panu
119     Patch71: rpm-4.6.0-ordererase.patch
120    
121     # don't conflict for doc files
122     # (to be able to install lib*-devel together with lib64*-devel even if they have conflicting manpages)
123     Patch83: rpm-4.6.0-no-doc-conflicts.patch
124    
125     # Fix http://qa.mandriva.com/show_bug.cgi?id=19392
126     # (is this working??)
127     Patch84: rpm-4.4.2.2-rpmqv-ghost.patch
128    
129     # Fix diff issue when buildroot contains some "//"
130     Patch111: rpm-check-file-trim-double-slash-in-buildroot.patch
131    
132     # [Dec 2008] macrofiles from rpmrc does not overrides MACROFILES anymore
133     Patch114: rpm-4.6.0-rc1-read-macros_d-dot-macros.patch
134    
135     # remove unused skipDir functionality that conflicts with patch124 below
136     Patch1124: rpm-4.6.0-rc1-revert-unused-skipDir-functionality.patch
137    
138     # [pixel] without this patch, "rpm -e" or "rpm -U" will need to stat(2) every dirnames of
139     # files from the package (eg COPYING) in the db. This is quite costly when not in cache
140     # (eg on a test here: >300 stats, and so 3 seconds after a "echo 3 > /proc/sys/vm/drop_caches")
141     # this breaks urpmi test case test_rpm_i_fail('gd') in superuser--file-conflicts.t,
142     # but this is bad design anyway
143     Patch124: rpm-4.6.0-rc1-speedup-by-not-checking-same-files-with-different-paths-through-symlink.patch
144    
145     # [from SuSE] handle "Suggests" via RPMTAG_SUGGESTSNAME
146     Patch133: rpm-4.6.0-rc1-weakdeps.patch
147    
148     # convert data in the header to a specific encoding which used in the selected locale.
149     Patch137: rpm-4.6.0-rc1-headerIconv.patch
150    
151     Patch140: rpm-russian-translation.patch
152    
153     # Mandriva does not need the (broken) ldconfig hack since it uses filetriggers
154     Patch141: rpm-4.6.0-rc1-drop-skipping-ldconfig-hack.patch
155    
156     # without this patch, "#%define foo bar" is surprisingly equivalent to "%define foo bar"
157     # with this patch, "#%define foo bar" is a fatal error
158     Patch145: rpm-forbid-badly-commented-define-in-spec.patch
159    
160     # cf http://wiki.mandriva.com/en/Rpm_filetriggers
161     Patch146: rpm-4.6.0-rc1-filetriggers.patch
162    
163     # add two fatal errors (during package build)
164     Patch147: rpm-rpmbuild-check-useless-tags-in-non-existant-binary-packages.patch
165    
166     # (nb: see the patch for more info about this issue)
167     Patch151: rpm-4.6.0-rc1-protect-against-non-robust-futex.patch
168    
169     Patch152: rpm-4.6.0-rc1-fix-nss-detection.patch
170    
171     Patch157: introduce-_after_setup-which-is-called-after-setup.patch
172     Patch158: introduce-_patch-and-allow-easy-override-when-the-p.patch
173     Patch159: introduce-apply_patches-and-lua-var-patches_num.patch
174    
175     # fixes backported from 4.7.1, see patch files for full changelog entries
176     # fixes ignored Requires(pre) and (post) when they have a plain Requires counterpart
177     Patch161: rpm-fix-corequisites.patch
178     Patch162: rpm-fix-islegacyprereq.patch
179     # map PreReq into Requires(pre,preun) at build
180     Patch163: rpm-map-prereq.patch
181    
182     # avoid "canonicalization unexpectedly shrank by one character" error from
183     # debugedit by adding '/' to the end of the string when the error would be
184     # triggered
185     # see https://bugzilla.redhat.com/show_bug.cgi?id=304121 and
186     # https://bugzilla.redhat.com/show_bug.cgi?id=482903
187    
188     Patch164: rpm-4.6.1-updated-debugedit-for-debug_pubtypes-section.patch
189     Patch165: rpm-4.6.0-fix-debugedit-canonicalization-error.patch
190    
191     #Patch1001: rpm-4.6.0-rc1-new-liblzma.patch
192    
193     # default behaviour in rpm-jbj >= 4.4.6
194     Patch1005: rpm-allow-conflicting-ghost-files.patch
195    
196     # (nb: see the patch for more info about this issue)
197     Patch1006: rpm-4.6.0-rc1-compat-PayloadIsLzma.patch
198    
199     Patch1007: rpm-4.6.0-rc3-xz-support.patch
200    
201     # Prevents $DOCDIR from being wiped out when using %%doc <fileinbuilddir>,
202     # as this breaks stuff that installs files to $DOCDIR during %%install
203     Patch1008: rpm-4.6.0-rc3-no_rm_-rf_DOCDIR.patch
204    
205     # Exposes packagecolor tag and adds new tags from rpm5 as it otherwise will
206     # break when these unknown tags might be found in the rpmdb. Notice that this
207     # will only make rpm recognize these, not implement actual support for them..
208     Patch1009: rpm-4.6.0-rpm5-tags.patch
209    
210     # Avoid adding Lua sources/patches twice when recursing. (backport from upstream git)
211     Patch1010: rpm-4.6.0-lua-add-sources-and-patches-only-once.patch
212    
213     # Check chroot return code before running lua script
214     Patch1011: rpm-4.6.0-do-not-run-lua-scripts-when-chroot-fails.patch
215    
216     # Check chroot return code before running external script
217     Patch1012: rpm-4.6.0-do-not-run-scripts-when-chroot-fails.patch
218    
219     # Make sure files in debug packages have good default perms, fixes bug #57758
220     Patch1013: rpm-4.6.0-fix-debug-info-default-permissions.patch
221    
222     # Remove BDB XA support to fix compilation with db 4.8 (upstream)
223     Patch1014: rpm-4.6.0-bdb-xa-removal.patch
224    
225     # Refuse to build a rpm with 2 identical triggers (#60699)
226     #Patch1015: rpm-4.6.0-duplicate-triggers.patch
227    
228     # fix %exclude behaviour to only exclude files from a specific package, not
229     # from adding the files to list of files that's not unpackaged.
230     # Reintroduces past behaviour as with rpm 4.4.8 & enforces compatibility with
231     # rpm5.org
232     Patch1016: rpm-4.6.0-dont-add-excluded-files-to-check_fileList.patch
233    
234     # make rpmvercmp handle missing values and make versioned conflicts behave
235     # consistently with requires. (#55810)
236     Patch1017: rpm-4.6.0-rpmvercmp-handle-missing-values.patch
237    
238     # Automatically handle ruby gem extraction in %setup
239     PAtch1018: rpm-4.6.1-setup-rubygems.patch
240    
241     # Turbolinux patches
242     # add writeHeaderListTofile function into rpm-python (needed by "buildman" build system) (Toshihiro, 2003)
243     Patch2002: rpm-4.6.0-rc1-python-writeHdlist.patch
244     # Crusoe CPUs say that their CPU family is "5" but they have enough features for i686.
245     Patch2003: rpm-4.4.2.3-rc1-transmeta-crusoe-is-686.patch
246    
247     # The following patch isn't needed for Mandriva, but Turbolinux has it and it can't hurt much
248     #
249     # This patch fixes the problem when the post-scripts launched by rpm-build.
250     # The post-scripts launched by rpm-build works in LANG environment. If LANG is
251     # other locale except C, then some commands launched by post-scripts will not
252     # display characters which you expected.
253     Patch2005: rpm-4.6.0-rc1-buildlang.patch
254    
255     Patch3000: mips_macros.patch
256     Patch3001: fix_stack_protector_check.patch
257     Patch3002: rpm-4.6.1-mips_define_isa_macros.patch
258     Patch3003: rpm-4.6.1-arm_mips_isa_macros.patch
259     Patch3004: rpm_add_armv5tl.patch
260    
261     License: GPL
262     BuildRequires: autoconf >= 2.57
263     BuildRequires: zlib-devel
264     BuildRequires: bzip2-devel
265     BuildRequires: liblzma-devel >= 4.999.6-0.alpha.5
266     BuildRequires: automake >= 1.8
267     BuildRequires: elfutils-devel
268     BuildRequires: sed >= 4.0.3
269     BuildRequires: libbeecrypt-devel
270     BuildRequires: ed, gettext-devel
271     BuildRequires: libsqlite3-devel
272     BuildRequires: db4.8-devel
273     BuildRequires: neon-devel
274     BuildRequires: popt-devel
275     BuildRequires: nss-devel
276     BuildRequires: magic-devel
277     %if %_vendor == Mandriva
278     BuildRequires: rpm-mandriva-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
279     %endif
280     BuildRequires: readline-devel
281     BuildRequires: ncurses-devel
282     BuildRequires: openssl-devel >= 0.9.8
283     BuildRequires: lua-devel
284     # Need for doc
285     #BuildRequires: graphviz
286     BuildRequires: tetex
287     %if %buildpython
288     BuildRequires: python-devel
289     %endif
290    
291     Requires: bzip2 >= 0.9.0c-2
292     Requires: lzma
293     Requires: cpio
294     Requires: gawk
295     Requires: glibc >= 2.1.92
296     Requires: mktemp
297     Requires: setup >= 2.2.0-8mdk
298     Requires: rpm-manbo-setup
299     %if %_vendor == Mandriva
300     Requires: rpm-mandriva-setup >= 1.85
301     %endif
302     Requires: update-alternatives
303     Requires: %librpmname = %epoch:%version-%release
304     Conflicts: patch < 2.5
305     Conflicts: menu < 2.1.5-29mdk
306     Conflicts: locales < 2.3.1.1
307     Conflicts: man-pages-fr < 0.9.7-16mdk
308     Conflicts: man-pages-pl < 0.4-9mdk
309     Conflicts: perl-URPM < 1.63-3mdv2008.0
310     # rpm 4.6.0 dropped support for --repackage, so urpmi-recover can not work anymore:
311     Conflicts: urpmi-recover
312     URL: http://rpm.org/
313     %define git_url http://rpm.org/git/rpm.git
314     Requires(pre): rpm-helper >= 0.8
315     Requires(pre): coreutils
316     Requires(postun): rpm-helper >= 0.8
317     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
318    
319     %description
320     RPM is a powerful command line driven package management system capable of
321     installing, uninstalling, verifying, querying, and updating software packages.
322     Each software package consists of an archive of files along with information
323     about the package like its version, a description, etc.
324    
325     %package -n %librpmname
326     Summary: Library used by rpm
327     Group: System/Libraries
328     Provides: librpm = %version-%release
329    
330     %description -n %librpmname
331     RPM is a powerful command line driven package management system capable of
332     installing, uninstalling, verifying, querying, and updating software packages.
333     This package contains common files to all applications based on rpm.
334    
335     %package -n %librpmnamedevel
336     Summary: Development files for applications which will manipulate RPM packages
337     Group: Development/C
338     Requires: rpm = %epoch:%{version}-%{release}
339     Provides: librpm-devel = %version-%release
340     Provides: rpm-devel = %version-%release
341     Obsoletes: rpm-devel < 4.4.1
342     Obsoletes: %{_lib}rpm4.4-devel
343     Obsoletes: %{_lib}rpm4.2-devel
344    
345     %description -n %librpmnamedevel
346     This package contains the RPM C library and header files. These
347     development files will simplify the process of writing programs
348     which manipulate RPM packages and databases and are intended to make
349     it easier to create graphical package managers or any other tools
350     that need an intimate knowledge of RPM packages in order to function.
351    
352     This package should be installed if you want to develop programs that
353     will manipulate RPM packages and databases.
354    
355     %package build
356     Summary: Scripts and executable programs used to build packages
357     Group: System/Configuration/Packaging
358     Requires: autoconf
359     Requires: automake
360     Requires: file
361     Requires: gcc-c++
362     # We need cputoolize & amd64-* alias to x86_64-* in config.sub
363     Requires: libtool-base >= 1.4.3-5mdk
364     Requires: patch >= 2.5.9-7mdv2009.1
365     Requires: make
366     Requires: tar
367     Requires: unzip
368     Requires: elfutils
369     Requires: rpm = %epoch:%{version}-%{release}
370     %if %_vendor == Mandriva
371     Requires: rpm-mandriva-setup-build %{?rpmsetup_version:>= %{rpmsetup_version}}
372     %endif
373    
374     %description build
375     This package contains scripts and executable programs that are used to
376     build packages using RPM.
377    
378     %if %buildpython
379     %package -n python-rpm
380     Summary: Python bindings for apps which will manipulate RPM packages
381     Group: Development/Python
382     Requires: python >= %{pyver}
383     Requires: rpm = %epoch:%{version}-%{release}
384     Obsoletes: rpm-python < %epoch:%version-%release
385     Provides: rpm-python = %version-%release
386    
387     %description -n python-rpm
388     The rpm-python package contains a module which permits applications
389     written in the Python programming language to use the interface
390     supplied by RPM (RPM Package Manager) libraries.
391    
392     This package should be installed if you want to develop Python
393     programs that will manipulate RPM packages and databases.
394     %endif
395    
396     %prep
397     %setup -q -n %name-%srcver
398     %apply_patches
399    
400     %build
401    
402     autoreconf
403    
404     %if %builddebug
405     RPM_OPT_FLAGS=-g
406     %endif
407     CFLAGS="$RPM_OPT_FLAGS -fPIC" CXXFLAGS="$RPM_OPT_FLAGS -fPIC" \
408     %configure \
409     --enable-nls \
410     --enable-python \
411     --enable-sqlite3 \
412     --without-javaglue \
413     %if %builddebug
414     --enable-debug \
415     %endif
416     --with-external-db \
417     %if %buildpython
418     --with-python=%{pyver} \
419     %else
420     --without-python \
421     %endif
422     --with-glob \
423     --without-selinux \
424     --without-apidocs
425    
426     %make
427    
428     %install
429     rm -rf $RPM_BUILD_ROOT
430    
431     make DESTDIR=%buildroot install
432    
433     %ifarch ppc powerpc
434     ln -sf ppc-mandriva-linux $RPM_BUILD_ROOT%{rpmdir}/powerpc-mandriva-linux
435     %endif
436    
437     #mv -f $RPM_BUILD_ROOT/%{rpmdir}/rpmdiff $RPM_BUILD_ROOT/%{_bindir}
438    
439     # Save list of packages through cron
440     mkdir -p ${RPM_BUILD_ROOT}/etc/cron.daily
441     install -m 755 scripts/rpm.daily ${RPM_BUILD_ROOT}/etc/cron.daily/rpm
442    
443     mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
444     install -m 644 scripts/rpm.log ${RPM_BUILD_ROOT}/etc/logrotate.d/rpm
445    
446     mkdir -p $RPM_BUILD_ROOT/var/lib/rpm
447     for dbi in \
448     Basenames Conflictname Dirnames Group Installtid Name Providename \
449     Provideversion Removetid Requirename Requireversion Triggername \
450     Packages __db.001 __db.002 __db.003 __db.004
451     do
452     touch $RPM_BUILD_ROOT/var/lib/rpm/$dbi
453     done
454    
455     test -d doc-copy || mkdir doc-copy
456     rm -rf doc-copy/*
457     ln -f doc/manual/* doc-copy/
458     rm -f doc-copy/Makefile*
459    
460     mkdir -p $RPM_BUILD_ROOT/var/spool/repackage
461    
462     mkdir -p %buildroot%_sysconfdir/rpm/macros.d
463     cat > %buildroot%_sysconfdir/rpm/macros <<EOF
464     # Put your own system macros here
465     # usually contains
466    
467     # Set this one according your locales
468     # %%_install_langs
469    
470     EOF
471    
472     # Get rid of unpackaged files
473     (cd $RPM_BUILD_ROOT;
474     rm -rf .%{_includedir}/beecrypt/
475     rm -f .%{_libdir}/libbeecrypt.{a,la,so*}
476     rm -f .%{_libdir}/python*/site-packages/rpmmodule.{a,la}
477     rm -f .%{rpmdir}/{Specfile.pm,cpanflute2,cpanflute,sql.prov,sql.req,tcl.req}
478     rm -f .%{rpmdir}/{config.site,cross-build,rpmdiff.cgi}
479     rm -f .%{rpmdir}/trpm
480     rm -f .%{_bindir}/rpmdiff
481     )
482    
483     %if %_vendor == Mandriva
484     %{rpmdir}/%{_host_vendor}/find-lang.pl $RPM_BUILD_ROOT %{name}
485     %else
486     %find_lang %{name}
487     %endif
488    
489     %clean
490     rm -rf $RPM_BUILD_ROOT
491    
492     %pre
493     if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
494     echo "
495     You have both
496     /var/lib/rpm/packages.rpm db1 format installed package headers
497     /var/lib/rpm/Packages db3 format installed package headers
498     Please remove (or at least rename) one of those files, and re-install.
499     "
500     exit 1
501     fi
502    
503     /usr/share/rpm-helper/add-user rpm $1 rpm /var/lib/rpm /bin/false
504    
505     rm -rf /usr/lib/rpm/*-mandrake-*
506    
507     %post
508     # nuke __db.00? when updating to this rpm
509     rm -f /var/lib/rpm/__db.00?
510    
511     if [ ! -e /etc/rpm/macros -a -e /etc/rpmrc -a -f %{rpmdir}/convertrpmrc.sh ]
512     then
513     sh %{rpmdir}/convertrpmrc.sh 2>&1 > /dev/null
514     fi
515    
516     if [ -f /var/lib/rpm/packages.rpm ]; then
517     /bin/chown rpm.rpm /var/lib/rpm/*.rpm
518     elif [ ! -f /var/lib/rpm/Packages ]; then
519     /bin/rpm --initdb
520     fi
521    
522     %postun
523     /usr/share/rpm-helper/del-user rpm $1 rpm
524    
525     %if %mdkversion < 200900
526     %post -n %librpmname -p /sbin/ldconfig
527     %endif
528     %if %mdkversion < 200900
529     %postun -n %librpmname -p /sbin/ldconfig
530     %endif
531    
532     %triggerpostun -- rpm < 1:4.4.2.3-11
533     if [ -f /etc/rpm/macros.cdb.rpmsave ]; then
534     echo "warning: restoring /etc/rpm/macros.cdb from macros.cdb.rpmsave, please check you really need the changes"
535     mv /etc/rpm/macros.cdb.rpmsave /etc/rpm/macros.cdb
536     fi
537    
538     %define rpmattr %attr(0755, rpm, rpm)
539    
540     %files -f %{name}.lang
541     %defattr(-,root,root)
542     %doc GROUPS CHANGES doc/manual/[a-z]*
543     %attr(0755,rpm,rpm) /bin/rpm
544     %attr(0755, rpm, rpm) %{_bindir}/rpm2cpio
545     %attr(0755, rpm, rpm) %{_bindir}/gendiff
546     %attr(0755, rpm, rpm) %{_bindir}/rpmdb
547     %attr(0755, rpm, rpm) %{_bindir}/rpmgraph
548     %attr(0755, rpm, rpm) %{_bindir}/rpmsign
549     %attr(0755, rpm, rpm) %{_bindir}/rpmquery
550     %attr(0755, rpm, rpm) %{_bindir}/rpmverify
551    
552     %dir %{_localstatedir}/spool/repackage
553     %dir %{rpmdir}
554     %dir /etc/rpm
555     %config(noreplace) /etc/rpm/macros
556     %dir /etc/rpm/macros.d
557     %attr(0755, rpm, rpm) %{rpmdir}/config.guess
558     %attr(0755, rpm, rpm) %{rpmdir}/config.sub
559     #%attr(0755, rpm, rpm) %{rpmdir}/convertrpmrc.sh
560     %attr(0755, rpm, rpm) %{rpmdir}/rpmdb_*
561     %attr(0644, rpm, rpm) %{rpmdir}/macros
562     %attr(0755, rpm, rpm) %{rpmdir}/mkinstalldirs
563     %attr(0755, rpm, rpm) %{rpmdir}/rpm.*
564     %attr(0644, rpm, rpm) %{rpmdir}/rpmpopt*
565     %attr(0644, rpm, rpm) %{rpmdir}/rpmrc
566    
567     %rpmattr %{rpmdir}/rpm2cpio.sh
568     %rpmattr %{rpmdir}/tgpg
569    
570     %dir %attr( -, rpm, rpm) %{rpmdir}/platform/
571     %ifarch %{ix86} x86_64
572     %attr( -, rpm, rpm) %{rpmdir}/platform/i*86-*
573     %attr( -, rpm, rpm) %{rpmdir}/platform/athlon-*
574     %attr( -, rpm, rpm) %{rpmdir}/platform/pentium*-*
575     %attr( -, rpm, rpm) %{rpmdir}/platform/geode-*
576     %endif
577     %ifarch alpha
578     %attr( -, rpm, rpm) %{rpmdir}/platform/alpha*
579     %endif
580     %ifarch %{sunsparc}
581     %attr( -, rpm, rpm) %{rpmdir}/platform/sparc*
582     %endif
583     %ifarch ppc powerpc
584     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
585     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
586     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
587     %attr( -, rpm, rpm) %{rpmdir}/platform/powerpc-*
588     %endif
589     %ifarch ppc powerpc ppc64
590     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc*series-*
591     %endif
592     %ifarch ppc64
593     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc-*
594     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc32-*
595     %attr( -, rpm, rpm) %{rpmdir}/platform/ppc64-*
596     %endif
597     %ifarch ia64
598     %attr( -, rpm, rpm) %{rpmdir}/platform/ia64-*
599     %endif
600     %ifarch x86_64
601     %attr( -, rpm, rpm) %{rpmdir}/platform/amd64-*
602     %attr( -, rpm, rpm) %{rpmdir}/platform/x86_64-*
603     %attr( -, rpm, rpm) %{rpmdir}/platform/ia32e-*
604     %endif
605     %ifarch %arm
606     %attr( -, rpm, rpm) %{rpmdir}/platform/armv*
607     %endif
608     %ifarch %mips
609     %attr( -, rpm, rpm) %{rpmdir}/platform/mips*
610     %endif
611     %attr( -, rpm, rpm) %{rpmdir}/platform/noarch*
612    
613     %{_mandir}/man[18]/*.[18]*
614     %lang(pl) %{_mandir}/pl/man[18]/*.[18]*
615     %lang(ru) %{_mandir}/ru/man[18]/*.[18]*
616     %lang(ja) %{_mandir}/ja/man[18]/*.[18]*
617     %lang(sk) %{_mandir}/sk/man[18]/*.[18]*
618     %lang(fr) %{_mandir}/fr/man[18]/*.[18]*
619     %lang(ko) %{_mandir}/ko/man[18]/*.[18]*
620    
621     %config(noreplace,missingok) /etc/cron.daily/rpm
622     %config(noreplace,missingok) /etc/logrotate.d/rpm
623    
624     %attr(0755, rpm, rpm) %dir %_localstatedir/lib/rpm
625    
626     %define rpmdbattr %attr(0644, rpm, rpm) %verify(not md5 size mtime) %ghost %config(missingok,noreplace)
627    
628     %rpmdbattr /var/lib/rpm/Basenames
629     %rpmdbattr /var/lib/rpm/Conflictname
630     %rpmdbattr /var/lib/rpm/__db.0*
631     %rpmdbattr /var/lib/rpm/Dirnames
632     %rpmdbattr /var/lib/rpm/Group
633     %rpmdbattr /var/lib/rpm/Installtid
634     %rpmdbattr /var/lib/rpm/Name
635     %rpmdbattr /var/lib/rpm/Packages
636     %rpmdbattr /var/lib/rpm/Providename
637     %rpmdbattr /var/lib/rpm/Provideversion
638     %rpmdbattr /var/lib/rpm/Removetid
639     %rpmdbattr /var/lib/rpm/Requirename
640     %rpmdbattr /var/lib/rpm/Requireversion
641     %rpmdbattr /var/lib/rpm/Triggername
642    
643     %files build
644     %defattr(-,root,root)
645     %doc CHANGES
646     %doc doc-copy/*
647     %rpmattr %{_bindir}/rpmbuild
648     %rpmattr %{_prefix}/lib/rpm/brp-*
649     %rpmattr %{_prefix}/lib/rpm/check-files
650     %rpmattr %{_prefix}/lib/rpm/debugedit
651     %rpmattr %{_prefix}/lib/rpm/find-debuginfo.sh
652     %rpmattr %{_prefix}/lib/rpm/find-lang.sh
653     %rpmattr %{_prefix}/lib/rpm/find-provides
654     %rpmattr %{_prefix}/lib/rpm/find-requires
655     %rpmattr %{_prefix}/lib/rpm/perldeps.pl
656     %rpmattr %{_prefix}/lib/rpm/perl.prov
657     %rpmattr %{_prefix}/lib/rpm/perl.req
658    
659     %rpmattr %{_prefix}/lib/rpm/check-buildroot
660     %rpmattr %{_prefix}/lib/rpm/check-prereqs
661     %rpmattr %{_prefix}/lib/rpm/check-rpaths
662     %rpmattr %{_prefix}/lib/rpm/check-rpaths-worker
663     %rpmattr %{_prefix}/lib/rpm/javadeps
664     %rpmattr %{_prefix}/lib/rpm/libtooldeps.sh
665     %rpmattr %{_prefix}/lib/rpm/macros.perl
666     %rpmattr %{_prefix}/lib/rpm/macros.php
667     %rpmattr %{_prefix}/lib/rpm/macros.python
668     %rpmattr %{_prefix}/lib/rpm/mono-find-provides
669     %rpmattr %{_prefix}/lib/rpm/mono-find-requires
670     %rpmattr %{_prefix}/lib/rpm/osgideps.pl
671     %rpmattr %{_prefix}/lib/rpm/pkgconfigdeps.sh
672     %rpmattr %{_prefix}/lib/rpm/rpmdiff
673    
674     %rpmattr %{_prefix}/lib/rpm/rpmdeps
675     #%rpmattr %{_prefix}/lib/rpm/trpm
676     %rpmattr %{_prefix}/lib/rpm/pythondeps.sh
677    
678     %{_mandir}/man8/rpmbuild.8*
679     %{_mandir}/man8/rpmdeps.8*
680    
681     %if %buildpython
682     %files -n python-rpm
683     %defattr(-,root,root)
684     %{_libdir}/python*/site-packages/rpm
685     %endif
686    
687     %files -n %librpmname
688     %defattr(-,root,root)
689     %{_libdir}/librpm-%{libver}.so
690     %{_libdir}/librpmio-%{libver}.so
691     %{_libdir}/librpmbuild-%{libver}.so
692    
693     %files -n %librpmnamedevel
694     %defattr(-,root,root)
695     %{_includedir}/rpm
696     %{_libdir}/librpm.la
697     %{_libdir}/librpm.so
698     %{_libdir}/librpmio.la
699     %{_libdir}/librpmio.so
700     %{_libdir}/librpmbuild.la
701     %{_libdir}/librpmbuild.so
702     %{_libdir}/pkgconfig/rpm.pc
703    
704    

  ViewVC Help
Powered by ViewVC 1.1.30