/[packages]/cauldron/rpmconstant/current/SPECS/rpmconstant.spec
ViewVC logotype

Contents of /cauldron/rpmconstant/current/SPECS/rpmconstant.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 332346 - (show annotations) (download)
Tue Dec 18 01:33:23 2012 UTC (11 years, 4 months ago) by tv
File size: 1939 byte(s)
- add support for rpm-4.8 - 4.11
- fix segfaulting with rpm-4.11 retrieving RPMLOG_*
1 %define name rpmconstant
2 %define version 0.1.4
3
4 %define major 0
5 %define libname %mklibname %name %major
6 %define develname %mklibname %name -d
7
8 Summary: A library to bind RPM constant values
9 Name: %{name}
10 Version: %{version}
11 Release: %mkrel 1
12 Source0: http://rpm4.zarb.org/download/%{name}-%{version}.tar.gz
13 Patch0: rpmconstant-fix-build-rpm46.patch
14 License: LGPLv2.1
15 Group: Development/C
16 Url: http://rpm4.zarb.org/
17 BuildRequires: popt-devel
18
19 %description
20 This library provides basic functions to map internal RPM constant values
21 with their name. This is useful for perl/python or other language which has
22 binding over rpmlib.
23
24 %package -n %libname
25 Summary: A library to bind rpm constant
26 Group: Development/C
27 Provides: lib%{name} = %version-%release
28
29 %description -n %libname
30 This library provides basics functions to map internal rpm constant value
31 with their name. This is useful for perl/python or other language which has
32 binding over rpmlib.
33
34 %package -n %develname
35 Summary: Development files from librpmconstant
36 Group: Development/C
37 Provides: %name-devel = %version-%release
38 Provides: lib%{name}-devel = %version-%release
39 Requires: %libname = %version-%release
40 Obsoletes: %mklibname rpmconstant 0 -d
41
42 %description -n %develname
43 This library provides basics functions to map internal rpm constant value
44 with their name. This is useful for perl/python or other language which has
45 binding over rpmlib.
46
47 You need this package to build applications using librpmconstant.
48
49 %prep
50 %setup -q
51 %patch0 -p1 -b .rpm46
52
53 %build
54 mv rpmconstanttbl.c rpmconstanttbl.c.old # Ensure this file is regenated
55 %configure2_5x --disable-static
56 %make
57
58 %install
59 %makeinstall_std
60 rm -f %{buildroot}%{_libdir}/*.la
61
62 %files
63 %doc AUTHORS ChangeLog README
64 %_bindir/%name
65
66 %files -n %libname
67 %_libdir/lib%name.so.%{major}
68 %_libdir/lib%name.so.%{major}.*
69
70 %files -n %develname
71 %doc constant.c AUTHORS ChangeLog README
72 %_includedir/%name/%name.h
73 %_libdir/lib%name.so

  ViewVC Help
Powered by ViewVC 1.1.30