1 |
joequant |
612836 |
%define gitversion c097d85 |
2 |
|
|
|
3 |
|
|
Name: rstudio |
4 |
|
|
Version: 0.98.501 |
5 |
|
|
Release: %mkrel 1 |
6 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
7 |
|
|
Group: Sciences/Mathematics |
8 |
|
|
License: GPLv3 |
9 |
|
|
URL: http://www.rstudio.com/ |
10 |
|
|
Source: %{name}-v%{version}.tgz |
11 |
|
|
Source1: https://s3.amazonaws.com/rstudio-buildtools/core-dictionaries.zip |
12 |
|
|
Source2: https://s3.amazonaws.com/rstudio-buildtools/mathjax-20.zip |
13 |
|
|
Source3: https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip |
14 |
|
|
|
15 |
|
|
BuildRequires: cmake |
16 |
|
|
BuildRequires: boost-devel |
17 |
|
|
BuildRequires: icu-devel |
18 |
|
|
BuildRequires: java-devel |
19 |
|
|
BuildRequires: pam-devel |
20 |
|
|
BuildRequires: qt4-devel |
21 |
|
|
BuildRequires: R-base |
22 |
|
|
BuildRequires: pkgconfig(fontconfig) |
23 |
|
|
BuildRequires: pkgconfig(freetype2) |
24 |
|
|
BuildRequires: pkgconfig(glib-2.0) |
25 |
|
|
BuildRequires: pkgconfig(liblzma) |
26 |
|
|
BuildRequires: pkgconfig(libpcre) |
27 |
|
|
BuildRequires: pkgconfig(libpng) |
28 |
|
|
BuildRequires: pkgconfig(libxml-2.0) |
29 |
|
|
BuildRequires: pkgconfig(sqlite3) |
30 |
|
|
BuildRequires: pkgconfig(uuid) |
31 |
|
|
BuildRequires: gwt |
32 |
|
|
Requires: R-base |
33 |
|
|
Requires: rstudio-common |
34 |
|
|
|
35 |
|
|
%description |
36 |
|
|
RStudio is a free and open source integrated development environment for R. |
37 |
|
|
|
38 |
|
|
%package server |
39 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
40 |
|
|
Group: Sciences/Mathematics |
41 |
|
|
License: GPLv3 |
42 |
|
|
URL: http://www.rstudio.com/ |
43 |
|
|
Requires: R-base |
44 |
|
|
Requires: rstudio-common |
45 |
|
|
|
46 |
|
|
%description server |
47 |
|
|
RStudio is a free and open source integrated development environment for R. |
48 |
|
|
|
49 |
|
|
%package common |
50 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
51 |
|
|
Group: Sciences/Mathematics |
52 |
|
|
License: GPLv3 |
53 |
|
|
URL: http://www.rstudio.com/ |
54 |
|
|
Requires: R-base |
55 |
|
|
|
56 |
|
|
%description common |
57 |
|
|
RStudio is a free and open source integrated development environment for R. |
58 |
|
|
|
59 |
|
|
%prep |
60 |
|
|
%setup -q -n rstudio-rstudio-%{gitversion} |
61 |
|
|
mkdir -p dependencies/common/dictionaries |
62 |
|
|
unzip -qd dependencies/common/dictionaries %{SOURCE1} |
63 |
|
|
mkdir -p dependencies/common/mathjax |
64 |
|
|
unzip -qd dependencies/common/mathjax %{SOURCE2} |
65 |
|
|
mkdir -p src/gwt/lib/gwt |
66 |
|
|
pushd src/gwt/lib/gwt |
67 |
|
|
ln -s /usr/share/java/gwt/ 2.5.1 |
68 |
|
|
popd |
69 |
|
|
mkdir -p src/gwt/lib/gin/1.5 |
70 |
|
|
unzip -qd src/gwt/lib/gin/1.5 %{SOURCE3} |
71 |
|
|
|
72 |
|
|
%build |
73 |
|
|
pushd . |
74 |
|
|
%cmake \ |
75 |
|
|
-DRSTUDIO_TARGET=Desktop \ |
76 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} |
77 |
|
|
# Too hungry for resources |
78 |
|
|
make %{?_smp_mflags} |
79 |
|
|
popd |
80 |
|
|
|
81 |
|
|
pushd . |
82 |
|
|
%cmake \ |
83 |
|
|
-DRSTUDIO_TARGET=Server \ |
84 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name}-server |
85 |
|
|
|
86 |
|
|
make %{?_smp_mflags} |
87 |
|
|
popd |
88 |
|
|
|
89 |
|
|
%install |
90 |
|
|
pushd . |
91 |
|
|
%cmake \ |
92 |
|
|
-DRSTUDIO_TARGET=Desktop \ |
93 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} |
94 |
|
|
%makeinstall_std |
95 |
|
|
|
96 |
|
|
mkdir -p %{buildroot}%{_bindir} |
97 |
|
|
ln -s %{_libdir}/%{name}/bin/%{name} %{buildroot}%{_bindir}/%{name} |
98 |
|
|
|
99 |
|
|
# The default one is too ugly |
100 |
|
|
rm -f %{buildroot}%{_datadir}/applications/%{name}.desktop |
101 |
|
|
cat > %{buildroot}%{_datadir}/applications/mandriva-%{name}.desktop << EOF |
102 |
|
|
[Desktop Entry] |
103 |
|
|
Name=RStudio |
104 |
|
|
Comment=IDE for R |
105 |
|
|
Exec=%{_bindir}/rstudio |
106 |
|
|
Icon=rstudio |
107 |
|
|
Type=Application |
108 |
|
|
Terminal=false |
109 |
|
|
Categories=Science;Math;X-MandrivaLinux-MoreApplications-Sciences-Mathematics; |
110 |
|
|
MimeType=text/x-r-source;text/x-r;text/x-R;text/x-r-doc;text/x-r-sweave;text/x-r-markdown;text/x-r-html;application/x-r-data;application/x-r-project;text/x-r-history;text/x-r-profile;text/x-tex;text/x-markdown;text/html;text/css;text/javascript; |
111 |
|
|
EOF |
112 |
|
|
popd |
113 |
|
|
|
114 |
|
|
%cmake \ |
115 |
|
|
-DRSTUDIO_TARGET=Server \ |
116 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name}-server |
117 |
|
|
%makeinstall_std |
118 |
|
|
ln -s %{_libdir}/%{name}-server/bin/%{name}-server %{buildroot}%{_bindir}/%{name}-server |
119 |
|
|
|
120 |
|
|
%files |
121 |
|
|
%doc README.md COPYING |
122 |
|
|
%{_bindir}/%{name} |
123 |
|
|
%{_libdir}/%{name} |
124 |
|
|
%{_datadir}/applications/mandriva-%{name}.desktop |
125 |
|
|
|
126 |
|
|
%files server |
127 |
|
|
%{_bindir}/%{name}-server |
128 |
|
|
%{_libdir}/%{name}-server |
129 |
|
|
|
130 |
|
|
%files common |
131 |
|
|
%{_datadir}/mime/packages/%{name}.xml |
132 |
|
|
%{_datadir}/pixmaps/%{name}.png |
133 |
|
|
%{_iconsdir}/hicolor/*/apps/%{name}.png |
134 |
|
|
%{_iconsdir}/hicolor/*/mimetypes/application-x-r-*.png |