1 |
joequant |
612836 |
%define gitversion c097d85 |
2 |
|
|
|
3 |
|
|
Name: rstudio |
4 |
|
|
Version: 0.98.501 |
5 |
|
|
Release: %mkrel 1 |
6 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
7 |
|
|
Group: Sciences/Mathematics |
8 |
|
|
License: GPLv3 |
9 |
|
|
URL: http://www.rstudio.com/ |
10 |
|
|
Source: %{name}-v%{version}.tgz |
11 |
|
|
Source1: https://s3.amazonaws.com/rstudio-buildtools/core-dictionaries.zip |
12 |
|
|
Source2: https://s3.amazonaws.com/rstudio-buildtools/mathjax-20.zip |
13 |
|
|
Source3: https://s3.amazonaws.com/rstudio-buildtools/gin-1.5.zip |
14 |
|
|
|
15 |
|
|
BuildRequires: cmake |
16 |
|
|
BuildRequires: boost-devel |
17 |
|
|
BuildRequires: icu-devel |
18 |
|
|
BuildRequires: java-devel |
19 |
|
|
BuildRequires: pam-devel |
20 |
|
|
BuildRequires: qt4-devel |
21 |
|
|
BuildRequires: R-base |
22 |
joequant |
613604 |
BuildRequires: pkgconfig(QtWebKit) |
23 |
joequant |
612836 |
BuildRequires: pkgconfig(fontconfig) |
24 |
|
|
BuildRequires: pkgconfig(freetype2) |
25 |
|
|
BuildRequires: pkgconfig(glib-2.0) |
26 |
|
|
BuildRequires: pkgconfig(liblzma) |
27 |
|
|
BuildRequires: pkgconfig(libpcre) |
28 |
|
|
BuildRequires: pkgconfig(libpng) |
29 |
|
|
BuildRequires: pkgconfig(libxml-2.0) |
30 |
|
|
BuildRequires: pkgconfig(sqlite3) |
31 |
|
|
BuildRequires: pkgconfig(uuid) |
32 |
|
|
BuildRequires: gwt |
33 |
|
|
Requires: R-base |
34 |
|
|
Requires: rstudio-common |
35 |
|
|
|
36 |
|
|
%description |
37 |
|
|
RStudio is a free and open source integrated development environment for R. |
38 |
|
|
|
39 |
|
|
%package server |
40 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
41 |
|
|
Group: Sciences/Mathematics |
42 |
|
|
License: GPLv3 |
43 |
|
|
URL: http://www.rstudio.com/ |
44 |
|
|
Requires: R-base |
45 |
|
|
Requires: rstudio-common |
46 |
|
|
|
47 |
|
|
%description server |
48 |
|
|
RStudio is a free and open source integrated development environment for R. |
49 |
|
|
|
50 |
|
|
%package common |
51 |
|
|
Summary: RStudio IDE is a powerful and productive user interface for R |
52 |
|
|
Group: Sciences/Mathematics |
53 |
|
|
License: GPLv3 |
54 |
|
|
URL: http://www.rstudio.com/ |
55 |
|
|
Requires: R-base |
56 |
|
|
|
57 |
|
|
%description common |
58 |
|
|
RStudio is a free and open source integrated development environment for R. |
59 |
|
|
|
60 |
|
|
%prep |
61 |
|
|
%setup -q -n rstudio-rstudio-%{gitversion} |
62 |
|
|
mkdir -p dependencies/common/dictionaries |
63 |
|
|
unzip -qd dependencies/common/dictionaries %{SOURCE1} |
64 |
|
|
mkdir -p dependencies/common/mathjax |
65 |
|
|
unzip -qd dependencies/common/mathjax %{SOURCE2} |
66 |
|
|
mkdir -p src/gwt/lib/gwt |
67 |
|
|
pushd src/gwt/lib/gwt |
68 |
|
|
ln -s /usr/share/java/gwt/ 2.5.1 |
69 |
|
|
popd |
70 |
|
|
mkdir -p src/gwt/lib/gin/1.5 |
71 |
|
|
unzip -qd src/gwt/lib/gin/1.5 %{SOURCE3} |
72 |
|
|
|
73 |
|
|
%build |
74 |
|
|
pushd . |
75 |
|
|
%cmake \ |
76 |
|
|
-DRSTUDIO_TARGET=Desktop \ |
77 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} |
78 |
|
|
# Too hungry for resources |
79 |
|
|
make %{?_smp_mflags} |
80 |
|
|
popd |
81 |
|
|
|
82 |
|
|
pushd . |
83 |
|
|
%cmake \ |
84 |
|
|
-DRSTUDIO_TARGET=Server \ |
85 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name}-server |
86 |
|
|
|
87 |
|
|
make %{?_smp_mflags} |
88 |
|
|
popd |
89 |
|
|
|
90 |
|
|
%install |
91 |
|
|
pushd . |
92 |
|
|
%cmake \ |
93 |
|
|
-DRSTUDIO_TARGET=Desktop \ |
94 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name} |
95 |
|
|
%makeinstall_std |
96 |
|
|
|
97 |
|
|
mkdir -p %{buildroot}%{_bindir} |
98 |
|
|
ln -s %{_libdir}/%{name}/bin/%{name} %{buildroot}%{_bindir}/%{name} |
99 |
|
|
|
100 |
|
|
# The default one is too ugly |
101 |
|
|
rm -f %{buildroot}%{_datadir}/applications/%{name}.desktop |
102 |
|
|
cat > %{buildroot}%{_datadir}/applications/mandriva-%{name}.desktop << EOF |
103 |
|
|
[Desktop Entry] |
104 |
|
|
Name=RStudio |
105 |
|
|
Comment=IDE for R |
106 |
|
|
Exec=%{_bindir}/rstudio |
107 |
|
|
Icon=rstudio |
108 |
|
|
Type=Application |
109 |
|
|
Terminal=false |
110 |
|
|
Categories=Science;Math;X-MandrivaLinux-MoreApplications-Sciences-Mathematics; |
111 |
|
|
MimeType=text/x-r-source;text/x-r;text/x-R;text/x-r-doc;text/x-r-sweave;text/x-r-markdown;text/x-r-html;application/x-r-data;application/x-r-project;text/x-r-history;text/x-r-profile;text/x-tex;text/x-markdown;text/html;text/css;text/javascript; |
112 |
|
|
EOF |
113 |
|
|
popd |
114 |
|
|
|
115 |
|
|
%cmake \ |
116 |
|
|
-DRSTUDIO_TARGET=Server \ |
117 |
|
|
-DCMAKE_INSTALL_PREFIX=%{_libdir}/%{name}-server |
118 |
|
|
%makeinstall_std |
119 |
|
|
ln -s %{_libdir}/%{name}-server/bin/%{name}-server %{buildroot}%{_bindir}/%{name}-server |
120 |
|
|
|
121 |
|
|
%files |
122 |
|
|
%doc README.md COPYING |
123 |
|
|
%{_bindir}/%{name} |
124 |
|
|
%{_libdir}/%{name} |
125 |
|
|
%{_datadir}/applications/mandriva-%{name}.desktop |
126 |
|
|
|
127 |
|
|
%files server |
128 |
|
|
%{_bindir}/%{name}-server |
129 |
|
|
%{_libdir}/%{name}-server |
130 |
|
|
|
131 |
|
|
%files common |
132 |
|
|
%{_datadir}/mime/packages/%{name}.xml |
133 |
|
|
%{_datadir}/pixmaps/%{name}.png |
134 |
|
|
%{_iconsdir}/hicolor/*/apps/%{name}.png |
135 |
|
|
%{_iconsdir}/hicolor/*/mimetypes/application-x-r-*.png |