/[packages]/cauldron/ruby/current/SPECS/ruby.spec
ViewVC logotype

Annotation of /cauldron/ruby/current/SPECS/ruby.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 290022 - (hide annotations) (download)
Sat Sep 8 10:59:01 2012 UTC (11 years, 6 months ago) by fwang
File size: 5890 byte(s)
SILENT: drop unused slash
1 fwang 289958 %define subver 1.9
2 fwang 290007 %define rubyapi 1.9.1
3 fwang 289958 %define rubyver 1.9.3
4     %define patchversion p194
5     %define rel 1
6 blino 1152
7 fwang 290007 # This is the local lib/arch and should not be used for packaging.
8     %define ruby_sitelibdir %{_datadir}/ruby/site_ruby/%{rubyapi}
9     %define ruby_sitearchdir %{_libdir}/ruby/site_ruby/%{rubyapi}
10    
11     # This is the general location for libs/archs compatible with all
12     # or most of the Ruby versions available in the Fedora repositories.
13     %define ruby_vendorlibdir %{_datadir}/ruby/vendor_ruby/%{rubyapi}
14     %define ruby_vendorarchdir %{_libdir}/ruby/vendor_ruby/%{rubyapi}
15    
16     # The RubyGems library has to stay out of Ruby directory three, since the
17     # RubyGems should be share by all Ruby implementations.
18     %define rubygems_dir %{_datadir}/ruby/gems/%{rubyapi}
19    
20 blino 1152 Summary: Object Oriented Script Language
21     Name: ruby
22     Version: %{rubyver}.%{patchversion}
23     Release: %mkrel %rel
24     License: Ruby or GPLv2
25     Group: Development/Ruby
26     BuildRequires: autoconf
27     BuildRequires: byacc
28     BuildRequires: ncurses-devel
29     BuildRequires: readline-devel
30     BuildRequires: tcl-devel tk-devel
31 fwang 276350 BuildRequires: db-devel
32 fwang 176940 BuildRequires: gdbm-devel >= 1.8.3
33 blino 1152 BuildRequires: openssl-devel
34     BuildRequires: zlib-devel
35 fwang 289987 BuildRequires: libffi-devel
36     BuildRequires: yaml-devel
37 fwang 289998 BuildRequires: rpm-mageia-setup >= 1.158
38 blino 1152 Obsoletes: ruby-rexml
39     Provides: ruby-rexml
40     # explicit file provides (since such requires are automatically added by find-requires)
41     Provides: /usr/bin/ruby
42     Provides: ruby(abi) = %subver
43    
44 fwang 289958 Source0: http://ftp.ruby-lang.org/pub/ruby/%{subver}/ruby-%{rubyver}-%{patchversion}.tar.bz2
45 blino 1152 Source3: ruby.macros
46     URL: http://www.ruby-lang.org/
47    
48 fwang 290007 # == FEDORA PATCHES BEGINS ==
49     # http://redmine.ruby-lang.org/issues/5231
50     Patch0: ruby-1.9.3-disable-versioned-paths.patch
51     # TODO: Should be submitted upstream?
52     Patch1: ruby-1.9.3-arch-specific-dir.patch
53     # http://redmine.ruby-lang.org/issues/5281
54     Patch2: ruby-1.9.3-added-site-and-vendor-arch-flags.patch
55     # Force multiarch directories for i.86 to be always named i386. This solves
56     # some differencies in build between Fedora and RHEL.
57     Patch3: ruby-1.9.3-always-use-i386.patch
58     # http://redmine.ruby-lang.org/issues/5465
59     Patch4: ruby-1.9.3-fix-s390x-build.patch
60     # Fix the uninstaller, so that it doesn't say that gem doesn't exist
61     # when it exists outside of the GEM_HOME (already fixed in the upstream)
62     Patch5: ruby-1.9.3-rubygems-1.8.11-uninstaller.patch
63     # http://redmine.ruby-lang.org/issues/5135 - see comment 29
64     Patch6: ruby-1.9.3-webrick-test-fix.patch
65     # Already fixed upstream:
66     # https://github.com/ruby/ruby/commit/f212df564a4e1025f9fb019ce727022a97bfff53
67     Patch7: ruby-1.9.3-bignum-test-fix.patch
68     # Allows to install RubyGems into custom directory, outside of Ruby's tree.
69     # http://redmine.ruby-lang.org/issues/5617
70     Patch8: ruby-1.9.3-custom-rubygems-location.patch
71     # Add support for installing binary extensions according to FHS.
72     # https://github.com/rubygems/rubygems/issues/210
73     Patch9: rubygems-1.8.11-binary-extensions.patch
74     # Make mkmf verbose by default
75     Patch12: ruby-1.9.3-mkmf-verbose.patch
76     # == FEDORA PATCHES ENDS ==
77    
78 blino 1152 %package doc
79     Summary: Documentation for the powerful language Ruby
80     Group: Development/Ruby
81 fwang 202696 BuildArch: noarch
82 blino 1152
83     %package devel
84     Summary: Development file for the powerful language Ruby
85     Group: Development/Ruby
86     Requires: %{name} = %{version}
87    
88     %package tk
89     Summary: Tk extension for the powerful language Ruby
90     Group: Development/Ruby
91     Requires: %{name} = %{version}
92    
93     %description
94     Ruby is the interpreted scripting language for quick and
95     easy object-oriented programming. It has many features to
96     process text files and to do system management tasks (as in
97     Perl). It is simple, straight-forward, and extensible.
98    
99     %description doc
100     Ruby is the interpreted scripting language for quick and
101     easy object-oriented programming. It has many features to
102     process text files and to do system management tasks (as in
103     Perl). It is simple, straight-forward, and extensible.
104    
105     This package contains the Ruby's documentation
106    
107     %description devel
108     Ruby is the interpreted scripting language for quick and
109     easy object-oriented programming. It has many features to
110     process text files and to do system management tasks (as in
111     Perl). It is simple, straight-forward, and extensible.
112    
113     This package contains the Ruby's devel files.
114    
115     %description tk
116     Ruby is the interpreted scripting language for quick and
117     easy object-oriented programming. It has many features to
118     process text files and to do system management tasks (as in
119     Perl). It is simple, straight-forward, and extensible.
120    
121     This package contains the Tk extension for Ruby.
122    
123     %prep
124     %setup -q -n ruby-%{rubyver}-%{patchversion}
125 fwang 290007 %apply_patches
126 blino 1152
127     %build
128     CFLAGS=`echo %optflags | sed 's/-fomit-frame-pointer//'`
129 fwang 290007 %configure2_5x --enable-shared --disable-rpath --enable-pthread \
130     --with-sitedir='%{ruby_sitelibdir}' \
131     --with-sitearchdir='%{ruby_sitearchdir}' \
132     --with-vendordir='%{ruby_vendorlibdir}' \
133     --with-vendorarchdir='%{ruby_vendorarchdir}' \
134 fwang 290022 --with-rubygemsdir='%{rubygems_dir}'
135 blino 1152 %make
136    
137     %install
138     %makeinstall_std install-doc
139    
140     install -d %buildroot%{_datadir}/emacs/site-lisp
141     cp -a misc/ruby-mode.el %buildroot%{_datadir}/emacs/site-lisp
142    
143     install -d %buildroot%{_sysconfdir}/emacs/site-start.d
144     cat <<EOF >%buildroot%{_sysconfdir}/emacs/site-start.d/%{name}.el
145     (autoload 'ruby-mode "ruby-mode" "Ruby editing mode." t)
146     (add-to-list 'auto-mode-alist '("\\\\.rb$" . ruby-mode))
147     (add-to-list 'interpreter-mode-alist '("ruby" . ruby-mode))
148     EOF
149    
150     # Install the rpm macros
151     mkdir -p %buildroot%{_sysconfdir}/rpm/macros.d
152     cp %{SOURCE3} %buildroot%{_sysconfdir}/rpm/macros.d
153 fwang 289961
154 blino 1152 %check
155     make test
156    
157 fwang 289961 %files
158 blino 1152 %{_bindir}/*
159     %{_libdir}/libruby.so.*
160 fwang 289970 %{_libdir}/ruby
161 blino 1152 %{_mandir}/*/*
162     %{_datadir}/emacs/site-lisp/*
163     %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
164     %{_sysconfdir}/rpm/macros.d/%{name}.macros
165    
166     %files doc
167     %{_datadir}/ri
168    
169     %files devel
170 fwang 290003 %{_includedir}/*
171 blino 1152 %{_libdir}/libruby-static.a
172     %{_libdir}/libruby.so
173 fwang 290003 %{_libdir}/pkgconfig/*.pc
174 blino 1152
175     %files tk

  ViewVC Help
Powered by ViewVC 1.1.30