1 |
tv |
2002394 |
## START: Set by rpmautospec |
2 |
|
|
## (rpmautospec version 0.2.6) |
3 |
|
|
%define autorelease(e:s:pb:) %{?-p:0.}%{lua: |
4 |
|
|
release_number = 1; |
5 |
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}")); |
6 |
|
|
print(release_number + base_release_number - 1); |
7 |
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist} |
8 |
|
|
## END: Set by rpmautospec |
9 |
|
|
|
10 |
|
|
# Generated by rust2rpm 22 |
11 |
|
|
%bcond_without check |
12 |
|
|
%global debug_package %{nil} |
13 |
|
|
|
14 |
|
|
%global crate lipsum |
15 |
|
|
|
16 |
|
|
Name: rust-lipsum |
17 |
|
|
Version: 0.8.2 |
18 |
|
|
Release: %mkrel 0.1 |
19 |
|
|
Summary: Lorem ipsum text generation library |
20 |
|
|
|
21 |
wally |
2132800 |
Group: Development/Rust |
22 |
tv |
2002394 |
|
23 |
|
|
License: MIT |
24 |
|
|
URL: https://crates.io/crates/lipsum |
25 |
|
|
Source: %{crates_source} |
26 |
|
|
|
27 |
|
|
BuildArch: noarch |
28 |
|
|
ExclusiveArch: %{rust_arches} |
29 |
|
|
|
30 |
|
|
BuildRequires: rust-packaging >= 21 |
31 |
|
|
|
32 |
|
|
%global _description %{expand: |
33 |
|
|
Lorem ipsum text generation library. It generates pseudo-random Latin text. Use |
34 |
|
|
this if you need filler or dummy text for your application. |
35 |
|
|
The text is generated using a simple Markov chain, which you can instantiate to |
36 |
|
|
generate your own pieces of pseudo-random text.} |
37 |
|
|
|
38 |
|
|
%description %{_description} |
39 |
|
|
|
40 |
|
|
%package devel |
41 |
|
|
Summary: %{summary} |
42 |
|
|
BuildArch: noarch |
43 |
|
|
|
44 |
|
|
%description devel %{_description} |
45 |
|
|
|
46 |
|
|
This package contains library source intended for building other packages which |
47 |
|
|
use the "%{crate}" crate. |
48 |
|
|
|
49 |
|
|
%files devel |
50 |
|
|
%license %{crate_instdir}/LICENSE |
51 |
|
|
%doc %{crate_instdir}/README.md |
52 |
|
|
%{crate_instdir}/ |
53 |
|
|
|
54 |
|
|
%package -n %{name}+default-devel |
55 |
|
|
Summary: %{summary} |
56 |
|
|
BuildArch: noarch |
57 |
|
|
|
58 |
|
|
%description -n %{name}+default-devel %{_description} |
59 |
|
|
|
60 |
|
|
This package contains library source intended for building other packages which |
61 |
|
|
use the "default" feature of the "%{crate}" crate. |
62 |
|
|
|
63 |
|
|
%files -n %{name}+default-devel |
64 |
|
|
%ghost %{crate_instdir}/Cargo.toml |
65 |
|
|
|
66 |
|
|
%prep |
67 |
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1 |
68 |
|
|
%cargo_prep |
69 |
|
|
|
70 |
|
|
%generate_buildrequires |
71 |
|
|
%cargo_generate_buildrequires |
72 |
|
|
|
73 |
|
|
%build |
74 |
|
|
%cargo_build |
75 |
|
|
|
76 |
|
|
%install |
77 |
|
|
%cargo_install |
78 |
|
|
|
79 |
|
|
%if %{with check} |
80 |
|
|
%check |
81 |
|
|
%cargo_test |
82 |
|
|
%endif |
83 |
|
|
|