/[packages]/cauldron/rust-parking_lot/current/SPECS/rust-parking_lot.spec
ViewVC logotype

Contents of /cauldron/rust-parking_lot/current/SPECS/rust-parking_lot.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1900894 - (show annotations) (download)
Tue Nov 1 12:40:55 2022 UTC (22 months, 2 weeks ago) by guillomovitch
File size: 4462 byte(s)
new version 0.12.1
1 # Generated by rust2rpm 21
2 %bcond_without check
3 %global debug_package %{nil}
4
5 %global crate parking_lot
6
7 Name: rust-%{crate}
8 Version: 0.12.1
9 Release: %mkrel 1
10 Summary: Compact and efficient implementations of standard synchronization primitives
11 Group: Development/Other
12
13 # Upstream license specification: MIT OR Apache-2.0
14 License: MIT or ASL 2.0
15 URL: https://crates.io/crates/parking_lot
16 Source: %{crates_source}
17
18 ExclusiveArch: %{rust_arches}
19
20 BuildRequires: rust-packaging >= 21
21 BuildRequires: crate(lock_api/default) >= 0.4.6
22 BuildRequires: crate(parking_lot_core/default) >= 0.9.0
23 %if %{with check}
24 BuildRequires: crate(bincode/default) >= 1.3.3
25 BuildRequires: crate(rand/default) >= 0.8.3
26 %endif
27
28 %global _description %{expand:
29 More compact and efficient implementations of the standard synchronization
30 primitives.}
31
32 %description %{_description}
33
34 %package devel
35 Summary: %{summary}
36 BuildArch: noarch
37
38 %description devel %{_description}
39
40 This package contains library source intended for building other packages which
41 use the "%{crate}" crate.
42
43 %files devel
44 %license %{crate_instdir}/LICENSE-APACHE
45 %license %{crate_instdir}/LICENSE-MIT
46 %doc %{crate_instdir}/CHANGELOG.md
47 %doc %{crate_instdir}/README.md
48 %{crate_instdir}/
49
50 %package -n %{name}+default-devel
51 Summary: %{summary}
52 BuildArch: noarch
53
54 %description -n %{name}+default-devel %{_description}
55
56 This package contains library source intended for building other packages which
57 use the "default" feature of the "%{crate}" crate.
58
59 %files -n %{name}+default-devel
60 %ghost %{crate_instdir}/Cargo.toml
61
62 %package -n %{name}+arc_lock-devel
63 Summary: %{summary}
64 BuildArch: noarch
65
66 %description -n %{name}+arc_lock-devel %{_description}
67
68 This package contains library source intended for building other packages which
69 use the "arc_lock" feature of the "%{crate}" crate.
70
71 %files -n %{name}+arc_lock-devel
72 %ghost %{crate_instdir}/Cargo.toml
73
74 %package -n %{name}+deadlock_detection-devel
75 Summary: %{summary}
76 BuildArch: noarch
77
78 %description -n %{name}+deadlock_detection-devel %{_description}
79
80 This package contains library source intended for building other packages which
81 use the "deadlock_detection" feature of the "%{crate}" crate.
82
83 %files -n %{name}+deadlock_detection-devel
84 %ghost %{crate_instdir}/Cargo.toml
85
86 %package -n %{name}+hardware-lock-elision-devel
87 Summary: %{summary}
88 BuildArch: noarch
89
90 %description -n %{name}+hardware-lock-elision-devel %{_description}
91
92 This package contains library source intended for building other packages which
93 use the "hardware-lock-elision" feature of the "%{crate}" crate.
94
95 %files -n %{name}+hardware-lock-elision-devel
96 %ghost %{crate_instdir}/Cargo.toml
97
98 %package -n %{name}+nightly-devel
99 Summary: %{summary}
100 BuildArch: noarch
101
102 %description -n %{name}+nightly-devel %{_description}
103
104 This package contains library source intended for building other packages which
105 use the "nightly" feature of the "%{crate}" crate.
106
107 %files -n %{name}+nightly-devel
108 %ghost %{crate_instdir}/Cargo.toml
109
110 %package -n %{name}+owning_ref-devel
111 Summary: %{summary}
112 BuildArch: noarch
113
114 %description -n %{name}+owning_ref-devel %{_description}
115
116 This package contains library source intended for building other packages which
117 use the "owning_ref" feature of the "%{crate}" crate.
118
119 %files -n %{name}+owning_ref-devel
120 %ghost %{crate_instdir}/Cargo.toml
121
122 %package -n %{name}+send_guard-devel
123 Summary: %{summary}
124 BuildArch: noarch
125
126 %description -n %{name}+send_guard-devel %{_description}
127
128 This package contains library source intended for building other packages which
129 use the "send_guard" feature of the "%{crate}" crate.
130
131 %files -n %{name}+send_guard-devel
132 %ghost %{crate_instdir}/Cargo.toml
133
134 %package -n %{name}+serde-devel
135 Summary: %{summary}
136 BuildArch: noarch
137
138 %description -n %{name}+serde-devel %{_description}
139
140 This package contains library source intended for building other packages which
141 use the "serde" feature of the "%{crate}" crate.
142
143 %files -n %{name}+serde-devel
144 %ghost %{crate_instdir}/Cargo.toml
145
146 %prep
147 %autosetup -n %{crate}-%{version_no_tilde} -p1
148 %cargo_prep
149
150 %generate_buildrequires
151 %cargo_generate_buildrequires
152
153 %build
154 %cargo_build
155
156 %install
157 %cargo_install
158
159 %if %{with check}
160 %check
161 %cargo_test
162 %endif

  ViewVC Help
Powered by ViewVC 1.1.30