/[packages]/cauldron/shorewall/current/SPECS/shorewall.spec
ViewVC logotype

Contents of /cauldron/shorewall/current/SPECS/shorewall.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 394718 - (show annotations) (download)
Tue Feb 5 19:33:43 2013 UTC (11 years, 2 months ago) by tmb
File size: 16281 byte(s)
SILENT: no need to add backup file
1 %define debug_package %{nil}
2
3 %define version_major 4.5
4 %define version_minor 10.1
5 %define version %{version_major}.%{version_minor}
6 %define version_main %{version}
7 %define version_lite %{version}
8 %define ipv6_ver %{version}
9 %define ipv6_lite_ver %{version}
10 %define sha1sums_ver %{version}
11 %define ftp_ver %{version_major}.10
12 %define ftp_path ftp://ftp.shorewall.net/pub/shorewall/%{version_major}/%{name}-%{ftp_ver}
13
14 %define name6 %{name}6
15
16 Summary: Iptables-based firewall for Linux systems
17 Name: shorewall
18 Version: %{version}
19 Release: %mkrel 4
20 License: GPLv2+ and LGPLv2.1+
21 Group: System/Servers
22 URL: http://www.shorewall.net/
23 Source0: %ftp_path/%{name}-%{version}.tar.bz2
24 Source1: %ftp_path/%{name}-lite-%{version_lite}.tar.bz2
25 Source2: %ftp_path/%{name}-docs-html-%{version}.tar.bz2
26 Source3: %ftp_path/%{name6}-%{ipv6_ver}.tar.bz2
27 Source4: %ftp_path/%{name6}-lite-%{ipv6_lite_ver}.tar.bz2
28 Source5: %ftp_path/%{sha1sums_ver}.sha1sums
29 Source6: %ftp_path/%{name}-core-%{version}.tar.bz2
30 Patch4: %{name}-4.4.23-allow-netmask-0.patch
31 Patch5: shorewall-core-fix-restore-typo.patch
32 Requires: iptables
33 Requires: iproute2
34 Requires: shorewall-core = %version-%release
35 Requires(post): rpm-helper
36 Requires(preun): rpm-helper
37 BuildConflicts: apt-common
38 BuildArch: noarch
39
40 %description
41 The Shoreline Firewall, more commonly known as "Shorewall", is a Netfilter
42 (iptables) based firewall that can be used on a dedicated firewall system,
43 a multi-function gateway/ router/server or on a standalone GNU/Linux system.
44
45 %package core
46 Summary: Shorewall core libraries
47 Group: System/Servers
48 Conflicts: shorewall < 4.5-3
49 Requires(post): rpm-helper
50 Requires(preun): rpm-helper
51
52 %description core
53 An IPv6 enabled and capable Shoreline Firewall.
54
55
56 %package ipv6
57 Summary: IPv6 capable Shorewall
58 Group: System/Servers
59 Requires: %{name} = %{version}-%{release}
60 Requires: iptables-ipv6
61 Requires: iproute2
62 Requires: shorewall-core
63 Requires(post): rpm-helper
64 Requires(preun): rpm-helper
65
66 %description ipv6
67 An IPv6 enabled and capable Shoreline Firewall.
68
69 %package ipv6-lite
70 Summary: Lite version of ipv6 shorewall
71 Group: System/Servers
72 Requires: %{name}-ipv6 = %{version}-%{release}
73 Requires: shorewall-core
74 Requires(post): rpm-helper
75 Requires(preun): rpm-helper
76
77 %description ipv6-lite
78 Shorewall IPv6 Lite is a companion product to Shorewall IPv6 that allows
79 network administrators to centralize the configuration of Shorewall-based
80 firewalls.
81
82 %package lite
83 Summary: Lite version of shorewall
84 Group: System/Servers
85 Requires: %{name} = %{version}-%{release}
86 Requires: shorewall-core
87 Requires(post): rpm-helper
88 Requires(preun): rpm-helper
89
90 %description lite
91 Shorewall Lite is a companion product to Shorewall that allows network
92 administrators to centralize the configuration of Shorewall-based firewalls.
93
94 %package doc
95 Summary: Firewall scripts
96 Group: System/Servers
97
98 %description doc
99 The Shoreline Firewall, more commonly known as "Shorewall", is a Netfilter
100 (iptables) based firewall that can be used on a dedicated firewall system,
101 a multi-function gateway/ router/server or on a standalone GNU/Linux system.
102
103 This package contains the docs.
104
105 %prep
106 %setup -q -c -n %{name}-%{version}
107 %setup -q -T -D -a 1
108 %setup -q -T -D -a 2
109 %setup -q -T -D -a 3
110 %setup -q -T -D -a 4
111 %setup -q -T -D -a 6
112
113 pushd %{name}-%{version_main}
114 %patch4 -p1 -b .allow-netmask-0
115 popd
116 pushd %{name}-core-%{version_main}
117 %patch5 -p1
118 popd
119
120 %build
121 # (tpg) we do nothing here
122
123 %install
124 mkdir -p %{buildroot}%{_unitdir}
125
126 export PREFIX=%{buildroot}
127 export OWNER=`id -n -u`
128 export GROUP=`id -n -g`
129
130 export CONFDIR=%{_sysconfdir}/%{name}
131
132 pushd %{name}-core-%{version_main}
133 ./configure.pl SYSTEMD=%{_unitdir} SBINDIR=%{_sbindir} LIBEXEC=%{_libexecdir}
134 DESTDIR=%{buildroot} ./install.sh shorewallrc.redhat
135 popd
136
137 pushd %{name}-%{version_main}
138 # (blino) enable startup (new setting as of 2.1.3)
139 perl -pi -e 's/STARTUP_ENABLED=.*/STARTUP_ENABLED=Yes/' configfiles/%{name}.conf
140
141 # Keep synced with net.ipv4.ip_forward var in /etc/sysctl.conf
142 perl -pi -e 's/IP_FORWARDING=.*/IP_FORWARDING=Keep/' configfiles/%{name}.conf
143
144 # blank Internal option
145 perl -pi -e 's/TC_ENABLED=Internal/TC_ENABLED=/' configfiles/%{name}.conf
146
147 # (tpg) do the optimizations
148 perl -pi -e 's/OPTIMIZE=.*/OPTIMIZE=1/' configfiles/%{name}.conf
149
150 # (tpg) set config path
151 perl -pi -e 's#CONFIG_PATH=.*#CONFIG_PATH=configfiles/%{/g_sysconfdir}/%{name}#' configpath
152
153 # (lmenut) mga kernel modules are compressed by default (mga #1147)
154 perl -pi -e 's#MODULE_SUFFIX=.*#MODULE_SUFFIX="ko ko.xz ko.gz"#' configfiles/%{name}.conf
155
156 # (alien) have accounting by default in the mangle table
157 perl -pi -e 's#ACCOUNTING_TABLE=.*#ACCOUNTING_TABLE=mangle#' configfiles/%{name}.conf
158
159 ./configure.pl SYSTEMD=%{_unitdir} SBINDIR=%{_sbindir} LIBEXEC=%{_libexecdir}
160
161 # let's do the install
162 DESTDIR=%{buildroot} ./install.sh shorewallrc.redhat
163 install -m 644 *.service %{buildroot}%{_unitdir}
164 popd
165
166 #(tpg) IPv6
167 pushd %{name6}-%{ipv6_ver}
168 # (blino) enable startup (new setting as of 2.1.3)
169 perl -pi -e 's/STARTUP_ENABLED=.*/STARTUP_ENABLED=Yes/' configfiles/%{name6}.conf
170 # Keep synced with net.ipv4.ip_forward var in /etc/sysctl.conf
171 perl -pi -e 's/IP_FORWARDING=.*/IP_FORWARDING=Keep/' configfiles/%{name6}.conf
172 # (lmenut) mga kernel modules are compressed by default (mga #1147)
173 perl -pi -e 's#MODULE_SUFFIX=.*#MODULE_SUFFIX="ko ko.xz ko.gz"#' configfiles/%{name6}.conf
174 ./configure.pl SYSTEMD=%{_unitdir} SBINDIR=%{_sbindir} LIBEXEC=%{_libexecdir}
175 DESTDIR=%{buildroot} ./install.sh
176 install -m 644 *.service %{buildroot}%{_unitdir}
177 popd
178
179 pushd %{name6}-lite-%{ipv6_lite_ver}
180 ./configure.pl SYSTEMD=%{_unitdir} SBINDIR=%{_sbindir} LIBEXEC=%{_libexecdir}
181 DESTDIR=%{buildroot} ./install.sh
182 install -m 644 *.service %{buildroot}%{_unitdir}
183 popd
184
185 pushd %{name}-lite-%{version_lite}
186 ./configure.pl SYSTEMD=%{_unitdir} SBINDIR=%{_sbindir} LIBEXEC=%{_libexecdir}
187 DESTDIR=%{buildroot} ./install.sh
188 install -m 644 *.service %{buildroot}%{_unitdir}
189 popd
190
191 # Suppress automatic replacement of "echo" by "gprintf" in the shorewall
192 # startup script by RPM. This automatic replacement is broken.
193 export DONT_GPRINTIFY=1
194
195 #(tpg) looks like these files are needed
196 touch %{buildroot}/%{_var}/lib/shorewall/{chains,nat,proxyarp,restarted,zones,restore-base,restore-tail,state,.modules,.modulesdir,.iptables-restore-input,.start,.restart,.restore}
197 touch %{buildroot}/%{_var}/lib/shorewall-lite/firewall
198
199 #(tpg) ipv6
200 touch %{buildroot}/%{_var}/lib/%{name6}/{chains,restarted,zones,restore-base,restore-tail,state,.modules,.modulesdir,.iptables-restore-input,.start,.restart,.restore}
201 touch %{buildroot}/%{_var}/lib/%{name6}-lite/firewall
202
203 #remove unused files because of %exclude misbehaviour
204 rm -f %{buildroot}%{_datadir}/%{name6}/configfiles/*
205 rm -f %{buildroot}%{_datadir}/shorewall/configfiles/*
206
207 # Remove sysv init files
208 rm -rf %{buildroot}%{_initrddir}
209
210 # Don't install systemd service in /lib/systemd
211 rm -f %{buildroot}/lib/systemd/system/shorewall.service
212
213 %post
214 if [ "$1" -ge 1 ] ; then
215 perl -pi -e 's#MODULE_SUFFIX=ko$#MODULE_SUFFIX="ko ko.xz ko.gz"#' %{_sysconfdir}/%{name}/%{name}.conf
216 perl -pi -e 's#MODULE_SUFFIX=\"ko ko.gz\"$#MODULE_SUFFIX="ko ko.xz ko.gz"#' %{_sysconfdir}/%{name}/%{name}.conf
217 fi
218 %_post_service shorewall
219
220 %create_ghostfile %{_var}/lib/%{name}/chains root root 644
221 %create_ghostfile %{_var}/lib/%{name}/nat root root 644
222 %create_ghostfile %{_var}/lib/%{name}/proxyarp root root 644
223 %create_ghostfile %{_var}/lib/%{name}/restarted root root 644
224 %create_ghostfile %{_var}/lib/%{name}/zones root root 644
225 %create_ghostfile %{_var}/lib/%{name}/restore-base root root 644
226 %create_ghostfile %{_var}/lib/%{name}/restore-tail root root 644
227 %create_ghostfile %{_var}/lib/%{name}/state root root 644
228 %create_ghostfile %{_var}/lib/%{name}/.modules root root 644
229 %create_ghostfile %{_var}/lib/%{name}/.modulesdir root root 644
230 %create_ghostfile %{_var}/lib/%{name}/.iptables-restore-input root root 644
231 %create_ghostfile %{_var}/lib/%{name}/.restart root root 700
232 %create_ghostfile %{_var}/lib/%{name}/.restore root root 700
233 %create_ghostfile %{_var}/lib/%{name}/.start root root 700
234
235 %preun
236 %_preun_service %{name}
237 if [ $1 = 0 ] ; then
238 rm -f %{_sysconfdir}/%{name}/startup_disabled
239 rm -f %{_var}/lib/%{name}/*
240 fi
241
242 %post lite
243 %_post_service %{name}-lite
244 %create_ghostfile %{_var}/lib/%{name}-lite/firewall root root 644
245
246 %preun lite
247 %_preun_service %{name}-lite
248
249 %post ipv6
250 if [ $1 > 1 ] ; then
251 perl -pi -e 's#MODULE_SUFFIX=ko$#MODULE_SUFFIX="ko ko.xz ko.gz"#' %{_sysconfdir}/%{name6}/%{name6}.conf
252 perl -pi -e 's#MODULE_SUFFIX=\"ko ko.gz\"$#MODULE_SUFFIX="ko ko.xz ko.gz"#' %{_sysconfdir}/%{name6}/%{name6}.conf
253 fi
254 %_post_service %{name6}
255
256 %create_ghostfile %{_var}/lib/%{name6}/chains root root 644
257 %create_ghostfile %{_var}/lib/%{name6}/restarted root root 644
258 %create_ghostfile %{_var}/lib/%{name6}/zones root root 644
259 %create_ghostfile %{_var}/lib/%{name6}/restore-base root root 644
260 %create_ghostfile %{_var}/lib/%{name6}/restore-tail root root 644
261 %create_ghostfile %{_var}/lib/%{name6}/state root root 644
262 %create_ghostfile %{_var}/lib/%{name6}/.modules root root 644
263 %create_ghostfile %{_var}/lib/%{name6}/.modulesdir root root 644
264 %create_ghostfile %{_var}/lib/%{name6}/.iptables-restore-input root root 644
265 %create_ghostfile %{_var}/lib/%{name6}/.restart root root 700
266 %create_ghostfile %{_var}/lib/%{name6}/.restore root root 700
267 %create_ghostfile %{_var}/lib/%{name6}/.start root root 700
268
269 %preun ipv6
270 %_preun_service %{name6}
271 if [ $1 = 0 ] ; then
272 rm -f %{_sysconfdir}/%{name6}/startup_disabled
273 rm -f %{_var}/lib/%{name6}/*
274 fi
275
276 %post ipv6-lite
277 %_post_service %{name6}-lite
278 %create_ghostfile %{_var}/lib/%{name6}-lite/firewall root root 644
279
280 %preun ipv6-lite
281 %_preun_service %{name6}-lite
282
283 %files
284 %doc %{name}-%{version_main}/{changelog.txt,releasenotes.txt,Samples}
285 %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
286 %dir %{_datadir}/%{name}
287 %dir %attr(755,root,root) %{_var}/lib/%{name}
288 %ghost %{_var}/lib/%{name}/*
289 %ghost %{_var}/lib/%{name}/.??*
290 %config %{_sysconfdir}/logrotate.d/%{name}
291 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/%{name}
292 #%attr(755,root,root) %{_sbindir}/%{name}
293 %attr(755,root,root) /sbin/%{name}
294 %{_datadir}/%{name}/action*
295 %{_datadir}/%{name}/configpath
296 %{_datadir}/%{name}/helpers
297 %{_datadir}/%{name}/lib.cli-std
298 %{_datadir}/%{name}/lib.core
299 %{_datadir}/%{name}/macro.*
300 %{_datadir}/%{name}/modules*
301 %{_datadir}/%{name}/version
302 %{_libexecdir}/%{name}/getparams
303 %{_libexecdir}/%{name}/wait4ifup
304 %{_mandir}/man5/%{name}-accounting.5.*
305 %{_mandir}/man5/%{name}-actions.5.*
306 %{_mandir}/man5/%{name}-blacklist.5.*
307 %{_mandir}/man5/%{name}-ecn.5.*
308 %{_mandir}/man5/%{name}-exclusion.5.*
309 %{_mandir}/man5/%{name}-hosts.5.*
310 %{_mandir}/man5/%{name}-interfaces.5.*
311 %{_mandir}/man5/%{name}-ipsets.5.*
312 %{_mandir}/man5/%{name}-maclist.5.*
313 %{_mandir}/man5/%{name}-masq.5.*
314 %{_mandir}/man5/%{name}-modules.5.*
315 %{_mandir}/man5/%{name}-nat.5.*
316 %{_mandir}/man5/%{name}-nesting.5.*
317 #%{_mandir}/man5/%{name}-notrack.5.*
318 %{_mandir}/man5/%{name}-netmap.5.*
319 %{_mandir}/man5/%{name}-params.5.*
320 %{_mandir}/man5/%{name}-policy.5.*
321 %{_mandir}/man5/%{name}-providers.5.*
322 %{_mandir}/man5/%{name}-proxyarp.5.*
323 #%{_mandir}/man5/%{name}-route_rules.5.*
324 %{_mandir}/man5/%{name}-routes.5.*
325 %{_mandir}/man5/%{name}-routestopped.5.*
326 %{_mandir}/man5/%{name}-rules.5.*
327 %{_mandir}/man5/%{name}-secmarks.5.*
328 %{_mandir}/man5/%{name}-tcclasses.5.*
329 %{_mandir}/man5/%{name}-tcinterfaces.5.*
330 %{_mandir}/man5/%{name}-tcpri.5.*
331 %{_mandir}/man5/%{name}-tcdevices.5.*
332 %{_mandir}/man5/%{name}-tcfilters.5.*
333 %{_mandir}/man5/%{name}-tcrules.5.*
334 %{_mandir}/man5/%{name}-tos.5.*
335 %{_mandir}/man5/%{name}-tunnels.5.*
336 %{_mandir}/man5/%{name}-vardir.5.*
337 %{_mandir}/man5/%{name}-zones.5.*
338 %{_mandir}/man5/%{name}.conf.5.*
339 %{_mandir}/man8/%{name}.8.*
340 %{_mandir}/man8/%{name}-init.8.*
341 %{_mandir}/man5/%{name}-blrules.5.*
342 %{_mandir}/man5/%{name}-conntrack.5.*
343 %{_mandir}/man5/%{name}-rtrules.5.*
344 %{_mandir}/man5/%{name}-stoppedrules.5.*
345 #%dir %{_datadir}/shorewall/Shorewall
346 %{_datadir}/perl5/vendor_perl/Shorewall/*.pm
347 %{_libexecdir}/shorewall/compiler.pl
348 %{_datadir}/shorewall/prog.footer
349 #%{_datadir}/shorewall/prog.header
350 %{_unitdir}/shorewall.service
351
352 %files ipv6
353 %doc %{name6}-%{ipv6_ver}/{changelog.txt,releasenotes.txt,tunnel,ipsecvpn,Samples6}
354 %config(noreplace) %{_sysconfdir}/sysconfig/%{name6}
355 %dir %{_sysconfdir}/%{name6}
356 %dir %{_datadir}/%{name6}
357 %dir %attr(755,root,root) %{_var}/lib/%{name6}
358 %ghost %{_var}/lib/%{name6}/*
359 %ghost %{_var}/lib/%{name6}/.??*
360 %config(noreplace) %{_sysconfdir}/%{name6}/*
361 %config %{_sysconfdir}/logrotate.d/%{name6}
362 %attr(755,root,root) %{_sbindir}/%{name6}
363 %{_datadir}/%{name6}/action*
364 #%{_datadir}/%{name}/prog.footer6
365 #%{_datadir}/%{name}/prog.header6
366 %{_datadir}/%{name6}/configpath
367 %{_datadir}/%{name6}/functions
368 %{_datadir}/%{name6}/helpers
369 %{_datadir}/%{name6}/lib.*
370 %{_datadir}/%{name6}/macro.*
371 %{_datadir}/%{name6}/modules*
372 %{_datadir}/%{name6}/version
373 #%{_libexecdir}/%{name6}/wait4ifup
374 %{_mandir}/man5/%{name6}-accounting.5.*
375 %{_mandir}/man5/%{name6}-actions.5.*
376 %{_mandir}/man5/%{name6}-blacklist.5.*
377 %{_mandir}/man5/%{name6}-exclusion.5.*
378 %{_mandir}/man5/%{name6}-hosts.5.*
379 %{_mandir}/man5/%{name6}-interfaces.5.*
380 %{_mandir}/man5/%{name6}-ipsets.5.*
381 %{_mandir}/man5/%{name6}-maclist.5.*
382 %{_mandir}/man5/%{name6}-modules.5.*
383 %{_mandir}/man5/%{name6}-nesting.5.*
384 #%{_mandir}/man5/%{name6}-notrack.5.*
385 %{_mandir}/man5/%{name6}-params.5.*
386 %{_mandir}/man5/%{name6}-policy.5.*
387 %{_mandir}/man5/%{name6}-providers.5.*
388 %{_mandir}/man5/%{name6}-proxyndp.5.*
389 #%{_mandir}/man5/%{name6}-route_rules.5.*
390 %{_mandir}/man5/%{name6}-routes.5.*
391 %{_mandir}/man5/%{name6}-routestopped.5.*
392 %{_mandir}/man5/%{name6}-rules.5.*
393 %{_mandir}/man5/%{name6}-secmarks.5.*
394 %{_mandir}/man5/%{name6}-tcclasses.5.*
395 %{_mandir}/man5/%{name6}-tcdevices.5.*
396 %{_mandir}/man5/%{name6}-tcfilters.5.*
397 %{_mandir}/man5/%{name6}-tcinterfaces.5.*
398 %{_mandir}/man5/%{name6}-tcpri.5.*
399 %{_mandir}/man5/%{name6}-tcrules.5.*
400 %{_mandir}/man5/%{name6}-tos.5.*
401 %{_mandir}/man5/%{name6}-tunnels.5.*
402 %{_mandir}/man5/%{name6}-vardir.5.*
403 %{_mandir}/man5/%{name6}-zones.5.*
404 %{_mandir}/man5/%{name6}.conf.5.*
405 %{_mandir}/man8/%{name6}.8.*
406 %{_mandir}/man5/%{name6}-blrules.5.*
407 %{_mandir}/man5/%{name6}-conntrack.5.*
408 %{_mandir}/man5/%{name6}-rtrules.5.*
409 %{_mandir}/man5/%{name6}-stoppedrules.5.*
410 %{_mandir}/man5/%{name6}-netmap.5.*
411 %{_unitdir}/shorewall6.service
412
413 %files lite
414 %doc %{name}-lite-%{version_lite}/*.txt
415 %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-lite
416 %dir %{_datadir}/%{name}-lite
417 %dir %attr(755,root,root) %{_var}/lib/%{name}-lite
418 %ghost %{_var}/lib/%{name}-lite/*
419 %config(noreplace) %{_sysconfdir}/%{name}-lite/*
420 %config %{_sysconfdir}/logrotate.d/%{name}-lite
421 %attr(755,root,root) %{_sbindir}/%{name}-lite
422 %{_datadir}/%{name}-lite/configpath
423 %{_datadir}/%{name}-lite/functions
424 %{_datadir}/%{name}-lite/helpers
425 %{_datadir}/%{name}-lite/lib.*
426 %{_datadir}/%{name}-lite/modules*
427 %{_datadir}/%{name}-lite/version
428 %{_mandir}/man5/%{name}-lite*
429 %{_mandir}/man8/%{name}-lite*
430 %{_libexecdir}/%{name}-lite/shorecap
431 #%{_libexecdir}/%{name}-lite/wait4ifup
432 %{_unitdir}/shorewall-lite.service
433
434 %files ipv6-lite
435 %doc %{name6}-lite-%{ipv6_lite_ver}/*.txt
436 %config(noreplace) %{_sysconfdir}/sysconfig/%{name6}-lite
437 %dir %{_datadir}/%{name6}-lite
438 %dir %attr(755,root,root) %{_var}/lib/%{name6}-lite
439 %ghost %{_var}/lib/%{name6}-lite/*
440 %config(noreplace) %{_sysconfdir}/%{name6}-lite/*
441 %config %{_sysconfdir}/logrotate.d/%{name6}-lite
442 %attr(755,root,root) %{_sbindir}/%{name6}-lite
443 %{_datadir}/%{name6}-lite/configpath
444 %{_datadir}/%{name6}-lite/functions
445 %{_datadir}/%{name6}-lite/helpers
446 %{_datadir}/%{name6}-lite/lib.*
447 %{_datadir}/%{name6}-lite/modules*
448 %{_libexecdir}/%{name6}-lite/shorecap
449 %{_datadir}/%{name6}-lite/version
450 #%{_datadir}/%{name6}-lite/wait4ifup
451 %{_mandir}/man5/%{name6}-lite*
452 %{_mandir}/man8/%{name6}-lite*
453 %{_unitdir}/shorewall6-lite.service
454
455 %files doc
456 %doc %{name}-docs-html-%{version}/*
457
458 %files core
459 %doc shorewall-core-%{version}/{COPYING,changelog.txt,releasenotes.txt}
460 %dir %{_datadir}/shorewall/
461 %{_datadir}/shorewall/coreversion
462 %{_datadir}/shorewall/functions
463 %{_datadir}/shorewall/lib.base
464 %{_datadir}/shorewall/lib.cli
465 %{_datadir}/shorewall/lib.common
466 %{_datadir}/shorewall/shorewallrc
467 #%dir %{_libexecdir}/shorewall
468 #%{_libexecdir}/shorewall/wait4ifup

  ViewVC Help
Powered by ViewVC 1.1.30