/[packages]/cauldron/springframework/current/SPECS/springframework.spec
ViewVC logotype

Contents of /cauldron/springframework/current/SPECS/springframework.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 293117 - (show annotations) (download)
Wed Sep 12 17:24:28 2012 UTC (11 years, 7 months ago) by dmorgan
File size: 21512 byte(s)
SILENT: Do not build context module
1 Name: springframework
2 Summary: Spring Java Application Framework
3 Version: 3.1.1
4 Release: %mkrel 13
5 Epoch: 0
6 License: ASL 2.0
7 Group: Development/Java
8 URL: http://www.springframework.org
9 BuildArch: noarch
10
11 # curl https://nodeload.github.com/SpringSource/spring-framework/tarball/v3.1.1.RELEASE > spring-framework-3.1.1.tar.gz
12 Source0: %{name}-%{version}.tar.gz
13 Source1: spring-framework-%{version}-pom.xml
14 # force use tomcat 7.x apis
15 Source2: spring-framework-%{version}-depmap
16
17 # Use the group id of Jetty 8, it has to be org.eclipse.jetty instead of
18 # org.mortbay.jetty:
19 Patch1: %{name}-update-jetty-gid.patch
20
21 # Remove the dependency on jaxws-api as this is part of the JDK:
22 Patch2: %{name}-remove-jaxws-api-dependency.patch
23
24 # Update the cglib group id (it should be net.sf.cglib instead of cglib) and
25 # the artifact id (it should be cglib instead of cglib-nodep):
26 Patch3: %{name}-update-cglib-gid-and-aid.patch
27
28 # Don't rename the asm package:
29 Patch4: %{name}-dont-rebundle-asm.patch
30
31 # Don't use the AWS extension:
32 Patch5: %{name}-dont-use-aws-extension.patch
33
34 # The groovy package that we have in the distribution at the
35 # moment provides the "groovy" artifact, but not the "groovy-all"
36 # artifact, required by spring. We are patching spring to use
37 # "groovy" instead of "groovy-all", but this should probably be
38 # reviewed in the groovy package:
39 Patch6: %{name}-downgrade-groovy-aid.patch
40
41 # Remove the dependency on JRuby (sources using it are also removed before
42 # building):
43 Patch7: %{name}-remove-jruby-dependency.patch
44
45 # Use the correct hibernate validator artifact id:
46 Patch9: %{name}-fix-hibernate-validator-aid.patch
47
48 # Remove the dependency on jsr-166 as this is part of the JDK:
49 Patch10: %{name}-remove-jsr166-dependency.patch
50
51 # Remove the dependency on WebSphere UOW as it is not open source and we will
52 # never be able to build it:
53 Patch11: %{name}-remove-websphere-uow-dependency.patch
54
55 # Use the the standard EJB API (currently provided by geronimo-ejb) instead of
56 # a spring specific one:
57 Patch12: %{name}-use-javax-ejb.patch
58
59 # Use the JCA API provided by JBoss:
60 Patch13: %{name}-use-jboss-jca-api.patch
61
62 # Use the correct Derby artifact id:
63 Patch14: %{name}-fix-derby-aid.patch
64
65 # Fix the tomcat catalina artifact id to use the one in Tomcat 7 as Tomcat 6
66 # has no POMs:
67 Patch15: %{name}-fix-tomcat-catalina-aid.patch
68 # change
69 # com.bea.commonj com.springsource.commonj org.apache.geronimo.specs geronimo-commonj_1.1_spec
70 # opensymphony with org.quartz-scheduler
71 # remove javax.activation
72 # fix jasperreports gId
73 Patch17: springframework-3.1.1-context_support-pom.patch
74 # fix build with velocity 1.7
75 Patch18: springframework-3.1.1-velocity.patch
76 # unavailable deps castor-xml
77 Patch19: springframework-3.1.1-oxm-remove-castor-xml.patch
78 # use jboss-connector-api_1.6_spec instead of geronimo-j2ee-connector_1.5_spec
79 Patch20: springframework-3.1.1-jms-connector-api.patch
80 # fix openjpa deps
81 Patch21: springframework-3.1.1-orm-pom.patch
82 # jpa-2.0-api support
83 Patch22: springframework-3.1.1-orm-jpa_api.patch
84 # add tiles-el
85 Patch23: springframework-3.1.1-web_servlet-pom.patch
86 # fix struts deps
87 Patch24: springframework-3.1.1-struts-pom.patch
88 # Build with Quartz 2.x only
89 Patch25: springframework-3.1.1-no-quartz1.patch
90
91 # Build requirements (alphabetical):
92 BuildRequires: aopalliance
93 BuildRequires: apache-commons-collections
94 BuildRequires: apache-commons-logging
95 BuildRequires: aspectjweaver
96 BuildRequires: atinject
97 BuildRequires: backport-util-concurrent
98 BuildRequires: bsh
99 BuildRequires: c3p0
100 BuildRequires: cglib
101 BuildRequires: derby
102 BuildRequires: ehcache-core
103 BuildRequires: geronimo-annotation
104 BuildRequires: geronimo-ejb
105 BuildRequires: geronimo-interceptor
106 BuildRequires: geronimo-jpa
107 BuildRequires: geronimo-jta
108 BuildRequires: geronimo-validation
109 BuildRequires: groovy
110 BuildRequires: h2
111 BuildRequires: hamcrest
112 BuildRequires: hibernate3
113 BuildRequires: hibernate3-entitymanager
114 BuildRequires: hibernate-jpa-2.0-api
115 BuildRequires: hibernate-validator
116 BuildRequires: hsqldb
117 BuildRequires: maven
118 BuildRequires: maven-compiler-plugin
119 BuildRequires: maven-install-plugin
120 BuildRequires: maven-jar-plugin
121 BuildRequires: maven-javadoc-plugin
122 BuildRequires: maven-resources-plugin
123 BuildRequires: maven-source-plugin
124 BuildRequires: maven-surefire-plugin
125 BuildRequires: jamonapi >= 2.73
126 BuildRequires: java-devel
127 BuildRequires: jboss-connector-1.6-api
128 BuildRequires: jboss-el-2.2-api >= 1.0.1-0.2
129 BuildRequires: jboss-jstl-1.2-api
130 BuildRequires: jetty
131 BuildRequires: joda-time
132 BuildRequires: jopt-simple
133 BuildRequires: jpackage-utils
134 BuildRequires: junit
135 BuildRequires: log4j
136 BuildRequires: objectweb-asm
137 BuildRequires: tomcat-el-2.2-api
138 BuildRequires: tomcat-lib >= 7.0.27-2
139
140 BuildRequires: apache-poi
141 BuildRequires: apache-commons-fileupload >= 1.2.2-5
142 BuildRequires: apache-commons-lang
143 BuildRequires: apache-commons-pool
144 BuildRequires: axis
145 BuildRequires: eclipselink
146 BuildRequires: eclipse-jdt
147 BuildRequires: freemarker >= 2.3.19
148 BuildRequires: geronimo-commonj
149 BuildRequires: geronimo-jaxrpc
150 BuildRequires: geronimo-jms
151 BuildRequires: geronimo-saaj
152 BuildRequires: glassfish-jaxb
153 BuildRequires: glassfish-toplink-essentials
154 BuildRequires: hessian4
155 BuildRequires: httpcomponents-client
156 BuildRequires: itext
157 BuildRequires: jackson
158 BuildRequires: jakarta-commons-httpclient
159 BuildRequires: jakarta-taglibs-standard
160 BuildRequires: jasperreports
161 BuildRequires: jboss-jsf-2.1-api
162 BuildRequires: jboss-jsp-2.2-api
163 BuildRequires: jdo2-api
164 BuildRequires: jexcelapi
165 BuildRequires: jfreechart
166 BuildRequires: jibx >= 1.2.4
167 BuildRequires: openjpa
168 BuildRequires: portlet-2.0-api
169 BuildRequires: quartz
170 BuildRequires: rome >= 0.9
171 BuildRequires: struts
172 BuildRequires: tiles
173 BuildRequires: tomcat-servlet-3.0-api
174 BuildRequires: velocity
175 BuildRequires: velocity-tools
176 BuildRequires: xmlbeans
177 BuildRequires: xstream
178 BuildRequires: jtype
179
180 # Runtime requirements (only for the main package, other requirements go in the
181 # subpackages):
182 Requires: apache-commons-collections
183 Requires: apache-commons-logging
184 Requires: aspectjweaver
185 Requires: objectweb-asm
186 Requires: java
187 Requires: log4j
188 Requires: jopt-simple
189 Requires: jpackage-utils
190
191
192 %description
193 Spring is a layered Java/J2EE application framework, based on code published in
194 Expert One-on-One J2EE Design and Development by Rod Johnson (Wrox, 2002).
195
196
197 %package javadoc
198 Summary: Javadocs for %{name}
199 Group: Documentation
200 Requires: jpackage-utils
201
202 %description javadoc
203 This package contains javadoc for %{name}.
204
205
206 %package aop
207 Summary: Spring Aspect Oriented Framework
208 Group: Development/Java
209 Requires: %{name}-beans = %{version}-%{release}
210 Requires: %{name} = %{version}-%{release}
211 Requires: apache-commons-logging
212 Requires: apache-commons-pool
213 Requires: aopalliance
214 Requires: aspectjweaver
215 Requires: cglib
216 Requires: jamonapi
217 Requires: objectweb-asm
218
219 %description aop
220 Spring AOP is an enabling technology that allows the implementation of custom
221 aspects and provides declarative transaction management without EJB.
222
223
224 %package beans
225 Summary: Spring Bean Factory
226 Group: Development/Java
227 Requires: %{name} = %{version}-%{release}
228 Requires: atinject
229 Requires: cglib
230 Requires: tomcat-el-2.2-api
231
232 %description beans
233 The Spring Bean Factory provides an advanced configuration mechanism capable of
234 managing beans of any nature, using potentially any kind of storage facility.
235
236 %if 0
237 %package context
238 Summary: Spring Application Context
239 Group: Development/Java
240 Requires: %{name} = %{version}-%{release}
241 Requires: %{name}-aop = %{version}-%{release}
242 Requires: %{name}-beans = %{version}-%{release}
243 Requires: %{name}-expression = %{version}-%{release}
244 Requires: %{name}-instrument = %{version}-%{release}
245 Requires: aspectjweaver
246 Requires: atinject
247 Requires: backport-util-concurrent
248 Requires: bsh
249 Requires: cglib
250 Requires: geronimo-annotation
251 Requires: geronimo-ejb
252 Requires: geronimo-interceptor
253 Requires: geronimo-jpa
254 Requires: geronimo-jta
255 Requires: geronimo-validation
256 Requires: groovy
257 Requires: hamcrest
258 Requires: hibernate-validator
259 Requires: joda-time
260 Requires: objectweb-asm
261
262 %description context
263 The Spring Application Context is a complete superset of a bean factory, and
264 adds enhanced capabilities to it, some of them more J2EE and
265 enterprise-centric.
266
267 %package context-support
268 Summary: Spring Context Support
269 Group: Development/Java
270 Requires: %{name} = %{version}-%{release}
271 Requires: %{name}-beans = %{version}-%{release}
272 Requires: %{name}-context = %{version}-%{release}
273 Requires: %{name}-jdbc = %{version}-%{release}
274 Requires: %{name}-tx = %{version}-%{release}
275 Requires: apache-commons-collections
276 Requires: freemarker >= 2.3.19
277 Requires: geronimo-commonj
278 Requires: jasperreports
279 Requires: javamail
280 Requires: velocity
281 # Should these be considered optional?
282 Requires: ehcache-core
283 Requires: quartz
284
285 %description context-support
286 Spring J2EE Framework.
287
288 This package provide Quartz/CommonJ scheduling,
289 UI templating, mail and caching.
290 %endif
291
292 %package expression
293 Summary: Spring Expression Language (SpEL)
294 Group: Development/Java
295 Requires: %{name} = %{version}-%{release}
296
297 %description expression
298 The Spring Expression Language (SpEL for short) is a powerful expression
299 language that supports querying and manipulating an object graph at runtime.
300
301
302 %package instrument
303 Summary: Spring Instrumentation
304 Group: Development/Java
305 Requires: %{name} = %{version}-%{release}
306
307 %description instrument
308 The Spring Instrumentation Framework exposes performance and resource utilization
309 metrics for the Spring container and gives you runtime control of the
310 container.
311
312
313 %package jdbc
314 Summary: Spring JDBC
315 Group: Development/Java
316 Requires: %{name} = %{version}-%{release}
317 Requires: %{name}-beans = %{version}-%{release}
318 #Requires: %{name}-context = %{version}-%{release}
319 Requires: %{name}-tx = %{version}-%{release}
320 Requires: c3p0
321 Requires: geronimo-jta
322 Requires: h2
323 Requires: hsqldb
324 Requires: derby
325
326 %description jdbc
327 Spring JDBC takes care of all the low-level details associated to the
328 development with JDBC.
329
330 %package jms
331 Summary: Spring jms
332 Group: Development/Java
333 Requires: %{name} = %{version}-%{release}
334 Requires: %{name}-aop = %{version}-%{release}
335 Requires: %{name}-beans = %{version}-%{release}
336 #Requires: %{name}-context = %{version}-%{release}
337 Requires: %{name}-oxm = %{version}-%{release}
338 Requires: %{name}-tx = %{version}-%{release}
339 Requires: aopalliance
340 Requires: apache-commons-pool
341 Requires: geronimo-jms
342 Requires: geronimo-jta
343 Requires: jackson
344 Requires: jboss-connector-1.6-api
345
346 %description jms
347 Spring J2EE Framework.
348 This package provide Java Message Service 1.0.2/1.1 support.
349
350 %package orm
351 Summary: Spring ORM
352 Group: Development/Java
353 Requires: %{name} = %{version}-%{release}
354 Requires: %{name}-aop = %{version}-%{release}
355 Requires: %{name}-beans = %{version}-%{release}
356 #Requires: %{name}-context = %{version}-%{release}
357 Requires: %{name}-jdbc = %{version}-%{release}
358 Requires: %{name}-tx = %{version}-%{release}
359 Requires: %{name}-web = %{version}-%{release}
360 Requires: aopalliance
361 Requires: eclipselink
362 Requires: geronimo-jta
363 Requires: glassfish-toplink-essentials
364 Requires: hibernate3
365 Requires: hibernate-jpa-2.0-api
366 Requires: jdo2-api
367 Requires: openjpa
368 Requires: tomcat-servlet-3.0-api
369
370 %description orm
371 Spring J2EE Framework.
372
373 This package provide JDO support, JPA support, Hibernate
374 support, TopLink support, iBATIS support.
375
376 %package oxm
377 Summary: Spring OXM
378 Group: Development/Java
379 Requires: %{name} = %{version}-%{release}
380 Requires: %{name}-beans = %{version}-%{release}
381 #Requires: %{name}-context = %{version}-%{release}
382 Requires: aopalliance
383 Requires: apache-commons-lang
384 Requires: glassfish-jaxb
385 Requires: jibx >= 1.2.4
386 Requires: xmlbeans
387 Requires: xstream
388
389 %description oxm
390 Spring J2EE Framework.
391
392 This package provide marshaling and unmarshalling
393 for XML with JAXB context and JiBX binding factories.
394
395 %package struts
396 Summary: Spring Web Struts
397 Group: Development/Java
398 Requires: %{name} = %{version}-%{release}
399 Requires: %{name}-beans = %{version}-%{release}
400 #Requires: %{name}-context = %{version}-%{release}
401 Requires: %{name} = %{version}-%{release}
402 Requires: %{name}-web = %{version}-%{release}
403 Requires: %{name}-webmvc = %{version}-%{release}
404 Requires: apache-commons-beanutils
405 Requires: jakarta-taglibs-standard
406 Requires: jboss-jsp-2.2-api
407 Requires: tomcat-servlet-3.0-api
408 Requires: struts
409
410 %description struts
411 Spring J2EE Framework.
412
413 This package provide integrate a Struts
414 application with Spring
415
416 %package tx
417 Summary: Spring Transaction Management
418 Group: Development/Java
419 Requires: %{name} = %{version}-%{release}
420
421 %description tx
422 Spring provides a consistent abstraction for transaction management that
423 provides a consistent programming model across different transaction APIs,
424 supports declarative transaction management, provides a simpler API for
425 programmatic transaction management and integrates with Spring's various data
426 access abstractions.
427
428 %package web
429 Summary: Spring Web
430 Group: Development/Java
431 Requires: %{name} = %{version}-%{release}
432 Requires: %{name}-aop = %{version}-%{release}
433 Requires: %{name}-beans = %{version}-%{release}
434 #Requires: %{name}-context = %{version}-%{release}
435 Requires: %{name}-oxm = %{version}-%{release}
436 Requires: aopalliance
437 Requires: apache-commons-fileupload >= 1.2.2-5
438 Requires: axis
439 Requires: hessian4
440 Requires: httpcomponents-client
441 Requires: jakarta-commons-httpclient
442 Requires: jackson
443 Requires: log4j
444 Requires: portlet-2.0-api
445 Requires: rome >= 0.9
446 Requires: tomcat-servlet-3.0-api
447 Requires: jboss-el-2.2-api
448 Requires: jboss-jsf-2.1-api
449 Requires: jboss-jsp-2.2-api
450 Requires: geronimo-jaxrpc
451 Requires: geronimo-saaj
452
453 %description web
454 Spring J2EE Framework.
455
456 This package provide web application context, multipart
457 resolver, HTTP-based remoting support.
458
459 %package webmvc
460 Summary: Spring Web Servlet
461 Group: Development/Java
462 Requires: %{name} = %{version}-%{release}
463 Requires: %{name}-beans = %{version}-%{release}
464 #Requires: %{name}-context = %{version}-%{release}
465 #Requires: %{name}-context-support = %{version}-%{release}
466 Requires: %{name}-expression = %{version}-%{release}
467 Requires: %{name}-orm = %{version}-%{release}
468 Requires: %{name}-oxm = %{version}-%{release}
469 Requires: %{name}-web = %{version}-%{release}
470 Requires: apache-poi
471 Requires: freemarker
472 Requires: geronimo-jta
473 Requires: geronimo-validation
474 Requires: itext
475 Requires: jackson
476 Requires: jakarta-taglibs-standard
477 Requires: jasperreports
478 Requires: jboss-el-2.2-api
479 Requires: jboss-jsp-2.2-api
480 Requires: jexcelapi
481 Requires: objectweb-asm
482 Requires: rome >= 0.9-11
483 Requires: tiles
484 Requires: tomcat-servlet-3.0-api
485 Requires: velocity
486 Requires: velocity-tools
487
488 %description webmvc
489 Spring J2EE Framework.
490
491 This package provide framework servlets, web MVC framework,
492 web controllers, web views for JSP, Velocity, Tiles,
493 iText and POI.
494
495 %package webmvc-portlet
496 Summary: Spring Web Portlet
497 Group: Development/Java
498 Requires: %{name} = %{version}-%{release}
499 Requires: %{name}-beans = %{version}-%{release}
500 #Requires: %{name}-context = %{version}-%{release}
501 Requires: %{name}-web = %{version}-%{release}
502 Requires: %{name}-webmvc = %{version}-%{release}
503 Requires: apache-commons-fileupload >= 1.2.2-5
504 Requires: jboss-el-2.2-api
505 Requires: jboss-jsp-2.2-api
506 Requires: objectweb-asm
507 Requires: portlet-2.0-api
508 Requires: tomcat-servlet-3.0-api
509
510 %description webmvc-portlet
511 Spring J2EE Framework.
512
513 This package provide support development of Portlet
514 applications with Spring.
515
516 %prep
517 %setup -q -n SpringSource-spring-framework-79c9ca1
518 %patch1 -p1
519 %patch2 -p1
520 %patch3 -p1
521 %patch4 -p1
522 %patch5 -p1
523 %patch6 -p1
524 %patch7 -p1
525 # %patch8 -p1
526 %patch9 -p1
527 %patch10 -p1
528 %patch11 -p1
529 %patch12 -p1
530 %patch13 -p1
531 %patch14 -p1
532 %patch15 -p1
533
534 %patch17 -p0
535 %patch18 -p0
536 %patch19 -p0
537 %patch20 -p0
538 %patch21 -p0
539 %patch22 -p0
540 %patch23 -p0
541 %patch24 -p0
542 %patch25 -p1
543
544 # ERROR: XThis is not public in Bsh
545 rm org.springframework.context/src/main/java/org/springframework/scripting/bsh/BshScriptFactory.java
546 rm org.springframework.context/src/main/java/org/springframework/scripting/bsh/BshScriptUtils.java
547
548 # ERROR: JRubyScriptUtils.java:[81,28] error: cannot access ByteList
549 rm org.springframework.context/src/main/java/org/springframework/scripting/jruby/JRubyScriptFactory.java
550 rm org.springframework.context/src/main/java/org/springframework/scripting/jruby/JRubyScriptUtils.java
551
552 # Remove classes which explicitly require Quartz 1.x (others are patched)
553 rm org.springframework.context.support/src/main/java/org/springframework/scheduling/quartz/JobDetailBean.java
554 rm org.springframework.context.support/src/main/java/org/springframework/scheduling/quartz/SimpleTriggerBean.java
555 rm org.springframework.context.support/src/main/java/org/springframework/scheduling/quartz/CronTriggerBean.java
556
557 # require castor-xml
558 rm -rf org.springframework.oxm/src/main/java/org/springframework/oxm/castor/*
559 # fix hessian aId
560 sed -i "s|<artifactId>com.springsource.com.caucho|<artifactId>hessian|" org.springframework.web/pom.xml
561 # not available build desp
562 rm -rf org.springframework.orm/src/main/java/org/springframework/orm/hibernate4/*
563 rm -rf org.springframework.orm/src/main/java/org/springframework/orm/ibatis/*
564
565 # Put the dummy root POM in place:
566 cp %{SOURCE1} pom.xml
567
568
569 %build
570
571 # Build without the tests, as they bring a lot of dependecies that are not
572 # available in the distribution at the moment:
573 mvn-rpmbuild \
574 -Dproject.build.sourceEncoding=ISO-8859-1 \
575 -Dmaven.local.depmap.file="%{SOURCE2}" \
576 -Dmaven.test.skip=true \
577 install \
578 javadoc:aggregate
579
580
581 %install
582
583 # Install jar and POM files:
584 install -d -m 755 %{buildroot}%{_javadir}/%{name}
585 install -d -m 755 %{buildroot}%{_mavenpomdir}
586 while read module_name artifact_id
587 do
588 pom_file="${module_name}/pom.xml"
589 jar_file="${module_name}/target/${artifact_id}-%{version}.RELEASE.jar"
590 depmap_suffix=${artifact_id#spring-}
591 install -p -m 644 ${pom_file} %{buildroot}%{_mavenpomdir}/JPP.%{name}-${artifact_id}.pom
592 if [ -f "${jar_file}" ]
593 then
594 install -p -m 644 ${jar_file} %{buildroot}%{_javadir}/%{name}/${artifact_id}.jar
595 %add_maven_depmap JPP.%{name}-${artifact_id}.pom %{name}/${artifact_id}.jar -f "${depmap_suffix}"
596 else
597 %add_maven_depmap JPP.%{name}-${artifact_id}.pom -f "${depmap_suffix}"
598 fi
599 done <<'.'
600 org.springframework.spring-parent spring-parent
601 org.springframework.aop spring-aop
602 org.springframework.beans spring-beans
603 org.springframework.core spring-core
604 org.springframework.expression spring-expression
605 org.springframework.instrument spring-instrument
606 org.springframework.jdbc spring-jdbc
607 org.springframework.transaction spring-tx
608 org.springframework.oxm spring-oxm
609 org.springframework.web spring-web
610 org.springframework.jms spring-jms
611 org.springframework.orm spring-orm
612 org.springframework.web.servlet spring-webmvc
613 org.springframework.web.portlet spring-webmvc-portlet
614 org.springframework.web.struts spring-struts
615 .
616
617 %if 0
618 org.springframework.context spring-context
619 org.springframework.context.support spring-context-support
620 %endif
621
622 # Install javadoc files:
623 install -d -m 755 %{buildroot}%{_javadocdir}/%{name}
624 cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}/.
625
626
627 %files
628 %dir %{_javadir}/%{name}
629 %{_javadir}/%{name}/spring-core.jar
630 %{_mavendepmapfragdir}/%{name}-parent
631 %{_mavendepmapfragdir}/%{name}-core
632 %{_mavenpomdir}/JPP.%{name}-spring-parent.pom
633 %{_mavenpomdir}/JPP.%{name}-spring-core.pom
634 %doc build-spring-framework/resources/*
635
636
637 %files javadoc
638 %{_javadocdir}/%{name}
639 %doc build-spring-framework/resources/license.txt
640
641
642 %files aop
643 %{_mavendepmapfragdir}/%{name}-aop
644 %{_mavenpomdir}/JPP.%{name}-spring-aop.pom
645 %{_javadir}/%{name}/spring-aop.jar
646
647
648 %files beans
649 %{_mavendepmapfragdir}/%{name}-beans
650 %{_javadir}/%{name}/spring-beans.jar
651 %{_mavenpomdir}/JPP.%{name}-spring-beans.pom
652
653
654 %if 0
655 %files context
656 %{_mavendepmapfragdir}/%{name}-context
657 %{_javadir}/%{name}/spring-context.jar
658 %{_mavenpomdir}/JPP.%{name}-spring-context.pom
659
660
661 %files context-support
662 %{_javadir}/%{name}/spring-context-support.jar
663 %{_mavenpomdir}/JPP.%{name}-spring-context-support.pom
664 %{_mavendepmapfragdir}/%{name}-context-support
665 %endif
666
667 %files expression
668 %{_mavendepmapfragdir}/%{name}-expression
669 %{_javadir}/%{name}/spring-expression.jar
670 %{_mavenpomdir}/JPP.%{name}-spring-expression.pom
671
672
673 %files instrument
674 %{_mavendepmapfragdir}/%{name}-instrument
675 %{_javadir}/%{name}/spring-instrument.jar
676 %{_mavenpomdir}/JPP.%{name}-spring-instrument.pom
677
678
679 %files jdbc
680 %{_mavendepmapfragdir}/%{name}-jdbc
681 %{_javadir}/%{name}/spring-jdbc.jar
682 %{_mavenpomdir}/JPP.%{name}-spring-jdbc.pom
683
684
685 %files jms
686 %{_javadir}/%{name}/spring-jms.jar
687 %{_mavenpomdir}/JPP.%{name}-spring-jms.pom
688 %{_mavendepmapfragdir}/%{name}-jms
689
690
691 %files orm
692 %{_javadir}/%{name}/spring-orm.jar
693 %{_mavenpomdir}/JPP.%{name}-spring-orm.pom
694 %{_mavendepmapfragdir}/%{name}-orm
695
696 %files oxm
697 %{_javadir}/%{name}/spring-oxm.jar
698 %{_mavenpomdir}/JPP.%{name}-spring-oxm.pom
699 %{_mavendepmapfragdir}/%{name}-oxm
700
701
702 %files struts
703 %{_javadir}/%{name}/spring-struts.jar
704 %{_mavenpomdir}/JPP.%{name}-spring-struts.pom
705 %{_mavendepmapfragdir}/%{name}-struts
706
707
708 %files tx
709 %{_mavendepmapfragdir}/%{name}-tx
710 %{_javadir}/%{name}/spring-tx.jar
711 %{_mavenpomdir}/JPP.%{name}-spring-tx.pom
712
713
714 %files web
715 %{_javadir}/%{name}/spring-web.jar
716 %{_mavenpomdir}/JPP.%{name}-spring-web.pom
717 %{_mavendepmapfragdir}/%{name}-web
718
719
720 %files webmvc
721 %{_javadir}/%{name}/spring-webmvc.jar
722 %{_mavenpomdir}/JPP.%{name}-spring-webmvc.pom
723 %{_mavendepmapfragdir}/%{name}-webmvc
724
725
726 %files webmvc-portlet
727 %{_javadir}/%{name}/spring-webmvc-portlet.jar
728 %{_mavenpomdir}/JPP.%{name}-spring-webmvc-portlet.pom
729 %{_mavendepmapfragdir}/%{name}-webmvc-portlet
730
731

  ViewVC Help
Powered by ViewVC 1.1.30