1 |
Name: squirrelsh |
2 |
Summary: A cross-platform alternative to system shell |
3 |
Version: 1.2.6 |
4 |
Release: %mkrel 1 |
5 |
Source0: http://switch.dl.sourceforge.net/project/squirrelsh/Squirrel%20Shell/1.2.6/%{name}-%{version}-src.tar.bz2 |
6 |
Source1: squirrel.xml |
7 |
URL: http://squirrelsh.sourceforge.net/ |
8 |
Patch0: squirrelsh-configure.patch |
9 |
Patch1: squirrelsh-configure-mime_in.patch |
10 |
Group: Shells |
11 |
License: GPLv2 |
12 |
|
13 |
BuildRequires: libpcre-devel |
14 |
Requires: grep |
15 |
|
16 |
%description |
17 |
Squirrel Shell is a cross-platform alternative to system shells like |
18 |
sh in Unix-like systems and cmd.exe (command.com) in Microsoft® Windows®. |
19 |
It is based on Squirrel scripting language which has these features: |
20 |
. object-oriented programming; |
21 |
. C++-like syntax; |
22 |
. dynamic typing; |
23 |
. delegation; |
24 |
. generators; |
25 |
. exception handling; |
26 |
. weak references; |
27 |
. more on http://www.squirrel-lang.org. |
28 |
Cross-platform nature of Squirrel Shell lets users write one script and use |
29 |
it everywhere instead of writing several scripts for doing the same thing, |
30 |
but in different OSes. Since Squirrel is a generic scripting language, this |
31 |
gives users more power as they aren't limited to functionality, specific to |
32 |
some dedicated purpose. |
33 |
|
34 |
%prep |
35 |
%setup -q |
36 |
%patch0 |
37 |
%patch1 |
38 |
|
39 |
%build |
40 |
%_configure --prefix=%{_prefix} --mime-buildroot=%{buildroot} |
41 |
%make |
42 |
|
43 |
%install |
44 |
rm -rf %{buildroot} |
45 |
%makeinstall_std |
46 |
rm -f doc/%name.1 doc/%name.tex |
47 |
rm -f %{buildroot}%{_sysconfdir}/mime.types |
48 |
install -m755 -d -D %{buildroot}%{_datadir}/apps/katepart/syntax |
49 |
install -m644 %{S:1} %{buildroot}%{_datadir}/apps/katepart/syntax/ |
50 |
|
51 |
%find_lang %{name} |
52 |
|
53 |
%files -f %{name}.lang |
54 |
%{_bindir}/squirrelsh |
55 |
%doc COPYING* HISTORY README doc |
56 |
%{_mandir}/man1/* |
57 |
%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/magic |
58 |
|
59 |
%package syntax |
60 |
Summary: Syntax definition file for Kate (version >= 2.3) |
61 |
Requires: katepart |
62 |
Requires: %{name} = %{version} |
63 |
Suggests: kate |
64 |
|
65 |
%description syntax |
66 |
Syntax definition file for Kate (version >= 2.3) |
67 |
|
68 |
%files syntax |
69 |
%{_datadir}/apps/katepart/syntax/squirrel.xml |
70 |
|
71 |
|
72 |
%post |
73 |
# adding mime type for squirrelsh scripts |
74 |
echo -e "application/x-squirrelshscript\t\tnut" >> %{_sysconfdir}/mime.types |
75 |
|
76 |
%postun |
77 |
# remove mime type that belongs to squirrelsh package |
78 |
# sed leave an empty line after the replacement |
79 |
#%__sed -i 's|application/x-squirrelshscript[[:space:]]*nut||g' %{_sysconfdir}/mime.types |
80 |
cat %{_sysconfdir}/mime.types | egrep -v 'application\/x-squirrelshscript' > %{_sysconfdir}/mime.types.new |
81 |
mv %{_sysconfdir}/mime.types.new %{_sysconfdir}/mime.types |