/[packages]/cauldron/systemd/current/SPECS/systemd.spec
ViewVC logotype

Contents of /cauldron/systemd/current/SPECS/systemd.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 197783 - (show annotations) (download)
Wed Jan 18 06:54:09 2012 UTC (12 years, 3 months ago) by dmorgan
File size: 20738 byte(s)
Add syslog fragment
1 # macros for sysvinit transition - should be equal to
2 # sysvinit %version-%release-plus-1
3 %define sysvinit_version 2.87
4 %define sysvinit_release %mkrel 13
5
6 %define libdaemon_major 0
7 %define liblogin_major 0
8 %define libjournal_major 0
9 %define libid128_major 0
10
11 %define libdaemon %mklibname systemd-daemon %{libdaemon_major}
12 %define libdaemon_devel %mklibname -d systemd-daemon %{libdaemon_major}
13
14 %define liblogin %mklibname systemd-login %{liblogin_major}
15 %define liblogin_devel %mklibname -d systemd-login %{liblogin_major}
16
17 %define libjournal %mklibname systemd-journal %{libjournal_major}
18 %define libjournal_devel %mklibname -d systemd-journal %{libjournal_major}
19
20 %define libid128 %mklibname systemd-id128 %{libid128_major}
21 %define libid128_devel %mklibname -d systemd-id128 %{libid128_major}
22
23 Summary: A System and Session Manager
24 Name: systemd
25 Version: 38
26 Release: %mkrel 5
27 License: GPLv2+
28 Group: System/Configuration/Boot and Init
29 Url: http://www.freedesktop.org/wiki/Software/systemd
30 Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
31 # Stop-gap, just to ensure things work fine with rsyslog without having to change the package right-away
32 Source4: listen.conf
33 # (cg) Upstream patches from git
34 # (cg/bor) clean up directories on boot as done by rc.sysinit
35 # - Lennart should be poked about this (he couldn't think why he hadn't done it already)
36 Patch501: systemd-18-clean-dirs-on-boot.patch
37 # (cg/bor) fix potential deadlock when onseshot unit is not finished
38 # - Lennart will do this eventually but believes this patch is insufficient.
39 Patch503: systemd-19-apply-timeoutsec-to-oneshot-too.patch
40 # (cg) We need to work out how to symlink (new install) or bind mount (upgrades) /var/run to /run
41 Patch504: systemd-tmpfilesd-utmp-temp-patch.patch
42 Patch506: systemd-33-rc-local.patch
43 Patch507: systemd-37-fix-prefdm.service.patch
44
45
46 BuildRequires: dbus-devel >= 1.4.0
47 BuildRequires: libudev-devel >= 172
48 BuildRequires: libcap-devel
49 BuildRequires: tcp_wrappers-devel
50 BuildRequires: pam-devel
51 BuildRequires: dbus-glib-devel
52 BuildRequires: vala >= 0.9
53 BuildRequires: gtk2-devel
54 BuildRequires: glib2-devel
55 BuildRequires: libnotify-devel
56 BuildRequires: intltool
57 BuildRequires: gettext-devel
58 BuildRequires: gperf
59 BuildRequires: pkgconfig(gee-1.0)
60 Requires: systemd-units = %{version}-%{release}
61 Requires: dbus >= 1.3.2
62 Requires: udev >= 172
63 Requires: initscripts >= 9.21-3
64 Requires: util-linux-ng >= 2.18
65 Requires: nss-myhostname
66 Conflicts: initscripts < 9.25
67
68 %description
69 systemd is a system and session manager for Linux, compatible with
70 SysV and LSB init scripts. systemd provides aggressive parallelization
71 capabilities, uses socket and D-Bus activation for starting services,
72 offers on-demand starting of daemons, keeps track of processes using
73 Linux cgroups, supports snapshotting and restoring of the system
74 state, maintains mount and automount points and implements an
75 elaborate transactional dependency-based service control logic. It can
76 work as a drop-in replacement for sysvinit.
77
78 # (TV) basically split b/c it pulls python in basesystem
79 %package tools
80 Summary: Non essential systemd tools
81 Group: System/Configuration/Boot and Init
82 Requires: %{name} = %{version}-%{release}
83 Requires: python-dbus
84 Requires: python-cairo
85 Conflicts: %{name} <= 37-15
86
87 %description tools
88 Non essential systemd tools
89
90 %package units
91 Summary: Configuration files, directories and installation tool for systemd
92 Group: System/Configuration/Boot and Init
93 Requires: %{name} = %{version}-%{release}
94 Conflicts: initscripts < 9.25
95 Requires(post): coreutils grep awk
96
97 %description units
98 Basic configuration files, directories and installation tool for the systemd
99 system and session manager.
100
101 %package gtk
102 Summary: Graphical frontend for systemd
103 Group: System/Configuration/Boot and Init
104 Requires: %{name} = %{version}-%{release}
105 Requires: polkit
106
107 %description gtk
108 Graphical front-end for systemd.
109
110 %package sysvinit
111 Summary: System V init tools
112 Group: System/Configuration/Boot and Init
113 Requires: %{name} = %{version}-%{release}
114 # (eugeni) systemd should work as a drop-in replacement for sysvinit, but not obsolete it
115 Provides: sysvinit = %sysvinit_version-%sysvinit_release
116 Conflicts: SysVinit
117
118 %description sysvinit
119 Drop-in replacement for the System V init tools of systemd.
120
121 %package -n %{libdaemon}
122 Summary: Systemd-daemon library package
123 Group: System/Libraries
124 Provides: libsystemd-daemon = %{version}-%{release}
125
126 %description -n %{libdaemon}
127 This package provides the systemd-daemon shared library.
128
129 %package -n %{libdaemon_devel}
130 Summary: Systemd-daemon library development files
131 Group: Development/C
132 Requires: %{libdaemon} = %{version}-%{release}
133 Provides: libsystemd-daemon-devel = %{version}-%{release}
134 Conflicts: %{name} <= 35-4
135
136 %description -n %{libdaemon_devel}
137 This package provides the development files for the systemd-daemon shared library.
138
139 %package -n %{liblogin}
140 Summary: Systemd-login library package
141 Group: System/Libraries
142 Provides: libsystemd-login = %{version}-%{release}
143
144 %description -n %{liblogin}
145 This package provides the systemd-login shared library.
146
147 %package -n %{liblogin_devel}
148 Summary: Systemd-login library development files
149 Group: Development/C
150 Requires: %{liblogin} = %{version}-%{release}
151 Provides: libsystemd-login-devel = %{version}-%{release}
152
153 %description -n %{liblogin_devel}
154 This package provides the development files for the systemd-login shared library.
155
156 %package -n %{libjournal}
157 Summary: Systemd-journal library package
158 Group: System/Libraries
159 Provides: libsystemd-journal = %{version}-%{release}
160
161 %description -n %{libjournal}
162 This package provides the systemd-journal shared library.
163
164 %package -n %{libjournal_devel}
165 Summary: Systemd-journal library development files
166 Group: Development/C
167 Requires: %{libjournal} = %{version}-%{release}
168 Provides: libsystemd-journal-devel = %{version}-%{release}
169
170 %description -n %{libjournal_devel}
171 This package provides the development files for the systemd-journal shared library.
172
173 %package -n %{libid128}
174 Summary: Systemd-id128 library package
175 Group: System/Libraries
176 Provides: libsystemd-id128 = %{version}-%{release}
177
178 %description -n %{libid128}
179 This package provides the systemd-id128 shared library.
180
181 %package -n %{libid128_devel}
182 Summary: Systemd-id128 library development files
183 Group: Development/C
184 Requires: %{libid128} = %{version}-%{release}
185 Provides: libsystemd-id128-devel = %{version}-%{release}
186
187 %description -n %{libid128_devel}
188 This package provides the development files for the systemd-id128 shared library.
189
190 %prep
191 %setup -q
192 %apply_patches
193 find src/ -name "*.vala" -exec touch '{}' \;
194
195 %build
196 # TODO for P13, remove when it is removed
197 autoreconf -fi
198 %configure2_5x \
199 --with-rootprefix= \
200 --with-sysvinit-path=%{_initrddir} \
201 --with-sysvrcd-path=%{_sysconfdir}/rc.d \
202 --with-rootlibdir=/%{_lib}
203
204 %make
205
206 %install
207 rm -rf %{buildroot}
208
209 %makeinstall_std
210 find %{buildroot} \( -name '*.a' -o -name '*.la' \) -exec rm {} \;
211
212 # Create SysV compatibility symlinks. systemctl/systemd are smart
213 # enough to detect in which way they are called.
214 mkdir -p %{buildroot}/sbin
215 ln -s ../bin/systemd %{buildroot}/sbin/init
216 ln -s ../bin/systemctl %{buildroot}/sbin/reboot
217 ln -s ../bin/systemctl %{buildroot}/sbin/halt
218 ln -s ../bin/systemctl %{buildroot}/sbin/poweroff
219 ln -s ../bin/systemctl %{buildroot}/sbin/shutdown
220 ln -s ../bin/systemctl %{buildroot}/sbin/telinit
221 ln -s ../bin/systemctl %{buildroot}/sbin/runlevel
222
223 # We create all wants links manually at installation time to make sure
224 # they are not owned and hence overriden by rpm after the used deleted
225 # them.
226 rm -r %{buildroot}/etc/systemd/system/*.target.wants
227
228 # Make sure the ghost-ing below works
229 touch %{buildroot}%{_sysconfdir}/systemd/system/runlevel2.target
230 touch %{buildroot}%{_sysconfdir}/systemd/system/runlevel3.target
231 touch %{buildroot}%{_sysconfdir}/systemd/system/runlevel4.target
232 touch %{buildroot}%{_sysconfdir}/systemd/system/runlevel5.target
233
234 # Make sure these directories are properly owned
235 mkdir -p %{buildroot}/lib/systemd/system/basic.target.wants
236 mkdir -p %{buildroot}/lib/systemd/system/default.target.wants
237 mkdir -p %{buildroot}/lib/systemd/system/dbus.target.wants
238 mkdir -p %{buildroot}/lib/systemd/system/syslog.target.wants
239
240 # And the default symlink we generate automatically based on inittab
241 rm -f %{buildroot}%{_sysconfdir}/systemd/system/default.target
242
243 # We are not prepared to deal with tmpfs /var/run or /var/lock
244 pushd %{buildroot}/lib/systemd/system/local-fs.target.wants && {
245 rm -f var-lock.mount
246 rm -f var-run.mount
247 popd
248 }
249
250 # (bor) make sure we own directory for bluez to install service
251 mkdir -p %{buildroot}/lib/systemd/system/bluetooth.target.wants
252
253 # use consistent naming and permissions for completion scriplets
254 mv %{buildroot}%{_sysconfdir}/bash_completion.d/systemd-bash-completion.sh \
255 %{buildroot}%{_sysconfdir}/bash_completion.d/systemd
256 chmod 644 %{buildroot}%{_sysconfdir}/bash_completion.d/systemd
257
258 # (tpg) use systemd's own mounting capability
259 sed -i -e 's/^#MountAuto=yes$/MountAuto=yes/' \
260 %{buildroot}/etc/systemd/system.conf
261
262 sed -i -e 's/^#SwapAuto=yes$/SwapAuto=yes/' \
263 %{buildroot}/etc/systemd/system.conf
264
265 # (bor) disable legacy output to console, it just messes things up
266 sed -i -e 's/^#SysVConsole=yes$/SysVConsole=no/' \
267 %{buildroot}/etc/systemd/system.conf
268
269 # (bor) enable rpcbind.target by default so we have something to plug
270 # portmapper service into
271 ln -s ../rpcbind.target %{buildroot}/lib/systemd/system/multi-user.target.wants
272
273 # (eugeni) install /run
274 mkdir %{buildroot}/run
275
276 # add missing ttys (mdv #63600)
277 # (cg) Do not start getty on tty1, it's used for X11 now (mga#3430)
278 mkdir -p %{buildroot}/etc/systemd/system/getty.target.wants
279 pushd %{buildroot}/etc/systemd/system/getty.target.wants
280 for _term in 2 3 4 5 6 ; do
281 ln -s /lib/systemd/system/getty@.service getty@tty$_term.service
282 done
283 popd
284
285 # create modules.conf as a symlink to /etc/
286 ln -s /etc/modules %{buildroot}%{_sysconfdir}/modules-load.d/modules.conf
287 # (tpg) symlink also modprobe.preload because a lot of modules are inserted there from drak* stuff
288 ln -s /etc/modprobe.preload %{buildroot}%{_sysconfdir}/modules-load.d/modprobe-preload.conf
289
290 # Create new-style configuration files so that we can ghost-own them
291 touch %{buildroot}%{_sysconfdir}/hostname
292 touch %{buildroot}%{_sysconfdir}/vconsole.conf
293 touch %{buildroot}%{_sysconfdir}/locale.conf
294 touch %{buildroot}%{_sysconfdir}/machine-id
295 touch %{buildroot}%{_sysconfdir}/machine-info
296 touch %{buildroot}%{_sysconfdir}/timezone
297 mkdir -p %{buildroot}%{_sysconfdir}/X11/xorg.conf.d
298 touch %{buildroot}%{_sysconfdir}/X11/xorg.conf.d/00-keyboard.conf
299
300 # Install rsyslog fragment
301 mkdir -p %{buildroot}%{_sysconfdir}/rsyslog.d/
302 install -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/rsyslog.d/
303
304
305 %triggerin -- glibc
306 # reexec daemon on self or glibc update to avoid busy / on shutdown
307 # trigger is executed on both self and target install so no need to have
308 # extra own post
309 if [ $1 -ge 2 -o $2 -ge 2 ] ; then
310 /bin/systemctl daemon-reexec 2>&1 || :
311 fi
312
313 %post
314 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
315 #/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
316
317 %triggerin units -- %{name}-units < 35-1
318 # Enable the services we install by default.
319 /bin/systemctl --quiet enable \
320 hwclock-load.service \
321 getty@.service \
322 quotaon.service \
323 quotacheck.service \
324 remote-fs.target \
325 systemd-readahead-replay.service \
326 systemd-readahead-collect.service \
327 rsyslog.service \
328 2>&1 || :
329 # rc-local is now enabled by default in base package
330 rm -f %_sysconfdir/systemd/system/multi-user.target.wants/rc-local.service || :
331
332 %post units
333 if [ $1 -eq 1 ] ; then
334 # Try to read default runlevel from the old inittab if it exists
335 runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
336 if [ -z "$runlevel" ] ; then
337 target="/lib/systemd/system/graphical.target"
338 else
339 target="/lib/systemd/system/runlevel$runlevel.target"
340 fi
341
342 # And symlink what we found to the new-style default.target
343 /bin/ln -sf "$target" %{_sysconfdir}/systemd/system/default.target 2>&1 || :
344
345 # Enable the services we install by default.
346 /bin/systemctl --quiet enable \
347 getty@.service \
348 quotaon.service \
349 quotacheck.service \
350 remote-fs.target \
351 systemd-readahead-replay.service \
352 systemd-readahead-collect.service \
353 rsyslog.service \
354 2>&1 || :
355 fi
356
357 hostname_new=`cat %_sysconfdir/hostname 2>/dev/null`
358 if [ -z $hostname_new ]; then
359 hostname_old=`cat /etc/sysconfig/network 2>/dev/null | grep HOSTNAME | cut -d "=" -f2`
360 if [ ! -z $hostname_old ]; then
361 echo $hostname_old >> %_sysconfdir/hostname
362 else
363 echo "localhost" >> %_sysconfdir/hostname
364 fi
365 fi
366
367
368 %preun units
369 if [ $1 -eq 0 ] ; then
370 /bin/systemctl --quiet disable \
371 getty@.service \
372 quotaon.service \
373 quotacheck.service \
374 remote-fs.target \
375 systemd-readahead-replay.service \
376 systemd-readahead-collect.service \
377 rsyslog.service \
378 2>&1 || :
379
380 /bin/rm -f %_sysconfdir/systemd/system/default.target 2>&1 || :
381 fi
382
383 %postun units
384 if [ $1 -ge 1 ] ; then
385 /bin/systemctl daemon-reload 2>&1 || :
386 fi
387
388 %files
389 %defattr(-,root,root)
390 # (cg) Note some of these directories are empty, but that is intended
391 %dir /run
392 %dir /lib/systemd
393 %dir /lib/systemd/system-generators
394 %dir /lib/systemd/system-shutdown
395 %dir %{_prefix}/lib/tmpfiles.d
396 %dir %{_prefix}/lib/sysctl.d
397 %dir %{_prefix}/lib/modules-load.d
398 %dir %{_prefix}/lib/binfmt.d
399 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
400 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
401 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
402 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
403 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
404 %config(noreplace) %{_sysconfdir}/systemd/systemd-journald.conf
405 %config(noreplace) %{_sysconfdir}/systemd/system.conf
406 %{_prefix}/lib/tmpfiles.d/legacy.conf
407 %{_prefix}/lib/tmpfiles.d/systemd.conf
408 %{_prefix}/lib/tmpfiles.d/tmp.conf
409 %{_prefix}/lib/tmpfiles.d/x11.conf
410 %{_sysconfdir}/systemd/systemd-logind.conf
411 %{_sysconfdir}/systemd/user.conf
412 %{_sysconfdir}/xdg/systemd
413 %ghost %config(noreplace) %{_sysconfdir}/hostname
414 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
415 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
416 %ghost %config(noreplace) %{_sysconfdir}/machine-id
417 %ghost %config(noreplace) %{_sysconfdir}/machine-info
418 %ghost %config(noreplace) %{_sysconfdir}/timezone
419 %ghost %config(noreplace) %{_sysconfdir}/X11/xorg.conf.d/00-keyboard.conf
420 %config(noreplace) %{_sysconfdir}/rsyslog.d/listen.conf
421 /bin/systemd
422 /bin/systemd-ask-password
423 /bin/systemd-loginctl
424 /bin/systemd-journalctl
425 /bin/systemd-machine-id-setup
426 /bin/systemd-notify
427 /bin/systemd-tmpfiles
428 /bin/systemd-tty-ask-password-agent
429 /lib/systemd/systemd-*
430 /lib/systemd/system-generators/systemd-*
431 /lib/udev/rules.d/*.rules
432 /%{_lib}/security/pam_systemd.so
433 %{_bindir}/systemd-cgls
434 %{_bindir}/systemd-nspawn
435 %{_bindir}/systemd-stdio-bridge
436 %{_datadir}/systemd/kbd-model-map
437 %{_mandir}/man1/systemd.*
438 %{_mandir}/man1/systemd-notify.*
439 %{_mandir}/man1/systemd-cgls.*
440 %{_mandir}/man1/systemd-ask-password.1.*
441 %{_mandir}/man1/systemd-loginctl.1.*
442 %{_mandir}/man1/systemd-nspawn.1.*
443 %{_mandir}/man3/*
444 %{_mandir}/man5/*
445 %{_mandir}/man7/*
446 %{_mandir}/man8/pam_systemd.*
447 %{_mandir}/man8/systemd-tmpfiles.*
448 %{_prefix}/lib/systemd/user/*.target
449 %{_prefix}/lib/systemd/user/*.service
450 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
451 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
452 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
453 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
454 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
455 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
456 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
457 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
458 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
459 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
460 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
461 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
462 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
463 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
464 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
465 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
466 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
467 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
468 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
469 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
470 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
471 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
472 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
473 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
474 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
475 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
476 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
477 %{_docdir}/systemd
478
479 %files tools
480 %defattr(-,root,root)
481 %{_bindir}/systemd-analyze
482
483 %files units
484 %defattr(-,root,root)
485 # (cg) Note some of these directories are empty, but that is intended
486 # NB I'm not totally sure of the ownership split of directories between systemd and systemd-units.
487 %dir %{_sysconfdir}/systemd
488 %dir %{_sysconfdir}/systemd/system
489 %dir %{_sysconfdir}/systemd/system/getty.target.wants
490 %dir %{_sysconfdir}/systemd/user
491 %dir %{_sysconfdir}/tmpfiles.d
492 %dir %{_sysconfdir}/sysctl.d
493 %dir %{_sysconfdir}/modules-load.d
494 %dir %{_sysconfdir}/binfmt.d
495 %dir %{_sysconfdir}/bash_completion.d
496 /bin/systemctl
497 %{_sysconfdir}/bash_completion.d/systemd
498 %{_sysconfdir}/modules-load.d/*.conf
499 %{_sysconfdir}/systemd/system/getty.target.wants/getty@*.service
500 /lib/systemd/system
501 %{_mandir}/man1/systemctl.*
502
503 %ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel2.target
504 %ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel3.target
505 %ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
506 %ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
507
508 %files gtk
509 %defattr(-,root,root)
510 %{_bindir}/systemadm
511 %{_bindir}/systemd-gnome-ask-password-agent
512 %{_mandir}/man1/systemadm.*
513
514 %files sysvinit
515 %defattr(-,root,root,-)
516 /sbin/init
517 /sbin/reboot
518 /sbin/halt
519 /sbin/poweroff
520 /sbin/shutdown
521 /sbin/telinit
522 /sbin/runlevel
523 %{_mandir}/man1/init.*
524 %{_mandir}/man8/halt.*
525 %{_mandir}/man8/reboot.*
526 %{_mandir}/man8/shutdown.*
527 %{_mandir}/man8/poweroff.*
528 %{_mandir}/man8/telinit.*
529 %{_mandir}/man8/runlevel.*
530
531 %files -n %{libdaemon}
532 %defattr(-,root,root,-)
533 /%{_lib}/libsystemd-daemon.so.%{libdaemon_major}*
534
535 %files -n %{libdaemon_devel}
536 %defattr(-,root,root,-)
537 %dir %{_includedir}/systemd
538 %{_includedir}/systemd/sd-daemon.h
539 %{_libdir}/libsystemd-daemon.so
540 %{_libdir}/pkgconfig/libsystemd-daemon.pc
541 %{_datadir}/pkgconfig/systemd.pc
542 # TODO: Move in its own sub package
543 %{_includedir}/systemd/sd-messages.h
544
545 %files -n %{liblogin}
546 %defattr(-,root,root,-)
547 /%{_lib}/libsystemd-login.so.%{liblogin_major}*
548
549 %files -n %{liblogin_devel}
550 %defattr(-,root,root,-)
551 %dir %{_includedir}/systemd
552 %{_includedir}/systemd/sd-login.h
553 %{_libdir}/libsystemd-login.so
554 %{_libdir}/pkgconfig/libsystemd-login.pc
555
556 %files -n %{libjournal}
557 %defattr(-,root,root,-)
558 /%{_lib}/libsystemd-journal.so.%{libjournal_major}*
559
560 %files -n %{libjournal_devel}
561 %defattr(-,root,root,-)
562 %dir %{_includedir}/systemd
563 %{_includedir}/systemd/sd-journal.h
564 %{_libdir}/libsystemd-journal.so
565 %{_libdir}/pkgconfig/libsystemd-journal.pc
566
567 %files -n %{libid128}
568 %defattr(-,root,root,-)
569 /%{_lib}/libsystemd-id128.so.%{libid128_major}*
570
571 %files -n %{libid128_devel}
572 %defattr(-,root,root,-)
573 %dir %{_includedir}/systemd
574 %{_includedir}/systemd/sd-id128.h
575 %{_libdir}/libsystemd-id128.so
576 %{_libdir}/pkgconfig/libsystemd-id128.pc

  ViewVC Help
Powered by ViewVC 1.1.30