1 |
%define name tidyp |
2 |
%define version 1.04 |
3 |
%define release %mkrel 2 |
4 |
%define libname %mklibname %{name} 1.04 |
5 |
%define develname %mklibname %name -d |
6 |
|
7 |
Summary: Program for tidying up messy HTML |
8 |
Name: %{name} |
9 |
Version: %{version} |
10 |
Release: %{release} |
11 |
Group: Text tools |
12 |
License: W3C License |
13 |
URL: http://tidyp.com/ |
14 |
Source0: http://github.com/downloads/petdance/tidyp/tidyp-%{version}.tar.gz |
15 |
Patch0: tidy-20081224cvs-fix-format-errors.patch |
16 |
|
17 |
%description |
18 |
tidyp is a program that can validate your HTML, as well as modify it to be more |
19 |
clean and standard. tidyp does not validate HTML 5. |
20 |
|
21 |
libtidyp is the library on which the program is based. It can be used by any |
22 |
other program that can interface to it. The Perl module HTML::Tidy is based on |
23 |
this library, allowing Perl programmers to easily validate HTML. |
24 |
|
25 |
tidyp is a fork of the tidy project. |
26 |
|
27 |
%package -n %{libname} |
28 |
Summary: Main library for %{name} |
29 |
Group: System/Libraries |
30 |
|
31 |
%description -n %{libname} |
32 |
This package contains the library needed to run programs dynamically |
33 |
linked with %{name}. |
34 |
|
35 |
%package -n %{develname} |
36 |
Summary: Headers for developing programs that will use %{name} |
37 |
Group: Development/Other |
38 |
Requires: %{libname} = %{version}-%{release} |
39 |
Provides: %{name}-devel = %{version}-%{release} |
40 |
|
41 |
%description -n %{develname} |
42 |
This package contains the headers that programmers will need to develop |
43 |
applications which will use %{name}. |
44 |
|
45 |
%prep |
46 |
%setup -q |
47 |
%patch0 -p1 |
48 |
|
49 |
%build |
50 |
%configure2_5x |
51 |
%make |
52 |
|
53 |
%install |
54 |
%__rm -rf %{buildroot} |
55 |
%makeinstall_std |
56 |
|
57 |
# don't ship .a, .la |
58 |
find %{buildroot} *.a | xargs rm -f |
59 |
find %{buildroot} *.la | xargs rm -f |
60 |
|
61 |
%clean |
62 |
%__rm -rf %{buildroot} |
63 |
|
64 |
%files |
65 |
%defattr(-,root,root) |
66 |
%doc README ChangeLog |
67 |
%{_bindir}/* |
68 |
|
69 |
%files -n %{libname} |
70 |
%defattr(-,root,root) |
71 |
%{_libdir}/*.so.* |
72 |
|
73 |
%files -n %{develname} |
74 |
%defattr(-,root,root) |
75 |
%{_includedir}/* |
76 |
%{_libdir}/*.so |